[INACTIVE][TP] MyWarp v2.0.1 - native PermissionsEx support - no superperms yet [1337]

Discussion in 'Inactive/Unsupported Plugins' started by flames, Apr 15, 2011.

  1. Offline


    Version: 2.0dev
    Download (JAR / ZIP)
    Source code

    MyWarp is now in development by SpathiZilla, please see here

    MyWarp was made by Taylor Kelly (tkelly), all credits go to him! I forked MyWarp and will provide updates in future, or until tkelly is back. There are no changes in usage or functionality. Just the same commands, same permission nodes and same features. Original description:

    ...is Basic
    Many server admins only want the very basics. MyWarp delivers on that, and still gives the speed and reliability of using a SQLite database.

    By only giving your users permission to mywarp.warp.basic.*, they will only be able to use the very basic commands.

    ...is Social
    However, sometimes your users will demand more. They'll want to make their warps private, invite only specific people to their warps, even give their warp to someone else. MyWarp can do that too.

    Give your users mywarp.warp.soc.*, and they'll be able to do all of that.

    ...is Intelligent
    Sometimes, warps can be long and hard to remember. This is where MyWarp's auto-complete abilities come into play. It tries to find the most applicable match, and sends you there. It only considers warps you have access to, and will not send you somewhere unless it knows it's correct.

    A few examples:
    There are warps: {"Mob Spawner", "Farm", "farm", "tkelly's house", "joe's house"}
    tkelly has access to: {"Mob Spawner", "Farm" "tkelly's house"}
    joe has access to: {"Mob Spawner", "Farm", "farm", "joe's house"}

    No matter who uses /warp spawn, they will be sent to "Mob Spawner"
    If tkelly uses /warp house, he'll be sent to "tkelly's house"
    If joe uses /warp house, he'll be sent to "joe's house"
    If tkelly uses /warp farm or /warp arm, he'll be sent to "Farm"
    If joe uses /warp farm, he'll be sent to "farm"
    But if joe uses /warp arm, it equally matches both "Farm" and "farm", so will send him to neither.

    ...is Sign-full
    Physical interactions with the world is what Minecraft is all about. That's why signs can be used to replace many of the basic commands. For now, you can have a sign warp you to one of your current warps (using the auto-complete). Feel free to suggest more things, and I'll build that in.

    In order to build a warping sign, create a sign with two lines of text (it doesn't matter what specific lines).

    If you don't use the basic permission-set, give your players following nodes:

    ...is Guiding
    Want to make your users work to get to their points of interest? Rather than giving them /warp permission, just give them (mywarp.warp.basic.compass) permission. This will let them /warp point <name> to a given warp, and that'll orient their compass to that warp, allowing them to use their own two legs to get there.

    ...is Restricting
    In addition to the compass restrictions, you can also limit the number of public and private warps users can make. You can find and change these settings in MyWarp.settings.

    Until Bukkit's permissions and groups get fleshed out, this is a global number. However, with another setting in MyWarp.settings, you can allow admins to go around this limit.

    ...is Helpful
    As an server administrator, warps can easily be abused. MyWarp gives you access to be able to visit and modify all the warps.

    Version 2.0dev
    • MySQL support
    • importing warps from warps.db to mysql
    • permissions 3.x
    • removed extremely old artifacts (import of hmod warps)
    • tested and works on CB928
    Version 1.10.7
    • added native support for PermissionsEx
    • fixed namespace
    Version 1.10.6
    • updated for CB786-793
    • updated to Help 3.0 ( not interesting for you until you compile from Lycano's fork on github :p )
    Version 1.10.5c
    • fixed the "Could not pass event PLAYER_INTERACT to MyWarp" error
    Version 1.10.5b
    • updated for CraftBukkit RB #677 (also tested with CB #678)
    • Permissions 2.5.5 or higher (tested with 2.6 and 2.7)
    • added GroupManager support
    • changed update URL where MyWarp downloads sqlite libraries
    kahlilnc, Mtihc, Charant and 5 others like this.
  2. Offline


    Good news! i fixed it. It wasn't generating the files and somehow myhomes is still floating around my computer somewhere. :p Anyway. Question. Is the compass pointing command ever going to work? I heard from another dev that MC broke it, but I thought I'd ask here too.
  3. Offline


  4. Offline


    works fine with craftbukkit 709.
  5. Offline


    That's good to know, hopefully that means if not much is changed between 709 and the first RB for 1.5 we wont have the same problems as we did with 1.4 update. :) Still waiting though for an RB before updating the server.
  6. Offline


    i think it will work, but we will see. if next RB breaks the plugin, i will update ofc.
  7. Offline


    has anyone figured out how to convert EssentialsWarp warps to MyWarp warps?
  8. Offline


    Hey I have a few suggestions for your sign teleportation system.

    The ability to change the text in the brackets. I'd like all my warp signs to say [Warp Sign] on them, personally.

    Ability to toggle colors on signs, or specify what color the stuff in brackets is.

    Ability to have players pay for warp signs usage and or creation (through iconomy)

    EDIT: Importantly, warp signs being able to use private warps. I want to make warps that my players can only use physical signs to access.
  9. Offline


    1. that is nice idea, but not worth of complicating the code.
    2. same as 1.
    3. same as 1, while xWarp has already iconomy support, i dont want bloat mywarp with tons of new features, i just updating this plugin as it is to new craftbukkit builds. if you like to have more features you might be satisfied with xWarp, or wait for tkelly is back and decides to add them. personally i like this plugins as simple a it actually is.
    4. this is already possible, read OP to learn how to use the fine grained permission nodes instead of basic permission nodes.
    sorry if that is not what you expected from me :p
  10. Offline


    org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin MyWarp v1.10.5c
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:255)
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:650)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:613)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:607)
            at net.minecraft.server.Packet3Chat.a(SourceFile:36)
            at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:73)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: java.lang.NullPointerException
            at me.taylorkelly.mywarp.WarpPermissions.permission(WarpPermissions.java:42)
            at me.taylorkelly.mywarp.WarpPermissions.publicCreate(WarpPermissions.java:108)
            at me.taylorkelly.mywarp.MyWarp.onCommand(MyWarp.java:200)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
  11. Offline


    Thank you for not overcomplicating this plugin. I love that it just does what it's meant to do, and thanks again for keeping it alive. I was worried when tKelly took off for school, but you're doing a great job with it.
  12. Offline


    @Black_Jack, i cant reproduce this with 709. will test tonight the newest (714) craftbukkit also.
    anyone else have that errors? craftbukkit build?
  13. Offline


    MyWarp is working absolutely without a hitch for me on 714. I do have a question however, I would like to rename my world... but when I did, of course none of the warps worked anymore. (they still point to the original world's name)

    I was wondering if there was a way I could rename the world for the warps as well.


    Retyped to make more sense.
  14. Offline


    yes, download some sqlite database manager/editor and modify the world of warps you want to change in the warps.db file
  15. Offline


    Thanks for this, i think im going to use this for my new testing server

    sorry to see that so many people are/were having problems with it
  16. Offline


    A nice easy program (which is also free to use and standalone) is SQLite Studio.
  17. Offline


    Thanks a lot! :D Will go try to do that now. :)


    This is simple enough, but wow... 95 warps to change by hand. xD

    Thank you again!
    khamseen_air likes this.
  18. Offline


    Ctrl+V and the down arrow are your friend. :)
  19. Offline


    I was just coming back to say that I found that little keyboard shortcut quite useful xD

    Done already and of course, still running smoothly :D
  20. Offline


    Does this work with #733?
  21. Offline


    Yes, tried and tested, all working with RB 733.
  22. Offline


    It doesn't work for me. No error-message but no warp too. :/
  23. Offline


    @khamseen_air, thanks, i was fiew day out of order, nice that you reported. just tested my self also, works :)
    khamseen_air likes this.
  24. Offline


    I am using a server that runs with MCMyAdmin, and it doesn't seem to want to execute the .jar file to be able to create the files it needs to run MyWarp. Any ideas?
  25. Offline


    Have you tried downloading the zip file so you have the files to see if that works?
  26. Offline


    iconomy support would be a very appreciated addition.
  27. Offline


    This plugin is not working for me, and also breaking my permissions system.
    This is one of the errors I get
    20:37:51 [SCHWERWIEGEND] java.lang.LinkageError: com/nijiko/permissions/PermissionHandler
    20:37:51 [SCHWERWIEGEND]        at com.sk89q.bukkit.migration.NijiPermissionsResolver.inGroup(NijiPermissionsResolver.java:77)
    20:37:51 [SCHWERWIEGEND]        at com.sk89q.bukkit.migration.PermissionsResolverManager.inGroup(PermissionsResolverManager.java:106)
    20:37:51 [SCHWERWIEGEND]        at com.sk89q.worldguard.bukkit.WorldGuardPlugin.inGroup(WorldGuardPlugin.java:219)
    20:37:51 [SCHWERWIEGEND]        at com.sk89q.worldguard.bukkit.WorldGuardPlayerListener.onPlayerJoin(WorldGuardPlayerListener.java:438)
    20:37:51 [SCHWERWIEGEND]        at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:206)
    20:37:51 [SCHWERWIEGEND]        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    20:37:51 [SCHWERWIEGEND]        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:257)
    20:37:51 [SCHWERWIEGEND]        at net.minecraft.server.ServerConfigurationManager.a(ServerConfigurationManager.java:94)
    20:37:51 [SCHWERWIEGEND]        at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:95)
    20:37:51 [SCHWERWIEGEND]        at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:74)
    20:37:51 [SCHWERWIEGEND]        at net.minecraft.server.Packet1Login.a(SourceFile:43)
    20:37:51 [SCHWERWIEGEND]        at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
    20:37:51 [SCHWERWIEGEND]        at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:40)
    20:37:51 [SCHWERWIEGEND]        at net.minecraft.server.NetworkListenThread.a(SourceFile:87)
    20:37:51 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
    20:37:51 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    20:37:51 [SCHWERWIEGEND]        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  28. Offline


    I can't upload the files to my server unless they are .jar files or whatever that file type is for permissions.
  29. Offline


    Thanks for good plugin.. My guys can not play my server without this.

    Can you add iConomy support like 100 coins for using the warp..?
  30. Offline


    When I warp sometimes my skin is changed to default. Higher chance on warp that I do not own.
  31. Offline


    That's a problem that can't be fixed. It's not the plugin causing it, it's a side effect of teleporting in Minecraft, just disconnect and reconnect to sort the skin issue. Also, the skin is only changed to default for you, others will still see your custom skin.

Share This Page