[INACTIVE][MECH] MobRider v0.32 - Finally a proper use for saddles! [674]

Discussion in 'Inactive/Unsupported Plugins' started by Edward Hand, Feb 25, 2011.

  1. Offline


    Hey, how do we install this into premissions? I put the commands for our groups, but it still doesn't work.
  2. Offline

    Edward Hand

    Just copy and paste the permissions from the original post or use mobRider.*
    That should work. (Unless you're getting a console error?)
  3. Offline


    I've noticed while using this mod that when riding spiders, I'm so low into it that whenever arrows or the fishing rod is used, it hits the spider.
    I'd recommend moving the position a bit higher (If its possible)
  4. Offline

    Edward Hand

    Not possible afaik. I usually have no problem with fishing rods, left clicking the direction I want to go. Not tried bows though (though to be honest spiders are just as good a weapons since they take all the damage for you). Just keep a supply of food for feeding it up to health and you can win every battle.
    (mobs can eat all kinds of useless things - eggs,wheat,bones, that kind of stuff)
    --- merged: Mar 1, 2011 9:34 PM ---
    If your permissions are still the same as the ones you posted last time (which I told you then were wrong) then it wont work (because theyre wrong, like I said).
  5. Offline


    Neither do.
    --- merged: Mar 1, 2011 9:38 PM ---
    There aren't any console errors now, it's just nothings happening.
    --- merged: Mar 1, 2011 11:36 PM ---
    Got it to work. YES!

    Attached Files:

  6. Offline

    Edward Hand

    I'm glad. What was the problem in the end?
  7. Offline


    No idea to be honest. I just was messing around with my premissions.yml, and eventually it worked.

    PS: Along with being able to select if you can only ride ___ mob, can you make it so you can prevent the mob "noise" chatspam?
  8. Offline

    Edward Hand

    You mean the way they talk to you when you give them commands?
  9. Offline


    Exactly. Eventually, it just gets chat spammy.
  10. Offline


    Hi there. I can't seem to get this to work. I am running Minecraft 1.3.1, CB 440, and the latest version of this plugin. When I boot up the server, I get a confirmation that the program is loaded, and that Permissions was detected. As an admin, with the "*" permission, I should be able to use any command/ability. However, right clicking on mobs with a saddle has no effect (except on pigs). Are there any known conflicts with other plugins I should know about?

    Edit: Is it possible a problem due to my using GroupManager and the FakePermissions plugin instead of the "real" Permissions?
  11. Offline


    I'm not sure if this has been reported, but here we go...

    This is a bit hard to explain... I got on a spider and another player came by and tried to steal said spider (Grand Theft Arthropod?), they immediately jumped off the spider again. At this point I was on the spider on my screen but not on the other player's screen. Next the other player used the saddle to ride on my head (while I was still on the spider) and when I dismounted we both rocketed up at an impossible speed that sent us so high we could no longer see the map below us. We eventually fell back down to our deaths after logging in and out.
  12. Offline


    wow fail thats cuz you got public proxys and it takes like 5 seconds to set up.
  13. Offline


    I noticed something weird if you try to ride a rider you shot WAY up in the air
  14. Offline

    Edward Hand

    Yes. A few people have noticed that. Its in the video in the first post too. I quite like it [​IMG]
  15. Offline


    CAN you make it so the mob is not hostile anymore and it doesnt despawn?
  16. Offline


    left clicking with the fishing rod never makes them go that direction, they still just wander around
  17. Offline


    What mobs does this work on? The pigs from mobspawner dont work.

  18. Offline


    This is some more crazy stuff we did, this was 4 - 6 mods that were doing this! loads of fun!
  19. Offline


    I have switched over to using Yeti's Permission, as well as CB 493, and this plugin still does not work. It does not give any error message either, and I can't really figure out what is going on. The only thing I can think ofis that this plugin requires Permissions 2.1, which Yeti's Permissions is not yet compatible with. Is there a workaround?
  20. Offline


    um.. i am using yeti on 493, as well as this plugin, and permissions 2.5.2
  21. Offline

    Edward Hand

    I (just like most people) am using yeti's permissions 2.5 and it is working fine....
    You have put in the correct permissions, right?

    Yes. It says pigs don't work in the first post. All other mobs work fine.
  22. Offline


    Yeah, double and triple checked them. I even added them to the admin permissions area, just in case this is one of those rare mods where "*" doesn't cover it. No dice. Right clicking on all mobs but pigs have no effect, despite getting a message when I start the server that MobRider is loaded, and that MobRider is using Permissions. None of my other plugins modify mobs in any way, so I'm not sure what is going on.
  23. Offline


    Im kinda n00by, but how do u install this? I mean its no .jar files. What do i do with the class files?
    Or should i rename it from .zip to .jar?
  24. Offline

    Edward Hand

    Double click on the zip file to open it. The jar is inside.
  25. Offline


    Ah yea i can see it now.. its the Extractor on mac.. it unpacks the jar after the zip. You should add a file inside so that other mac users wont have the same problem aswell.. :)

    i mean like the .jar file and a txt file or something
  26. Offline


    Could you make it so that whichever creature you rode last wont despawn? I've become quite attached to Mr. Sheepy, and I don't want him to despawn.
  27. Offline


    could you add a .txt file for options like completely disabling certain mounts? I want to make it so riding a zombie, skeleton, or creeper is impossible on my server, because thats just wrong! XD
  28. Offline


    Riding a ghast is buggy but funny as hell
  29. Offline


    I've updated to your v0.2 and have noticed a few things on build #493. I loaded build #452 to see if perhaps there was something different. The problems still existed.

    1) Riding a Zombie - The chat is spammed with:
    [|||||] Zombie: Null!
    [|||||] Zombie: Null!
    [|||||] Zombie: Null!
    [|||||] Zombie: Null!
    [|||||] Zombie: Null!
    also, I take damage while riding the zombie. I enabled /god to test some more. When I give it commands, the message changes to:
    [|||||] Zombie: Null (no more ! at the end)
    Of course, this message is quickly zooms off the chat log with the other zombie spam.

    2) Skeletons still try to (and successfully do) shot me when I ride them. I've tried reasoning with them...but they insist on shooting me. Only course of action is to punish them by punching them on the top of their blocky head until they die.

    Everything else seems to be working great. I do enjoy the fact that the animals reply with a "Cluck?" or "mooooo?" when they don't understand the command.

    Still, this plugin is awesome. Thanks again for the awesome work!
  30. Offline


Share This Page