[INACTIVE][MECH] GodMode v1.3.2 - A mortality toggle plugin [670]

Discussion in 'Inactive/Unsupported Plugins' started by 8e8, Jan 18, 2011.

  1. Offline

    8e8

    GodMode - A mortality toggle plugin
    v1.3.1 [670]
    Updated: 4/11/2011 6:03am EST

    Download [JAR | config.yml] - Donate
    Previous: v1.3.1 [490], v1.3 [440], v1.2 [232]

    GodMode is a plugin which toggles mortality. It was my first java project, and is now going to be discontinued. Immunity (WIP), GodMode's predecessor, will have the features of GodMode and many more.
    Configuration (open)

    plugin/GodMode/config.yml
    Code:
    # Log commands to server.log?
    logCommands: false
    
    # Remove GodMode when player quits?
    removeOnExit: false
    
    # Enable GodMode globally?
    globalGods: false
    Commands (open)

    Aliases can be set by opening GodMode.jar as if it were a zip file and modifying the plugin.yml. Examples below.
    Code:
      godmode/self:
        description: Toggle GodMode on self
        aliases:
          - godmode/s
          - god/s
          - godmode
          - god
        usage: |
               /<command>
      godmode/player:
        description: Toggle GodMode on a player
        aliases:
          - god/player
          - godmode/p
          - god/p
        usage: |
               /<command> <playerName>
               Example: /<command> 8e8 - Toggle GodMode on 8e8
      godmode/all:
        description: Toggle GodMode on all
        aliases:
          - god/all
          - godmode/a
          - god/a
        usage: |
               /<command>
      godmode/reconfig:
        description: Reconfigure GodMode
        aliases:
          - god/reconfig
          - godmode/r
          - god/r
        usage: |
               /<command>
    
    Permissions (open)

    Permissions plugin
    plugins/Permissions/config.yml
    Code:
    permissions:
        - 'godmode.toggle.self'
        - 'godmode.toggle.player'
        - 'godmode.toggle.all'
        - 'godmode.reconfig'
    # For global permissions
        - 'godmode.*'
    
    Changelog (open)

    v1.3.2
    v1.3.1
    v1.3
    v1.2
    v1.1.4
    v1.1.3
    v1.1.2
    v1.1.1
    v1.1

    [​IMG]
     
  2. Offline

    nothigh

    The download link worked perfect, thanks!
     
  3. Offline

    8e8

    Total fail. Forgot to make it a public link.
    Fixed.
     
  4. Offline

    osterbro2100

    link broken :(
     
  5. Offline

    TheArcher

    The download works. I'll be sure to try it if I get the chance tomorrow.
     
  6. Offline

    8e8

    Tell your friends!
    I'll update the post once support for the rest of the damage events has been added.
     
  7. Offline

    FlairGun

    Nice mod it works! fall damage doesnt tho ;[ thats what i die from the most lol
     
  8. Offline

    8e8

    Yes, I'm aware. Bottom of the post explains that. I decided against leaving the fix for that in the code since it will be fixed anyway.
     
  9. Offline

    8e8

    If anyone has some suggestions I'm open to ideas. I just don't plan on making this plugin too complicated, because I want to keep it simple.
     
  10. Offline

    8e8

    Updated to v1.1
    Made a minor update to remove some leftover things from testing.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 6, 2016
  11. Offline

    Scizzr

    Great job. Works on #164. ;-)
     
  12. Offline

    8e8

    Thanks for testing it out on there. I haven't got around to testing on the later versions of cbukkit. Cheers.
     
  13. Offline

    Arisilde

    I just updated to the most recent craftbukkit version and now /god doesn't work. I just get a message saying incorrect usage of the command when I type /god.
     
  14. Offline

    8e8

    Thanks for reporting that. I'm in the process of updating all of my plugins to work with the newest version.
     
  15. Offline

    Arisilde

    Awesome :)
     
  16. Offline

    8e8

    Updated to work with #168
     
  17. Offline

    Josch

    Seems broken with #173 and Permissions!
    Always tells me I am not authorized!
     
  18. Offline

    Murdertrain

    Dose anyone's client crash as well when they /god?
     
  19. Offline

    8e8

    I haven't experienced that in testing. It may be due to another plugin you're using. More information would be nice

    @Josch
    Updated to work with #186 (should work with #173 as well). If you're still experiencing the problem with Permissions be sure to look over your config.yml.
     
  20. Offline

    Josch

    It sort of works... I now get the crashes!
    Here are the Plugins I have:
    Code:
    dynmap.jar
    GodMode.jar
    PreciousStones.jar
    BigBrother.jar
    Essentials.jar
    LWC.jar
    SpawnMob.jar
    BombBeGone.jar
    VoxelSniper.jar
    BukkitUp.jar
    Permissions.jar
    
     
  21. Offline

    8e8

    Try to troubleshoot which plugin is causing that. I've tested with Permissions and Essentials, and it works fine with both. Disable them one by one until the crashing stops. Also, post an error if you can.
     
  22. Offline

    Josch

    There is no error, only the Client crashes, not the server...
    But I try what is causing it...
     
  23. Offline

    8e8

    If the client crashes there will probably be an internal server error or something of that sorts in your console.
     
  24. Offline

    Josch

    No, nothing...
    Code:
    2011-01-31 19:34:36 [INFO] [GodMode] enabled on J0s3f by J0s3f
    
    And then the client crashes with this:
    Code:
    
          Minecraft has crashed!
          ----------------------
    
    Minecraft has stopped running because it encountered a problem.
    
    If you wish to report this, please copy this entire text and email it to support@mojang.com.
    Please include a description of what you did when the error occured.
      
    --- BEGIN ERROR REPORT a1dce528 --------
    Generated 31.01.11 20:34
    
    Minecraft: Minecraft Beta 1.2_02
    OS: Windows 7 (amd64) version 6.1
    Java: 1.6.0_22, Sun Microsystems Inc.
    VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
    LWJGL: 2.4.2
    OpenGL: ATI Radeon HD 4800 Series         version 3.3.10428 Compatibility Profile Context, ATI Technologies Inc.
    
    java.lang.StringIndexOutOfBoundsException: String index out of range: 44
        at java.lang.String.charAt(Unknown Source)
        at nh.a(SourceFile:152)
        at nh.a(SourceFile:119)
        at pe.a(SourceFile:238)
        at ll.b(SourceFile:346)
        at net.minecraft.client.Minecraft.run(SourceFile:668)
        at java.lang.Thread.run(Unknown Source)
    --- END ERROR REPORT f7c6f7f ----------
    
    But the Server runs without problems...
     
  25. Offline

    8e8

    Do what I said before with plugin troubleshooting. If you're using an updated Craftbukkit #186 with Permissions it should be fine. The issue seems to be because of a conflict with another plugin.
     
  26. Offline

    FaronFox

    Trying to use Permissions for commands doesn't work, adding your name to the users file causes the client to crash on activation.
     
  27. Offline

    insanj

    For some reason this plugins doesn't really work for me.
    Whenever I type in /god it always displays the "Incorrect usage of the command /god" message, even though I have no other plugins installed, disabled using Permissions, and added myself to the users file, with a command after my name.
    Any idea what's up?
     
  28. Offline

    Chuxor

    The 1.1.3 update still advertises as 1.1.2 when it loads.
     
  29. Offline

    8e8

    My apologies to those having the Permissions error. I forgot to address the changes when I removed GroupUsers support. The plugin should work fine with Permissions 1.9, and craftbukkit #186.

    If you're encountering errors still, please be sure to include any information you can about your setup and the error.

    @insanj
    You shouldn't be adding the command after your name in the users file. Follow the example in the original post. Permissions should be used now anyway.

    @Chuxor
    I tend to forget to update the plugin.yml when I make a change. The correct version # will show now.
     
  30. Offline

    Josch

    I found a Bug:
    Slimes still do damage!
    Best to test with some mobspawning plugin... Just spame one and you will die, even with godmode on!
     

Share This Page