[INACTIVE][ADMN] SimpleSave v3.25 Simple automatic saving! [000] - Backups!

Discussion in 'Inactive/Unsupported Plugins' started by desmin88, Mar 11, 2011.

  1. Offline

    desmin88

  2. Offline

    ehird

    I'm using CraftBukkit build 953 and SimpleSave v3.24.

    Here's my configuration:
    Code:
    #SimpleSave Config File
    #Sun Jul 17 12:41:34 UTC 2011
    plugin.version=3.1
    plugin.send.saveoff-on=true
    plugin.ignore.noplayers=true
    save.use=true
    save.interval=5
    save.message.send=true
    save.message.color=RED
    save.message.starting=[SimpleSave] Beginning world save
    save.message.ending=[SimpleSave] Ending world save
    backup.use=true
    backup.interval=180
    backup.directory=backup
    backup.date.format=yyyy-MM-ddThh:mm:ssZ
    backup.history.length=10000
    backup.world.filter=
    backup.message.send=true
    backup.message.color=RED
    backup.message.ending=[SimpleSave] Ending world backup
    backup.message.starting=[SimpleSave] Beginning world backup
    Unfortunately, this does not work. I never see any save or backup messages in the console. When I do /ssBackup, (which, by the way, it seems that non-ops can use as well as ops!) it prints out the backup messages, but here's what the backups directory looks like:
    Code:
    $ ls backup
    world  world_nether
    No timestamps. The only other plugins I have installed are Permissions, WorldEdit, CommandBook and HeroicDeath. Is this a known bug, or could there be something wrong with my configuration?

    By the way, after seeing it in another configuration posted in this thread, I tried using "backup.world.filter=;" instead, but that didn't change anything.
     
  3. Offline

    desmin88

    @ehird
    Expect 3.25 very soon.
     
    tekac and ehird like this.
  4. Offline

    tekac

    Using build #1000

    I don't believe its actually "saving"
    The message shows, however no command /save-all is actually sent. It just spams the message
    Code:
    Beginning Save
    Ending Save
    
    All at once.
     
  5. Offline

    fffizzz

    since updating to 3.24 yesterday, it hasnt backed anything up. i did a manual ssbackup this morning and it worked as intended.
    Code:
    -rw-r--r--  1 kelso kelso 401253840 2011-07-17 13:11 ww2011-07-17 01-11-36.zip
    -rw-r--r--  1 kelso kelso 401265749 2011-07-17 14:11 ww2011-07-17 02-11-15.zip
    -rw-r--r--  1 kelso kelso 401299813 2011-07-17 15:05 ww2011-07-17 03-05-28.zip
    -rw-r--r--  1 kelso kelso 401059594 2011-07-17 04:06 ww2011-07-17 04-06-02.zip
    -rw-r--r--  1 kelso kelso 401311052 2011-07-17 16:16 ww2011-07-17 04-16-18.zip
    -rw-r--r--  1 kelso kelso 401348100 2011-07-17 16:49 ww2011-07-17 04-49-12.zip
    -rw-r--r--  1 kelso kelso 401059598 2011-07-17 05:06 ww2011-07-17 05-05-45.zip
    -rw-r--r--  1 kelso kelso 401402608 2011-07-17 17:19 ww2011-07-17 05-19-17.zip
    -rw-r--r--  1 kelso kelso 401058874 2011-07-17 06:06 ww2011-07-17 06-05-55.zip
    -rw-r--r--  1 kelso kelso 401077056 2011-07-17 06:42 ww2011-07-17 06-42-35.zip
    -rw-r--r--  1 kelso kelso 401122216 2011-07-17 07:43 ww2011-07-17 07-43-31.zip
    -rw-r--r--  1 kelso kelso 401137884 2011-07-17 08:44 ww2011-07-17 08-43-51.zip
    -rw-r--r--  1 kelso kelso 401468836 2011-07-17 21:19 ww2011-07-17 09-19-10.zip
    -rw-r--r--  1 kelso kelso 401139210 2011-07-17 10:05 ww2011-07-17 10-05-09.zip
    -rw-r--r--  1 kelso kelso 401201086 2011-07-17 11:11 ww2011-07-17 11-11-21.zip
    -rw-r--r--  1 kelso kelso 401241689 2011-07-17 12:11 ww2011-07-17 12-11-23.zip
    -rw-r--r--  1 kelso kelso 404829269 2011-07-18 07:04 ww2011-07-18 07-04-19.zip
    
    config:
    Code:
    #SimpleSave Config File
    #Fri Jul 08 09:26:49 EDT 2011
    save.interval=10
    save.use=true
    backup.message.ending=Ending world backup
    backup.message.starting=Beginning world backup
    backup.directory=backup
    backup.history.length=100
    save.message.send=true
    backup.use=true
    plugin.send.saveoff-on=true
    backup.interval=60
    plugin.ignore.noplayers=false
    backup.world.filter=
    save.message.color=RED
    backup.message.color=RED
    plugin.version=3.1
    backup.message.send=true
    save.message.starting=Beginning world save
    save.message.ending=Ending world save
    backup.date.format=yyyy-MM-dd hh-mm-ss
    
    
     
  6. Offline

    ACStache

    edit: sorry, color isn't working right for me for some reason

    Unfortunately I can confirm fffizzz's findings. I have become accustomed to ignoring the in-game announcements, and when I don't see them I think it's still working fine. However I had restarted the server and lost quite a bit of work. I know it's my own fault, but just as a heads up it's not saving/backing up as of 3.24 on b953 (I've just upgraded to RB1000 after it happened, and it still looks like it's not working)

    config: (haven't changed this since I originally installed SimpleSave)
    Code:
    #SimpleSave Config File
    #Tue Jun 28 18:40:06 EDT 2011
    [COLOR=rgb(255, 0, 0)]save.interval=30[/COLOR] [COLOR=rgb(0, 128, 128)](no saves recorded)[/COLOR]
    save.use=true
    backup.message.ending=[SimpleSave] Ending world backup
    backup.message.starting=[SimpleSave] Beginning world backup
    backup.directory=backup
    backup.history.length=20
    save.message.send=true
    backup.use=true
    plugin.send.saveoff-on=true
    [COLOR=rgb(255, 0, 0)]backup.interval=60 [/COLOR][COLOR=rgb(0, 128, 128)](no back ups made)[/COLOR]
    plugin.ignore.noplayers=false
    backup.world.filter=
    save.message.color=RED
    backup.message.color=RED
    plugin.version=3.1
    backup.message.send=true
    save.message.starting=[SimpleSave] Beginning world save
    save.message.ending=[SimpleSave] Ending world save
    backup.date.format=yyyy-MM-dd hh-mm-ss
    
    server.log:
    Code:
    2011-07-17 17:34:44 [INFO] Starting minecraft server version Beta 1.7.2
    2011-07-17 17:34:44 [INFO] Loading properties
    2011-07-17 17:34:44 [INFO] Starting Minecraft server on *:25565
    2011-07-17 17:34:44 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-904-g9277096-b953jnks (MC: 1.7.2)
    2011-07-17 17:34:45 [INFO] DataSourcePool [LightLevel] autoCommit[false] transIsolation[SERIALIZABLE] min[2] max[20]
    2011-07-17 17:34:45 [INFO] SubClassFactory parent ClassLoader [org.bukkit.plugin.java.PluginClassLoader]
    2011-07-17 17:34:45 [INFO] Entities enhanced[0] subclassed[1]
    2011-07-17 17:34:46 [INFO] [Permissions] (Yeti) was initialized.
    2011-07-17 17:34:46 [INFO] [Permissions] version [3.1.6] (Yeti)  loaded
    2011-07-17 17:34:46 [INFO] Preparing level "world"
    2011-07-17 17:34:46 [INFO] Preparing start region for level 0 (Seed: 2949727993687137503)
    2011-07-17 17:34:46 [INFO] Preparing start region for level 1 (Seed: -230859046716587294)
    -snip (plugins loading)
    [COLOR=rgb(255, 0, 0)][B]2011-07-17 17:34:48 [INFO] SimpleSave: Parts of config file are blank, but not null. Possible errors might happen.[/B][/COLOR]
    [COLOR=rgb(255, 0, 0)][B]2011-07-17 17:34:48 [INFO] SimpleSave: DON'T! Post this 'warning' on the thread.[/B][/COLOR]
    [COLOR=rgb(255, 0, 0)][B]2011-07-17 17:34:48 [INFO] SimpleSave: 3.24 Initialized[/B][/COLOR]
    -snip (plugins loading)
    2011-07-17 17:34:48 [INFO] Done (0.267s)! For help, type "help" or "?"
    2011-07-17 17:35:19 [INFO] dasbreen [/127.0.0.1:61550] logged in with entity id 111 at ([world] -15.338551805012525, 75.0, 20.300000011920933)
    2011-07-17 17:35:19 [INFO] CraftPlayer{name=dasbreen} logged in with entity id111
    2011-07-17 17:35:19 [INFO] [StealthLogin] dasbreen logged in secretly!
    2011-07-17 17:35:34 [INFO] hallsy9 [/24.168.52.36:52100] logged in with entity id 5239 at ([world] -295.375, 63.0, -12.0)
    2011-07-17 17:35:54 [INFO] dasbreen lost connection: disconnect.quitting
    2011-07-17 17:35:54 [INFO] Connection reset
    2011-07-17 17:35:54 [INFO] [StealthLogin] dasbreen logged out secretly!
    2011-07-17 17:36:44 [INFO] <hallsy9> why does /i not work for me
    2011-07-17 17:39:49 [INFO] dasbreen [/127.0.0.1:61626] logged in with entity id 16603 at ([world] -15.34375, 75.0, 20.28125)
    2011-07-17 17:39:49 [INFO] CraftPlayer{name=dasbreen} logged in with entity id16603
    2011-07-17 17:39:49 [INFO] [StealthLogin] dasbreen logged in secretly!
    2011-07-17 17:40:06 [INFO] <dasbreen> what do you mean it doesn't work?
    2011-07-17 17:40:33 [INFO] <dasbreen> does it say you don't have permission or does it not work at all?
    2011-07-17 17:40:57 [INFO] <hallsy9> it says no item type known
    2011-07-17 17:41:04 [INFO] <dasbreen> what did you try typing?
    2011-07-17 17:42:02 [INFO] <hallsy9> t/ i <326>
    2011-07-17 17:42:10 [INFO] <dasbreen> oh :D
    2011-07-17 17:42:16 [INFO] <dasbreen> the < and > aren't needed
    2011-07-17 17:42:21 [INFO] <dasbreen> try just /i 326
    2011-07-17 17:42:40 [INFO] <dasbreen> sorry if that wasn't clear in the commands list, the <>'s aren't needed
    2011-07-17 17:42:47 [INFO] <dasbreen> it's just to separate stuff in the list
    2011-07-17 17:42:53 [INFO] <dasbreen> since there's so much info
    2011-07-17 17:43:02 [INFO] <hallsy9> cool it worked
    2011-07-17 17:46:17 [INFO] <dasbreen> glad to hear :)
    2011-07-17 17:46:40 [INFO] Connection reset
    2011-07-17 17:46:40 [INFO] dasbreen lost connection: disconnect.quitting
    2011-07-17 17:46:40 [INFO] [StealthLogin] dasbreen logged out secretly!
    2011-07-17 17:51:23 [INFO] [Permissions] All worlds reloaded.
    2011-07-17 17:54:36 [INFO] Running Garbage Collection please wait...
    2011-07-17 17:54:37 [INFO] Garbage Collection is complete.
    2011-07-17 18:24:50 [INFO] Connection reset
    2011-07-17 18:24:50 [INFO] hallsy9 lost connection: disconnect.quitting
    
    [COLOR=rgb(255, 0, 0)]should be a back up here, no one else was on.[/COLOR]
    
    2011-07-17 21:46:38 [INFO] amukon [/69.183.146.119:1947] logged in with entity id 67902 at ([world] 268.6875, 78.375, 222.6875)
    2011-07-17 21:55:53 [SEVERE] java.net.SocketException: Socket closed
    2011-07-17 21:55:53 [INFO] Connection reset
    2011-07-17 21:55:53 [INFO] amukon lost connection: disconnect.quitting
    -snip (irrelevant error)
    
    [COLOR=rgb(255, 0, 0)]he errors out alot, but it should back up here[/COLOR]
    
    2011-07-17 21:55:56 [INFO] amukon [/69.183.146.119:2819] logged in with entity id 72960 at ([world] 286.625, 74.0, 213.6875)
    
    [COLOR=rgb(0, 128, 128)]save should have been here[/COLOR]
    
    2011-07-17 22:33:07 [SEVERE] java.net.SocketException: Connection reset by peer: socket write error
    -snip (irrelevant error)
    2011-07-17 22:33:07 [SEVERE] java.net.SocketException: Connection reset by peer: socket write error
    -snip (irrelevant error)
    2011-07-17 22:33:07 [INFO] amukon lost connection: disconnect.endOfStream
    
    [COLOR=rgb(255, 0, 0)]and a backup here[/COLOR]
    
    2011-07-17 22:33:13 [INFO] amukon [/69.183.146.119:2095] logged in with entity id 89614 at ([world] 279.3125, 77.1875, 231.15625)
    
    [COLOR=rgb(0, 128, 128)]save should have been in here[/COLOR]
    
    2011-07-17 23:14:47 [INFO] <amukon> hey brian
    2011-07-17 23:14:52 [INFO] <*Console*>: yes?
    2011-07-17 23:15:02 [INFO] <amukon> whasts up?
    2011-07-17 23:15:13 [INFO] <amukon> hows rift>?
    2011-07-17 23:15:18 [INFO] dasbreen [/127.0.0.1:63508] logged in with entity id 120700 at ([world] -15.34375, 75.0, 20.28125)
    2011-07-17 23:15:18 [INFO] CraftPlayer{name=dasbreen} logged in with entity id120700
    2011-07-17 23:15:18 [INFO] [StealthLogin] dasbreen logged in secretly!
    2011-07-17 23:15:22 [INFO] <dasbreen> pretty good
    2011-07-17 23:15:25 [INFO] <dasbreen> was about to play some
    2011-07-17 23:15:32 [INFO] <dasbreen> also
    2011-07-17 23:15:43 [INFO] <dasbreen> craftbukkit finally released a new recommended build for 1.7.3
    2011-07-17 23:15:54 [INFO] <dasbreen> so once the main plugins update, i'll update the whole server
    2011-07-17 23:16:32 [INFO] <dasbreen> as it stands right now, only 1 plugin I use claims RB#1000 ready
    2011-07-17 23:16:33 [INFO] <dasbreen> lol
    2011-07-17 23:16:57 [INFO] <amukon> log in real quick and tell me what u think about the town. pelase
    2011-07-17 23:17:11 [INFO] <dasbreen> i am signed in :D
    2011-07-17 23:17:15 [INFO] <dasbreen> i'm sneaky like that
    2011-07-17 23:17:24 [INFO] <amukon> tp to me then
    2011-07-17 23:17:45 [INFO] <amukon> town hall
    2011-07-17 23:17:50 [INFO] <dasbreen> one moment
    2011-07-17 23:17:53 [INFO] <dasbreen> chunks are still loading
    2011-07-17 23:17:54 [INFO] <dasbreen> lol
    2011-07-17 23:18:02 [INFO] <amukon> ur welcome to build anywhere u see fit
    2011-07-17 23:18:24 [INFO] <dasbreen> it's awesome looking
    2011-07-17 23:18:26 [INFO] <dasbreen> great job
    2011-07-17 23:18:41 [INFO] <dasbreen> a harbor side town
    2011-07-17 23:18:46 [INFO] <dasbreen> it's coming out great
    2011-07-17 23:18:58 [INFO] <amukon> like i said, could use the help to build more buildings as i am running out of ideas
    2011-07-17 23:19:08 [INFO] <dasbreen> yea
    2011-07-17 23:19:15 [INFO] <amukon> i got 10 building here
    2011-07-17 23:19:21 [INFO] <dasbreen> so the unfinished building here is town hall you said?
    2011-07-17 23:19:29 [INFO] <amukon> plus a spot for a boat
    2011-07-17 23:19:46 [INFO] <amukon> the one with the laight on it
    2011-07-17 23:19:54 [INFO] <amukon> i am standing in it
    2011-07-17 23:19:59 [INFO] <amukon> the town hall
    2011-07-17 23:20:02 [INFO] <amukon> eventually
    2011-07-17 23:20:03 [INFO] <dasbreen> kk
    2011-07-17 23:20:17 [INFO] <amukon> and then i ahave a foundation for another building
    2011-07-17 23:20:19 [INFO] <dasbreen> whats this 2 story one here
    2011-07-17 23:20:26 [INFO] <amukon> a huse
    2011-07-17 23:20:32 [INFO] <amukon> house*
    2011-07-17 23:20:51 [INFO] <dasbreen> is there supposed to be a ladder to the roof or no?
    2011-07-17 23:21:01 [INFO] <amukon> ...
    2011-07-17 23:21:09 [INFO] <amukon> most have flight anyway
    2011-07-17 23:21:16 [INFO] <dasbreen> i know, i'm just curious
    2011-07-17 23:21:20 [INFO] <amukon> yes
    2011-07-17 23:21:36 [INFO] <dasbreen> very nice
    2011-07-17 23:21:54 [INFO] <dasbreen> you going to leave the well open or do you want water in it?
    2011-07-17 23:22:16 [INFO] <amukon> ur welcome to build anybuildning u want here, as long has it has a noutical or small town vibe
    2011-07-17 23:22:46 [INFO] <dasbreen> to be honest i'll probably spelunk a bit around here
    2011-07-17 23:23:03 [INFO] <dasbreen> just cuz it's in my nature to do so
    2011-07-17 23:23:24 [INFO] <amukon> there are a lot of caves around here
    2011-07-17 23:23:26 [WARNING] dasbreen moved wrongly!
    -snip (irrelevant error)
    2011-07-17 23:24:29 [WARNING] amukon moved wrongly!
    -snip (irrelevant error)
    2011-07-17 23:25:02 [INFO] <dasbreen> made a couple of signs, come see :D
    2011-07-17 23:25:03 [INFO] <amukon> well, i am looging of for the night, goodnight brian
    2011-07-17 23:25:17 [INFO] <dasbreen> waaaaaaaaait
    2011-07-17 23:25:19 [INFO] <dasbreen> come see :P
    2011-07-17 23:25:33 [SEVERE] java.net.SocketException: Connection reset by peer: socket write error
    -snip (irrelevant error)
    2011-07-17 23:25:33 [SEVERE] java.net.SocketException: Connection reset by peer: socket write error
    -snip (irrelevant error)
    2011-07-17 23:25:33 [INFO] amukon lost connection: disconnect.endOfStream
    2011-07-17 23:25:48 [INFO] amukon [/69.183.146.119:2252] logged in with entity id 140020 at ([world] -114.40625, 69.0, 197.96875)
    2011-07-17 23:26:07 [INFO] <amukon> ummm
    2011-07-17 23:26:10 [INFO] <dasbreen> here
    2011-07-17 23:26:44 [SEVERE] java.net.SocketException: Connection reset by peer: socket write error
    -snip (irrelevant error)
    2011-07-17 23:26:44 [SEVERE] java.net.SocketException: Connection reset by peer: socket write error
    -snip (irrelevant error)
    2011-07-17 23:26:44 [INFO] amukon lost connection: disconnect.endOfStream
    2011-07-17 23:26:58 [INFO] amukon [/69.183.146.119:2325] logged in with entity id 142614 at ([world] -101.71875, 69.0, 197.96875)
    2011-07-17 23:27:09 [INFO] <amukon> you know the tower?
    2011-07-17 23:27:25 [INFO] <amukon> there is a spot for a trian station insiode it
    2011-07-17 23:27:54 [INFO] <dasbreen> this one?
    2011-07-17 23:27:59 [INFO] <amukon> follow me
    2011-07-17 23:28:37 [INFO] <amukon> right in there
    2011-07-17 23:28:40 [INFO] <dasbreen> ok
    2011-07-17 23:28:46 [INFO] <dasbreen> i'll make it work then
    2011-07-17 23:28:58 [INFO] <amukon> i never finished it
    2011-07-17 23:29:02 [INFO] <dasbreen> that's fine
    2011-07-17 23:29:05 [INFO] <amukon> but it is there
    2011-07-17 23:29:10 [INFO] <dasbreen> railroads are my specialty :P
    2011-07-17 23:29:19 [INFO] <dasbreen> i'll work on it tomorrow after work most likely
    2011-07-17 23:29:44 [INFO] <amukon> try to use smooth stone
    2011-07-17 23:29:51 [INFO] <dasbreen> ok
    2011-07-17 23:30:06 [INFO] <amukon> there aer furnaces above with a bunch of smoothstone
    2011-07-17 23:30:29 [INFO] <dasbreen> ok
    2011-07-17 23:30:35 [INFO] <dasbreen> i'll probably grab some from my lair too
    2011-07-17 23:30:46 [INFO] <dasbreen> got 2 full chests of cobble/smooth
    2011-07-17 23:30:59 [INFO] <dasbreen> i'll cook the cobble and grab the smooth
    2011-07-17 23:31:14 [INFO] <amukon> aky
    2011-07-17 23:32:53 [INFO] <amukon> these cheset out side on the docks hjave lots of reasources in it
    2011-07-17 23:32:58 [INFO] <dasbreen> i saw
    
    [COLOR=rgb(0, 128, 128)]save should have been here[/COLOR]
    [COLOR=rgb(255, 0, 0)]as well as a back up[/COLOR]
    
    2011-07-17 23:33:28 [INFO] <amukon> including some smootthstone
    2011-07-17 23:33:28 [INFO] <dasbreen> made a harbor warp
    2011-07-17 23:33:36 [INFO] <dasbreen> type /warp harbor
    2011-07-17 23:33:57 [INFO] <dasbreen> you get a nice view coming in
    2011-07-17 23:34:14 [INFO] <amukon> u might want to put that into the anouncements or email the command out
    2011-07-17 23:34:28 [INFO] <dasbreen> i kind of have already, just type /warp list
    2011-07-17 23:34:32 [INFO] <dasbreen> or /warp list 2
    2011-07-17 23:34:49 [INFO] <dasbreen> it'll list which warps are made, and which are private
    2011-07-17 23:35:17 [INFO] <dasbreen> but i'll add key visitation locations to the commands list
    2011-07-17 23:35:50 [INFO] <dasbreen> such as the harbor and the pyramid, although the harbor is coming out better i think
    2011-07-17 23:35:58 [INFO] <dasbreen> we need to put stuff IN the pyramid next
    2011-07-17 23:36:03 [INFO] <dasbreen> have you talked to legs at all lately?
    2011-07-17 23:36:11 [INFO] <amukon> that is legs all the way
    2011-07-17 23:36:33 [INFO] <dasbreen> k
    2011-07-17 23:36:51 [INFO] <amukon> did u find the furnace room?
    2011-07-17 23:37:20 [INFO] <dasbreen> nah i went back /home
    2011-07-17 23:37:21 [INFO] <dasbreen> lol
    2011-07-17 23:38:31 [INFO] <amukon> oh, i triad placing TNT agian
    2011-07-17 23:38:38 [INFO] <amukon> and i couldn't
    2011-07-17 23:38:43 [INFO] <amukon> y?
    2011-07-17 23:38:47 [INFO] <dasbreen> i disabled tnt for everyone for the time being
    2011-07-17 23:38:53 [INFO] <dasbreen> just cuz whitmore was complaining
    2011-07-17 23:38:56 [INFO] <amukon>: is sad
    2011-07-17 23:38:57 [INFO] <dasbreen> and rather than give you all tnt
    2011-07-17 23:39:01 [INFO] <dasbreen> i took it away
    2011-07-17 23:39:08 [INFO] <dasbreen> i'd rather not have a bunch of craters :P lol
    2011-07-17 23:39:23 [INFO] <dasbreen> plus when the higherexplosives plugin updates, hopefully he can reinstate punching
    2011-07-17 23:39:28 [INFO] <dasbreen> as a igniter
    2011-07-17 23:39:32 [INFO] <dasbreen> or a primer
    2011-07-17 23:39:35 [INFO] <dasbreen> so you don't break it
    2011-07-17 23:39:37 [INFO] <amukon> i was using it to clear some islands that were in the way of the harbor
    2011-07-17 23:39:39 [INFO] <dasbreen> it arms and goes boom
    2011-07-17 23:39:48 [INFO] <dasbreen> just /ib them
    2011-07-17 23:40:01 [INFO] <dasbreen> it'd be easier to fix them at that point too :D
    2011-07-17 23:40:10 [INFO] <amukon> haha
    2011-07-17 23:41:09 [INFO] <amukon> do u have a plugin that changes gravel into clay when hit with water?
    2011-07-17 23:41:14 [INFO] <dasbreen> yes
    2011-07-17 23:41:28 [INFO] <dasbreen> it's an older feature of the predecessor of craftbukkit
    2011-07-17 23:41:33 [INFO] <dasbreen> from what i've read
    2011-07-17 23:41:42 [INFO] <dasbreen> or atleast an old out of date plugin
    2011-07-17 23:41:51 [INFO] <dasbreen> but clay is such a pain to find otherwise
    2011-07-17 23:42:04 [INFO] <dasbreen> now it's just get some gravel and some water and boom
    2011-07-17 23:42:05 [INFO] <dasbreen> clay
    2011-07-17 23:42:24 [INFO] <dasbreen> you can actually drop it in water, you don't have to place each block
    2011-07-17 23:42:32 [INFO] <dasbreen> so if you drop a whole 64 stack of gravel
    2011-07-17 23:42:38 [INFO] <dasbreen> you get 4x 64 stacks of clay
    2011-07-17 23:42:58 [INFO] <dasbreen> and ultimatelyl a 64 stack of bricks
    2011-07-17 23:43:42 [INFO] <amukon> goodnight
    2011-07-17 23:43:45 [INFO] <dasbreen> good night
    2011-07-17 23:43:51 [INFO] amukon lost connection: disconnect.quitting
    2011-07-17 23:43:51 [INFO] Connection reset
    2011-07-17 23:50:08 [INFO] dasbreen lost connection: disconnect.quitting
    2011-07-17 23:50:08 [INFO] Connection reset
    2011-07-17 23:50:08 [INFO] [StealthLogin] dasbreen logged out secretly!
    2011-07-17 23:51:18 [INFO] dasbreen [/127.0.0.1:64028] logged in with entity id 187651 at ([world] -15.34375, 75.0, 20.28125)
    2011-07-17 23:51:18 [INFO] CraftPlayer{name=dasbreen} logged in with entity id187651
    2011-07-17 23:51:18 [INFO] [StealthLogin] dasbreen logged in secretly!
    2011-07-17 23:52:52 [WARNING] dasbreen moved wrongly!
    -snip (irrelevant error)
    2011-07-17 23:56:28 [INFO] Connection reset
    2011-07-17 23:56:28 [INFO] dasbreen lost connection: disconnect.quitting
    
    [COLOR=rgb(255, 0, 0)]and finally one last back up here[/COLOR]
    
    2011-07-17 23:56:28 [INFO] [StealthLogin] dasbreen logged out secretly!
    2011-07-18 01:40:13 [INFO] Stopping the server..
    2011-07-18 01:40:13 [INFO] Stopping server
    -snip (plugins disabling)
    [COLOR=rgb(255, 0, 0)]2011-07-18 01:40:13 [INFO] SimpleSave: Powered down[/COLOR]
    -snip (plugins disabling)
    2011-07-18 01:40:13 [INFO] Saving chunks
    2011-07-18 01:40:13 [INFO] Stopping server
    
    none of the errors in the server log are from simplesave or any plugins, just the one user disconnecting a bunch and a couple moved wrongly.
     
  7. Offline

    fffizzz

    still no backups since manual backup this morning. plugin is broken with 3.24

    for giggles, im gonan let it generate a new config.
     
  8. Offline

    ACStache

    for the time being i've removed it, and told everyone to /save-all occasionally (they're all OPs lol)
     
  9. Offline

    desmin88

    @ACStache
    @fffizzz
    I'm aware of the issue, and am going about the best way to fix it.

    For the meantime, setting plugin.ignore.noplayers to false will fix it.
     
  10. Offline

    ACStache

    cool, can't wait to be running at 100% again :)
     
  11. Offline

    fffizzz

    Thank you kind sir :)
     
  12. Offline

    desmin88

    @ACStache
    @fffizzz
    Mind trying now with 3.25? I can't reproduce the error as I've said before, so I'm blindly fixing it...
     
  13. Offline

    ACStache

    when I get home, most certainly. I tend to browse the bukkit forums during downtime at work :p lol
     
  14. Offline

    fffizzz

    well, on a reload, it performed a backup, which is better than its done in 3.24, will let ya know how its going in a couple hours.

    thanks for quick response
     
  15. Offline

    desmin88

    @fffizzz
    Sweet. I think I fixed it.
     
  16. Offline

    fffizzz

    @desmin88
    I need to let it go a little longer, no backup occured during the 2pm hour, last backup was 1:10pm, and its now 3:10. the one at 1:10 was when i loaded 3.25 and it backed up on reload.

    Ill keep ya posted.

    Wish I had good news but I dont. No new backups...

    Also worth mentioning, a grep of the server.log for SimpleSave reveals nothing since the last restart 4 hours ago. Backup interval is 60.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 17, 2016
  17. Offline

    toffo

    Just a thought, we're playing with downloaded maps on our server, some that are a few hundred megs on they own. Would it be possible to disable backup for some worlds?

    Like a config option with a comma-separated list? ie.
    Code:
    backup.ignoreworlds=worldtemp,worldother
     
  18. Offline

    fffizzz

    reading the first post goes a long way :)
    backup.world.filter=; Worlds to not backup, example custom1,custom2,custom3
     
    masasuka likes this.
  19. Offline

    toffo

    Lol, thanks @fffizzz, I guess I should have went to bed earlier than I did, and now I'm here again cause I saw that someone answered on my cellphone.. I didn't notice that, I actually "tried" reading through the config codeblock in the first post before I posted, but I guess I was too tired to find that ;)

    Thanks though, I will surely try that out tomorrow! :D
     
  20. Offline

    JukeboxJohnny

    I keep getting this error:
    Code:
    00:20:08 [INFO] SimpleSave: Parts of config file are blank, but not null. Possible errors might happen.
    
    Yet there are no empty parts on my config:
    Code:
    #SimpleSave Config File
    #Wed Jul 20 00:17:17 EDT 2011
    save.interval=30
    save.use=true
    backup.message.ending=Backup complete.
    backup.message.starting=Backup beginning. Prepare for possible lag.
    backup.directory=backup
    backup.history.length=24
    save.message.send=true
    backup.use=true
    plugin.send.saveoff-on=true
    backup.interval=60
    plugin.ignore.noplayers=false
    backup.world.filter=;
    save.message.color=RED
    backup.message.color=RED
    plugin.version=3.1
    backup.message.send=true
    save.message.starting=World save beginning.
    save.message.ending=World save complete.
    backup.date.format=yyyy-MM-dd hh-mm-ss
    
    What can I do? I'm at a loss here. I've removed the config file to let it generate a new one, configured that new one, and I still get this.
     
  21. Offline

    ACStache

    if you notice the line right below that, it says:
    Code:
    [INFO] SimpleSave: DON'T! Post this 'warning' on the thread.
    
    basically it's fine. the only part you have blank is the back.world.filter, and that's not required to be filled in. putting a world in that section omits it from being backed up.

    On another note: @desmin88 I'm still not seeing any back ups happening on 3.25. been running the server for several hours (and was logged in for most of them). I didn't change my config at all, but I might go mess with it in a moment to see if anything different happens.
     
  22. Offline

    JukeboxJohnny

    I also am not seeing any backups either. I have my interval set to 60minutes (seen above) and there hasn't been any activity since I updated to 3.25.
     
  23. Offline

    wassilij

    I get heavy laggs with this plugin.

    Bukkit 1000.
     
  24. Offline

    Andys

    Strange problem - it does not shedule autosaves/backups when I start server or reload with no players.
    When I start server I do not get [INFO] SimpleSave: Current save interval is xxx minute(s). No autosaves or backups are run after that. I can run only manual ssbackup.
    When I run 'reload' on empty server I do not get that either.
    When I run 'reload' and then one player logs in, it still doesn't run saves, I waited for a hour and nothing. Intervals are set to 5-10 minutes (just to test it before adding to server permanently).

    BUT when there's at least one person logged in and I run reload - It works. Prints 'Current save interval is xxx minute(s)'. And correctly runs the saves/backup in set intervals.
    config is default, except intervals (1 and 3 mins) and plugin.ignore.noplayers=true
    versions - Craftbukkit 953, SimpleSave 3.25
    Dunno, maybe I am doing something wrong?
     
  25. Offline

    DarthNinja

    I'd also like to see a force-backup command. [cake]

    This may have been reported, but it seems like saves/backups won't start running until I manually run a /save-all.
    -Edit: Also just noticed I'm out of date with version 3.1, so ignore any of this post that no longer applies.
     
  26. Offline

    fffizzz

    Darth: /ssbackup, or ssbackup from console.
     
  27. Offline

    DarthNinja

    Cool, thanks
     
  28. Offline

    JokerReaction45

    I'm having an issue. Not does it not save it never backs up my worlds. It just doesnt.
    And another Q. When the worlds are backed up, does it have it's onfile where they are saved or logged?
     
  29. Offline

    dunem

    IMPORTANT
    this plugin has caused adverse effects on our server.

    It mearly sends a global message saying "saving"

    it DOES NOT SAVE CHUNKS and therefore is not a save plugin!!!

    Each time we have restarted our server AFTER using the simplesave, NO blocks were saved and we lose upto 15 minutes of work each time we use it.

    Plugin has since been removed.
     
  30. Offline

    Remnant

    Since updating my server will not initiate saves. The only way I can get it to save is to use the ssbackup command. I see others having the same problem. Anyone have a solution for this with the 3.25 version?
     
  31. Offline

    DarthNinja

    fyi desmin88:
    It looks like the version listed in the 3.25 config file is still 3.1.
     

Share This Page