[INACTIVE][ADMN] BukkitUpdater v0.3 - Plugin Manager for CraftBukkit [670]

Discussion in 'Inactive/Unsupported Plugins' started by KokaKiwi, Mar 3, 2011.

  1. Offline

    KokaKiwi

    BukkitUpdater - Plugin Manager for CraftBukkit:
    Version: v0.3

    BukkitUpdater is a plugin manager which allow you to control plugins like packet manager 'apt' for Linux.

    Plugins list is based on decentralized plugin's repositories (XML files), which can be personalised in config.yml file.

    A XML plugin's repository should be written as follows:

    Code:
    <plugin>
        <id>bukkitupdater</id>  <!-- Plugin ID, must be in lower case - REQUIRED -->
        <name>BukkitUpdater</name> <!-- Plugin name, must be the same name that plugin's description show - REQUIRED -->
        <version>0.1</version> <!-- Version, must be in format "NUMBER.NUMBER.etc..." NO LETTERS! - REQUIRED -->
        <author>KokaKiwi</author> <!-- Author, not used but - REQUIRED -->
        <url>http://github.com/KokaKiwi/BukkitUpdater</url> <!-- Plugin website URL - OPTIONAL -->
        <file-type>archive</file-type> <!-- File type (jar for .jar, archive for .zip) Tar.Gz not implemented - REQUIRED -->
        <file-url>http://kokakiwi.github.com/test.zip</file-url> <!-- Plugin file URL - WARNING : Don't use https:// in file URL, BukkitUpdater couldn't check them for the moment - REQUIRED -->
        <dependencies> <!-- Plugin dependencies - OPTIONAL -->
            <dep id="kiwiplugin" version="1.1" /> <!-- Plugin dependency, "id" is dependency's ID, version not used - OPTIONAL -->
        </dependencies>
        <website>http://www.minerepo.tk</website>
        <description>Bukkit plugins and core updater</description>
        <bukkit-build>670</bukkit-build> <!-- CraftBukkit Core Build dependency - OPTIONAL -->
    </plugin>
    A website is in preparation. It will allow all plugins developers to register their plugins to an "official" repository.

    Features:
    • Based on decentralized plugin's repositories (XML files)
    • Allow you to install a plugin directly from console or IG
    Commands: /updater <subcommand> <args> (Works in console too, without "/")

    • /updater update : Update all installed plugins
    • /updater check : Check updates, but didn't download them
    • /updater install <pluginID> : Install a plugin defined by his ID
    • /updater remove <pluginID> : Remove a plugin defined by his ID
    • /updater purge <pluginID> : Remove a plugin and delete his data folder (usually "plugins/[pluginName]")
    • /updater enable <pluginID|pluginName> : Enable a plugin
    • /updater disable <pluginID|pluginName> : Disable a plugin
    • /updater load <pluginName> : Load a jar file located at "plugin" folder with name "[pluginName].jar"
    • /updater info <pluginID> : Get infos about a plugin
    Download BukkitUpdater
    Source Code

    Changelog:
    Show Spoiler

    Version 0.3
    • Added Info command
    • Improved List command
    • Added website and description field to plugin definition in XML file
    • Some minors modifications
    Version 0.2.3
    • Added eisental fixes and adding :)
    Version 0.2.2
    • Bugs fixes
    Version 0.2.1
    • Quick changes to fix somes urgent bugs.
    • Changed repository to MineRepo repository
    Version 0.2
    • Added "/updater list" command (only installed subcommand is on, "avalailable" is unimplementable, too long if there is a lot of plugins)
    • Added "http://bukkitupdater.tk/updateList.xml" to default repositories. You must delete your config.yml file to update it!
    Version 0.1.1
    • Added local repository
    • Fixed somes bugs
    Version 0.1
    • First release, with some bugs that will be fixed soon

    ToDo:
    • Add a cache system (to prevent error during loading update lists)
    • Add dependencies versions support (some plugins can't work with certains plugins version)
    • Add plugin files cache, for backup old plugins versions (if new version crash the server)
     
    ksevelyar and cobra1162 like this.
  2. Offline

    Ismoh

    i cannot change updateList.xml :-/
    so that i cant use this plugin

    i changed updateList.xml after that i overwrote the old updateList.xml...after i started Server updateList.xml was automatically overwrote and the old updateList.xml is used -.-
     
  3. Offline

    KokaKiwi

    You can host your own updateList.xml with your plugins list, and add it to 'plugins/BukkitUpdater/config.yml' config file ;)
    For now, I must fill the default repository referenced in default config file (http://www.kokabsolu.com/updateList.xml) :eek:
    --- merged: Mar 4, 2011 3:25 PM ---
    Hum, files contained in 'plugins/BukkitUpdater/caches' are temporary files for a future feature (a cache system), and they are overwrited each time BukkitUpdater download lists :/
    I'll add a local repository for users who wants made their own repository ;)
     
  4. Offline

    Ismoh

    omg :D
    im such stupid...
    im really sorry!
    thank you :-*


    Edit:
    Wonderfull!
    It works well! ;)
    Thank you!
     
  5. Offline

    Wulfspider

    Looks great so far! Thanks :)
     
  6. Offline

    RioS

    Hi, I got the following error when I try to use your plugin.

    Can you help me ?

    17:21:36 [INFO] BukkitUpdater : None permissions plugins loaded, using OPs settings!
    17:21:36 [INFO] BukkitUpdater : Updating...
    17:21:37 [ATTENTION] BukkitUpdater : Error during downloading 'http://jenkins.lukegb.com/job/dev-C...rtifact/target/craftbukkit-0.0.1-SNAPSHOT.jar'
    17:21:37 [GRAVE] java.io.FileNotFoundException: bukkitUpdater/craftbukkit-0.0.1-SNAPSHOT.jar (No such file or directory)
    17:21:37 [GRAVE] at java.io.FileOutputStream.open(Native Method)
    17:21:37 [GRAVE] at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
    17:21:37 [GRAVE] at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
    17:21:37 [GRAVE] at org.kokakiwi.bukkitupdater.utils.FileDownloader.download(FileDownloader.java:34)
    17:21:37 [GRAVE] at org.kokakiwi.bukkitupdater.updater.BUpdater.update(BUpdater.java:193)
    17:21:37 [GRAVE] at org.kokakiwi.bukkitupdater.BukkitUpdater.onEnable(BukkitUpdater.java:55)
    17:21:37 [GRAVE] at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:140)
    17:21:37 [GRAVE] at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:424)
    17:21:37 [GRAVE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:187)
    17:21:37 [GRAVE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:80)
    17:21:37 [GRAVE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
    17:21:37 [GRAVE] at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:198)
    17:21:37 [GRAVE] at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:185)
    17:21:37 [GRAVE] at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    17:21:37 [GRAVE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:240)
    17:21:37 [GRAVE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    17:21:37 [INFO] BukkitUpdater : New CraftBukkit build available (#493), this server using build #463 !
    17:21:37 [INFO] You should update the server. New version downloaded in bukkitUpdater folder.
     
  7. Offline

    KokaKiwi

  8. Offline

    RioS

    Thanks, it works now.

    You should add a command to list available plugins.
    e.g:
    /updater list [intalled/available]

    How the local repository works ?

    /updater remove <pluginID> and /updater purge <pluginID> don't work.
    They try to install the plugin :x
     
  9. Offline

    KokaKiwi

    Yeah, good idea :D I'll add this in next version ;)

    It's works as the remote repositories, the plugin load it after others repositories ;)

    Arf >< I had forgotten these commands sorry :s
    I'll fix it soon, thanks for report :)
     
  10. Offline

    Ismoh

    gota new error after updating BukkitUpdater 0.1 to BukkitUpdatert 0.1.1:
    you know how to fix?
     
  11. Offline

    Wulfspider

    Yeaaah, I still haven't figured out how to get the plugin to utilize the local repository. I have the updateList.xml under the BukkitUpdater folder, but it still doesn't load it. I can't specify a local file directory in the config.yml, because that causes errors, and I've tried putting it in cache, which doesn't do anything either. Where does the file go and what should it be named?
     
  12. Offline

    KokaKiwi

    Ah, it's the BukkitUpdater listed in local repository, and it's a false plugin reference :/
    I'll change it soon
    --- merged: Mar 5, 2011 6:31 PM ---
    The local repository is located at plugins/BukkitUpdater/cache/local.xml ;)
     
  13. Offline

    Wulfspider

    Well, I did that... and it deleted it! I didn't save a copy elsewhere, so trying to find and undelete it now... haha.
     
  14. Offline

    Ismoh

    Thanks a lot ;)
    Ill keep watching ur thread caus i lov ur plugin
     
  15. Offline

    EvilSeph Retired Staff

    Please test your plugin with the latest Recommended Build (493) and update your release post accordingly as it is now a requirement of the submissions process, since the newest RB contains breakages.
     
  16. Offline

    KokaKiwi

    Sorry, I can't work on BukkitUpdater yet because I've some others things to do :(
    I think I can update BukkitUpdater for thursday ;)

    I've tested BukkitUpdater with CraftBukkit build 493, and it's work fine :)
    I'll update post title ;)
     
  17. Offline

    Beaverbeliever

    This is an awesome idea! You should add a form to allow people to add plugins to the list! I would be happy to add on to it.
     
  18. Offline

    GizmoTheGreen

    this looks really awesome
     
  19. Offline

    KokaKiwi

    New plugin update!
    I've fixed remove and purge subcommands, added "list" subcommand and added a new default repository.

    I didn't have implemented "list available" subcommand. If the repositories contains a lot of plugin, it could be unreadable :/

    A website is in construction (http://bukkitupdater.tk), and it will allow plugins developers to register their plugins to an "official" plugins repository easily :)

    New update available at: https://github.com/downloads/KokaKiwi/BukkitUpdater/BukkitUpdater-0.2.jar

    PS: 250 downloads! YEAH o/
     
  20. Offline

    Oldcustard

    I recently downloaded build 531 but BukkitUpdater keeps telling me I have 516 and it "downloads" 531, but when I replace my jar with the downloaded one, it claims it is 516, therefore downloading again. But it downloads 516 [​IMG]

    Also when I added the new repository to the config.yml and started the server, it received a 500 HTTP status code.
    Any help?

    Great plugin, just can't use it yet :D
     
  21. Offline

    KokaKiwi

    Er, I don't know...An other updater plugin tell me the same thing :/
    It could be a problem during extract build number in CraftBukkit version I think :eek:
    It's normal, i didn't create the new repository yet, I'll add it when website is done ;)
     
  22. Offline

    Wulfspider

    Version is still showing as 0.1 even though I've downloaded the latest BukkitUpdater twice.
    Also getting the CB 516 issue when I am in fact using CB 531.

    Could you add an option to change where the updates are downloaded to? I'd appreciate that.

    You should remove the http://bukkitupdater.tk/updateList.xml from your OP to avoid any confusion until you get it up and running.
     
  23. Offline

    KokaKiwi

    The website should be up soon, I've other things to do before (I've a Bukkit server to administrate :p)
    Pending, you should remove http://bukkitupdater.tk/updateList.xml from repositories list ;)

    PS: 400 downloads!
     
  24. Offline

    Manyman

    18:11:59 [INFO] BukkitUpdater : Using Group Manager v0.99c
    18:11:59 [INFO] BukkitUpdater : Local repository created.
    18:11:59 [INFO] BukkitUpdater : Updating...
    18:12:00 [WARNING] BukkitUpdater : Error during downloading 'http://bukkitupdater.tk/updateList.xml'
    18:12:00 [SEVERE] java.io.IOException: Server returned HTTP response code: 500 for URL: http://bukkitupdater.tk/updateList.xml
    18:12:00 [SEVERE] at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    18:12:00 [SEVERE] at java.net.URL.openStream(Unknown Source)
    18:12:00 [SEVERE] at org.kokakiwi.bukkitupdater.utils.FileDownloader.download(FileDownloader.java:33)
    18:12:00 [SEVERE] at org.kokakiwi.bukkitupdater.updater.BUpdater.downloadLists(BUpdater.java:58)
    18:12:00 [SEVERE] at org.kokakiwi.bukkitupdater.updater.BUpdater.update(BUpdater.java:174)
    18:12:00 [SEVERE] at org.kokakiwi.bukkitupdater.BukkitUpdater.onEnable(BukkitUpdater.java:67)
    18:12:00 [SEVERE] at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:117)
    18:12:00 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:414)
    18:12:00 [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:187)
    18:12:00 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:80)
    18:12:00 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
    18:12:00 [SEVERE] at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    18:12:00 [SEVERE] at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    18:12:00 [SEVERE] at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    18:12:00 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    18:12:00 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    18:12:01 [WARNING] BukkitUpdater : Error during parsing repository '1300174920078.25348.updateList.xml'
    18:12:01 [SEVERE] java.io.FileNotFoundException: C:\Documents and Settings\Jake\My Documents\Bukkit\plugins\BukkitUpdater-0.2\cache\1300174920078.25348.updateList.xml (The system cannot find the file specified)
    18:12:01 [SEVERE] at java.io.FileInputStream.open(Native Method)
    18:12:01 [SEVERE] at java.io.FileInputStream.<init>(Unknown Source)
    18:12:01 [SEVERE] at java.io.FileInputStream.<init>(Unknown Source)
    18:12:01 [SEVERE] at sun.net.www.protocol.file.FileURLConnection.connect(Unknown Source)
    18:12:01 [SEVERE] at sun.net.www.protocol.file.FileURLConnection.getInputStream(Unknown Source)
    18:12:01 [SEVERE] at com.sun.org.apache.xerces.internal.impl.XMLEntityManager.setupCurrentEntity(Unknown Source)
    18:12:01 [SEVERE] at com.sun.org.apache.xerces.internal.impl.XMLVersionDetector.determineDocVersion(Unknown Source)
    18:12:01 [SEVERE] at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
    18:12:01 [SEVERE] at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
    18:12:01 [SEVERE] at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
    18:12:01 [SEVERE] at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
    18:12:01 [SEVERE] at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
    18:12:01 [SEVERE] at org.jdom.input.SAXBuilder.build(SAXBuilder.java:518)
    18:12:01 [SEVERE] at org.jdom.input.SAXBuilder.build(SAXBuilder.java:905)
    18:12:01 [SEVERE] at org.jdom.input.SAXBuilder.build(SAXBuilder.java:884)
    18:12:01 [SEVERE] at org.kokakiwi.bukkitupdater.updater.BUpdater.updateLists(BUpdater.java:100)
    18:12:02 [SEVERE] at org.kokakiwi.bukkitupdater.updater.BUpdater.update(BUpdater.java:175)
    18:12:02 [SEVERE] at org.kokakiwi.bukkitupdater.BukkitUpdater.onEnable(BukkitUpdater.java:67)
    18:12:02 [SEVERE] at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:117)
    18:12:02 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:414)
    18:12:02 [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:187)
    18:12:02 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:80)
    18:12:02 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
    18:12:02 [SEVERE] at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    18:12:02 [SEVERE] at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    18:12:02 [SEVERE] at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    18:12:02 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    18:12:02 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
     
  25. Offline

    KokaKiwi

    @Manyman : It's normal, I've not finished the BukkitUpdater's Website yet. It will be fixed soon ;)
     
  26. Offline

    contex

    Looks sweet, looking forward to see more :) !
     
  27. Offline

    Josh Harwood

    Code:
    2011-03-24 00:21:53 [WARNING] BukkitUpdater : Error during parsing repository '1300922513476.39060.updateList.xml'
    2011-03-24 00:21:53 [SEVERE] org.jdom.input.JDOMParseException: Error on line 1 of document file:/minecraft/plugins/BukkitUpdater-0.2/cache/1300922513476.39060.updateList.xml: Premature end of file.
    2011-03-24 00:21:53 [SEVERE]    at org.jdom.input.SAXBuilder.build(SAXBuilder.java:530)
    2011-03-24 00:21:53 [SEVERE]    at org.jdom.input.SAXBuilder.build(SAXBuilder.java:905)
    2011-03-24 00:21:53 [SEVERE]    at org.jdom.input.SAXBuilder.build(SAXBuilder.java:884)
    2011-03-24 00:21:53 [SEVERE]    at org.kokakiwi.bukkitupdater.updater.BUpdater.updateLists(BUpdater.java:100)
    2011-03-24 00:21:53 [SEVERE]    at org.kokakiwi.bukkitupdater.updater.BUpdater.update(BUpdater.java:175)
    2011-03-24 00:21:53 [SEVERE]    at org.kokakiwi.bukkitupdater.BukkitUpdater.onEnable(BukkitUpdater.java:67)
    2011-03-24 00:21:53 [SEVERE]    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
    2011-03-24 00:21:53 [SEVERE]    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:451)
    2011-03-24 00:21:53 [SEVERE]    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:217)
    2011-03-24 00:21:53 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:92)
    2011-03-24 00:21:53 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:70)
    2011-03-24 00:21:53 [SEVERE]    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    2011-03-24 00:21:53 [SEVERE]    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    2011-03-24 00:21:53 [SEVERE]    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    2011-03-24 00:21:53 [SEVERE]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    2011-03-24 00:21:53 [SEVERE]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-24 00:21:53 [SEVERE] Caused by: org.xml.sax.SAXParseException: Premature end of file.
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:174)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:388)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1414)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(XMLDocumentScannerImpl.java:1059)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:140)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:511)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:808)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:119)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
    2011-03-24 00:21:53 [SEVERE]    at org.jdom.input.SAXBuilder.build(SAXBuilder.java:518)
    2011-03-24 00:21:53 [SEVERE]    ... 15 more
    2011-03-24 00:21:53 [SEVERE] Caused by:
    2011-03-24 00:21:53 [SEVERE] org.xml.sax.SAXParseException: Premature end of file.
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:174)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:388)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1414)
    2011-03-24 00:21:53 [SEVERE]    at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(XMLDocumentScannerImpl.java:1059)
    
     
  28. Offline

    Weegee

    Code:
    Could not load plugins/BukkitUpdater-0.2.jar in plugins: null
    org.bukkit.plugin.InvalidPluginException
    	at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:69)
    	at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:159)
    	at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:107)
    	at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
    	at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    	at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    	at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.util.zip.ZipException: error in opening zip file
    	at java.util.zip.ZipFile.open(Native Method)
    	at java.util.zip.ZipFile.<init>(ZipFile.java:127)
    	at java.util.jar.JarFile.<init>(JarFile.java:135)
    	at java.util.jar.JarFile.<init>(JarFile.java:99)
    	at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:56)
    	... 8 more
    
    Using craftbukkit 566 ... what to do? D:
     
  29. Offline

    Wulfspider

    Go back to the latest recommended build of CraftBukkit?


    @KokaKiwi , you are still grabbing the wrong info for the CraftBukkit build.
    git-Bukkit-0.0.0-544-g6c6c30a-b556jnks (MC: 1.3)

    You should be grabbing the 556, not the 544. BukkitUpdater keeps trying to get the latest, when I already have it because of this.
     
  30. Offline

    N3X15

    Mind if I fork this as an eventual pull request? I have some dependency resolution code and an idea to implement pulling from Maven repo's (for SNAPSHOT builds).
     

Share This Page