Solved I Get A Error Loading My Plugin

Discussion in 'Plugin Development' started by telesew123, Jul 1, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    telesew123

    If you are reading this please help me whenever i load my plugin i get this error http://pastebin.com/bKEjDCGg If You need the code for my plugin its here http://pastebin.com/tZPDveWj if you need my plugin yml its right here
    name: HeroBuildsPlugin
    main: me.telesew123.herobuilds.Main
    version: 0.1
    description: HeroBuildsCustom
    auther: telesew123
    commands:
    hub:
    description: Teleports The Player To Hub
     
  2. Offline

    NoLiver92

    telesew123 Firstly its author not auther

    secondly theres a problem with the class path for the main, it cannot be found. as far as I can see the names are identical so i dont know exactly where the problem lies. are you sure that its the correct path in plugin.yml?
     
    CMG likes this.
  3. Offline

    telesew123

    i had two bukkit plugin devs see my code the error and my plugin.yml they see nothing wrong with it so i posted it on here

    and yes i am sure it is the right path

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 9, 2016
  4. Offline

    teej107

    telesew123 What have you tried? (Like actually reading the stacktrace). The problem is that this: me.telesew123.herobuilds.Main does not exist. How do I know? I read the stacktrace.
     
  5. Offline

    telesew123

    i know that but i copy and pasted my package name and them tried putting Main as main and Main i tried making a new plugin file and copying the code over with a different class name i don't know what else to try
     
  6. Offline

    Chew

    What does your plugin.yml look like?
     
  7. Offline

    teej107

    telesew123
    in your plugin.yml:
    main: your.package.that.contains.JavaPlugin (it is case sensitive)
     
  8. Offline

    agent6262

    Could we have a copy of you .jar that you created.
     
    daboross likes this.
  9. Offline

    Heirteir

    telesew123
    Are you sure you didn't put your plugin.yml in your package folder instead of your whole folder :/
    Also did you try turning your computer off then back on? (lol)
     
  10. Offline

    NoLiver92

    Very good point actually!

    telesew123 take a screenshot of your package explorer and post it here please, note please expand everything
     
  11. Offline

    telesew123

    Screenshot_20.png
     
  12. Offline

    agent6262

    Assuming you use eclipse(correct me if I'm wrong) what do you export into your jar?
     
  13. Offline

    NoLiver92

    That isnt a maven project, look at the tutorial and follow it. things have changed alot so you need to keep up with it. follow the tutorial and then post back with results.

    Tutorial
     
    chocolate_with likes this.
  14. Offline

    telesew123

    Okay thanks for the help
     
  15. Offline

    muuknl

    NoLiver92, what are you talking about maven. It is a normal java project, not maven
     
  16. Offline

    NoLiver92

    You obviously dont program much, since the update formats have changed therefore the tutorial has been updated and the plugins are written in a maven project. Look at the link for the tutorial and you will see that its now maven.
     
  17. Offline

    xTigerRebornx

    NoLiver92 It may be written to use Maven, that doesn't automatically make the other method obsolete and wrong to use. The other method works, and it is a choice to use whatever method they choose.
    There is more then one way to do things, and just because a tutorial says that one way is how its done, it doesn't mean all the other ways shouldn't be used.
     
    agent6262 likes this.
  18. Offline

    telesew123

    So still i don't get why my plugin won't load?
     
  19. Offline

    xTigerRebornx

    telesew123 If you have WinRAR/7Zip, check and see if you are exporting your classes with your jar.
    If you don't, export it again in eclipse and make sure the classes are being exported.
     
  20. Offline

    agent6262

    telesew123
    And be sure to include your plugin.yml
     
  21. Offline

    telesew123

    ok so i made one class which was called main but in the jar there are 2 classes Main$1 and Main leads to my plugin.ywl main$1 leads to my code but there is no plugin.ywl file in the jar
     
  22. Offline

    xTigerRebornx

    telesew123 You need to export the plugin.yml w/ your jar.
     
  23. Offline

    telesew123

    It worked! thanks for helping me sorry if i was annoying i am just starting out in making plugins and couldn't figure outt this error thank you
     
Thread Status:
Not open for further replies.

Share This Page