Solved [Help] Towny regenerates chunks.

Discussion in 'Bukkit Help' started by LynnJordison, Apr 12, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hi, before I start I'd like to say thanks for any help you can provide.

    I've been running a server for a couple of months. I'm using Towny and there's a problem when someone unclaimes a town block.
    I have changed usingPlotManagementRevert to false but it keeps happening and even if I //regen them with WorldEdit, it keeps regenerating in a wrong way. There are like big holes in the zone that go down to bedrock, and some sort of "colums" with bedrock or lava on the top layers.
    I have disabled Towny and now it doesn't happen, and as I need to use Towny I don't know how to fix this.

    The bukkit version is 1.2.4-R1.0-b2126 and the Towny's

    Thanks for any help and sorry for my english!
  2. Offline


  3. Offline


    I figured out how to solve it!
    Once you have the flags set to false, theres a file inside Towny's 'data' folder called regen.txt, there you will have listed a queue of chunks, those are the ones that are going to be regenerated, and there's no way to stop it unless you delete everything them from that list. I verified them and they were the numbers of the chunks I was having problems with.
    Just delete that list (not the file), and if you have the flags set to false, it shouldn't happen again.
    At least that worked for me and now they don't regenerate anymore :D of course the chunks won't go back to their original state but I thinks it's better this way.

    I really hope it helps you!
    andrewpo likes this.
  4. Offline


    If your issue is resolved, please change the prefix of your topic title to Solved by going to Thread Tools then 'Edit Thread'
    LynnJordison likes this.
  5. Offline


    Done. I tried but I couldn't figure out how to change that, sorry D:

    Thank you very much!
Thread Status:
Not open for further replies.

Share This Page