Admin [GUI/ADMIN]The Bukkit GUI Project v1.8.0.548 - A powerful, lightweight GUI - Port fowarding!

Discussion in 'Bukkit Tools' started by Bertware, Oct 5, 2011.

Thread Status:
Not open for further replies.
  1. v1.6.5.412 is available on www.get.bertware.net !
    Even after huge updates like 1.7, the GUI still works. build 412 fixes some minor issues with the playerlist on MC 1.7 servers.

    In the meanwhile, I was able to make this screenshot:
    [​IMG]
    Port forwarding will be available in the next update :)
     
  2. Offline

    bvm1228

    For some reason when I updated to 1.6.5.410 this message has been flooding the console:
    FUCK ME: PacketPlayOutUpdateTime
    I tried starting my server using just a run.bat and the problem went away.
     
  3. The GUI doesn't affect the server. This seems like a plugin. You might be starting a different server when using the bat file.
     
  4. Offline

    bvm1228

    Ok I found the plugin. Also with 1.7.2, why doesn't the WARNING messages change colors anymore. Everything in the console is all blue.
     
  5. bvm1228 make sure you're using the dev build of the gui, found at get.bertware.net
     
  6. Portforwarding has been added in the dev build (v1.7.0.413)
    You can open the port forwarding dialog from the superstart tab. You can see existing settings and add new ports. Future updates will extend this functionality.
    http://get.bertware.net/detail/BukkitGUI
     
  7. Offline

    Jackilegs

    Hmm...I get an error when I click on "Set-up Port Forwarding"

    Show Spoiler
    Could not load file or assembly "Interop.NATUPNPLib, Version=1.0.0.0, Culture=neutral, PublicKeyToken=9c9e5ac8d47563bd" or one of its dependencies.The system cannot find the file specified

    [Details] [Continue] [Quit]


    If I click continue, when I try and add the port the same error appears.
     
  8. get the latest version, #414 (you're using #413 now I believe) Anyway, the last version from get.bertware.net, will fix this issue :)
     
  9. I'm always getting this error on server start: WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream

    This does only happen with BukkitGUI, not with Run.bat or similar.
    I'm using Spigot latest build and also your Dev Version of BukkitGUI.
     
  10. I'll check it out if I can prevent this, though it doesn't affect the server.
     
  11. Bertware in what language did you write it (I guess a C one?)
     
  12. Datdenkikniet vb.net :)

    In the meanwhile: since v1.7.1.418, the plugin manager can link your installed plugins to their online equivalent 100% correct, meaning there aren't any mismatches. You can't update to the wrong plugin anymore :) (there still are about 4% defective plugins on bukkitdev, you can't update those)
     
  13. I keep getting this warning message in the bukkitGUI. Any idea how to fix it, or if its related to the GUI?
    7:15:17 AM [warning] 07:15:17,061 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream
     
  14. That doesn't affect the server at all. I did some testing, and no matter how I launch the server that message appears, but it doesn't affect the correct working or anything.
     
  15. Thanks!
     
  16. Update:
    There have been some minor bugfixes and improvements.
    Spigot updates are now possible from within the GUI.

    As always, you can find the latest builds on http://get.bertware.net
     
  17. Offline

    Blocky4Programs

  18. Offline

    zarkann

    can someone tell me if this should be working on Windows 8.1 ? im having a popup 'has stopped working' on my server. always worked fine before until i updated to win8.1

    i do have the c++ 2013 redist/ java 7 update 51/.net 3.5 and 4(.5?)

    folder is not read only, and im starting the gui as admin.

    all permissions are 'full control'.

    im starting to regret the win8.1 update :(
     
  19. Offline

    Blocky4Programs

    zarkann
    Actually 8.1 in desktop mode is exactly the same as win 7...
    So it might just be a result of a setting that changed...
    Is it the server or the bukkitGUI that has stopped cause java can do some crazy stuff...
     
  20. Offline

    zarkann

    the server work just fine, thats whats puzzling me. everything work but the gui. i tried everything i think off and did search all over the place but cannot find anything.

    i am using the latest bukkit gui with the latest stable craftbukket 1.6.4.

    i have checked all permissions, deleted the appdata config, checked the registry but nothing.
     
  21. Offline

    zarkann

    one thing i did not tried and it just struct me right now is to replicate the batch file within the config.xml of the bukkit GUI. ill do this when im back home (on my iphone right now).
     
  22. Offline

    zarkann

    Ok, i got it to start by changing this value to 'true' !

    <lightmode>true</lightmode>

    if i put it back to false, it crash.

    any idea what would do this ?
     

    Attached Files:

  23. Offline

    zarkann

    Bertware, if this can help ,

    this is where it breaks :

    ---------------------------------------------------------------
    setload("Initializing output handler", 70)
    Try
    serverOutputHandler.init()
    Catch ex As Exception
    livebug.write(loggingLevel.Severe, "Splashscreen", "Failed to initialize module: ServerOutputHandler")
    End Try
    -----------------------------------------------------------------

    the thing is that the init() method does not seems to be doing anything specially 'hardcore' beside doing few Drawing.ColorTranslator. it does crash right away before even stepping into the method.
     
  24. Offline

    zarkann

    sorry to 'spam' like this but one thing i did is to step into the code all the way until the gui launches. if i do it slowly, it will launch at the end but the 'cpu info' is unknown.
    debug.jpg
     
  25. Offline

    zarkann

    ok, so the first one above was giving me issue so i reenabled it, but drilled down to the heart of the problem. if i comment these 3 lines everything works but the 'Total CPU Usage'

    'TotalCpu = Math.Round(_pcCpu.NextValue())
    'If TotalCpu > 100 Then TotalCpu = 100
    'If TotalCpu < 0 Then TotalCpu = 0

    looks like pcCpu ( which is an object from the PerformanceCounter class from system.diag NS ) is breaking the GUI.

    here is some of the log i get so looks like the values are setup properly before calling that line (i removed the exit 0 lines) :
    livebug: [Livebug] CPU ; mfg: GenuineIntel
    livebug: [Livebug] CPU ; name: Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
    livebug: [Livebug] CPU ; cores: 4
    livebug: [Livebug] CPU ; threads: 4
    livebug: [Livebug] CPU ; speed: 3001
    livebug: [Livebug] RAM ;
    livebug: [Livebug] RAM ; amount: 2147483648

    Also there seems to be an issue with that line (maybe its the source of the problem..) :

    _pcCpu.CounterName = "% Processor Time"

    it display the below in the log :
    livebug: [performance] total CPU initialization failed ; Conversion from string "% Processor Time" to type 'Integer' is not valid.
    A first chance exception of type 'System.InvalidCastException' occurred in Microsoft.VisualBasic.dll

    Now, i dont think its a hardware issue on my side, because with Windows 8 (not 8.1) i was able to launch the GUI without any issue. i also had the same Java/.net etc because i have VS 2012 installed.

    Edit:
    i found this on the .net 3.5 page for the CountName property

    Platform:
    Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98
     
  26. check your WMI, that might be broken and be causing this. No way things in the init routine are making it crash, since they're inside a try statement to provide crashes. Loading happens asynchronous to speed it up, so another thread might be trying to read the CPU info. Light mode disables the performance measurements.

    This ticket might provide a fix:
    http://dev.bukkit.org/bukkit-plugin...bars-not-displaying-cpu-usage-on-the-general/
     
  27. Offline

    zarkann

    yep , looks like wmi is having issue. i tried to fix it but it is saying there is nothing to fix. i just noticed that mmc performance monitor from the computer management tab in control panel throws the same error.

    so, looks like its another screwed update from ms !

    by the way i was reviewing the code from bukkitgui and its really good. good job on it and cant wait for the ver.2

    Bingo ! was able to fix the WMI issue... BukkitGUI is launching and i can see the total cpu usage, i also get back the 'performance' monitor in the computer management tab in the control panel.

    do not ask me how i fixed it, im still unsure, but i have noticed that after the win8.1 update, in the program and features, all of my apps were updated to the current date. i have uninstalled the big ones from there (VS 2012 and VMWare being a couple of them). i must have uninstalled a big bunch of them but they were all related to system tools or would make change to the system.

    everything is fine now, and no more error in the event viewer.

    thanks.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 20, 2016
  28. Offline

    mrhack98

  29. Offline

    Ngar

Thread Status:
Not open for further replies.

Share This Page