Admin [GUI/ADMIN]The Bukkit GUI Project v1.8.0.548 - A powerful, lightweight GUI - Port fowarding!

Discussion in 'Bukkit Tools' started by Bertware, Oct 5, 2011.

Thread Status:
Not open for further replies.
  1. Use the development builds, available at get.bertware.net for the best expierience! They're stable. They're only marked as development because they're not suited for bukkitdev. www.get.bertware.net/detail/bukkitgui

    [​IMG]

    Problems? Please read the f.a.q.
    View frequently asked questions

    The bukkit GUI project - shortened BukkitGUI - is intended to provide server owners
    with a easy to use, powerful GUI. Except from clearly displaying server information,
    it also adds some powerful functions, like a task planner, error logger and solver, plugin manager, .
    At this moment it does only use 30MB of your RAM, and 0% CPU when your server is running.
    *CPU usage may raise when there is a lot of output, like on startup (with many plugins or) reload.

    Features:
    • Bukkit Auto-updater
    • Colored output, colors definable in settings
    • advanced list with online players, richt click for quick commands
    • Advanced options to launch bukkit
    • Download or update bukkit from within the GUI
    • Highly precise memory measurement
    • Low on resources, performance can be adjusted in settings
      (+- 30MB RAM - 0% CPU when server is normal running)
    • Error logging, searching for the cause, and if possible, solving of errors
    • Tray icon (with support to minimize to tray) ,balloon tips and sounds.
    • Rarely/Never breaks on Minecraft/bukkit update
    • Backups (multiple backup defenitions possible)
    • Install, update, manage plugins from within the GUI
    • Mass update plugins
    • Light mode: only the essential features, reduces cpu usage
    Use:
    See the Quick install Guide about how to set it up. Click here to view it.

    Remote Server Support
    The GUI can also show output and send commands to remote servers.
    The recommended way to use a remote server is by using JSONAPI.
    In order for this to work, the JSONAPI plugin should be installed on your server.

    Click here to see how to set up a remote server connection using JSONAPI

    Click here to see a list of all supported remote severs

    Documentation
    The documentation isn't finished yet.
    Click here for the quick install guide

    Screenshots:
    Show Spoiler


    [​IMG]


    More screenshots on bukkitdev
    Click here to go to the screenshots page

    Downloads
    All downloads are available at get.bertware.net
    Always download the latest version, even dev builds are stable!

    To-Do
    • Support for more remote servers
    • Fix-all button for errors
    • Maybe: permissions manager
    Known Issues
    • Some plugins might cause conflicts, though this shouldn't affect the correct working of the GUI.
    compatibility
    operating systems:
    servers:
    The following minecraft servers are supported:
    • Bukkit build 800 and higher (lower isn't tested)
    • Vanilla
    • Tekkit
    • MCPC (set server type to vanilla,generic java, or to bukkit with disabled "retrieve current version on server start")
    • CraftBukkit++
    Support
    Go to the help pages, click here

    Changelog

    Full Changelog

    Source

    The source code is available on github under the Mozilla Public License 2.0. If you have any questions, contact me.
    You can find the source code on github: https://github.com/Bertware/bukkitgui


    Note:
    This project if freely available, but it takes a lot of time to maintain
    it and to add additional functions.
    A lot of functions are using my own scripts on my own (hired) server.
    So if you like the project and want to support me:

    [​IMG]
    [​IMG]
     
    Dzikoysk and pointfit like this.
  2. Offline

    Tolerance

    Please include the plugin version in the title. (Before the description)
     
  3. 1)it dont want to change java path,that brings problem №2
    2)crash,because can't find java
     
  4. @tolerance: corrected the title
    @Nibelton:
    Strange, i can change both java paths.
    Make sure you select the java base path, e.g. C:/Program Files/Java
    I pushed a version to github which catches the error, so it doesn't crash
    Which OS are you using? You could also try running it as admin.
     
  5. Good job
     
  6. XP,doubt that XP need to run as admin,if im admin in the first place.
    omg,im not that stupid.
     
  7. I uploaded a new version to github, i foud a possible reason why this could happen. please download it and try if it works. If not:
    Can you explain precise whats going wrong?
    Does the browse dialog pop-up? Can you adjust the text(by selecting it and replacing, so without the browse popup)
    Which java version do you have?
     
  8. Offline

    Komavok

    Hi, could you please explain to me why this error occurs:

    Details of the operational
    (JIT) debugging instead of this dialog
    box found at the end of this message.

    ************** Exception Text **************
    System.ComponentModel.Win32Exception: Can not find the file specified
    in System.Diagnostics.Process.StartWithCreateProcess (ProcessStartInfo startInfo)
    in System.Diagnostics.Process.Start ()
    in BukkitGUI.Form1.startbukkit ()
    in BukkitGUI.Form1.btnLaunchBukkit_Click (Object sender, EventArgs e)
    in System.Windows.Forms.Control.OnClick (EventArgs e)
    in System.Windows.Forms.Button.OnClick (EventArgs e)
    in System.Windows.Forms.Button.OnMouseUp (MouseEventArgs mevent)
    in System.Windows.Forms.Control.WmMouseUp (Message & m, MouseButtons button, Int32 clicks)
    in System.Windows.Forms.Control.WndProc (Message & m)
    in System.Windows.Forms.ButtonBase.WndProc (Message & m)
    in System.Windows.Forms.Button.WndProc (Message & m)
    in System.Windows.Forms.Control.ControlNativeWindow.OnMessage (Message & m)
    in System.Windows.Forms.Control.ControlNativeWindow.WndProc (Message & m)
    in System.Windows.Forms.NativeWindow.Callback (IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    ************** ************** Loaded assembly
    mscorlib
    Assembly Version: 2.0.0.0
    Version Win32: 2.0.50727.5446 (Win7SP1GDR.050727-5400)
    CodeBase: file: / / / C: / Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    ----------------------------------------
    BukkitGUI
    Assembly Version: 0.9.5.0
    Version Win32: 0.9.5.0
    CodeBase: file: / / / D: / Server%% 201.8.0/BukkitGUI.exe 20Minecraft/Server
    ----------------------------------------
    Microsoft.VisualBasic
    Assembly Version: 8.0.0.0
    Version Win32: 8.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase:
    ----------------------------------------
    System
    Assembly Version: 2.0.0.0
    Version Win32: 2.0.50727.5447 (Win7SP1GDR.050727-5400)
    CodeBase: file: / / / C: / Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 2.0.0.0
    Version Win32: 2.0.50727.5446 (Win7SP1GDR.050727-5400)
    CodeBase:
    ----------------------------------------
    System.Drawing
    Assembly Version: 2.0.0.0
    Version Win32: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase: file: / / / C: / Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Runtime.Remoting
    Assembly Version: 2.0.0.0
    Version Win32: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase:
    ----------------------------------------
    System.Configuration
    Assembly Version: 2.0.0.0
    Version Win32: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase:
    ----------------------------------------
    System.Xml
    Assembly Version: 2.0.0.0
    Version Win32: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase: file: / / / C: / Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------
    System.Windows.Forms.resources
    Assembly Version: 2.0.0.0
    Version Win32: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase:
    ----------------------------------------
    mscorlib.resources
    Assembly Version: 2.0.0.0
    Version Win32: 2.0.50727.5446 (Win7SP1GDR.050727-5400)
    CodeBase: file: / / / C: / Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    ----------------------------------------

    ************** Operational debugging (JIT) **************
    To connect the RAM (JIT) debugging file. Config this
    application or computer (machine.config) must have
    value jitDebugging, established in section system.windows.forms.
    The application must also be compiled to include
    debugging.

    For example:

    <configuration>
    <system.windows.forms jitDebugging="true" />
    </ Configuration>

    When JIT debugging is enabled, any unhandled exception
    sent to the debugger JIT, registered on the computer,
    rather than be handled by this dialog box.
     
  9. Since you posted enough information, I was able to find the exact problem:
    You didn't speciefied the correct java path or the correct bukkit location.
    I see you're using 0.9.5.0. I recommend downloading the development build from github (v0.9.5.3)
    It has some bugfixes, i think i fixed this problem in 0.9.5.3. (I'll move it soon to recommended build)
    so can you try 0.9.5.3? (see development build from github in the start post)

    Edit:
    v0.9.5.3 is now recommended build.
    This version includes some important bugfixes (it solve the problems above), update recommended.
     
  10. Offline

    Komavok

    Yes, it helped!
     
  11. now it works,but minecraft launcher don't work,server memory/cpu usage not showing,well,it doenst show anything at all,plus i can't connect to the server,always "lost connection"
     
  12. The latest minecraft launcher should work. (from 0.9.5.3) Make sure you allocate enough memory. Can you explain what precisely is going wring?
    v0.9.5.4 is released and recommended now, it fixes the performance counter not showing.
    It's normal that the CPU measurment isn't working at this moment, this code is harder to write.
    About the lost connection: that doesn't seems like it's the GUI, but bukkit. You could try setting white list off, online mode off, and see if it helps. Note that all server files will be generated in the same folder as bukkitGUI. So if it's in another folder, these files will be regenerated.
    EDIT: I just tested, the lost connection has nothing to do with the GUI. Don't forget BukkitGUI has to be in the same folder as the jar file, OR you should edit the new made config files in the folder where your BukkitGUI is placed.
     
  13. why then i can connect if i start server from bat,but with GUI cant?
    everything is as it should be.
    you mean wrong ?well...quite obviously,it just not starting
     

    Attached Files:

    • zzz.png
      zzz.png
      File size:
      99.8 KB
      Views:
      4
  14. It should work indeed.
    Can you place the GUI in an emty map, and use the automatic download function to create a new server?
    Try if that works. This is strange, I'm going to investigate that immediatly. Can you get the reason for disonnect? (see the output from bukkit)
    I pushed a version to github with debug options. Enable debug under "options", and attach the debug.txt file.
    The minecraft launcher works but it's kinda buggy. I suggest not changing the RAM, unless you're using 64 bit java. Around 1024MB ram should work.
     
  15. Offline

    VitalViper

    Seems like running this without a custom command line is eating up a lot of RAM
     
  16. how do you mean vitalviper?
     
  17. Code:
    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.
    
    ************** Exception Text **************
    System.IO.IOException: The process cannot access the file 'D:\MineCraftServer\debug.txt' because it is being used by another process.
       at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
       at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
       at System.IO.FileStream..ctor(String path, FileMode mode)
       at BukkitGUI.Form1.chkDebug_CheckedChanged(Object sender, EventArgs e)
       at System.Windows.Forms.CheckBox.OnCheckedChanged(EventArgs e)
       at System.Windows.Forms.CheckBox.set_CheckState(CheckState value)
       at System.Windows.Forms.CheckBox.OnClick(EventArgs e)
       at System.Windows.Forms.CheckBox.OnMouseUp(MouseEventArgs mevent)
       at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ButtonBase.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    
    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
        CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    ----------------------------------------
    BukkitGUI
        Assembly Version: 0.9.5.4
        Win32 Version: 0.9.5.4
        CodeBase: file:///D:/MineCraftServer/BukkitGUI.exe
    ----------------------------------------
    Microsoft.VisualBasic
        Assembly Version: 8.0.0.0
        Win32 Version: 8.0.50727.3053 (netfxsp.050727-3000)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    ----------------------------------------
    System
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Runtime.Remoting
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
    ----------------------------------------
    System.Configuration
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    ----------------------------------------
    System.Xml
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------
    
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    
    For example:
    
    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>
    
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
    :D

    now i can connect...maybe it was some rare glitch
     
  18. I'm happy to hear it works :) . I'll optimize the debug possibilities (debug logging caused that error, it was added in about 2 minutes to help you)
    I'm currentrly working on the complete rewrite of the code which is responsible for shutting down the server and the GUI. This rewrite will remove the latest bugs. (80% done :))
    I have to say thanks already for not dropping it in your recycle bin, but helping me to debug it;)

    Edit:
    v0.9.6.0 is recommended version, see changelog for details
     
  19. now when trying to enable debugging
    Code:
    Something has gone worng when enabling debug. Try running the application as administrator.
     
  20. yeah. that message replaced the error. But if everything works, you don't have to run debug ;)
    v0.9.6.1 on github might fix that.
    (I didn't focus on the debug option for v0.9.6.0)
     
  21. minecraft launcher does not work,that why i wanted to use debug
     
  22. Offline

    Hextler

    I would prefer a option to autostart the Bukkit server on Programm startup:)
     
  23. Offline

    Komavok

    The problem is that on, nothing happens when I start the server ... 1.JPG
     
  24. Can you add an option where the background turns black? The white background hurts my eyes >.>
     
  25. I'm going to investigate it, but the fact is java is hard to get. Too much memory, too less, errors in loading...
    default values are working on my computer. Do you get a cmd popup which closes very quick?
    whats the location of your minecraft.jar?
    do you have v0.9.6.1? (from github, bugfix in debug option)
    Nice idea! Going to program it right away, isn't much work.
    what is your:bukkit version and your BukkitGUI version? it's working fine on my server. (v0.9.6.0 / v0.9.6.1)
    I see exactly what is going wrong, but can't get why it is going wrong. I guess you're using an outdated version (I'm fixing much bugs). Maybe post your CPU also. (The missing data is handled by another thread, so I suppose that thread can't run (???) or shut down immediatly after activation (bug that is fixed in v0.9.6.0))
    Ok, isn't much work, maybe you get it already this evening (same for hextler)

    New release: v0.9.6.2
    Added autostart and custom background color.
    If you use another background color: Black letters will be replaced by the "Others" color.
    @Technicus: Is this enough, or do you want an option to change the whole application background color?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 20, 2016
  26. Offline

    Hextler

    The Color tags are not well shown:

    Code:
    2011-10-08 21:40:00 [INFO] ------------------------- HELP (1/1) --------------------------
    2011-10-08 21:40:00 [INFO] /help [plugin] :            Displays the full help for [plugin]
    2011-10-08 21:40:00 [INFO] /help AnimalCompanion :       Display AnimalCompanion commands.
    2011-10-08 21:40:00 [INFO] /help DynMap :                         Display DynMap commands.
    2011-10-08 21:40:00 [INFO] /help General :                    Help for the General plugin.
    2011-10-08 21:40:00 [INFO] /help Help :                        Displays more /help options
    2011-10-08 21:40:00 [INFO] /help PermissionsBukkit :    Display the PermissionBukkit help.
    2011-10-08 21:40:00 [INFO] /home :                                     Go home young chap!
    2011-10-08 21:40:00 [INFO] /home set :                                       Set your home
    and it is not possible to type in any slash commands of plugins.
     
  27. Offline

    Komavok

    I just moved its entire server to a new computer. Just copy the folder server, not what is not changing. And Bukkit GUI refuses to run the server, Bukkit GUI session length after the start and close it as not impossible, and have to kill the processBukkit GUI.

    P.S. I do not know very well English. Sorry if that something is wrong
     
  28. @Hextler
    those colors are something I should add to the server.
    I just have to find a way to efficiently remove the color codes and replace them by a color.
    ( I guess I'm going to remove the codes first, adding the colors later)
    Feel free to send me the codes for each color.
    And as far as I know, you don't have to place a slash before a command to the server.

    @Komavok
    Since 0.9.6.0 all problems around shutdown should be solved. I knew there were problems with shutdowns in 0.9.5.x, but these are now solved(It has a minimize to tray option, if this is enabled bukkit and the GUI will keep working in the background. Minimize to tray can be enabled/disabled in the settings tab, upper left corner) . Make sure your Java path is correct, your java settings are correct (disable JRE7 and Java 64 bit if you don't have them, standard:disabled),your bukkit path is correct. Try debug mode (it doesn't work perfect, but it should be able to create a small log "debug.txt"). You can find debug mode you can enable debug in the right-bottom corner of the settings tab. Please also say which version of BukkitGUI you're running.
     
  29. Offline

    Hextler

    i mean you can't type in "dynmap fullrender" for example, the plugin dynmap doesn't receive the command...
     
  30. Thats very strange.
    I can by example reload my permissions (the plugin) file using the GUI.
    Simplegod works also (just tried these 2 after reading your post)
    Can you try another plugin?
     
Thread Status:
Not open for further replies.

Share This Page