[GEN/SEC/ECON/TP/ADMN] Essentials - A collection of useful commands

Discussion in 'Archived: Plugin Releases' started by EssentialsTeam, Apr 30, 2011.

  1. Offline


    how can i add my own kits? i really would like to know
  2. Offline


    @bushingenna you have to manually edit the config file in your essentials folder (just open it up with wordpad, or some word program that includes formatting, ergo not notepad). Scroll down to the Global section, and right after the restricted commands should be the kit section. You will see:
        delay: 10
          - 277 1
          - 278 1
          - 279 1
    you then have to alter it like this:
        delay: 10
          - 277 1
          - 278 1
          - 279 1
        delay: 10
          - [item id#] [quantity]
    You can enter as many items and quantities as possible. You must reference the item id numbers shown here: http://www.minecraftwiki.net/images/8/8c/DataValuesBeta.png

    If you are running the server when you make the alterations, just do /reload -all and it should load it up!
  3. Offline


    My friend and I have a problem with our server!
    Admins can't take any damage! :O
    We first noticed it yesterday.
    Then we tried all plugins and found out that this problem comes from Essentials.
    PS: We have Version 2.3.3
  4. Offline


    How do I disable/get rid off EssentialsEco?
  5. Dunno is this reported already but, you can hack yourself into protected chests by destroying the block underneath the protection sign.

    And I am not sure if spawn protection is affected by MultiVerse, but after MultiVerse plugin enabled you cannot place block on spawn area protection but you're able to destroy them.

    EDIT: It looks like it works only on World1, but not on World2...

    EDIT2: Looks like spawn isn't multi-world supported :/

    EDIT3: Managed to make two spawn points (one for each world), but World2 is still lacking spawn protection (cannot place blocks, but you can destroy them).
  6. Offline


    I would also appreciate the return of an enable/disable flag for Eco. I often get errors from Essentials Eco when stopping the server (and we use iConomy with the depend:iconomy plugin.yml fix).
  7. Offline


    My server has a problem, for most plugins it says "an internal error occurred while attempting to perform this command", and people have said it is because of Essentials, and I would like to know how to fix this!
  8. Offline


    oh thanks i knew all that except the [kitname]. thats what confused me
  9. Offline


    Im having trouble with the /world command.... im typing in my world (build) and it says invalid world :/ anyone know how to fix?
  10. Offline


  11. Offline


    Is it possible to utilize the Essentials Economy signs with Iconomy? Like the buy/sell or even paid warp signs?
  12. Offline


    Hey, I'm trying to get rid of the warp commands in the plugin.yml file (when I extract the contents of the essentials.jar file) but I can't for the life of me recompress into a jar file and get it to run on bukkit. I use fastjar and type

    jar -cvf Essentials.jar Essentials

    And it spits out a file half the size of the original plugin. What am I doing wrong? I need to do this to get the commands for xWarp to work.

  13. Offline


    ya, i agree, i would love to be able to put up a warp sign and have it take 10 credits out of their iconomy account. is there any way to use the signs but instead of essentials keeping track of the money, use iconomy?
  14. Offline


  15. Offline


    @Daninator1: Check your EssentialsProtect settings and if god mode for the admin is enabled.
    @Tumpo: Thanks for the info.
    @Nichiatu, staticfactory: You can't disable EssentialsEco. It should play along with iConomy, if you use the special Essentials.jar from the first post.
    @Bunnizor: More info please.
    @Wolfeman: Use Multiverse plugin.
    @Bjourk, Nicolasgreen7, seaniscrazy: Yes we support iConomy, just get iConomy and use the special Essentials.jar from the first post.
    @TPMJB: Jar files are the same as zip files
    @Poeschl: No, we don't support CBUTD.
  16. Offline


    Can I Disable Free Signs ?
  17. Offline


    @Tumpo: InstaBreak, (and also the SuperPickaxe from WorldEdit) don't send a BlockBreakEvent, and directly modify the world, so we can't stop them. So, don't give such tools to anyone who is not allowed to destroy chests.
    @Makan747: Don't give your users rights to create/use them.
  18. Offline


    Come to find out I found the problem. At one time I was messing with storageconfig and added:

    Daniel: world

    Well this is where the capital "D" was coming into the picture at and things started to go down hill. The good news is now when I issues commands it's no longer case sensitive. It seems permissions does have a case problem with this but o well it's working now!

    Note: world does not allow the item command but it did allow the other commands so it makes sense.

    The original issue I was having was I got all the other commands working but not item. This now works. The only thing I can figure out is that essentials calls for world checks and at times it may be uppercase and other times it may be lowercase.

    The reason I say this is because in the Daniel world users by default could use god command but in the world they could not this is because world doe snot have god ability. So the world inheritance was not taking effect. But for the item command it was not working. Somehow essentials is calling "Daniel" when using the item command yet calling "daniel" when using the god command.

    Who knows. Anyway I hope this helps other users out.
  19. Offline


    Why cant people TP? They have the essentials.tp and essentials.tpohere

    They cant use /i
    Maybe Essentials is not recognising Permissions?
  20. Offline

    tha d0ctor

    McMyAdmin has a horrible permissions system, its doesnt use existing config files, it makes it own based on the little permissions applet you if you use mcmyadmin you need to redo all your permissions within mcymadmin
  21. Offline


    @essentialsteam, the quick fix (add "Depend: [iConomy]" to the plugin.yml in the Essentials.jar, or download the modded .jar like I did) didn't seem to work for me, as I still get the same error. Do you have any suggestions, like go to a previous version, or wait for a new version?

    Also, I'm getting the below error. Yes, I know it's because I got rid of EssentialsGroupBridge.jar, which I'm an idiot for doing just because it seemed unnecessary, but I currently have the EssentialsGroupBridge.jar back in the plugins folder, and it seems to no longer load it. Any suggestions?

    Here's the error exactly:
    2011-06-14 11:07:46 [SEVERE] Could not load 'plugins/EssentialsGroupBridge.jar' in folder 'plugins': GroupManager
    org.bukkit.plugin.UnknownDependencyException: GroupManager
    	at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:132)
    	at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:194)
    	at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:117)
    	at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:109)
    	at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    	at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    	at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  22. Offline


    When is the new Permissions supported?
  23. Offline


    Can someone quickly help me. I accidentally bound /tree to a wooden sign so now whenever i Place a sign it grows a tree. How do I unbind this? Thank You
  24. Offline


    Is there any way that you can edit the help message on essentials?
  25. Offline


    Can you set up a shop with this and lock doors and chests and whenever i type /help I get error:null. Please help!!
  26. Offline


    So, I noticed there is a /back command. How do I disable it? I have permissons... and the node isnt on there
  27. Offline


    How do I make ops not have the /lightning command? all of my admins are ops as most plugins need Ops to use their commands.
    My layout:
    The line "- -essentials.lightning.*" stops non-op admins from using the command but they're all ops so I dont know what to do.

    Any help?
  28. Offline


    yeah...remove groupmanager in favor of permissions...(in a polite way of speaking...or asking)
    essentials are better than other of this kind but groupmanager...i think permissions has more feature
  29. Offline


    Why does every one want Iconomy so bad? I just want to know why its better. If you have a good reason maybe the codemasters can add that functionality insted of doing all this work around to get a few extra goodies out of the money plugin?

Share This Page