[GEN/SEC/ECON/TP/ADMN] Essentials - A collection of useful commands

Discussion in 'Archived: Plugin Releases' started by EssentialsTeam, Apr 30, 2011.

  1. Offline


    The new bed rule is confusing, as it sets no real home...
    Also it seems to be a bit bugged, as some of my users tell me that they are ported to the wrong place...
  2. Offline


    Its still a work in progress as far as I am aware.
    I try to keep the news on the wiki updated. Just wait til you see whats in 3.0 ;)
  3. Offline


    I've always used this... I love it!
  4. Offline


    I get this when I try to run EssentialsGeoIP:
    2011-12-21 15:44:22 [SEVERE] Error occurred while enabling EssentialsGeoIP v2.7.2 (Is it up to date?): com/earth2me/essentials/I18n
    java.lang.NoClassDefFoundError: com/earth2me/essentials/I18n

    at com.earth2me.essentials.geoip.EssentialsGeoIP.onEnable(EssentialsGeoIP.java:33)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:188)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:968)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:186)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:169)
    at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:348)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:335)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:165)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:399)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    Caused by: java.lang.ClassNotFoundException: com.earth2me.essentials.I18n
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 11 more
  5. Offline


    Please add some ban info cmds like:

    /baninfo [name] - shows info about ban like who banned and reason. (time if tempban)
    /banlist - shows all banned players.
    /plaeyerip - shows player ip.

    Any other please quote this message what you think !
  6. Offline


    make feature requests here: http://www.assembla.com/spaces/essentials/support/tickets
    /whois shows the ip of the player.
    /banlist would be too long to be useful
  7. Offline


    Good to hear that :) Enjoy!
    flarnot likes this.
  8. Offline


    Can i configure my Eco so that when people get in the negatives they can't buy anything? Plase tell me how!
  9. Offline


    Hello there! I have problem. I updated my Groupmanager plugin then copied all persmissions to new group note.
    I configured everything right and then when i tried to make me Host like so: /manpromote Hydroblue host
    , it showed me this: Groupmanager problem.png
  10. Offline


    1. u set pemissions for promote ?
    2. correct group ? maybe u mean "owner" or "admin" ?
  11. Offline


    Hello !

    I am using Permissions 3, even wehen i start the Server, the Server Announce :
    But the Server does not use the permission system. The Permissions are set correctly.
  12. Offline


    did u use 2 different permission plugins ?
  13. Offline


    No, only Permissions 3
  14. Offline


    and what part of essentials u use ?
  15. Offline


    Only Essentials.jar and EssentialsSpawn.jar
  16. Offline


    I only downloaded this mod for the /setspawn and /sethome commands. /sethome works excellent but when I type /home this text shows up: Error: org.bukkit.entity.Player.teleportTo(Lorg/bukkit/Location;)V and I cannot teleport home. When I do /setspawn it says: Unknown command. Type "help" for help. Same thing with /spawn.
    The plugins I have are; ChestShop, Essentials, HeroSneak, iConomy, iConomyDeath, Lockette, MobDisguise, Permissions and PreciousStones. My nodes in the permission-text for default is;

    - lockette.user.create.*
    - ChestShop.shop.*
    - preciousstones.benefit.*
    - preciousstones.whitelist.*
    - herosneak.sneak.*
    - iConomyDeath.*
    - iConomyDeath.use.*
    - essentials.suicide.*
    - essentials.spawn.*
    - essentials.home.*
    - essentials.sethome.*
    And for the admins it's every permission.
    When I installed the plugin I just putted the Essentials.jar in the plugins-folder and started the server. I haven't edited the plugins/Essentials/config.yml anything.
  17. Offline


    You need the EssentialsSpawn.jar, too.
  18. Offline


    I'm not sure if this is the right place to post this problem, but I'm having troubles with GroupManager, using the /manpromote /mandemote commands. When I use either of these commands on any other users, I get the message:
    "Can't modify player using groups with different heritage line.", Again i'm not sure if anyone would be able to help me with this, as I may have posted this in the wrong place.
    Also: is there a permission, to notify everyone, on the server when someone uses the /give command?
  19. Offline


    Any advice on this matter? (Third post now)
  20. Offline


    i use a blacksmith for that from "Citizens"
  21. Offline


    I feel like a major noob asking this, but I looked through the config and can't seem to find it.

    How do my users remove a set home? I have multiple homes set via Permissions.

    /sethome NAME

    But to remove a home, how?

    Help is appreciated, thanks!
  22. Offline


    I am using PermissionsEX (PEX) and I am having trouble getting some of the permission nodes for Essentials to work properly. Some of the nodes that are not working are essentials.item and essentials.back, I also added the commands into the essentials config.yml to allow Essentials to take priority over the commands even though I know I am not running anything else that conflict with the commands aliases. Anyone verify that these nodes are not working with Bukkit 1597 and the current PEX and Essentials 1597?
  23. Offline


    Tons of errors:
    20:25:59 [SEVERE] Could not pass event PLAYER_JOIN to Essentials
    at com.earth2me.essentials.perm.GroupManagerHandler.getPrefix(GroupManagerHandler.java:78)
    at com.earth2me.essentials.perm.PermissionsHandler.getPrefix(PermissionsHandler.java:80)
    at com.earth2me.essentials.User.getNick(User.java:269)
    at com.earth2me.essentials.User.setDisplayNick(User.java:292)
    at com.earth2me.essentials.EssentialsPlayerListener.onPlayerJoin(EssentialsPlayerListener.java:136)
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:265)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:339)
    at net.minecraft.server.ServerConfigurationManager.c(ServerConfigurationManager.java:129)
    at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:113)
    at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:80)
    at net.minecraft.server.Packet1Login.a(SourceFile:59)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:46)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:94)
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:527)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:425)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    20:26:00 [INFO] connect from ip
  24. Offline


    i have been running a server on my pc for some time now and i just bought a server that is hosted by ultimate game servers. so i transferred all my server files to their server and now when i log onto my server it says that essentials [rotect is in emergency mode. check your log for errors. how do i fix this? thanks in advance.
  25. Offline


    I am thinking of using Essentials as a simpler economic system. I want to have the money show up as "1500g", but the currency-symbol config looks to be a prefix. Is there a way to make it a suffix instead?
  26. Offline


    Do you need group manager to have colored names in-game?
  27. Offline



    no fantasy.....
  28. Offline


    How do I give myself all permissions node's using group manager? I tried *. But it wont work I tried http://yaml-online-parser.appspot.com/.

        default: false
        - *
        - legend
          prefix: ''
          build: true
          suffix: ''
  29. Offline


  30. Offline


    I just love this plugin ;)
    Is there any way to "pay for warping"?

Share This Page