[GEN] General 3.6.2 (Webern) -- A plugin for general commands, now on BukkitDev! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Mar 6, 2011.

  1. Offline

    Celtic Minstrel

    General 3.6.2 [Webern]
    NOTE: If you are updating from 3.4.1 or earlier, you must copy the aliases section from the sample config file into your own config file. If you don't do this, many commands will not work.
    Download from the BukkitDev page (Older versions | Source)

    General provides a small set of basic commands for your server. See more details on the BukkitDev page.

    General is a fork of Nijikokun's plugin. It adds a few commands to the original set provided by General.

    Without Nijikokun's original General plugin, this plugin would never have been possible. Or at least, I would not have made it. General Essentials (the source of the /kit command) was created by wjykk and has had some input from cjc343. The SpawnMob plugin, from which I adapted the code for the /mobspawn command, was created by xmlns and is now maintained by jordanneil23.

    I recommend using sk89q's CommandHelper in conjunction with this plugin. Starting from 3.4.5, there is a command-helper.txt file included with the download which you can copy to CommandHelper's config.txt for some handy aliases, such as /spawn and /home.

    Differences from cjc343's now-inactive fork
    • Does not detect that another plugin has registered the same command.
    • /playerlist and /who are two separate commands
    • Different items.db format
    • Does not support setting or viewing the raw time.
  2. Offline


    Thank you for your volunteer work on this!
  3. Offline

    Celtic Minstrel

    Oh, I forgot to mention; 3.6.1 is available, which fixes a few bugs.
  4. Offline


    Great plugin!

    However, I am having one problem. I'm just using Basic commands right now, but when I go to type in '/general help' the server gives me the following error:

    20:14:38 [SEVERE] [General-3.6.1] There was an error with command [general] duri
    ng HELP! Please report this!
    20:14:38 [SEVERE] [General-3.6.1] Full command string: [general help]
    20:14:38 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 1
    20:14:38 [SEVERE]       at net.craftstars.general.util.Toolbox.join(Toolbox.java
    20:14:38 [SEVERE]       at net.craftstars.general.command.generalCommand.getHelp
    20:14:38 [SEVERE]       at net.craftstars.general.command.CommandBase.onCommand(
    20:14:38 [SEVERE]       at org.bukkit.command.PluginCommand.execute(PluginComman
    20:14:38 [SEVERE]       at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCo
    20:14:38 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.dispatchCommand(Cr
    20:14:38 [SEVERE]       at net.minecraft.server.NetServerHandler.handleCommand(N
    20:14:38 [SEVERE]       at net.minecraft.server.NetServerHandler.chat(NetServerH
    20:14:38 [SEVERE]       at net.minecraft.server.NetServerHandler.a(NetServerHand
    20:14:38 [SEVERE]       at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:3
    20:14:38 [SEVERE]       at net.minecraft.server.NetworkManager.b(NetworkManager.
    20:14:38 [SEVERE]       at net.minecraft.server.NetServerHandler.a(NetServerHand
    20:14:38 [SEVERE]       at net.minecraft.server.NetworkListenThread.a(SourceFile
    20:14:38 [SEVERE]       at net.minecraft.server.MinecraftServer.h(MinecraftServe
    20:14:38 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftSer
    20:14:38 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(Sour
    Any idea what's causing that? Near as I can tell the commands are working fine, just the help portion isn't. :p
  5. Offline

    Celtic Minstrel

    I think I've fixed that in 3.6.2. :)
  6. Offline


    @Celtic Minstrel A quick question that I do not see being asked anywhere below is one of my kits. I am needing it to be placed in my inventory in the order that you see but the Torchs always end in the last slot in my inventory is there a possible reason why ?

    - TORCH: 64
    - WOOD_AXE
    delay: 0
    cost: 0.0
  7. Offline

    Celtic Minstrel

    That was an easy one to fix. I was storing the items in a HashMap, which doesn't preserve the order; I simply switched to a LinkedHashMap which preserves the order they were inserted in.

    Since this is not a critical malfunction, the fix will be in 4.0. Exactly when that will be released I'm not sure, but hopefully within the next month.
  8. Offline


    Thank you sir YOU ROCK ....
  9. Offline


    I'm getting the same exception callstack in 3.6.2 when using "/general help".

    Additionally, General disables my default /help (nothing in log either)
  10. Offline

    Celtic Minstrel

    Please post it. It may look the same to you, but it's probably subtly different, and if so the older stacktrace won't help determine the exact location of the error.

    It shouldn't do that... what default /help do you mean?
  11. Offline


    16:26:43 [SCHWERWIEGEND] [General-3.6.2] There was an error with command [general] during HELP! Please report this!
    16:26:43 [SCHWERWIEGEND] [General-3.6.2] Full command string: [general help]
    16:26:43 [SCHWERWIEGEND] java.lang.ArrayIndexOutOfBoundsException: 1
    16:26:43 [SCHWERWIEGEND]        at net.craftstars.general.util.Toolbox.join(Toolbox.java:195)
    16:26:43 [SCHWERWIEGEND]        at net.craftstars.general.command.generalCommand.getHelpTopic(generalCommand.java:71)
    16:26:43 [SCHWERWIEGEND]        at net.craftstars.general.command.CommandBase.onCommand(CommandBase.java:55)
    16:26:43 [SCHWERWIEGEND]        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    16:26:43 [SCHWERWIEGEND]        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    16:26:43 [SCHWERWIEGEND]        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:352)
    16:26:43 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:737)
    16:26:43 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:701)
    16:26:43 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:694)
    16:26:43 [SCHWERWIEGEND]        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    16:26:43 [SCHWERWIEGEND]        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    16:26:43 [SCHWERWIEGEND]        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:89)
    16:26:43 [SCHWERWIEGEND]        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    16:26:43 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:454)
    16:26:43 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
    16:26:43 [SCHWERWIEGEND]        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Using CB1060 w/ PEX and nothing else
  12. Offline

    Celtic Minstrel

    Alright, I shall investigate.
  13. Offline



    I cannot seem to get the kits.yml to populate correctly. When I create the yml file myself, the plugin does not recognize it. When I create the file in game, it doesn't create the yml file and forgets the kit on reboot. When I leave a blank yml file and create the kit in game, it doesn't populate the yml. The documentation I can find seems to be outdated and I have been unable to locate any posts where anyone else is having the same difficulty.

    Although I have put due diligence into figuring this out, I am sure this is an oversight on my part. Any direction is appreciated. If there's somewhere up to date that explains how to properly configure the kits, please feel free to point me to documentation.

    Thank you!
  14. Offline


    I to had issues with the kits but I have done did figure them out post your kits.yml file so we can take a look.
  15. Offline


    I sincerely appreciate the offer. In fact, I even tried using a bit from one of your previous posts concerning kits, but it would not read the kit from the kits.yml. Ultimately, I don't have a kits.yml at the moment, because I haven't the faintest on how to format it to get it to read it. The outdated directions indicated: <name>:<list>,<of>,<items>:<delay>

    However, I just noticed something different a bit higher on the config page.

    delay: 3
    cost: 5.2
    - apple: 3
    - workbench

    I knew I overlooked something. It was only about 15 lines above the outdated instructions about the kits.yml file. I am away from my server at the moment, but will try that format when I get to it. It seems simple enough. I'll post back if I have any issues. Once again, thank you for offering your time to assist. It is appreciated. :)
  16. Offline

    Celtic Minstrel

    Yeah, the wiki still has the old instructions as well as the new... I suppose there's no real reason to keep them there now since I want to encourage people to use the new format in preparation for 4.0 which will drop the old one.
  17. Offline


    You are most welcome
  18. Offline


    This happened to me when i typed help in console:

    [SEVERE] [General-3.6] There was an error with command [general] during INIT! Please report this!
    2011-09-14 20:13:14 [SEVERE] [General-3.6] Full command string: [help ]
    2011-09-14 20:13:14 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 0
    2011-09-14 20:13:14 [SEVERE]     at net.craftstars.general.command.generalCommand.isHelpCommand(generalCommand.java:44)
    2011-09-14 20:13:14 [SEVERE]     at net.craftstars.general.command.CommandBase.onCommand(CommandBase.java:53)
    2011-09-14 20:13:14 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-09-14 20:13:14 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    2011-09-14 20:13:14 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:344)
    2011-09-14 20:13:14 [SEVERE]     at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:489)
    2011-09-14 20:13:14 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:468)
    2011-09-14 20:13:14 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
    2011-09-14 20:13:14 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    This is what i have in my Plugins>General:
    - commands.help
    - config.yml
    - general.help
    - general.motd
    - items.yml
    - kits.yml
    - messages_en.yml
    - mobs.yml
  19. Offline

    Celtic Minstrel

    Please update to the latest (version 3.6.3) and let me know if you still have the error. Also, the general.help file is no longer used. Check the wiki for what it should be called; I think it's toc.help, but not sure.
  20. Offline


    I have updated to the latest and greatest General Plugin. I am still not able to give my users the /teleport spawn command. "I'm sorry Dave, I'm afraid I can't do that". Everything else seems fine, /i, other aliases. It works fine as an OP but will not work for anyone else (even mods with the general.teleport.* node) Is it possible the 1.8 craftbukkit build (1118) im using is usurping the general.teleport command? Its giving me the default bukkit no permissions error instead of the "no permissions" error I get for other commands.

    I am using permissions 2.5.5 (yeah i know its old, but it _Works!_)

    Is there some sort of work around we can apply?

    Thanks for your great plugin and help--

  21. Offline

    Celtic Minstrel

    The "I'm sorry Dave" is a result of using the vanilla Minecraft /tp command. If /tp isn't listed as an alias of General's teleport (in the config.yml), it'll go to the vanilla command instead. If it is listed as an alias and still not working, that's likely a Bukkit bug.

    By the way, you'll want to migrate away from Permissions 2.5.5 soon enough, since General 4.0 is not maintaining support for it.
  22. Offline


    Hi, I want to update my Server to 1.8, does general 1.6.3 work with bukkit 1185?
  23. Offline

    Celtic Minstrel

  24. Offline


    I just tested it and got the issue:
    18:28:51 [SCHWERWIEGEND] [General-3.6.3] There was a big problem loading permissions system [GroupManager]! Please report this error!
    18:28:51 [SCHWERWIEGEND] java.lang.ClassNotFoundException: net.craftstars.general.security.GroupManagerPermissionsHandler
    18:28:51 [SCHWERWIEGEND]        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    18:28:51 [SCHWERWIEGEND]        at java.security.AccessController.doPrivileged(Native Method)
    18:28:51 [SCHWERWIEGEND]        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    18:28:51 [SCHWERWIEGEND]        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    18:28:51 [SCHWERWIEGEND]        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    18:28:51 [SCHWERWIEGEND]        at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    18:28:51 [SCHWERWIEGEND]        at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    18:28:51 [SCHWERWIEGEND]        at net.craftstars.general.General.setupPermissions(General.java:184)
    18:28:51 [SCHWERWIEGEND]        at net.craftstars.general.General.loadAllConfigs(General.java:136)
    18:28:51 [SCHWERWIEGEND]        at net.craftstars.general.General.onEnable(General.java:117)
    18:28:51 [SCHWERWIEGEND]        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    18:28:51 [SCHWERWIEGEND]        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:920)
    18:28:51 [SCHWERWIEGEND]        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:278)
    18:28:51 [SCHWERWIEGEND]        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:173)
    18:28:51 [SCHWERWIEGEND]        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:156)
    18:28:51 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
    18:28:51 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
    18:28:51 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
    18:28:51 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
    18:28:51 [SCHWERWIEGEND]        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    18:28:51 [INFO] [General-3.6.3] Using [Basic (isOp)] for permissions.
    how can I get around this?
  25. Offline

    Celtic Minstrel

    If you have WorldEdit installed, try changing permissions system to WorldEdit in the config; it can interface with GroupManager as well. I would however recommend that you instead switch to PermissionsEx or one of the other superperms systems (PermissionsBukkit, zPermissions, and bPermissions are the ones I know of). GroupManager has been obsolete for quite awhile now; explicit support for it has already been removed in General, and the implicit support of using it via WorldEdit will be removed soon as well.
  26. Offline


    Hi, thanks for your advice, but there a so many permission system, I get confused about them.
    What do you think, which one of them last the longest time? As I let my players use some kits and some teleportation and world points, you can imagine how large my permission config file is :)
    So it's quite hard, if i need to change the permission system every update.
  27. Offline


    when PermissionBukkit support ?
  28. Offline

    Celtic Minstrel

    @devzero – If I recall correctly and a GroupManager config is basically the same as a Permissions config, then it would probably be easiest going to PermissionsEx which also uses (mostly) the same format as Permissions. Nijikokun also has a converter from the Permissions format to your format of choice, though I'm not sure if it'll work on a GroupManager config.

    @brzavr – It's been supported pretty much right from the start.
  29. Offline


    in config.yml
    # The ops-only flag is used if the permissions system is set to Basic, and specifies which actions
    # should be restricted to ops. If any other permissions system is specified, it is ignored.
    # Valid permission systems: Basic, Permissions, GroupManager, WorldEdit, CraftBukkit
    Permissions = PermissionBukkit ?

    if set system: Permissions
    [INFO] [General-3.6.3] [Permissions] not detected; falling back to [Basic] permissions.
    CB 1185
    permissionBukkit 1.2
    General 3.6.3

    P.S. and support iConomy 6.x ?
  30. Offline

    Celtic Minstrel

    In config.yml it should be system: Bukkit. As for iConomy 6, I think it's supported, but if not it will be in 4.0.
    brzavr likes this.
  31. Offline


    2011-10-10 21:29:44 [SEVERE] [General-4.0] There was an error with command [general] during HELP! Please report this!
    2011-10-10 21:29:44 [SEVERE] [General-4.0] Full command string: [general help 2]
    2011-10-10 21:29:44 [SEVERE] java.lang.IllegalArgumentException: can't parse argument number: pink
    2011-10-10 21:29:44 [SEVERE] at java.text.MessageFormat.makeFormat(MessageFormat.java:1356)
    2011-10-10 21:29:44 [SEVERE] at java.text.MessageFormat.applyPattern(MessageFormat.java:475)
    2011-10-10 21:29:44 [SEVERE] at java.text.MessageFormat.<init>(MessageFormat.java:367)
    2011-10-10 21:29:44 [SEVERE] at java.text.MessageFormat.format(MessageFormat.java:828)
    2011-10-10 21:29:44 [SEVERE] at net.craftstars.general.text.Messaging.send(Messaging.java:52)
    2011-10-10 21:29:44 [SEVERE] at net.craftstars.general.util.Toolbox.showFile(Toolbox.java:185)
    2011-10-10 21:29:44 [SEVERE] at net.craftstars.general.text.HelpHandler.displayEntry(HelpHandler.java:140)
    2011-10-10 21:29:44 [SEVERE] at net.craftstars.general.command.CommandBase.onCommand(CommandBase.java:53)
    2011-10-10 21:29:44 [SEVERE] at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40)
    2011-10-10 21:29:44 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
    2011-10-10 21:29:44 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:355)
    2011-10-10 21:29:44 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:757)
    2011-10-10 21:29:44 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:722)
    2011-10-10 21:29:44 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:715)
    2011-10-10 21:29:44 [SEVERE] at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    2011-10-10 21:29:44 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-10-10 21:29:44 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    2011-10-10 21:29:44 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    2011-10-10 21:29:44 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:471)
    2011-10-10 21:29:44 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    2011-10-10 21:29:44 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)

    Looks like I cant use colors in the help files. I tried to use my old help file that used "&" and they would not show up at all then changed to {color} and I get the error above.

    Also it seems I can alias "help" to "general help" and "motd" to "general motd" as neither of the main command see to work any more. I have them formatted in the config.yml as "help: [general help]" and "motd: [general motd]"

    Any help would be great.


Share This Page