Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    no its probably because in ur essentials config u typed a wrong character that console doesnt understand
  3. Offline


    Thanks that was the problem! :)
  4. Offline


    yep! happens to me all the time
    --- merged: Feb 12, 2011 1:38 PM ---
    chilli1997 can u see my pastebin submittion
  5. Offline


    Yeah i'm stressing over it lol

    It seems to be an issue with Essentials or Craftbukkit, testing it out trying to find out.
  6. Offline


    ok thanks for all your help :)
  7. Offline


    Essentials 183 works fine for me but some are saying that 189 is working for them, I cant get it too atm tied up with support, so I will be working on it.
  8. Offline


    ok i am running essentials 189
  9. Offline


    I actually has to start a new folder then added permissions , essentials 189 , and CB 314 and then the help works fine
  10. Offline


    Only global spawn? I'm lost without per-world spawns..
  11. Offline


    We just implemented per group spawns, I'm sure per world will be coming soon :)
  12. Offline


    can u do /tp or /tphere
  13. Offline


    Not quite sure what that means but yes they work fine.
  14. Offline


    I really look forward to per world global spawns this will help me greatly to be able to move it, when you die in our nether map and respawn you respawn under/in a lake of lava >_>! Then you have to /spawn back to the main map to get out because you just keep respawning in the lake of lava. D:

    So yes a exact spawn, and exact respawn for per-world would be awesome and appreciated!
  15. Offline


    It doesn't work for me either....I'm using Essentials 189 as well. I'm not sure what the problem is as I'm not using any mods that conflict with it.

    When I try /tp it goes back to the legacy minecraft server version of /tp (aka no bukkit).

    None of the other teleport commands work as well... If you'd like to see what I'm talking about come on
  16. Offline


    I dont think bukkit actually has the nether set up for individual settings which would also include spawns and things like that, all that would require either a)seperate folders for settings, or b)coordiante extention from other worlds. I'm not sure if a plugin alone could give such a variety but it is an idea and something I'm sure a lot of people are working on.
  17. Offline


    Well if you look at the spawn data in essentials

    default: {yaw: 89.99996, pitch: -3.450014, z: -37.404117112439444, y: 64.0, world: world,
    x: -5.774029360877206}

    Change world: world, to world: nether? And instead of it being default: it would be default2: or world1: Since it goes in order the main map being 0, when your in anything but 0 and you do a /setspawn it should add new spawn data under the default: one and use what world your on to determine the spawn your setting so instead it would be.

    default1: {yaw: 89.99996, pitch: -3.450014, z: -37.404117112439444, y: 64.0, world: nether,
    x: -5.774029360877206}


    world1: {yaw: 89.99996, pitch: -3.450014, z: -37.404117112439444, y: 64.0, world: nether,
    x: -5.774029360877206}
  18. Offline


    The nether portals only working going to nether not back
  19. Offline


    # If you want to use special characters in this document, such as accented letters, you MUST save the file as UTF-8, not ANSI.
    # If you receive an error when Essentials loads, ensure that:
    #   - No tabs are present: YAML only allows spaces
    #   - Indents are correct: YAML heirarchy is based entirely on indentation
    #   - You have "escaped" all apostrophes in your text: If you want to write "don't", for example, write "don''t" instead (note the doubled apostrphe)
    #   - List items are prefixed with a hyphen and indented:
    #       lists:
    #         - look like this
    #       not:
    #       - like this
    #   - Text with symbols is enclosed in single or double quotation marks
    #   - CraftBukkit and Permissions have been updated: CraftBukkit and Essentials almost always line up, but sometimes other plugins fall behind CraftBukkit's multiple daily updates
    #   - You have saved the document as UTF-8, NOT the default, ANSI
    # A color code between 0-9 or a-f. Set to 'none' to disable.
    ops-name-color: 'c'
    # The character(s) to prefix all nicknames, so that you know they are not true usernames.
    nickname-prefix: '~'
    # The delay, in seconds, required between /home, /tp, etc.
    teleport-cooldown: 0
    # The delay, in seconds, before a user actually teleports.  If the user moves or gets attacked in this timeframe, the teleport never occurs.
    teleport-delay: 0
    # The delay, in seconds, required between /heal attempts
    heal-cooldown: 60
    # The number of items given if the quantity parameter is left out in /item or /give.
    default-stack-size: 64
    # Whether or not to reclaim memory on player logout; this is technical, and should only be disabled under special circumstances.
    # This generally increases server stability unless very specific runtime configurations are used.
    reclaim-onlogout: true
    # Should primitive spawn protection be enabled?  For most servers, this should be flase; it is better to use a third-party plugin to protect it.
    spawn-protection: false
    # Nether settings (switch between worlds with "/world nether" and "/world normal")
    # Sets whether the nether system is enabled, what folder to save the world in, and whether portals should teleport players between worlds.
      enabled: enabled
      folder: nether
      portals-enabled: false
    # Mob limit on spawnmob
    spawnmob-limit: 10
    #Show other plugins commands in help
    non-ess-in-help: true;
    # The message of the day, displayed on connect and by typing /motd.
      - '&cWelcome, {PLAYER}&c!'
      - '&fType &c/help&f for a list of commands.'
      - 'Currently online: {PLAYERLIST}'
    # The server rules, available by typing /rules
      - '[1] Be respectful'
    # Disabled commands will be completelly unavailable on the server.
     - nick
    # Restricted commands will only be available to ops.
    # These will have NO EFFECT if you have Permissions installed!
    # These are here only if you want something simpler than Permissions.
      - bigtree
      - item
      - give
      - heal
      - plugin
      - time
      - top
      - tp
      - tphere
      - tree
    # Note: All items MUST be followed by a quantity!
    # Times are measured in seconds.
        delay: 10
          - 277 1
          - 278 1
          - 279 1
    # End of File
    So yea, basically i dotn see anything wrong =/
  20. Offline


    Reported the bug some time ago, but no reply... Wondered if the community had any answers for this.

    When users try to /sell they get this error:
    "you do not have enough of that item to sell"

    Tried latest version of bukkit and essentials, and tried some older versions.
    Anyone know of a fix? Thanks :)
  21. Offline


    I am having the devs look into this , just noticed it earlier today.
  22. Offline


    ok its not letting me tp to or to me everything else works im using i believe craftbook 213 or something its the newest that isnt messed up lol the message im getting when I try and tp someone or them to me is

    syntax error, please provice a source and target. how do I fix this?
  23. Offline


    12-Feb-2011 18:44:12 org.bukkit.plugin.SimplePluginManager callEvent
    SEVERE: Could not pass event PLAYER_MOVE to Essentials
    java.lang.IllegalStateException: Failed to add player. net.minecraft.server.Enti
    tyPlayer@72 already is in chunk 2, -1
    at net.minecraft.server.PlayerInstance.a(
    at net.minecraft.server.PlayerManager.a(
    at org.bukkit.craftbukkit.entity.CraftPlayer.teleportTo(
    at com.earth2me.essentials.User.teleportToNow(
    at com.earth2me.essentials.EssentialsPlayerListener.onPlayerMove(Essenti
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    at net.minecraft.server.NetworkManager.a(SourceFile:232)
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
    at net.minecraft.server.MinecraftServer.h(
  24. Offline


    I am getting the same /tp errors as the rest. It seems to me that there is no EssentialsTele JAR anywhere, yet the wiki says it is split up like the rest. I don't know how that works... Great plugin nonetheless. Everything else works perfectly!
  25. Offline

    David Peralty

    I am having an issue with /warp it doesn't list the warps. The warps work, but I get Error: null when just doing /warp is there something I'm missing? Today's Craftbukkit and Essentials.
  26. Offline


    Using 188 (although it reports 189 in the server startup log) with build 318. Compass appears to have east and west reversed. The degrees are right but E and W are wrong. N and S are correct.

  27. Offline

    adamjon858 sucks not having tele. Ops (specified in ops.txt in minecraft root) are able to use the built in /tp command still though. /tp <persontomove> <persontomoveto>
  28. Offline


    Ah, yes. Forgot about that built in feature. Lol. Thanks!
  29. Offline


    I have a problem. i have been at this for hours trying to fix this:
    SEVERE: Could not load plugins\Permissions.jar in plugins: null
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.c(
            at net.minecraft.server.MinecraftServer.d(
    Caused by: java.lang.reflect.InvocationTargetException
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
            at java.lang.reflect.Constructor.newInstance(Unknown Source)
            ... 8 more
    Caused by: while parsing a block collection
     in "<reader>", line 58, column 13:
                    - 'cleaner.clean'
    expected <block end>, but found Scalar
     in "<reader>", line 85, column 16:
                    - 'essentials.mail.send'
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceEntry.produce(
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
            at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.jav
            at org.yaml.snakeyaml.composer.Composer.composeNode(
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
            at org.yaml.snakeyaml.composer.Composer.composeNode(
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
            at org.yaml.snakeyaml.composer.Composer.composeNode(
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
            at org.yaml.snakeyaml.composer.Composer.composeNode(
            at org.yaml.snakeyaml.composer.Composer.composeDocument(
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
            at org.yaml.snakeyaml.Yaml.load(
            at org.bukkit.util.config.Configuration.load(
            at com.nijikokun.bukkit.Permissions.Permissions.<init>(
            ... 13 more
    Any help as to what the hell this means, and how i could fix it, would be greatly appreciated :)
    (Btw i am on build 317 of craftbukkit)
    Thanks in advance :)
  30. Offline


    Update Craftbukkit
    --- merged: Feb 12, 2011 10:17 PM ---
    Look right befoe or right after
    - 'cleaner.clean' line 58
    - 'essentials.mail.send' line 89

    There might be a wrong character
  31. Offline


    Thanks for the quick reply! But no joy JOY!

    I checked both sides of the two nodes and there is nothing i tried retyping it aswell but still same error :(
    Anything else that i could try?
    Very stupid mistake i did miss a character: i missed an apostrophe of the node prior to the one giving an error.

    EPIC facepalm! lol thanks for the help anyway :)

Thread Status:
Not open for further replies.

Share This Page