Inactive [GEN] Essentials v2.1 [?]

Discussion in 'Inactive/Unsupported Plugins' started by Zenexer, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    I still don't understand how to make it work... All access to my server is done on a website.
  3. Offline


    it all depends on what they give you access to, i use xenonservers and they have pretty much opened up everything since bukkit updates so much , so ours is simple.

    Can you upload .jar files? Can you edit .yml files?
  4. Offline


    Can anyone post an example config with iconomy and costs for commands? No matter what I try, or read on this forum or the wiki, I can't find info to get that set up. Even a few pages back the OP posted use of the costs, but that doesn't even work. Actually, it might be useful to pust most options in an example config so people know how to use them properly.
  5. Offline


    For some reason, non-OPs can use restricted commands on mine. I've been trying to work with it for an hour and have no clue what the problem is.
    # A color code between 0-9 or a-f. Set to 'none' to disable.
    ops-name-color: '1'
    # The character(s) to prefix all nicknames, so that you know they are not true usernames.
    nickname-prefix: '~'
    # The delay, in seconds, required between /home, /tp, /warp, etc.
    teleport-cooldown: 15
    # The delay, in seconds, required between /heal attempts
    heal-cooldown: 15
    # The number of items given if the quantity parameter is left out in /item or /give.
    default-stack-size: 1
    # The message of the day, displayed on connect and by typing /motd.
      - 'Welcome {PLAYER}! Your IP is {IP}. Enjoy your stay.'
      - 'Currently online: {PLAYERLIST}'
    # The server rules, available by typing /rules
      - '[1] Be respectful - No griefing or flaming. There are server logs and a whitelist for a reason.'
      - '[2] Use common sense'
    # Disabled commands will be completelly unavailable on the server.
     - nick
    # Restricted commands will only be available to ops.
    # These will have NO EFFECT if you have Permissions installed!
    # These are here only if you want something simpler than Permissions.
      - tp  - tele  - tphere  - telehere  - s  - item  - i  - give  - g  - home  - sethome  - spawn  - setspawn  - tree  - bigtree  - top  - time  - kit
    # Note: All items MUST be followed by a quantity!
    # Times are measured in seconds.
        delay: 10
          - 277 1
          - 278 1
          - 279 1
          - 276 1
    # End of File
    That's my entire config file, the main issue is with the restricted-commands. Everything else works. I've defaulted to that since I really only need admins and regulars, and Permissions was erroring every time I tried to start the server. Any help would be appreciated.
  6. Offline


    I can upload .jar files but I don't know if I can edit the .yml files. I can make people moderators admins and regulars through the website. Other than that idk.
  7. Offline


    How do I get the latest version? Through the wiki? I follow the change log and I the one I downloaded from the download link is an older version I believe.
  8. Offline


    if yo
    if you can upload the .yml files then just make one on your desktop and then upload it and it will overwrite the one there. If you need some help convo me here and tell me what you want to do. I will try to help

    @waffulz just click on download at the top of the page, should be b119
  9. Offline


    @waffulz The download link in the first post is the newest.
  10. Offline


    Hurray :D

    Haha glad I could help!

    Aww still no private warps tho haha. But I'm still thankful hehe! :)
  11. Offline


    The download link is current, when he updates it he refreshes the link.
  12. Offline


    an editable help file would be awesome as many of the plugins dont list the commands in a help file or list them in a seperate help file that you need to link to
  13. Offline


    This is what my config says for permissions...
    # Supports "Default" and "GroupUsers"
            system: default
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another
    #   group simply place the groups name in the "inheritance:"
    #   field seperated by commas.
    #   Example: inheritance: Default,Admins,
    #   All permissions including the asterisks must be placed in single quotes.
    #   like so:
    #       - 'general.spawn'
    #   Otherwise errors will happen!
    #   Globalized Permission settings:
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #           - 'general.*'
    #       This will allow you to use all general commands.
    #   Single Asterisk denotes all commands:
    #       - '*'
            default: true
                build: true
                - 'general.spawn'
            default: false
                build: true
                - Default
                - '*'
            default: false
                build: true
                - Moderator
                - '*'
    # DarkGrave has control over all commands.
    # sk89q can use /spawn & /time
            group: Admins
            group: Default
                - 'general.time'
    I want to add people but I don't know how... and how do I give people the ability to do only some commands?
  14. Offline


    Is it possible to add a command that allows you to transfer everything in your inventory to a chest, perhaps the chest you're looking at
  15. Offline


    @wwZaraki i will be mailing you

    Check your inbox and keep up lol we have a lot to cover
  16. Offline


    Another chime in regarding colours not showing up on the MOTD.

    It's showing up as wcWelcome although the config string is listed as &cWelcome.
  17. Offline


    @atomicben I think I fixed it. Let me know :)
  18. Offline


    you might want to check that a little closer or post your code because mine is working great
  19. Offline


    Ok, gonna throw it out there.

    An 'aliases' section in the config.yml, an 'aliases.txt' or whatever else for a way to assign your own aliases to commands?

    The command parser looks through aliases.txt for the command before it goes for the full command?

    *shrug* ... just an idea?
  20. Offline


    i think what he is saying is disable it yourself lmao
  21. Offline


    Nope... just a way to work around other commands clashing.

    If you set an alias in the essentials plugin, you [should|might] then be able to code it to ensure that it was calling the full command from the essentials plugin, not the conflicting command from the other plugin.

    If I had any idea about java, I'd offer to help code!
  22. Offline


    well the /g is just a short for /give, most plugins accept either, so it shouldnt be a problem to just delete it as an option, i know many item.dbs now have several word forms of the item as to try to cover them all
  23. Offline


    @Zenexer, does the /warp ing coflict with basicwarp? I could stop using basicwarp but could I paste the warp coords somewhere? nm, figured it out. :)

    try this
  24. Offline


    Just updated to b120 for the warp stuff. Goodbye to three other plugins that this one is replacing! :D

    A few things:
    • It says "Error: null" just after installing Essentials and no warps have been set yet and you try to use them. Maybe check for a warps dir, and then if any files exist in the dir. If not, echo the below 'no warps' sentence to screen? (or create the warp dir on first run, as does happen with the Essentials dir, config.yml, users.yml & items.db?
    • It may not come up all the time, but just to make it a bit neater, if there are no warps in the warps dir, could you make it say 'You currently have no warps set' or something to that effect?
    • None of the /warp commands appear in /help. NM. Found 'em! [​IMG]
    Love your work. Definitely the quickest of plugin developers to get suggestions into their plugin.

    Might have to download the source to have a play with so I can learn me some java.
  25. Offline


    Update time!
    - Teleports to a player can now be toggled with /tptoggle
    - /tpo overrides /tptoggle
    - /tpc and /tpchere have been renamed to /tpahere and /tpa, irrespectively :p
    - /accept has been renamed to /tpaccept, and /tpdeny has been added
    - /help has had a complete makeover
    - /g has been removed
    - Preparations have been made for custom aliases

    Note that the new teleport system is in the ALPHA stage and WILL change.

    Update #2:
    - Tidied up teleport toggle persistence
  26. Offline



    You're good.
  27. Offline


    huh, weird i finally got the permissions to work yesterday after added the extra spaces.
    And then i upgraded to B120 to fix motd. And now I just kicked by a builder again. Derp!! =P I suck at setting this up!

    Can i suggest a command?


    that works with permissions, would be awesome to do in-game.
  28. Offline


    How do I completely delete my nickname?
  29. Offline


    /nick off
  30. Offline


    @pabbie /mod [player] [group] <-- Just added it a few updates ago :D

    @Drizien The easiest way is to use /nick off. If that doesn't work for whatever reason, you can remove the corresponding line from users.yml manually (careful not to touch anything else!)
  31. Offline


    my kits are broken now. im the only one who can get kits :( is anyone else having this problem or just my luck ?
Thread Status:
Not open for further replies.

Share This Page