[GEN] BukkitInventoryTools - Find it on BukkitDev.

Discussion in 'Inactive/Unsupported Plugins' started by Gabriel333, Sep 11, 2011.

  1. Offline


    olimoli123 likes this.
  2. Offline


    I will fix the Backpack sharing between worlds... Because I understand the need.

    PEX has an equivalent feature I think it is:
    - -permissionnode
    - ^permissionnode

    Does LWC support doubledoors? or whats the problem? Im trying to make my plugin so lwc and bit does not conflict and then let the players choose which one they like to use. So I there is a conflict I will fix it if posible.

    I have looked at the old source code.

    And it is hard to guess how it worked previously???
    What did you previously write in your config.yml to share backpack between world and nether, but not creative? Please give me an example, then I make that part.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  3. Offline


    I did not bother to add it since i wont be using the plugin compilation, but here you go:

    - pvp
    - jail
    InventoriesShare?: false
    InventoriesShare?: true
    InventoriesShare?: true
  4. Offline


    Thanks, I will make it for other users then :)

    Thanks for your help. I have fixed this now ... I know you will not use my plugin anyway :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
    crazyish likes this.
  5. Offline


    hi. i have been getting this error a lot and just want to know what it means and try to fix it. Thanks.
    18:13:21 [WARNING] [BukkitInventoryTools](4)Error at SQL Query: No operations al
    lowed after connection closed.Connection was implicitly closed by the driver.
  6. Offline


    I would love to use the backpack aspect of this, but I don't want to use anything else. Is this possible?
  7. Offline


    yes if you use permissions...
  8. Offline


    Im Having this problem when trying to run BukkitInventoryTool On My Server Error is Highlighted in Red
    Im just Placing the Jar file in the Plugin Folder Like Most of the Jar Files
    Help, Please.
    THank you.
    161 recipes
    17 achievements
    04:41:20 [INFO] Starting minecraft server version Beta 1.8.1
    04:41:20 [INFO] Loading properties
    04:41:20 [INFO] Starting Minecraft server on
    04:41:20 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1131
    -g86b7fa8-b1337jnks (MC: 1.8.1)
    04:41:21 [SEVERE] Could not load 'plugins\BukkitInventoryTools.jar' in folder 'p
    lugins': Spout
    org.bukkit.plugin.UnknownDependencyException: Spout
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:136)
    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:112)
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:136)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    04:41:21 [INFO] [Permissions] (Yeti) was initialized.
    04:41:21 [INFO] [Permissions] version [3.1.6] (Yeti) loaded
    04:41:21 [INFO] Preparing level "Cuban's Survival Land"
    04:41:21 [INFO] Default game type: 0
    04:41:22 [INFO] Preparing start region for level 0 (Seed: -798017895)
    04:41:23 [INFO] Preparing spawn area: 65%
    04:41:23 [INFO] Preparing start region for level 1 (Seed: -798017895)
    04:41:24 [INFO] Preparing spawn area: 48%
    04:41:24 [INFO] CivilizedSpawn (v1.0) is enabled!
    04:41:25 [INFO] CivilizedSpawn config loaded.
    04:41:25 [INFO] CraftBookCommon 347-2723723 enabled.
    04:41:25 [INFO] CraftBookCommon: Permissions plugin detected! Using Permissions
    plugin for permissions.
    04:41:25 [INFO] CraftBookCircuits 347-2723723 enabled.
    04:41:25 [INFO] CraftBookCircuits: Permissions plugin detected! Using Permission
    s plugin for permissions.
    04:41:25 [INFO] CraftBookCircuits: Permissions plugin detected! Using Permission
    s plugin for permissions.
    04:41:25 [INFO] CraftBook: Enumerating chunks for self-triggered components...
    04:41:25 [INFO] CraftBook: 1250 chunk(s) for 2 world(s) processed (0s elapsed)
    04:41:25 [INFO] CraftBookMechanisms 347-2723723 enabled.
    04:41:25 [INFO] CraftBookMechanisms: Permissions plugin detected! Using Permissi
    ons plugin for permissions.
    04:41:25 [INFO] 1 cauldron recipe(s) loaded
    04:41:25 [INFO] CraftBookVehicles 347-2723723 enabled.
    04:41:25 [INFO] CraftBookVehicles: Permissions plugin detected! Using Permission
    s plugin for permissions.
    04:41:25 [INFO] [CreeperHeal] Loaded 0 traps
    04:41:25 [INFO] [CreeperHeal] Loading config
    04:41:25 [INFO] [CreeperHeal] Loading world: Cuban's Survival Land
    04:41:25 [INFO] [CreeperHeal] Loading world: Cuban's Survival Land_nether
    04:41:25 [INFO] [CreeperHeal] Successfully detected Lockette
    04:41:25 [INFO] [CreeperHeal] version 4.2.1 by nitnelave is enabled
    04:41:25 [INFO] [Doors Open Doors] v1.0 (Helium) enabled.
    04:41:25 [INFO] [Doors Open Doors] Developed by: [Mattera, Steven (IchigoKyger)]
    04:41:25 [INFO] [Doors Open Doors] Based on: Kassoon's single player mod.
    04:41:25 [INFO] [DwarfForge] Restored 0 active Forges.
    04:41:25 [INFO] [DwarfForge] Version 1.7.1 enabled.
    04:41:25 [INFO] Easy Switch version 1.1 is enabled
    04:41:25 [INFO] [iConomy - Celty] Enabled (34 ms)
    04:41:25 [INFO] Lockette version 1.4.4 is being enabled! Yay! (Core version 1.
    04:41:25 [INFO] Lockette: Detected craftbukkit build [1337] ok.
    04:41:26 [INFO] Lockette: Linked to Permissions plugin version 3.1.6
    04:41:26 [INFO] Lockette: Using ops file for admin permissions.
    04:41:26 [INFO] Lockette: Ready to protect your containers.
    04:41:26 [INFO] [LoginBonus] 0.6: Has been enabled.
    04:41:26 [INFO] [Permissions] SQL Interface enabled!
    04:41:26 [INFO] PlgSetspawn version 5.0 is enabled!
    04:41:26 [INFO] [ScubaKit][3.0.0.C] Enabled started
    04:41:26 [INFO] [ScubaKit][3.0.0.C] Remember to update any permissions nodes of
    ScubaKit.ScubaGear to ScubaKit.ScubaGear.*
    04:41:26 [INFO] [ScubaKit][3.0.0.C] SuperPerms is set to true, aborting legacy p
    ermissions hook
    04:41:26 [INFO] [SpawnMob] Permission system found, plugin enabled
    04:41:26 [INFO] [SpawnMob] Version 1.9.9 enabled.
    04:41:26 [INFO] [Spawnmob] ERROR: No kits.properties was found
    04:41:26 [INFO] please download from the Bukkit forum thread
    04:41:26 [INFO] or from github.com/jordanneil23/SpawnMob
    04:41:26 [INFO] WorldEdit 4.7 enabled.
    04:41:26 [SEVERE] WorldEdit: Unable to read default configuration: config.yml
    04:41:26 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
    for permissions.
    04:41:26 [INFO] [WorldSaver] enabled. Visit goo.gl/HWbai for plugin info
    04:41:26 [INFO] [AdminCmd] Plugin Enabled. (version 5.9.1 (BUILD 30.09.2011 @ 19
    04:41:27 [INFO] [AdminCmd] 88 extra help entries loaded from files: AdminCmd(88)
    04:41:27 [INFO] [AdminCmd] bal_extinguish has all his alias already registered.
    Command deactivated
    04:41:27 [INFO] [AdminCmd] bal_list has all his alias already registered. Comman
    d deactivated
    04:41:27 [INFO] [AdminCmd] Disabled Alias(es) for bal_setspawn : setspawn,
    04:41:27 [INFO] [AdminCmd] Disabled Alias(es) for bal_whois : ws,
    04:41:27 [INFO] [AdminCmd] Disabled Alias(es) for bal_undo : undo,
    04:41:27 [INFO] [AdminCmd] Disabled Alias(es) for bal_spawn : spawn,
    04:41:27 [INFO] [AdminCmd] Disabled Alias(es) for bal_sp : sp,
    04:41:27 [INFO] [AdminCmd] Disabled Alias(es) for bal_uptime : up,
    04:41:27 [INFO] [AdminCmd] 0 blacklisted items loaded.
    04:41:27 [INFO] [AdminCmd] 1655 alias loaded.
    04:41:27 [INFO] [AdminCmd] 2 kits loaded.
    04:41:27 [INFO] [AdminCmd] 0 banned players loaded.
    04:41:27 [INFO] [AdminCmd] Successfully linked with Yeti's Permissions.
    04:41:28 [INFO] [Jail] Loaded 1 jail zones.
    04:41:28 [INFO] [Jail] Loaded 0 prisoners.
    04:41:28 [INFO] [Jail] Loaded 5 cells.
    04:41:28 [INFO] [Jail] Jail v2.0.3 loaded!
    04:41:28 [INFO] [MobBounty] v4.2 (Oxygen) enabled.
    04:41:28 [INFO] [MobBounty] Developed by: [Mattera, Steven].
    04:41:28 [INFO] [MobBounty] Config loaded.
    04:41:28 [INFO] [MobBounty] Payment plugin iConomy v6 found!
    04:41:28 [INFO] [SetSpeed] Spout not found Disabling SetSpeed.
    04:41:28 [INFO] [SetSpeed] version 1.8.1_2 is disabled!
    04:41:28 [INFO] WorldBorder version 1.4.4 loading
    04:41:28 [INFO] [WorldBorder] [CONFIG] Using round border, knockback of 3.0 bloc
    ks, and timer delay of 5.
    04:41:28 [INFO] [WorldBorder] [CONFIG] Border-checking timed task started.
    04:41:28 [INFO] [WorldBorder] [CONFIG] Will use plugin for permissions: Permissi
    ons v3.1.6
    04:41:28 [INFO] For reference, the main world's spawn location is at X: -297 Y:
    68 Z: 85
    04:41:29 [INFO] Server permissions file permissions.yml is empty, ignoring it
    04:41:29 [INFO] Done (0.734s)! For help, type "help" or "?"
  9. Offline


    This looks sooo awesome! It alone will make Sprout worth installing! Thankyou!!!
  10. Offline


    You need to install Spout to make this plugin work and if you want to use ALL features, you need SpoutCraft as well.
  11. Offline


    I tried this in every way I could and because of Spoutcraft and MySQL AND SQLlite, I cannot use this Plugin. Isn't there ANY easier way for you to make this easier to work with?
  12. Offline


    You have to give me more details if Im going to be able to help op...

    Show your console when you start your server.

    basicly is should not be different from many other plugins, so i dont know why you have troubles?
  13. Offline


    Using this with the 805 of Spoutcraft throws up a lot of back packet errors client-side when trying to access any kind of GUI
  14. Offline


    Im waiting for next release of SpoutCraft / Spout / Bukkit. Until they release a stable version without bugs. I have done some testing with a the newest dev build of bukkit+Spout, but there are still errors.

    If you want to test dev builds, then you should use dev builds of all three: Bukkit+Spout+SpoutCraft - but I canr garantee that if works until things has become stable again. The Minecraft 1.0 must have had major changes since Bukkit/Spout/SpoutCraft is not released in stable versions yet.
  15. Offline


    Found a bug. I had an enchanted iron pickaxe and 3 unenchanted pickaxes. When I sorted my chest, it stacked the pickaxes and they all became enchanted.

    Also, I was wondering if I disable the digilock portion of this plugin? I hear the digilock sound every time I open a door, and it put my double lockette doors out of sync. Another question I have is, does this plugin retain SpoutBackpack's ability to lose backpack on death?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  16. Offline


    That's the thing, it won't show up on the console after it is done. It will pop up ( The Pail Window ) and it won't show anything about it, but when the starter comes up in command console it says

    [SEVERE] Could not Load 'plugins/BukkitInventoryTools.jar' in folder 'plugins' : Spout

    and then a bunch of lines saying things like

    org.bukkit.plugin.UnknownDependencyException : Spout

    This all comes up BEFORE the Pail Window activates though, and I can't copy and paste the logs otherwise.
    I am assuming this has something to do with Spout. The thing about Spout is that I don't know the difference between Spout and Spoutcraft and the Plugin Developer doesn't really explain how to install it and such, only explaining the benefits of having it, which I tried the regular way ( only with Spout - not Spoutcraft ) by putting the JAR in my Plugins folder, and it went crazy on me and made an infinite loop of random lines on the console, which I couldn't even stop the server without force closing it. I'm not even using a developers build either. I have no idea what to do about this. This mod looks amazingly cool, but because of Spout ( Apparently ) I can't use it.
    Do you know of what to do, or should I contact the Spout developers about this?

  17. Offline


    You need to use SpoutCraft to launch Minecraft.

    Spout must be installed on the server. Put Spour.jar and Bukkitinventorytools.jar into folder "plugins"
  18. Offline


    can you make it for when a player places a ches it automaticly locks?
  19. Offline


    Yes that would be possible. Could I please ask you to make a ticket on BukkitDev, then I will make this, when I get time.
  20. Offline


    Awesome plugin, just a little question. I keep getting the following in my console when users connect: [WARNING] [BukkitInventoryTools] Missing parameter:SBP.InventoriesShare.worldname

    Am I missing a config setting or is that a error?
  21. Offline


    2011-12-17 15:52:28 [SEVERE] Could not pass event BLOCK_PHYSICS to BukkitInventoryTools
    java.lang.ClassCastException: org.getspout.spout.block.SpoutCraftBlock cannot be cast to org.bukkit.material.Door
    at dk.gabriel333.BukkitInventoryTools.DigiLock.BITDigiLock.isLeftDoubleDoor(BITDigiLock.java:1738)
    at dk.gabriel333.BukkitInventoryTools.DigiLock.BITDigiLock.getLeftDoubleDoor(BITDigiLock.java:1768)
    at dk.gabriel333.BukkitInventoryTools.DigiLock.BITDigiLock.getDigiLockBlock(BITDigiLock.java:233)
    at dk.gabriel333.BukkitInventoryTools.DigiLock.BITDigiLock.isLocked(BITDigiLock.java:190)
    at dk.gabriel333.BukkitInventoryTools.DigiLock.BITBlockListener.onBlockPhysics(BITBlockListener.java:52)
    at org.bukkit.plugin.java.JavaPluginLoader$30.execute(JavaPluginLoader.java:469)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:339)
    at net.minecraft.server.World.k(World.java:514)
    at net.minecraft.server.World.applyPhysics(World.java:500)
    at net.minecraft.server.World.update(World.java:463)
    at net.minecraft.server.World.setData(World.java:406)
    at net.minecraft.server.BlockDoor.interact(BlockDoor.java:108)
    at net.minecraft.server.BlockDoor.interact(BlockDoor.java:99)
    at org.getspout.spout.block.mcblock.CustomBlock.interact(CustomBlock.java:323)
    at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:275)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:593)
    at net.minecraft.server.Packet15Place.a(SourceFile:39)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:93)
    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:550)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:527)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:425)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
  22. Offline


    What does Hotkey L Mean
  23. Offline


  24. Offline



    Having the same error. Please fix as it's flooding the console with errors constantly.
  25. Do I need spout?
  26. Offline


    same error [SEVERE] Could not pass event BLOCK_PHYSICS to BukkitInventoryTools here too
  27. Another plugin disturbs BIT.
  28. Offline


  29. Offline


    This is fixed in V3.1.3

    This is fixed in V3.1.3

    You need to add your worlds in the config.yml, so BIT knows which worlds who share the Backpack

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  30. Offline


    Sort of. Now it gives this error instead:

    It makes the server take longer to shut down too because it floods the console with errors on shutdown.
  31. Offline


    Its another bug. I have added a fix for this bug in V3.1.6. (It will solve SOME of the errors in the console).

Share This Page