[FUN/SPOUT] DeadMines v0.3.1a - Bringing hell to a server near you! Stability patch is out! 1.0.1-R

Discussion in 'WIP and Development Status' started by DrBoweNur, Jul 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    DrBowe

    @M1sT3rM4n
    Another thing I should have mentioned, whoops!
    If you make it so that eternal night is off, the only way zombies will be able to spawn during the day is if Apocalyptic-Spawn-Mode is on. This allows zombies to spawn during the day, and also allows them to spawn much closer to players (and also spawns much more of them)
    Currently, this is the only way to allow zombies to spawn during the day, as I can't simply override animal spawns, for example (so I must implement my own spawning mechanism)

    @Duffreaper
    I can't modify the size of zombies without a client mod, and (if what I know is correct) I can't make a zombie walk voluntarily away from the player. Sadly, server manipulation has its limits :(
     
  2. Offline

    M1sT3rM4n

    Sounds great! I was afraid mob-entity spawning during the day wasn't a possibility because of the way some mobs die when in direct contact with sunlight.
     
  3. Offline

    Wahrheit

    @DrBoweNur FYI, shows as .2 not .3 on startup.
     
  4. Offline

    FFLink

    Great plugin, by the way. Really loving this for one of our worlds.

    One issue, though (Might just be me being stupid):

    I want the zombies to only appear at night. This means naturally and through "hordes".

    It all works fine, but there are still horde spawns throughout the day, even though there are server messages claiming they have gone for the day.

    My config file looks like this:

    Code:
    Specific-Zombie-Settings:
        Jockeys:
            Point-Amount: 5
            Credits-Per-Kill: 3.0
            Spawn-Chance: 15
        Webbers:
            Point-Amount: 5
            Credits-Per-Kill: 3.0
            Spawn-Chance: 20
        Leapers:
            Point-Amount: 5
            Credits-Per-Kill: 3.0
            Spawn-Chance: 15
        Splitters:
            Point-Amount: 5
            Credits-Per-Kill: 3.0
            Spawn-Chance: 15
        Generic-Zombies:
            Point-Amount: 1
            Credits-Per-Reanimated: 1.0
            Credits-Per-Normal: 2.5
        Shades:
            Point-Amount: 5
            Credits-Per-Kill: 3.0
            Spawn-Chance: 15
        Infernites:
            Point-Amount: 5
            Credits-Per-Kill: 3.0
            Spawn-Chance: 10
        Zombie-Lords:
            Default-Health: 200
            Point-Amount: 50
            Credits-Per-Kill: 30.0
    General-Settings:
        Apocalyptic-Spawn-Mode: false
        Zombies-Resistant-To-Arrow-Pushback: true
        Persist-Through-Reload: true
        Synergy-Per-Zombie: 5
        Use-Sunscreen-If-No-Night: false
        Synergy-Per-Spawned-Zombie: 2
        Start-at-Night-End-at-Day: true
        Start-Up-Delay-In-Seconds: 15
        Use-Eternal-Night: false
    Multi-World-Settings:
        Use-Multi-World: true
        Apocalypse-Worlds:
        - ZombieWorld
    Horde-Settings:
        Base-Horde-Chance: 20
        Amount-Per-Horde: 4
        Horde-Spawn-Interval: 20
    
    Any help here?
     
  5. Offline

    M1sT3rM4n

    He did mention that the transition of the apocalypse from night to day might be bugged still. I think it's only eternally night or day for now.
     
  6. Offline

    FFLink

    Yeah, I did read that.

    In that case, consider the above a bug report :p
     
  7. Offline

    undeadmach1ne

    another quick bug report regarding multiworld settings. i made a map with an external generator for a quick look/test (nothing to do with zombiecraft) and when i loaded up the server and joined the game in my hub world (not my zombiecraft enabled world) i got the 'your time is up prepare for the hordes' message. i was in a hurry so i /zc stop and went about my testing of the other map. dunno what happened but thought i would mention it...
     
  8. Offline

    DrBowe

    @Everyone
    Thanks for all the bug reports.
    Yeah, the issues with hordes during the daytime is going to be dealt with, and I'm going to have to modify my message broadcasting to only include players in zombie worlds.

    @undeadmach1ne
    I think that may have something to do with what you experienced. If you had 'persist-through-reload' to true, then the event would fire up the moment you started the server. Then, after joining, it might have fired off a server broadcast (when really, it should only fire the message to players that are on zombie worlds)

    I'll look into it.

    @FFLink
    Yeah, as mentioned above, I need to work on that specific option (as there are quite a few bugs with it)

    @Wahrheit
    Thanks for the heads up, I always seem to forget about the yml :/

    Out of curiosity, are any of you guys experiencing any lag, or is the server being sluggish while using this? Don't panic, I'm not saying that it should be an issue. I'm just wondering, seeing as my server is relatively strong, so lag typically isn't an issue. I'm just trying to make sure that its not weighing down the smaller servers, because if it is, I can prioritize optimizing the code before I add more features.
     
  9. Offline

    M1sT3rM4n

    When I was localhosting I can notice a bit of performance lag like hiccups, not sure whether it's tied to mob-spawning.
     
  10. Offline

    DrBowe

    @M1sT3rM4n
    If anyone has McMyAdmin, I'd love it if they could throw it on there and watch for any CPU spikes. :D
     
  11. Offline

    M1sT3rM4n

    I can arrange for that :)
     
  12. Offline

    undeadmach1ne

    i experienced a few bouts of heavy lag in testing this. i run bukkit on localhost and never have problems like that (~100fps at worst under normal circumstances). (e8400@3.8ghz, 4 gigs, enthusiast/overclocking parts heavily tweaked for performance etc) during testing i experienced a few extended bouts of heavy lag where the framerate became visibly choppy for sometimes up to a minute (maybe more even) then returned back to normal.
     
  13. Offline

    M1sT3rM4n

    Good to hear that you're having the same issue and that it's not just me. At first I thought it was because of the map generation in progress. My FPS also dropped by as much as 20% while running this plugin, but often as "hiccup-periods."
     
  14. Offline

    undeadmach1ne

    yeah for me it was just seemingly random bouts of it. i thought it might be map related too because i downloaded a pretty large city map to use for this plugin and there is tons of stuff in it...but if i /zc stop and walk around there, the lag never happens.
     
  15. Offline

    DrBowe

    @undeadmach1ne
    Well, I was talking more about a sluggish behaviour. I'm not sure if this would cause FPS spikes, because thats an entirely different issue. However, I'll look into any possible issues where that could be caused by this, though FPS is usually linked to massive production of particle effects, which this doesn't really do (Unless you're spawning 20000 Shades)

    I'll have to see if its possible for a plugin to cause FPS drops (without particle generation), though I don't know if that's the case.

    EDIT:
    @M1sT3rM4n
    Ah, well if the issue is the same for two people, I may have to test this further. Though personally, I've never experienced any FPS drops, I'll flip on f3 and run around for a while to see if I can see large drops in FPS at random intervals.
     
  16. Offline

    undeadmach1ne

    well im playing on the server box so if the server is having heavy cpu or mem usage my client will suffer for it.
     
  17. Offline

    M1sT3rM4n

    @DrBoweNur:

    8-3-2011 9-22-39 PM.png

    Gigantic spike after server started with plugin. Think it might be because the zombies kept spawning out of control.

    After:

    8-3-2011 9-33-29 PM.png
     
  18. Offline

    DrBowe

    @M1sT3rM4n
    Was that with/without Apocalyptic?

    I know Apocalyptic is still very buggy, and there is no good way to keep the zombie spawning under control (That I've come up with, yet)

    If that's not with Apocalyptic on, then I've got a serious problem, and I need to figure out whats causing the CPU spikes.

    EDIT:
    Ok, are any of you using ZombieAttack with this?

    I can not seem to reproduce any CPU spikes what-so-ever...which is really bugging me. I'm going to throw ZombieAttack on, and see if thats the culprit. Seeing as I've heard a few people saying it has CPU issues.

    Here are the results of my test: (Mind you, only 2 people were on, though I dont see how having more people would cause higher spikes...since players arent monitored too closely)
    McMyAdmin Photos (open)

    [​IMG]
    [​IMG]

    Server was running the entire time with Apocalyptic-Enabled. Killed several zombies and made sure to spawn a few lords and additional zombies to test for spikes on deaths. I'm not saying the problem doesnt exist, I'm just saying thats its mind boggling that I'm not getting any sort of spikes while using it.

    Holy crap, do NOT use this with ZombieAttack. there are some MAJOR unresolved CPU spikes with that plugin. Whether the spikes are related to the two plugins conflicting, or whether its just zombieattack all on its own...I'm not sure.

    If anyone wants to test with zombieattack alone, be my guest. I'll be uploading screenshots of MyMcAdmin to show the difference when zombieattack is on.

    EDIT:
    MyMcAdmin with ZombieAttack & ZombieCraft (open)

    [​IMG]
    Initial start-up. Unusual spike the moment the server is up, zombie-craft has not been enabled yet, and it is daytime (so no zombies).

    [​IMG]
    The moment I start up ZombieCraft (apocalypse mode on), CPU sky-rockets.

    [​IMG] CPU is reaching its peak at some points, there is a very noticable lag on the server. (roughly half a second)

    [​IMG]
    I restart the server after removing ZombieAttack, CPU drops back to its normal 1-3%. It's very easy to tell where the restart happens.


    Point being, do not use ZombieAttack with this plugin. As I said earlier, they may be conflicting, or it may just be poor infrastructure within ZombieAttack. I'm not sure.

    If you guys are getting these spikes without ZombieAttack, then I'm at a loss of words. I'd appreciate config files, to see what settings you're using, and I'll try to replicate it exactly.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  19. Offline

    undeadmach1ne

    i installed zombie attack and zc at the same time and never looked back [zombie] i guess thats my problem. now the painful choice to live with lag and awesomeness or lose a feature i love in return for smooth gameplay...should someone make a bug report to (infected) or have you already?
     
  20. Offline

    DrBowe

    I'm going to send him the screenshots and try to get it resolved.
     
  21. Offline

    M1sT3rM4n

    First one was with, and the other was with it off.
     
  22. Offline

    DrBowe

    @M1sT3rM4n
    Did you happen to have ZombieAttack on the server as well? Because that seems to be the source of @undeadmach1ne 's issues
     
  23. Offline

    M1sT3rM4n

    I also did have ZombieAttack but when I ran the plugin with only ZombieAttack it functioned normally. I will do more extensive testing.
     
  24. Offline

    DrBowe

    @M1sT3rM4n
    I think its the combination of the two that is problematic.

    With ZombieCraft, you're going to have a LOT of zombies.
    Which means that ZombieAttack is going to have a LOT of calculations to perform (per tick).

    Where the true problem lies is beyond me. I might run some tests exclusively on ZombieAttack tonight, to see how badly it spikes the CPU with normal zombies
     
  25. Offline

    M1sT3rM4n

    That's definitely possible, since the zombie spawning rate was very ridiculous the last time I tested it. Maybe you can set a limit of mobs in the world? Like 250 or something
     
  26. Offline

    DrBowe

    @M1sT3rM4n
    There's actually a built-in limit already, as its the only way I can spawn zombies without them creating an endless loop (that crashes a server)

    It's currently set to 200 additional zombies. What I consider 'additional' is zombies that are spawned in lit up areas (essentially any zombie spawned by Apocalyptic-Mode)

    Normal zombie spawns aren't blocked or limited, but thats because the server will automatically limit generic spawns.

    I'll make a note to include an option for max-zombies in the config, but I feel like even without Apocalyptic, those two plugins aren't going to play nice.
     
  27. Offline

    M1sT3rM4n

    I am currently monitoring the resource use of the zombieattack plugin and it looks like it's eating up some resources as well.

    Boing.PNG
     
  28. Offline

    DrBowe

    @M1sT3rM4n

    If you have some sort of mob-spawning commands/mechanisms, see how the CPU reacts to 4-5 zombies at once. Out of curiosity, of course.
     
  29. Offline

    M1sT3rM4n

    Testing now, give me a second.

    After spawning 20 zombies:

    View attachment 5444

    So definitely a spike.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  30. Offline

    DrBowe

    @M1sT3rM4n

    Alright, I'll assume that ZombieAttack is the culprit (or most of the culprit) for now. Have you tried plain 'ole vanilla ZombieCraft? (without ZombieAttack)

    Also, thanks so much for running these extensive tests. It saves me a lot of time and allows me to do other important things...like eat :D
     
Thread Status:
Not open for further replies.

Share This Page