Inactive [FUN/MISC] Giant Trees v0.4.3 - Make Massive Trees in Minecraft [1.1-R6]

Discussion in 'Inactive/Unsupported Plugins' started by Connor Mahaffey, Jun 13, 2011.

  1. Offline

    Connor Mahaffey

  2. Offline


    I'm having issues with getting my trees to come out birch. I type in /gt 50 10 birch and it still comes out the normal trees. >.> Any idea how to fix this?
  3. Offline

    Connor Mahaffey

    If you want to do custom trees you need to specify a leaf type too. Try /gt 50 10 birch birch (Also, you may want to use 50 8 instead of 50 10).
  4. Offline


    Yeah, I'm fairly sure I did. But anyhow, the problem occured twice then went away! So now it all works fine.

    Thank you for an awesome mod!
  5. Offline

    Connor Mahaffey

    You're quite welcome, glad it's working now!
  6. Offline


    i have a bad feeling the chop tree plugin will make this giant tree fall instantly possibly crashing the server?
  7. Offline

    Connor Mahaffey

    Probably, but I really don't have any way to stop that from happening. Definitely remove/disable it if you plan on chopping up the tree.
  8. Offline


    Hello, i am having problems with this plugin, ANY ginttree commands i do, even help and other suff it gives me the "an internal error occurred while attempting to perform this command" Error! please help!

    My plugins are: AutoPlant,Bedrock,BlockHat,CommandBook,CraftBook,CraftBookCircuits,CraftBookMechanisms,Essentials,EssentialsChat,FastObby,FriendlyCreepers,GiantTrees,HeroicDeath,IPGet,Lockette,Log,MultipleHomes,Paid2Mine,Permissions,QuantumConnectors,RemoteBukkit,SuperPowers,VanishNoPickup,WorldEdit,WorldGuard,antixray,godPowers,iConomy,iConomyChestShop,mcMMO,nscommand
  9. Offline

    Connor Mahaffey

    I need the error from the console. It should be a bunch of text saying something about an exception. Give me all of it.
  10. Offline


    [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'gt' in plugin Giant Trees v0.3.2
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.NetServerHandler.handleCommand(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.a(
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NullPointerException
    at gianttrees.Main.checkPermission(
    at gianttrees.Main.onCommand(
    at org.bukkit.command.PluginCommand.execute(
  11. Offline

    Connor Mahaffey

    Seems to be a problem with Permissions. What Permissions version are you using? Are you running this server directly or through some kind of website? Are you running a cracked server? Did you try and execute a command via the console?

    Also (though it doesn't matter) you are one version lower than the current (v0.3.3 is the current).
  12. Offline


    im using multiplay, and no it is not a cracked server. when i try to execute via the console i get

    Error executing: gt (Unhandled exception executing command 'gt' in plugin Giant Trees v0.3.2)
  13. Offline

    Connor Mahaffey

    You cannot execute Giant Trees commands via the console, you need to be in-game. That's your problem.
  14. Offline


    i thought you told me to execute via the console, and i DID try it ingame, thats where i get the internal error
  15. Offline

    Connor Mahaffey

    Can you answer these questions from before:

  16. Offline


  17. Offline


    I'm sorry if I repeat anything, but I'm having problems with the plugin. It says I don't have the permissions to use the commands. I've tried '*' and i've tried putting in all the permission nodes. I even got rid of permissions to see if it would work with just the OP system, but it didn't. could someone help me please?
  18. Offline

    Connor Mahaffey

    I've had problems with this website before - another user had the exact same problem. In the end he went without permissions because the permissions on that site are broken. Permissions 3.0a is quite outdated - so outdated in fact that the method to check permissions does not exist (at least not the one used in 3.x). What's more their automated permission creation is quite crap. Try and install the current version if you can, or go without permissions. You could also try contacting their support, if they have any. I'm sorry but there's not much I can do.

    This has never been an issue before. What Permission system are you using? Do any of your other plugins have problems with permissions?
  19. Offline


    i deleted permissions and the plugin is great :)
  20. Offline


    i'm also having trouble with LazyRoad and Citizens plugins. I'm using the most updated one 3x Permissions. I've also tried deleting it and making no trace of permissions, and it still doesn't work. Like shouldn't it work without Permissions just using OPS? Yeah idk. It might be my permissions. Does it matter that i'm running through a mac or is that not a big deal?
  21. Offline

    Connor Mahaffey

    Awesome :) sorry for the inconvenience

    Yes it should default to ops if permissions aren't installed. Getting rid of permissions should have worked. Hmmm, are you sure you have Permissions set up correctly?
  22. Offline


    xD this plugin is just to good

    i have a suggestion, maybe make it so logs replace existing blocks if there isnt enough space, lets say for instance you do /gt in a 1x1 hole, it would reserve space and the tree's blocks would overwrite the existing blocks in that area, if that makes sense.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
    Connor Mahaffey likes this.
  23. Offline

    Connor Mahaffey

    It should already overwrite the blocks in a given area if you do that
  24. Offline


    Looks AWESOME!

    Connor Mahaffey likes this.
  25. Offline

    Connor Mahaffey

    Added pic to the top ;)
  26. Offline


    plz help I have this error why trying every comand
  27. Offline

    Connor Mahaffey

    You have to be in-game to execute the commands, you can't do it from console.
  28. Offline


    I'm having the same problem, whenever I try and run it I just get an error "An internal error has ocurred whilst trying to process this command".

    I've updated java, deleted permissions and it still does it
  29. Offline


    I tried

    /gt 38 4 1 1

    .. And i got a tree out of Stone, i thought log-/ and lead types would be like 0=normal;1=spruce;2=birch
    ? :D this Plugin, btw ;D
  30. When you add auto spawn on trees?
  31. Offline

    Connor Mahaffey

    I need the error from the console to help you.

    Haha no, if you want normal actually type in "normal" so /gt 38 4 normal normal - if you do a number it will do a block, in this case stone.

    I currently re-writing the entire project to make it more hard drive efficient, better coded, and adding an API for other developers. I'll try and add autospawn and planted trees then. Planted trees I can do for sure, autospawn I'm less sure of, because there is no way to check for a tree growth event in bukkit.

Share This Page