Inactive [FUN/MISC] Giant Trees v0.4.3 - Make Massive Trees in Minecraft [1.1-R6]

Discussion in 'Inactive/Unsupported Plugins' started by Connor Mahaffey, Jun 13, 2011.

  1. Offline

    Connor Mahaffey

  2. Offline


    When I do /gt undo my tree trunk goes away, but the treecrown remains! Not very funny to remove a 70x10 tree's whole crown!

    Anyone else had the issue?
  3. Offline


    :D great plugin!
  4. Offline

    Emiya Shirou

    Installed this on my server, It's AWESOME! I'm waiting for the functionality when those trees will spawn naturally ^.^ (of cores via your plugin ^^ )

    Keep Up The Good Job! \(^.^)/
  5. Offline


    This looks like a fantastic mod, but i cannot get it to work.

    I am using a multiplay remote server running Craftbukkit. I got your Mod via their list of pre prepared mods and so it's install is automated.

    When i try to use any /gt or /gianttree command i get the error message:

    Here is the server log output. I had just restarted the server before the test.

    Show Spoiler
    2011-07-13 19:02:57 [INFO] Starting minecraft server version Beta 1.7.2
    2011-07-13 19:02:57 [INFO] Loading properties
    2011-07-13 19:02:57 [INFO] Starting Minecraft server on
    2011-07-13 19:02:57 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-904-g9277096-b953jnks (MC: 1.7.2)
    2011-07-13 19:02:57 [INFO] Preparing level
    2011-07-13 19:02:57 [INFO] Preparing start region for level 0 (Seed: -3370808493809026609)
    2011-07-13 19:02:58 [INFO] Preparing start region for level 1 (Seed: 2656981478123529730)
    2011-07-13 19:02:58 [INFO] Preparing spawn area: 52%
    2011-07-13 19:02:59 [INFO] CraftBookCommon craftbook-nightly-169zml enabled.
    2011-07-13 19:02:59 [INFO] CraftBookCommon: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-07-13 19:02:59 [INFO] [HeroChat] HeroChat version 4.10.3 enabled.
    2011-07-13 19:02:59 [INFO] DropChest version 0.7.8 is enabled!
    2011-07-13 19:02:59 [INFO] File /data/games/minecraft/beta/79202/plugins/DropChest/dropchest.cfg not found.
    2011-07-13 19:02:59 [INFO] CraftBookCircuits craftbook-nightly-169zml enabled.
    2011-07-13 19:02:59 [INFO] CraftBookCircuits: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-07-13 19:02:59 [INFO] CraftBookCircuits: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-07-13 19:02:59 [INFO] CraftBook: Enumerating chunks for self-triggered components...
    2011-07-13 19:02:59 [INFO] CraftBook: 1254 chunk(s) for 2 world(s) processed (0s elapsed)
    2011-07-13 19:02:59 [INFO] [Giant Trees] version 0.3.1 is enabled
    2011-07-13 19:02:59 [INFO] motd version 1.0 is enabled!
    2011-07-13 19:02:59 [INFO] Growbie version 2.4 enabled.
    2011-07-13 19:02:59 [INFO] Enabled FlamingArrows!
    2011-07-13 19:02:59 [INFO] - Author(s): [Geoffrey Davis]
    2011-07-13 19:02:59 [INFO] - Version: 1.2.2
    2011-07-13 19:02:59 [INFO] [BananaChunk] version 4.6 is enabled!
    2011-07-13 19:02:59 [INFO] Stackable: Configuration file loaded.
    2011-07-13 19:02:59 [INFO] Stackable: Version 0.5.1 enable.
    2011-07-13 19:02:59 [INFO] CraftBookMechanisms craftbook-nightly-169zml enabled.
    2011-07-13 19:02:59 [INFO] CraftBookMechanisms: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-07-13 19:02:59 [INFO] 1 cauldron recipe(s) loaded
    2011-07-13 19:02:59 [INFO] [RemoteBukkit] Query running
    2011-07-13 19:02:59 [INFO] [RemoteBukkit] v0.3 Plugin Enabled.
    2011-07-13 19:02:59 [INFO] [RemoteBukkit] RCON running on
    2011-07-13 19:02:59 [INFO] Loaded Essentials build 2.4.2 by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo, ceulemans and Xeology
    2011-07-13 19:02:59 [INFO] SignThatChest version 1.5 is enabled.
    2011-07-13 19:02:59 [INFO] [TeslaCoil] version 1.4 by [Darklust] Loaded; performance boosted by GOAE
    2011-07-13 19:02:59 [INFO] [Permissions] Loaded default permissions
    2011-07-13 19:02:59 [INFO] [Permissions] Using default permissions for world: XX
    2011-07-13 19:02:59 [INFO] [Permissions] Using default permissions for world: XX
    2011-07-13 19:02:59 [INFO] [Permissions] v3.0b (MultiplayCompat) enabled
    2011-07-13 19:02:59 [INFO] [HeroChat] Permissions 3.0b found.
    2011-07-13 19:02:59 [INFO] CraftBookCircuits: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-07-13 19:02:59 [INFO] [Vegetation]: Permissions found!
    2011-07-13 19:02:59 [INFO] [Vegetation]: Settings for world [HONGville] loaded.
    2011-07-13 19:02:59 [INFO] [Vegetation]: Vegetation v3.3 enabled.
    2011-07-13 19:02:59 [INFO] WorldEdit 4.6 enabled.
    2011-07-13 19:02:59 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-07-13 19:02:59 [INFO] Done (0.202s)! For help, type "help" or "?"
    2011-07-13 19:04:06 [INFO] ellyhong logged in with entity id 26
    2011-07-13 19:04:14 [INFO] §9[PLAYER_COMMAND] ellyhong: /help
    2011-07-13 19:04:23 [INFO] §9[PLAYER_COMMAND] ellyhong: /help tree
    2011-07-13 19:04:37 [INFO] §9[PLAYER_COMMAND] ellyhong: /help gianttree
    2011-07-13 19:04:45 [INFO] §9[PLAYER_COMMAND] ellyhong: /help 23
    2011-07-13 19:04:55 [INFO] §9[PLAYER_COMMAND] ellyhong: /help 22
    2011-07-13 19:05:10 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'gt' in plugin Giant Trees v0.3.1
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.NetServerHandler.handleCommand(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.a(
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NullPointerException
    at gianttrees.Main.checkPermission(
    at gianttrees.Main.onCommand(
    at org.bukkit.command.PluginCommand.execute(
    ... 12 more
    2011-07-13 19:05:40 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?

    My permission with Users and groups seem to work fine for all my other mods. I am set up as Admin.

    I badly want to be able to use your Mod, so any help would be appreciated.

  6. Offline

    Connor Mahaffey

    Thanks for your patience, I'll try and get a fix up today or tomorrow. And I think no one else reported it because very few must build in their trees D:

    Thank you both :D

    Hmmmm, I might be able to. I'll have to test it out. If I can I'll add it as a setting in the config. Probably not in the fix coming but maybe in 4.0.

    It definitely shouldn't do that! Are you sure you let it build the whole way before undoing it?

    First off, thanks for the excellent error report. Now, are you trying to run the commands from console? Because that won't work. Also, if you are in offline mode (aka for cracked clients) it probably won't work either (but it doesn't sound like you are). The only other thing it could be is your Permissions version. You have 3.0b and the current version is 3.1.6.
  7. Offline


    Connor, thanks for responding. I am rather stumped.

    I must first apologise for any ignorance i show as i only picked up Minecraft a few weeks back and hadn't used any coding language/terminology before that. So it has been somewhat of a learning curve. SSP first (lots of gnashing teeth) then finally SMP (teeth worn down to nubs)!!

    I am unsure what you mean by console. In my plain speak, I am attempting to use these commands while logged into in the game itself. i.e press 't' to get text entry option and then typed /gt or /gianttree. Which generated error.

    I am Online and no cracked client, licensed client only for me.

    Hmm, not a huge ammount i can do about this version of Permissions.

    It is the only one available to "Auto-install" from the Multiplay (MP) account admin section. Though i could ask the support team to install 3.1.6 (Will try that after i post this.)

    I am however hoping to join MPs FTP server testing which will allow any plugins to be installed i assume just like a standard 953 build Bukkit Server without Admin restrictions.

    I have my account set up as admin with - '*' permissions so in theory all should work.

    What can you advise i use instead of the Permissions plugin if that is causing the issues?

  8. Offline


    Treehouses are fun ^-^'
    Connor Mahaffey likes this.
  9. Offline

    Connor Mahaffey

    Wow, that's quite a journey. Sorry your having issues with my plugin.

    This is a very strange error. Are you having problems with Permissions in any of your other plugins, specifically DropChest or Craftbook?

    The only thing that jumps out at me is that Permissions should be initialized before all other plugins, and its not. Ex. look at an old server log:

    Show Spoiler

    2011-06-12 19:24:46 [INFO] Starting minecraft server version Beta 1.6.6
    2011-06-12 19:24:46 [INFO] Loading properties
    2011-06-12 19:24:46 [INFO] Starting Minecraft server on *:25565
    2011-06-12 19:24:46 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-823-gb9d0b04-b860jnks (MC: 1.6.6)
    2011-06-12 19:24:46 [INFO] Preparing level "world"
    2011-06-12 19:24:46 [INFO] Preparing start region for level 0
    2011-06-12 19:24:47 [INFO] Preparing spawn area: 69%
    2011-06-12 19:24:48 [INFO] Preparing start region for level 1
    2011-06-12 19:24:48 [INFO] Preparing spawn area: 60%
    2011-06-12 19:24:49 [INFO] [Permissions] (Phoenix) was Initialized.
    2011-06-12 19:24:49 [INFO] [AFK] version 0.1 is enabled
    etc. - all other plugins load

    You'll see Permissions is initialized before any other plugins load. Perhaps Giant Trees is loading, seeing the permissions plugin, and getting it before it's loaded the permissions? It's the only other thing I can think of. Permissions should load itself first automatically, so all I can think of is that maybe this older version didn't do that. But then DropChest and Craftbook should also have problems with Permissions.

    I'm assuming you're using some kindof easy host with a "control panel" that you use from the web. These "easy" hosts are often running earlier version of Permissions, etc. so that it's compatible with their software.

    Ask them if there is an available upgrade to 3.1.6. If not there isn't much I can do. Giant Trees will run without Permissions and default to OPs, but to make it do so you need to remove the Permissions plugin entirely.

    It's a longshot, but you can always try re-downloading Giant Trees and Permissions, sometimes the downloads are corrupted somehow and it gets messed up. Make sure the server is stopped when you install/overwrite plugins.

    Hope that made sense. Feel free to contact me in a PM.


    0.3.2 released!

    Fixed tree decay issue - but you'll need to make a new tree :/ sorry - and careful if you undo it, it could erase your tree house

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  10. Offline


    @Connor Mahaffey - Glad you figured it out! I figured, but it's not big deal, I'm just going to use world edit to cut and paste the house part of the tree back into it :)
    Connor Mahaffey likes this.
  11. Offline

    Connor Mahaffey

    Sorry I missed your guy's posts.

    Just a problem with the algorithm I use to spawn the trees. Try turning up the density?

    Are you close enough to the tree? Are you getting any errors?
  12. Offline


    Thanks for the help. I had conflicts with Permissions 3.0b and once i deinstalled that (after having to remove Craftbook also due to it requiring Permissions) i created myself a tree!

    Some photies are below for your perusal. Birch, Density 20. 58 high (Max possible from base height of 70 my fort levelis built at) , 10 width, birch wood and Leaves


    All Father Tree at Fort Grendel

    All Father Tree at Fort Grendel 2011-07-15_15.12.21.JPG All Father Tree at Fort Grendel 2011-07-15_15.17.22.JPG All Father Tree at Fort Grendel 2011-07-15_15.19.31.JPG All Father Tree at Fort Grendel 2011-07-15_15.21.49.JPG All Father Tree at Fort Grendel 2011-07-15_15.23.02.JPG
    Connor Mahaffey likes this.
  13. Offline


    Every time I spawn a giant tree in my server with the command that is less than 20 density, the leaves end up as lava. I think we have a bug.
  14. Offline

    Connor Mahaffey

    I think you're doing the command wrong. Tell me the command you are using.

    Just tried this on my personal server and that didn't happen. And I really don't see a way it could happen.
  15. Offline


    /gt 50 4 birch 15

    That is the command I am using. Turns the leaves into Lava and forms a very hard to get rid of tower of doom (lava) in my server. Even if I undo the tree, the lava stays.
  16. Offline

    Connor Mahaffey

    Yes that's wrong :) the command format is /gt <height> <width> <logtype> <leaftype> <density> - so for you, /gt 50 4 birch birch 15
  17. Offline


    Well, I managed to get rid of the tower of doom and I created Trees using the command /gt 50 4 oak 19. Guess I got lucky. But if you think about it, the lava thing is pretty funny after the cleanup. *LOL*
  18. Offline

    Connor Mahaffey

    Yea, water and lava don't clean up well because they run all over the place. Just remember you need to do the log and leaf type, and then density. Otherwise you'll get some very strange, potentially dangerous, trees.
  19. Offline


    I tried it but it made a massive Lava tree, i tried to undo it but it didn't work. Please could you make a no lava plugin as I don't think there is a way to get rid of that massive lava tried water but it didn't work. Also its on my server and there a are quite a few wooden houses around it, its already destroyed 2, please help. Thanks
  20. Offline


    Hey Connor Mahaffey, i have a request for you. Well i think this could make your Great Plugin even more better than it is: Well i think there should be a option for 'Branches' like -
    /gt <height> <width> <logtype> <leaftype> <density> <branches-yes/branches-no>
    I Would think this would go GREAT with this plugin, please respond :) Thanks Hope i helped xD
  21. Offline


    Got some questions about updating...[I'm currently on 0.3.1]

    Will my current trees disappear?
    or will it just prevent me from undoing old trees?

    I understand that if i want the new leaf decay tweaks, my old trees wont be effected by it..but i'm worried that if i upgrade my trees will vanish :(
  22. Offline

    Connor Mahaffey

    Undo only removes the source blocks so all the lava that fell is still left over. Try using WorldEdit and create a box of "air" around the spot to remove the lava. You can always prevent lava trees by removing the permission gianttrees.customdangerous.

    Well there are branches but they don't show up too well. Unless you mean branches like sticking out of the tree trunk halfway up. I really need to re-code the project so I can add things like this. The way its set up right now isn't the best. I'll definitely keep it in mind though. At least one dev said that if I made a way to "hook in" to the block spawner, he'd work on making some other types of trees.

    Oh no your trees should be fine! :D Just replace the old .jar with the new one, and any trees you make after that shouldn't decay. You can still undo all your old trees, etc. This version just changed the way trees are made so there is more wood. No worries.
  23. Offline


    I've built a few trees with this plugin (way cool, btw) and it seems like the canopy of the trees are all built by placing the same basic 'canopy unit' (for lack of a better term). Would it be a big deal to have 2 or 3 different 'canopy units' that get used? I think that'd help make the trees a little more organic.
  24. Offline

    Connor Mahaffey

    Yes they are all built using one wood block surrounded by leaf blocks on all sides - then multiplied several times in an area, basically. I do still want to change how trees spawn some. Mostly to make them a little less square and fix some coverage issues but that could be a feature as well. I could randomly add a few leaves outside the "basic unit" - as long as they are within 4 blocks they shouldn't decay.

    Thanks for the idea :) I'm always trying to improve the look of the trees.
  25. Offline


    I also cannot run giant trees (along with dreamland and effective arrows) because it causes permissions to crash. Since I need permissions, I can't use giant trees right now. :(
  26. Offline

    Connor Mahaffey

    Could you give me the error? Giant Trees should not have problems with Permissions. It even works with PermissionsEx apparently.
  27. Offline


    Very nice plugin to play around with!
    Connor Mahaffey likes this.
  28. Offline


    19:20:50 [SEVERE] java.lang.IllegalAccessError: tried to access class com.nijiko
    .permissions.ModularControl$RefreshTask from class com.nijiko.permissions.Modula
    19:20:50 [SEVERE] at com.nijiko.permissions.ModularControl.<init>(ModularC
    19:20:50 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.setupPer
    19:20:50 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.onLoad(P
    19:20:50 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    19:20:50 [SEVERE] at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer
    19:20:50 [SEVERE] at net.minecraft.server.ServerConfigurationManager.<init
    19:20:50 [SEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftSe
    19:20:50 [SEVERE] at
    19:20:50 [SEVERE] at
    19:20:50 [SEVERE] [Permissions] Unable to load permission data.
    19:20:50 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    19:20:50 [INFO] [Permissions] (Yeti) was initialized.
    19:20:50 [INFO] [Permissions] (Yeti) disabled successfully.

    That's what it tosses if I have gianttrees.jar in the plugins directory.
  29. Offline

    Connor Mahaffey

    I know there were a few plugins that caused illegal access errors in the past. It seems to be a problem with Permissions - the error path doesn't link back to my plugin.

    Are you using the latest version of Permissions? 2.X or 3.X ? Have you tried re-downloading the .jars?

    If nothing turns up I'll post it as an issue on Permissions Github page.
  30. Offline


    i stand right next to it. like, half a block away. it says the tree should be gone... but it's still there.
  31. Offline

    Connor Mahaffey

    Hmmmm, I really don't know what the problem could be if there are no errors, etc. In the meantime you can use WorldEdit to get rid of it. Sorry for the inconvenience, but I really don't know what the issue is.


    0.3.3 released!

    Added PermissionsBukkit support (the new official bukkit permissions for those of you who didn't know).

    This plugin will still default to Permissions 3.x if it is installed. Otherwise it will use PermissionsBukkit, and if that isn't configured, default to ops. If you are using PermissionsBukkit and want an op to not have a command, you will need to specifically say so in your config.yml ex. gianttrees.undoall: false.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016

Share This Page