Inactive [FUN/MISC] Giant Trees v0.4.3 - Make Massive Trees in Minecraft [1.1-R6]

Discussion in 'Inactive/Unsupported Plugins' started by Connor Mahaffey, Jun 13, 2011.

  1. Offline

    Connor Mahaffey

  2. Offline


    in game I have the same error
  3. Offline

    Connor Mahaffey

    You're sure its the exact same error? The error you showed me occurs when someone tries to type a command via the console. Execute a command in game and show me that error.
  4. Offline


    here is the error [​IMG]
  5. Offline

    Connor Mahaffey

    Thanks, that's better. What Permission's version are you using - is it the latest 3.1.6 ? Not some obscure version like 3.0a or something?
  6. Offline


    oh there's the problem lol I don't know how to use permissions or how to activate that plugin I have permissions 3.1.6 plz help D:
  7. Offline


    this plugin is pure Chuck Norris creation ! good jobs !
    Connor Mahaffey likes this.
  8. Offline


    This is what happens when you don't read instructions and start entering random numbers

  9. Offline


    that looks great but I read all....maybe why I speak spanish and not english so I need some more help D:
  10. Offline


    cool plugin guna use this to make a elf town :D
    Connor Mahaffey likes this.
  11. Offline


    Here it is:

  12. Offline

    Connor Mahaffey

    Afraid I can't - try the Bukkit Help subforum.

    Hahaha yea, lava trees are not fun to clean up....You should have seen a glitch before where you could make "torch" trees. They all popped off because they had nothing to stick on and shot all over the place.

    You are using an outdated version of Bukkit. With no permissions, this plugin defaults to Bukkit Permissions, which means you need at least build 1000. Note: You don't actually need to have Bukkit Permissions set up to use the plugin, they just need to exist - if that makes sense.

    EDIT: @wallkie - I figured out your problem, you are also using an outdated version of bukkit, upgrade to build 1000

    And if you want to learn how to set up Bukkit Permissions try here:

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  13. Offline


    Thanks very much, that was the problem. Great plugin btw
    Connor Mahaffey likes this.
  14. Offline


    oh... I see D:
  15. Offline


    this dident work very well alot of the time it just made crappy random trees :/
  16. Offline


    you should add a command to create a tree with a hollow trunk. that would make building treehouses much easier. also i cannot seem to get the tree to spawn as anything other than the normal. no dark wood or white wood
  17. Offline

    Connor Mahaffey

    I've though about it but it'd be difficult to make a hollow tree. And try this: /gt 24 4 birch spruce
  18. Offline


    thank you that really helped on the tree type problem i was having. but still a hollow tree would be greatly appreciated. and i understand how it could be hard seeing is how im still just a new programmer myself. i still cant work with java though mostly just html5
  19. Offline


    This rocks, thanks for creating this! I was hoping to use it to build some crazy tree-house city, like here: but for that I'd need some seriously big trees - bigger than I think you intended your trees to be.

    I'm trying to create one that's 16 blocks wide, max height (starting at sea level) and it looks ok until about 10 blocks up, and then it's just flat on top with four spindly branches coming off it at 45 degree angles (see screenshot or spawn one with density set to 0 to see what I mean). Any chance you might tweak it so that the trunk goes nearly to the top, with a steady tapering of the width? Doesn't need to come to a point either, could have the top be 1/4 the width of the base maybe.

    Attached Files:

  20. Offline

    Connor Mahaffey

    It's a good idea I think. Just make the top like the trunk, except opposite.

    There's a massive update coming but its going to be awhile, but I'll try and add it then. In the meantime I'd just hack in a few blocks and build it yourself if you can. Thanks for using my plugin ;)
  21. Offline


    love it
    Connor Mahaffey likes this.
  22. Really cool, suggestion: its very irritating when its says not enough space for tree, if it could be more specific it would be nice (eg. can't build such a high tree here, not enough space for tree base, ect.)

    AlsoKnownAsJazz likes this.
  23. Offline


    When i try to make a diamond tree it says i dont have permissions even though its my server and im admin
  24. Offline


    this is a nice plugin. but it doesn't make the tree type i want and that is the multi branch trees. can that be something added be able to grow a multi branch tree?
  25. Offline


    @Connor Mahaffey : Want to consider checking for LeaveCraft as an option to make "branchless" trees? :)
  26. Offline

    Connor Mahaffey

    Have you given yourself the proper permission to make custom trees?

    Maybe in a future update. With the upcoming version it will be easier, but I'm not sure how I would handle it in the command structure as it is right now.

    Hmmm it'd mess up the way I have it right now, would require a lot of if statements. Next version will have an API though, so idk.
  27. Offline


    im having troubles is say i dont have permision and i am the owner of the server how would i fix this in permisions because my permisions came with essentials and i dont know how to fix this
    plz help and ill giv u some [cake][diamond][gold] if u dont help me a [creeper] will blow u up

    also i am using a mac so :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  28. Offline

    Connor Mahaffey

    Did you give yourself permission to use Giant Trees in your permissions file?
  29. Offline


    idk how
  30. Offline

    Connor Mahaffey

    Well you need to figure that out. Or delete permissions entirely and rely on ops.
  31. Offline


    well i still dnt know how it wuz downloaded with essentials :(

Share This Page