Inactive [FUN/ECON/DEV] uQuest v1.50 - Overly customizable quest system [793 - 602]

Discussion in 'Inactive/Unsupported Plugins' started by Hawox, Mar 4, 2011.

  1. Offline


    As most of you can guess I have not worked on this plugin in a long time. I'm working full time at a grocery store as well as going to college. I literally have no time for sleep let alone Minecraft. Recently someone has contacted me saying they are working on my plugin. I appreciate his work and effort while I am away. This is a link to his topic. His download can be found at
    uQuest - Overly customizable quest system!
    German Questlist 5/16/11
    Coming Soon!
    Gui Questmaker (Heres a beta build!)
    Upload/download area for quests!
    mcMMO extension!

    Laxlux - New German quest list maintainer
    HiMyNameIsAJ - Creating a uQuest website
    Looking for:
    • Someone to make a nice looking website for uquest (Not my cup of java).
    • Someone to add MySql support.
    • Plugin attachment devs!
    • Someone with ideas on different quest types!
    • People to write some random quests to be thrown in the defaults!

    -----------------------Plugin summery below this point-----------------------
    ~Comes preloaded with 53 quests!~

    Support for: (You don't NEED any of these for the plugin to work.)
    Permissions (but not needed!)
      -"uQuest.CanQuest.*" - Allows all these sub permissions
      -"uQuest.CanReloadQuests" - Allows the use of /reloadquests
      -"uQuest.CanReloadQuestConfig" - Allows the use of /reloadquestconfig
     iConomy (but not needed!)
     BOSEconomy (Again, not needed!)
     Essentials! (Again, not needed!)
    Alright here goes, theres a lot to cover so I may miss something on this first go threw! Want a better way to get money into your server economy that selling items to the server or random lottery's? Do you like QUESTS?!?! Do you want your users to compete to see who is a better quester? Then uQuest might be for you!

    uQuest offers your users a simple way to quest! No need to walk miles and miles to a random NPC or click on some block at spawn. All they need to do is type '/uquest give' and uQuest will give them a random quest from it's database! A yml file is provided where you type out each quest for your users. That's right. YOU can decide how many quests there are, what they are, and how you want your users to do them (creating and editing this file are explained on the wiki). You can broadcast every x quests someone finishes to the server as well as give out rewards for x amount of quests. I'll leave the rest for the features section, just thought I'd get you hooked with that :3 If you grab the .zip (which you need to if you want to store your users in a SQLite database!) I have included 53 quests inside!

    All of that not enough? Well theres an API! Other plugin authors can use this as a base for their own plugins!

    Here's a quick screenshot of what the text looks like:

    (I may miss a few, there's quite a bit)

    ~Quest Types~
    All of these can have specific locations set to them! (Can only do in this area etc)
    (More to come I promise!!)

    (More to come I promise!!)

    ~Watch out~
    With great power (of customization)... Come's great responsibility.... There is a lot that can go wrong if you don't pay attention when your changing files. Thankfully, I've tried to have the plugin spew out as many warnings as it could on the servers start. Always give it a check to make sure the plugin loaded all of your work!!!

    ~Plugin Attachments~
    (These plugins add new features to the basic uQuest system)
    Just started this as an example of what people can do. All it currently has is /qadmin givequest
    OP's and people with the permissions (not required for this either) node 'uQuest.MoreModCommands' can use it.
    Simply shows someones progress on a quest everytime they do something for it. IE. I punch a log as part of my quest (grey text)Log Punches 7/10.
    Just put the jar into your plugins folder and it will work on it's own!
    Updates needed: Move quests | Picking up items. | Support for uQuest levels
    Completes quests automagicly! Works with the same methods as showtracker so it has the same flaws. There is this weird bug when running both at the same time that spams some weird extra text. Try to ignore it for now.
    Just put the jar into your plugins folder and it will work on it's own!
    Updates needed: Move quests | Picking up items. | Unknown status on working with quest levels. | Odd text bug with showtracker/this mix.

    ~Plugins using the API~
    (These plugins use the uQuest API to shape their own plugin)

    Since people don't read the above, I'll post this again here so I don't have to write the reply back to this anymore.
  2. Offline


    Last edited by a moderator: Dec 15, 2016
  3. Offline


    I go to download the plugin but when I click Versions and Downloads it just takes me to a blank page and nothing happens :(
  4. Offline

    Randy Schouten

    You, sir, are blind.
    You might wanna look one post above your own.
  5. Offline


    Someone must officially start updating it :(...
  6. Offline

    Randy Schouten

    Or follow my quest plugin.
    It's still in beta, but I'm getting there :)

    There's a link in my signature. (Which you can see right above your post)
  7. Offline


    I'll check it out :).
  8. Offline


  9. Offline


    How can I reduce the amount of money given as a reward? I tried editing it by the config file, but it still remains the same.​
  10. Offline


    Hi there,

    I want to make a quest where, among other items, you should collect a birch sapling. So i put this in the quest:
          Type: Gather
            Item_ID: 6
            Display_Name: Birch Sapling
            Amount: 32
            Durability: 2
    But the durability isn't working. If i collect some normal sapling i can complete the quest...

    Can anyone help me?
  11. Offline


    Still works for 1.8.1 and still useing this great plugin. hope to see it finshed great plugin bring it back.
  12. Offline


    It's a lot harder now that i am working full time. However I am gettig back into Minecraft. so I MAY come back to plugging programing. Keep an eye out.
  13. Offline


    I hope you do bring this back <3 !
  14. Offline


    Got some major error going on here...
    The quests dont seem to work with iConomy

    When I try /uquest done it will display that the quest is complete and increase your amount of completed quests by 1 but then you get a error when trying to give a reward.

    "An internal error occurred while trying to perform this command"

    14:50:21 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'uque
    st' in plugin uQuest v1.5
            at org.bukkit.command.PluginCommand.execute(
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.
    Caused by: java.lang.NoClassDefFoundError: com/iConomy/iConomy
            at hawox.uquest.QuestInteraction.getMoney(
            at hawox.uquest.QuestInteraction.hasEnoughMoney(
            at hawox.uquest.commands.Cmd_uquest.onCommand(
            at org.bukkit.command.PluginCommand.execute(
            ... 6 more
    Same thing happens when I try /uquest drop

    any ideas???

    Currently using iConomy 6.0 and uQuest 1.5
    Osviux likes this.
  15. Offline


    I have the same problem.
  16. Offline


    I believe the error is with permissions and iConomy

    From looking at the source it seemed to use Permissions and I used PermissionsBukkit
    It also used com.iConomy in the source where as the new iConomy6 uses com.iCon6

    Been playing about with the code and what not.. remover the other conomy supports and modded iCon to use iCon6

    I'm just having a few issues understanding the code.. I havent ever done plugins before and never used java ether xD done some C++ and so thats helping understand some of it..

    I'm hoping my mods to it will eventually fix these bugs but no idea if thats actually true or not.
    May just end up making it worse =[

    If someone can look through the source and fix it that would be awesome..

    Need to fix this..
    if(UQuest.getPermissions() == null){
                Plugin PermissionsBukkit = UQuest.getBukkitServer().getPluginManager().getPlugin("PermissionsBukkit");
                if (PermissionsBukkit != null) {
                        System.out.println("[uQuest] Successfully linked with Permissions.");
    and this..

    if(player != null){
    			if(plugin.isUsePermissions() == true){
    				if(UQuest.getPermissions().has(player, "uQuest.CanReloadQuestConfig"))
    //.has function to be changed/fixed
    					process = true;
    Original and my Part Fix (NOT COMPLETE SO WONT WORK YET)
    <Edit by Moderator: Redacted mediafire url>
    Last edited by a moderator: Dec 15, 2016
  17. Offline

    Don Redhorse

    if anybody is picking that up... use vault... supports all economies and all permission systems..
  18. Offline


    Would do if I had any clue what I was doing xD
    Like I say im just patching what I can, and have no exp in any form of Java or plugins.. I just want it to work xD

    Would be awesome if someone did patch this up though.
    As far as I know it changed from uQuest to iQuest to RPGQuest and never got finished or updated.. Shame really as a good SIMPLE quest plugin would be handy.
  19. Offline

    Don Redhorse

    take a guess why I learned java and some plugins are still around..

    if you can wait around 1 month you will perhaps find something nice for a special world on my plugin page...otherwise.. well I guess plugin request could always work.
  20. Offline



    I actually managed to fix it..
    Coded it to work with PermissionsBukkit as thast what I use but it actually works ^_^

    I actually started jumping with joy :p

    1st plugin and 1st time ever coding in java ever and it works xD
    hers the link guys ;) <Edit by Moderator: Redacted mediafire url>

    I take that back ¬_¬

    All did kind of work but permissions is slightly wrong.
    Ill keep working on it over next few days

    EDIT 2:
    After talking with SpaceManiac about his Permissions I finally got this plugin working again..
    <Edit by Moderator: Redacted mediafire url>

    Quick update before I go to sleep.. (7:05am)

    I did find one issue with using PuzzleQuest/RedstoneChips (Not sure if your using this?)

    When using the "QuestCircuit - Finish Chip":
    It seems to finish a quest even though you haven't got all the things required..

    I have actually fixed this by making it call the CheckDone function again before continuing with the finish function..
    Making it check to see if all the required objectives are done before it runs the rest of the finish function.
    If CheckDone returns False (because you have a objective left) the finish function exits, stopping quests from being completed without all objectives complete.

    Again this will only effect you if you use the finish quest function... If you use the /uQuest done command it should still work fine.
    If you do use that function you WILLneed the new Jar file
    <Edit by Moderator: Redacted mediafire url>

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 15, 2016
  21. Offline


    I have a little problem, maybe someone can help me? -> The plugin works fine, but when I want to end a quest (/uquest done) there comes a text that says that the quest is finished, but it isn't.... Because when I type: /uquest give after this it says: You already have a quest active. Please help... anyone...
  22. Offline


    Just tested your problem out on my fixed v0.4 and this is what happens..

    /uQuest give 0 (gives quest 0)
    I then do the required tasks needed to complete the quest (Kill 4 pigs and get 2 Raw Porkchops)
    /uQuest info (Should then show tasks needed for current quest)
    It shows me that I have got all the tasks completed..
    /uQuest done (tries to finish the quest)
    Message shows that quest is complete and I get a reward.

    /uQuest info (Should then show tasks needed for current quest)
    I get a message saying you currently have no active quest.

    Are you using one of my fix's if so what one and if not try downloading fix v0.4
  23. Offline


    I tryed it with your fix too, but than I get a internal error with every uquest command
  24. Offline


    Any chance you can post the error log...
  25. Offline


    I use now BOSEconomy and now it's finishes the quest and I can do another quest but now I ony get no reward

    Have a look at this, this is the config (a part) ->
    #### PluginSupport:
    #The number of seconds after enabling to check for plugin linkage. Make this larger if your having issues with uQuest detecting plugins.
    pluginTimerCheck: 10
    #Set to true if you want to have support for these plugins.
    usePermissions: true
    #Options (copy exactly): iConomy, BOSEconomy, Essentials
    MoneyPlugin: BOSEconomy
    moneyName: Monies

    And this is what text I get in the run.bat ->
    19:45:59 [INFO] [uQuest] Successfully linked with Permissions.
    19:45:59 [INFO] [uQuest] Successfully linked with BOSEconomy.
    19:45:59 [INFO] [uQuest] Successfully linked with Essentials.
    19:45:59 [SEVERE] [uQuest] iConomy is not loaded. Turning iConomy support off.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  26. Offline


    In my fix I had to disable BOSEconomy and Essentials.

    I didn't use them and so didnt have the jar source for them to link with the uQuest source in order to see what needed fixing..

    Fix v0.4 should work with iConomyv6 and PermissionsBukkit (maybe other permissions im not too sure as of yet)

    You have to make sure that they have the ermission node for drop/give etc in order to use those commands..

    Other than that there shouldn't be a problem.. but ill take a look this sat when I have a day off from work.
  27. Offline


    I think the plugin author has long since moved on, but this is still an incredibly popular plugin on my server and had worked amazingly well despite no updates for a long time. Haven't found any other Quest plugin that is as good as uQuest, so I will probably invest the effort to get it updated to R6. Anyone out there still using this and interested in the update if I do? I'll consider sharing if so.
  28. Offline


    +1 from me - that's for sure
  29. Offline


    I went ahead and updated it for R6. I've tested it locally and it works well enough to load and print results on "/q" commands, but I've not exercised it past that and have not upgraded my prod server yet. So no guarantees, but you're welcome to pull the download and give it a test yourself:

    Note I am NOT picking up support for this plugin. I will get it working for my server and since that means updating it to R6, I'm willing to share that with others, but I will not respond to questions about issues or bugs. You're on your own there. If what I publish works for you, great and enjoy. If it doesn't, you're welcome to post an issue here but no guarantees I will respond or fix it, maybe some other friendly dev with free time to spare will come along to help.
  30. Offline

    Randy Schouten

  31. Offline


    I'm really thankfull for your work on getting uQuest to still work (it's working on 1.2.4) I hope that you will continue updating when it would stop working.

Share This Page