Failed To Load Main-Class manifest attribute from....(CB.jar name)

Discussion in 'Bukkit Help' started by KraaZe, Nov 20, 2011.

Thread Status:
Not open for further replies.
  1. This only happens on Bukkit 1.0.0

    I've tried this on both my CentOS Dedicated box, and my Windows PC. When I type java -version, I get:

    java version "1.6.0_20"
    OpenJDK Runtime Environment (IcedTea6 1.9.10) (rhel-
    OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)

    I get the EXACT error:

    > java -Xms1024M -Xmx1024M -jar craftbukkit.jar nogui
    Failed to load Main-Class manifest attribute from

    Any ideas? $5 PayPal to whoever gives the right answer. I will PM you.

    Bump. I really need this fixed :S

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 21, 2016
  2. I think the build you got might not have been compiled correctly, as this is not a recommended build - it may be why.
    What version of Bukkit are you running? I'll download it and see if I get the same error.
    We'll work from there.
  3. Offline


    I've got the same issue, just tried using the latest dev build to get plugins on our new 1.0 server, on a linux box. Ah well, may have to wait until a recommended release is up I guess?
  4. Thanks guys.
  5. Offline


    Thanks! Wellp, I get this when I give it a shot

    18:39:34 [SEVERE] java.lang.NullPointerException
    18:39:34 [SEVERE] at net.minecraft.server.WorldServer.c(
    18:39:34 [SEVERE] at net.minecraft.server.World.a(
    18:39:34 [SEVERE] at net.minecraft.server.Chunk.addEntities(
    18:39:34 [SEVERE] at net.minecraft.server.ChunkProviderServer.getChunkAt(
    18:39:34 [SEVERE] at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(
    18:39:34 [SEVERE] at net.minecraft.server.World.getChunkAt(
    18:39:34 [SEVERE] at net.minecraft.server.World.getTypeId(
    18:39:34 [SEVERE] at net.minecraft.server.World.isEmpty(
    18:39:34 [SEVERE] at net.minecraft.server.World.a(
    18:39:34 [SEVERE] at net.minecraft.server.WorldProviderHell.canSpawn(SourceFile:37)
    18:39:34 [SEVERE] at net.minecraft.server.World.canSpawn(
    18:39:34 [SEVERE] at net.minecraft.server.World.c(
    18:39:34 [SEVERE] at net.minecraft.server.World.<init>(
    18:39:34 [SEVERE] at net.minecraft.server.WorldServer.<init>(
    18:39:34 [SEVERE] at net.minecraft.server.SecondaryWorldServer.<init>(
    18:39:34 [SEVERE] at net.minecraft.server.MinecraftServer.a(
    18:39:34 [SEVERE] at net.minecraft.server.MinecraftServer.init(
    18:39:34 [SEVERE] at
    18:39:34 [SEVERE] at
    18:39:34 [SEVERE] Unexpected exception
    at net.minecraft.server.WorldServer.c(
    at net.minecraft.server.World.a(
    at net.minecraft.server.Chunk.addEntities(
    at net.minecraft.server.ChunkProviderServer.getChunkAt(
    at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(
    at net.minecraft.server.World.getChunkAt(
    at net.minecraft.server.World.getTypeId(
    at net.minecraft.server.World.isEmpty(
    at net.minecraft.server.World.a(
    at net.minecraft.server.WorldProviderHell.canSpawn(SourceFile:37)
    at net.minecraft.server.World.canSpawn(
    at net.minecraft.server.World.c(
    at net.minecraft.server.World.<init>(
    at net.minecraft.server.WorldServer.<init>(
    at net.minecraft.server.SecondaryWorldServer.<init>(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
Thread Status:
Not open for further replies.

Share This Page