Solved Essentials API started crashing my plugin.

Discussion in 'Plugin Help/Development/Requests' started by ilov3garfield, Nov 17, 2017.

Thread Status:
Not open for further replies.
  1. Offline


    Hey. It might be a simple mistake because I just started learning bukkit, but I spent like 2 hours trying to fix that. I tried reinstalling JDK and updating Java, tried redownloading plugins. EVERYTHING worked perfectly yesterday, but I did something and it started crashing. Essentials do load. If I don't try to get players balance or do anything with essentials in my code it runs perfectly.


  2. Offline


    Are you sure you set,in the plugin.yml , that your plugin as dependent on essentials? If not, your plugin may load before essentials, causing it to break because it can't find essentials.
  3. Offline



    YES! Got it working. I think the problem was that I wrote softdepend: [EssentialsX] but not softdepend: [Essentials] even tho I'm using EssentialsX. :p I am so happy actually:D thanks for the help, you made me look more into that :)
    Last edited: Nov 17, 2017
  4. Offline


    mabye get a plugin like load priority(does that exist?)
Thread Status:
Not open for further replies.

Share This Page