[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline

    Multiverse

    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:
    http://dev.bukkit.org/server-mods/multiverse-core/
    http://dev.bukkit.org/server-mods/multiverse-portals/
    http://dev.bukkit.org/server-mods/multiverse-netherportals/

    Thanks!

    [​IMG]

    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet


    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Description
    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..


    The Multiverse Team:
    Developers:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!

    Documenters:
    @Elizacat
    @AkiTensai
    @Xanipher

    Testers (official I know a bunch of you have helped, thanks!):
    @jonDatz
    @jfulleton


    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...
    Requirements

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki


    Downloads:
    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)


    Why multiple Downloads?
    https://github.com/Multiverse/Multiverse-Core/wiki/Plugins-of-Multiverse-2

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:
    https://github.com/Multiverse/Multiverse-Portals/wiki/Basic-portal-tutorial

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:
    https://github.com/Multiverse/Multiverse-Core/wiki/FAQ

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki


    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelog:

    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)



    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1





    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7





    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4





    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3





    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2





    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'





    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]





    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)






    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)






    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)






    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...


    [​IMG]
     
    TGF, maino, aTxT and 58 others like this.
  2. Offline

    Chris Lewis

    @Rigby90
    @fernferret
    Ok, if you guys get a update/fix out for that let me know, i will dl and implement right away, my admins are getting fussy having to use coins :) lols, they could use /mvtp but just dont want to... lazy admins ;)
     
  3. Offline

    minifjurt

    need help! my multiverse is not working :'(

    Untitled.png
     
  4. Offline

    MatCat

    Dunno how this is supposed to work but portal creation just does not work. I do /mvpc and it yells about needing to set coordinates, well I use worldedit but the default config is the wooden axe so I tried that and all Igot was worldedit's spew and command still does not work, then I tried changing the setting in the yml to something else, still did not work. So what is the trick to creating portals?

    CB612
     
  5. Offline

    Reterg

    More info? What about it is not working? What are you trying to do that is not working? Your screenshot just shows the help / command list. Doesn't give anyone an idea of what you are trying to do?
     
  6. Offline

    minifjurt

    i tryed to use /mvlist

    plz help me!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 18, 2016
  7. Offline

    TravisAmes

    For some reason it doesn't want to work. I have it put into my plugins folder and I have the permissions set up right but it still doesn't want to do anything. I even downloaded it 3 times from the bottom link because the top link for dropbox isn't working. Help?
     
  8. Offline

    ultimak

    The selection tool is a wooden pickaxe for multiverse, portal creation is detailed pretty deeply in the OP under the detailed command list spoiler and below is the relevant section.

     
  9. Offline

    Kevinskie555

    Hmm, creating a portal at the bottom of a the world kinda crashes your server?
    Well I think it did for me :p
    (Or maybe it's because the destination is at the total top? Or maybe because the destination is right above the portal??)
    Yeah, if the destination is right above the portal, it crashes. :p
     
  10. Offline

    fernferret

    Just a friendly reminder, read this:
    http://forums.bukkit.org/threads/request-saying-its-broke-doesnt-help-solve-the-issue.839/
    Before doing this:
    Can you post some logs on pastebin? Console errors?

    There are no known bugs(Other than the bug stated that was due to the 1.4-1.6 switch) with anything above 612. You should be fine.
    Thanks to everyone who sent this in, sorry, my bad. DropBox DL is fixed.

    As soon as Rigby Pushes the 1.5 code, I will merge it with the changes that I made to the 1.4 to get 1.6... if that makes sense to anyone but me, i'll be amazed.
     
  11. Offline

    minifjurt

    i need help!
    when i do a multiverse command except mvhelp i yous got this

    Untitled.png


    sombody help me!!!
    (sorry for my bad english)
     
  12. Offline

    ksevelyar

    b617, all works fine.
     
  13. Offline

    MatCat

    Yes I read that quite a few times, but as I said I changed it in the config to something I know no plugin utilizes, it does nothing, no message when using the coordinates selecting tool, and only tells me to select coordinates when I try to create a portal, I did follow those instructions just it does not work. And that is not a detailed explination, the way that command reference is setup I feel like I am reading a json string.
     
  14. Offline

    Pomme72

    Don't work, sorry. :s
     
  15. Offline

    ultimak

    The only thing you mention using in your first post is using a wooden axe, nothing about trying to use a wooden pickaxe. What tool did you change it to from the wooden pickaxe?
     
  16. Offline

    kalner123456

    when i try to make a portal to my dif world. It gives me a error saying. No destriantion set or something like that.
    I type this for command. /mvpc Nether Portal Nether
     
  17. Offline

    Itssnowing

    That's because it's trying to make a portal to a place called Portal Nether. You need didn't define whether where you want it go is a portal or world, and there's spaces in it.
    Try this:
    /mvpc NetherPortal w:Nether
     
  18. Offline

    Zimmies

    Hi there

    my Wooden Pickaxe allways writes 2 Positions when i do a left click..like this

    Position 2 - Set
    Position 1 - Set

    and on right click just Position 2 - Set------most portals work, only some horizontal not

    any idea whats the problem here? someone else with the same Problem?
     
  19. Offline

    Itssnowing

    I've been getting it too. Just click somewhere else, then click the place you want again until it comes up as position 1 - set.
    Have you tried using the two position 2s to make a portal? I haven't gotten a chance yet, and it would be good to know what happens when the two positions are point 2s.
     
  20. Offline

    kalner123456

    still get the same error " You have not set your coordinates yet"
     
  21. Offline

    Itssnowing

    Coordinates? I think it actually says destination.
    Anyway, try typing /mvpc Netherportal
    Then /mvps Netherportal
    Then /mvpd w:Nether
     
  22. Offline

    Zimmies

    THX for the answer....good someone else has it, lowers the chance that i did something wrong ^^.

    well i had it once, at 60 blocks depth that both klicks where pos 2....but i did not use it, i reclickt....

    letzt wait for an update then

    greetz
     
  23. Offline

    OitsLeo

    I'm not sure if someone already asked this (too many pages) but if we create another world using multiverse, will our permissions be ported over automatically? If manually, how do u copy your permissions to another world?

    Thanks!
     
  24. Offline

    kalner123456

    reply still nothing
     
  25. Offline

    Itssnowing

    Saying "Still nothing" Doesn't mean anything to me. Are you getting errors? does nothing happen?
    What's your nether world's name?

    I do not believe they will. However, if you copy/paste the permissions' config file and rename it to the name of the new world, (So you have two config files, one for each world) it will give permissions for that world. You can even have each world have entirely different permissions by changing the respective config files :B

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 18, 2016
  26. Offline

    ChronicSyncope

    Every map I create except for the main one has major lag. I'm using craftbukkit 612 and the latest version of multiverse, it happens no matter how many people are on my server. As soon as I teleport back to the main world, the lag is gone for me. And people only experience lag while in the created world.

    Edit: Actually, maybe I wasn't updated. Now though it's telling me permissions is out of date. Just FYI the link on your front page goes to permissions 2.1, but I went and installed (reinstalled) permissions 2.5.5 and it's still saying that it's out of date or missing.
     
  27. Offline

    OitsLeo

    Oh okay, thanks! :D
     
  28. Offline

    kalner123456

    no im getting the same error on first
    then on others says something about portal doesnt exist and portal not selected.
     
  29. Offline

    Itssnowing

    You used /mvpc NetherPortal?
    You used /mvps NetherPortal?
    You used /mvpd w:Nether?

    You have to have selected an area before using the /mvpc command, mind.
     
  30. Offline

    kalner123456

    sorry how do you selct area if you dont mean wich world.
     
  31. Offline

    Michael Erikson

    I get the same problem, with trying to set the coordinates before creating a portal. I get the error message saying u haven't set the coordinates yet, after putting in "/mvpc nether w:nether" and i am set to all permissions so i know it is not a permissions conflict. The problem is when i use the wooden pickaxe to attempt to set the coordinates, when i right or left click, it doesn't tell me position 1/2 set, it doesn't do anything out of the ordinary. I even tried going into the configuration files and changing off the default wooden pickaxe into some other item. Same result, no positions set, i know I'm doing everything right but for some reason it does not work.
     
    Flascher likes this.

Share This Page