[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Multiverse seems to be ignoring the pvp options for each world in worlds.yml they are set to false in some places and true in others but seem to have no effect at all.
  3. Offline


    818 and 819 cause a lot of multiworld issues, 820 is the most recent build that is know to be stable and fixes some of these issues
    Such as Teleporting to the wrong location
    Permissions only reading from default
    Settings being ignored (Animals, Mobs, PVP)
    Freestyling likes this.
  4. Offline


    I'm on b820 and pvp settings are still being ignored.
  5. Offline


    Then the PVP bug still needs to be fixed, I know for a fact that Teleporting to the wrong location is fixed, permissions, 95% sure
  6. Offline


    I can confirm PVP setting issues - if i enable pvp in my server.properties pvp is enabled in the main world, yet all other worlds it is disabled, even if I set it to true in worlds.yml
  7. Offline


    Thank you for explaining
    Multiverse guys add the reason to the topic please for other people
  8. Offline


    Hi, don't want to complain or anything, but after the update I have gotten some problems with this plugin. I can't warp or tp to an exact person or place in another world. I only teleport to the same coordinates as I was in the world I came from.
    Please check it out, it would help a lot :)
  9. Offline


    Make sure oyu are on bukkit 820+

    I'm getting this spammed when I shut my server down. Doesn't do anything, but it's a bit annoying:

  10. Offline


    Same here, SpawnX do not change anything, still respawning in default world after death.

    But everything else seems ok.
  11. I have the same problem, but not for nether but a nomral type pvp world.
  12. Offline


    Hey, is it possible to disable/enable certain plug-ins on certain worlds?
  13. Offline


    If those plugins have can use permissions then yes it can be done per group per world via permissions
    Otherwise no
  14. Offline


    Never Mind! As I thought, the Sky Dimension is always mid-day and there is never any rain or snow although it can get cloudy. The previous day/night cycles came from it being set to NORMAL it seems.
  15. Offline


    Tried CB #830 with rehabilitation of custom spawn / world, but nothing new, still spawning on default world after death.
  16. Offline


    2011-06-06 20:00:13 [SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
    at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(MVPlayerListener.java:199)
    at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.java:285)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:139)
    at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  17. Offline


    i had a problem trying to portal after creating a skylands maps (on 818, and 820). when i tried to do "/mvtp sky", the client(all users) would get "Read Error", then nobody could logon until i restarted the server, where it would happen again.
    i even deleted my sky map and regenned it multiple times.
    i finally updated to 833 and it worked fine (although kinda slower compared to a vanilla server on the same machine)

    server specs: (2 Dual-core Xenon's 3.00Ghz, 64bit, 6gb RAM - 4GB dedicated to server, RAID 0 - 15k RPM HDDs, rackmount server, CLI - Ubuntu: sun-java)

    EDIT: Hmmm... I've explored and explored my "skylands" map. Its just the regular world generator, except always in a snow biome, there are no clouds, and the sun never sets, and the sky is grey. it doesnt look like the other pics i've seen on here...

    I'm currently sitting on a boat in an ocean with snow all around, (no ice though), basically an infinite regular snow biome with the sky/sun/clouds of a skyland world.

    b835 (currently, with brand-new "skylands")
    somethings not right here.

    a quick look at the data file show the files being saved like a regular world. I kinda thought they might be in a DIM-2 folder (like the nether is in DIM-1)
  18. Offline


  19. Offline


    it appears that nethrar is the problem with my server at the moment. With no config changes it has decided to start throwing out exceptions net.minecraft.world, etc. etc.

    Is there a cause to this

    CB#820+ (i've tried multiple)

    Again, it crashed without any configuration changes.
  20. Offline


    Just testing our server running 1.6.6 (craftbukkit 820 as suggested), using wormholes to travel between worlds works fine, but if we use /spawn or /home or any other teleporting command between worlds/in worlds we get the above error and it kicks us after leaving us falling for ages/placing us in rock and not moving us to the surface.
  21. Offline


    PVP in multiworld fixed and tested in Build 832 :) All is good in the world until MV 2.0 when dead people can spawn in their respective worlds ;)

    Just wanted to update!
  22. Offline


    I'm setting this up and am using essentials.

    I needed to add a essentials spawn in just to set my initial first time spawn position.

    But when joining for the first time I'm moving randomly at the spawn in essentials.

    I really want mvspawn to take over on the initial spawn.

    We had this setup somehow but now we cant redo it on a proper build setup.
  23. Offline


    Kind of stuck here. With 818 being the latest Recommend Build, I cant update to 820 to fix all my multiworld spawn bugs.

    I know everything is working hard, fast and for free.

    So I guess I wait for CB to come out with a new Recommend Build or for Multiverse to support the lastest RB....I guess it will be the first considering all the bugs in 818; which makes me wonder why 818 is still a RB????
  24. Offline


    You know essentials is terrible right? You'd be much better off using one of the good general plugins as essentials has caused a lot of issues in the past conflicting with more than 1 plugin, your issue here is probably just essentials.
  25. Offline


    Even removing essentials.spawn I was still warping around and initial first login wasn't spawning me right.

    So the spawn thing appears to be this plugin not taking over the first login spawn and being precise on it.

    Tried every combination and this is my conclusion.
  26. Offline


    I Get kicker for my server everytime i try to use a portal. The exact sentence is : You moved too quickly :( (Hacking !)

    I use Mv 1.6.4 and bukkit 818.

    For the plug-in, i can tell you but i have alot : 45-50
    Someone know why ?
  27. Offline


    Would like a fix for /mvcreate
    148 recipes
    16 achievements
    16:28:33 [INFO] Starting minecraft server version Beta 1.6.6
    16:28:33 [INFO] Loading properties
    16:28:33 [INFO] Starting Minecraft server on
    16:28:33 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-787-g1153d04-b838jnks (MC: 1.6.6)
    16:28:33 [INFO] Preparing level "Home"
    16:28:33 [INFO] Preparing start region for level 0
    16:28:34 [INFO] Preparing start region for level 1
    16:28:34 [INFO] Preparing spawn area: 32%
    16:28:35 [INFO] LWC     Loading shared objects
    16:28:35 [INFO] LWC     Native library: plugins/LWC/lib/native/Windows/amd64/sqlitejdbc.dll
    16:28:35 [INFO] [General-0.0] Loaded.
    16:28:35 [INFO] [Permissions] (Yeti) was initialized.
    16:28:35 [INFO] Backup v1.6 was sucessfully loaded!
    16:28:35 [WARNING] [General-3.4] An error occured: either general.kits does not exist or it could not be read;
     kits ignored
    16:28:35 [INFO] [Permissions] version [3.1.4] (Yeti)  loaded
    16:28:35 [INFO] [General-3.4]  Using [Permissions 3.1.4] for permissions.
    16:28:35 [INFO] [General-3.4] [Codename: Hindemith] Plugin successfully loaded!
    16:28:35 [WARNING] [General-3.4] [Help] isn't detected. No /help support; instead use /general help
    16:28:35 [INFO] [iChat] Found Permissions (v3.1.4)
    16:28:35 [INFO] iChat (v2.3.1) enabled
    16:28:36 [INFO] LWC     Loaded 116 locale strings (0 overrides)
    16:28:36 [INFO] Updater Need to download 2 file(s)
    16:28:36 [INFO] Updater  - Downloading file: sqlite.jar
    16:28:42 [INFO] Updater   + Download complete
    16:28:42 [INFO] Updater  - Downloading file: sqlitejdbc.dll
    16:28:43 [INFO] Updater   + Download complete
    16:28:43 [INFO] LWC     Using Nijikokun's permissions plugin for permissions
    16:28:43 [INFO] LWC     Loading SQLite
    16:28:43 [INFO] SQLite  Using: Native
    16:28:43 [INFO] LWC     At version: v2.31
    16:28:43 [INFO] [MultiVerse] Permissions Found
    16:28:43 [INFO] [MultiVerse] - Version 1.7.2 Enabled
    16:28:43 [INFO] [MultiVerse] Loading World & Settings - 'Home' - NORMAL
    16:28:44 [INFO] [MultiVerse] Loading World & Settings - 'Home_nether' - NETHER
    16:28:44 [INFO] [MultiVerse] 2 - World(s) loaded.
    16:28:44 [INFO] [MultiVerse] Loading Portals
    16:28:44 [INFO] [MultiVerse] 0 - Portal(s) loaded.
    16:28:44 [INFO] [Permissions] SQL Interface enabled!
    16:28:44 [INFO] SimpleSignEdit v1.3.4 enabled.
    16:28:44 [INFO] Using Permissions for sign editing.
    16:28:44 [INFO] WorldBorder version 1.2.1 loading
    16:28:44 [INFO] [WorldBorder] [CONFIG] Using round border, knockback of 3.0 blocks, and timer delay of 5.
    16:28:44 [INFO] [WorldBorder] [CONFIG] Border-checking timed task started.
    16:28:44 [INFO] [WorldBorder] [CONFIG] Will use plugin for permissions: Permissions v3.1.4
    16:28:44 [INFO] For reference, the main world's spawn location is at X: 0 Y: 64 Z: 0
    16:28:44 [INFO] Done (1.030s)! For help, type "help" or "?"
    16:28:45 [INFO] Xaymar [/] logged in with entity id 115 at (7.605661744205916, 70.0, -3.8280
    16:29:06 [INFO] Creating user Xaymar
    16:31:23 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvcreate' in plugin MultiVerse v1.
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:128)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:287)
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:718)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:684)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:677)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:225)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NullPointerException
            at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:185)
            at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:106)
            at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(ChunkProviderServer.java:117)
            at net.minecraft.server.World.getChunkAt(World.java:251)
            at net.minecraft.server.World.getTypeId(World.java:194)
            at net.minecraft.server.World.isEmpty(World.java:198)
            at net.minecraft.server.World.a(World.java:165)
            at net.minecraft.server.WorldProviderSky.a(SourceFile:56)
            at net.minecraft.server.World.canSpawn(World.java:157)
            at net.minecraft.server.World.c(World.java:143)
            at net.minecraft.server.World.<init>(World.java:108)
            at net.minecraft.server.WorldServer.<init>(WorldServer.java:29)
            at org.bukkit.craftbukkit.CraftServer.createWorld(CraftServer.java:384)
            at org.bukkit.craftbukkit.CraftServer.createWorld(CraftServer.java:358)
            at org.bukkit.craftbukkit.CraftServer.createWorld(CraftServer.java:354)
            at com.onarandombox.Rigby.MultiVerse.MVCommands.worldCreateImport(MVCommands.java:212)
            at com.onarandombox.Rigby.MultiVerse.MVCommands.MVCreate(MVCommands.java:75)
            at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:167)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
            ... 12 more
    After that, I can simply import the world without a problem, but mvcreate will always return an internal error.
  28. Offline


    this all is great except for one BIG problem, it doesn't matter where you die: you will always spawn at the default spawn point... that is annoying if players have to safe money to get in a world!
  29. Offline


    You can easily fix this in the MultiVerse's config. Open it up, then scroll down to the bottom of the config and find the setting called respawntodefault: and set it to false. It fixed it for me, should fix it for you.

    Ok, I'm having a problem trying to set up SkyLands.
    Here is what I have set up, but when I try to load it up (do /mvtp SkyLands), the server freezes up and I have to kill the java process to stop it.
    Here is the Worlds.yml: (part of it)
            animals: true
            pvp: false
            alias: 'skyland'
            blockBlacklist: ''
            worldBlacklist: ''
            spawn: 116:71:59:0.0:0.0
            mobs: true
            price: 100.0
            environment: SKYLANDS
            editWhitelist: g:Visitor
            playerBlacklist: g:Builder
            playerWhitelist: ''
            editBlacklist: ''
    I am running CraftBukkit 839.
    My OS is Ubuntu
    I have Java 1.6 (latest version)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  30. Offline

    Brian Haberer

    So one issue I'm having is that there are no mobs that spawn normally or daytime changes in SKYLANDS maps due them not being completely finished.

    I don't know if there's any way to fix this, but if it would be possible to have day time shifts and normal mob spawning in Skylands, that would be amazing.

    An alternate solution could be to be an option to allow for suspension of chunk generation for a given world. That way we could generate a large area of skylands , and then turn off new terrain generation and switch the map to "NORMAL" to gain the time changes and mob spawns of the normal maps. But, I can only imagine that disabling chunk generation may very well be a massive pain in the ass.
  31. Offline


    In server properties i have set Pvp= True but when disabling Pvp in the config! Pvp is still working.
    I have 4 worlds but i want only pvp in the world Eastland why is Pvp working in the other worlds i have set it to false in the config.


Share This Page