Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    SpoutDev

    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use www.spout.org for support with our projects going forward.
     
  2. Offline

    Mirkwood12

    you cant start the launcher as he hangs at auto downloading the needed files, so the 1.0.6 file doesn't help you out ;)
    Just sit down and wait some time until the server isn't overloaded anymore.
     
  3. Offline

    TfT_02

    It wont even start here, so I'll stick with a manual install for now.
     
  4. Offline

    Nycrux

    I have a problem whit update sputcraft, someone can help me? [​IMG]
     
  5. Offline

    DrakeBD

    Same problem here on all my machines server is fine but client launcher is flawed somehow cant get it to work at all
    Client takes ages to load on laptop on towers dont load at all
     
  6. Offline

    Nycrux

    Someone can upload the client or repair launcher :), i want spout client!!!!
     
  7. Offline

    liveoles

    I have downloaded Spout #1185 (not spoutcraft), it took 30+min to download a 9xx kb==
    whatever, i have uploaded it to mediafire, the link is here

    <Edit by Moderator: Redacted mediafire url>

    (Guarantee no virus)
     
    Last edited by a moderator: Nov 13, 2016
    Koksman likes this.
  8. Offline

    crazyjoe567

    thanks man :)
     
    Last edited by a moderator: Nov 13, 2016
  9. Offline

    simsor

    Somebody with the md5 to verify this ?
     
  10. Offline

    Koksman

  11. Offline

    JargonTheRed

    I've got that too. It does in fact start, it just takes craploads of time. Go grab a drink or something and it'll be running when you get back.
     
  12. Offline

    Nycrux

    I can't play with spout client!!!! i download a <Edit by Moderator: Redacted mediafire url>
     
    Last edited by a moderator: Nov 13, 2016
  13. Offline

    Koksman

    I've recognized that too, because the jawaw.ex runs and runs. The servers must be really overloaded.

    Oh and the idea with the drink is great ;)

    Edit: And Nycrux: You downloaded the jar-file for a bukkitserver. When you only want to play with SpoutCraft you must download the Spoutcraft.exe. Run it and then you must wait a lot of time, because the servers are overloade!
     
  14. Offline

    Vaupell

    Could you guys get a new host, this is terrible,,
    Been unable to download this for several days now :(
     
  15. Offline

    Marcos Cosmos

    it never used to do this but i noticed it too.. I actually was leaving it for hours didnt load.. (laptop,) I'ma gunna try deleting .spoutcraft
     
  16. Offline

    FergyJay1.8

    :confused: Site just loading cant wait IMA COMING 8)
     
  17. Offline

    BeerHuntor

    This plugin has brought me nothing but problems. Why the hell allow it to download automatically. I do not want it. It does nothing but fuck my server up and corrupt my worlds! THIS SHOULD NOT BE DOWNLOADED AUTOMATICALLY.

    I would, if it wouldnt corrupt my server to the point of not being able to access files.

    The only Spout Compatible plugin i have is LevelCraft Core.

    Why not just take the option out of your API, or is it not from your API.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 10, 2018
  18. Offline

    Schlumpf

    Hello,
    on Bukkit DEV is the download link for the manually recommended Build - Client down!!
    Code:
    Status Code: 404
    
    Exception:
    Stacktrace:
    
    (none)
    
    Generated by Winstone Servlet Engine v0.9.10 at Sat Sep 24 15:55:25 UTC 2011
     
  19. Offline

    Top_Cat

    We don't want it to download automatically either, truce?
     
  20. Offline

    BeerHuntor

    Well your the Dev, sort it out!
     
  21. Offline

    Top_Cat

    Our plugin doesn't (and can't), and our stance is that no-one else should. They do though, and we can't stop it, but it's not our fault.
     
  22. Offline

    alta189

    We realize that our Jenkins is down, we are working hard to resolve the issue. DO NOT POST DOWNLOADS FOR SPOUT HERE! All downloads should go through us!

    Why is Jenkins down?
    Well when the update happened we had thousands of people download files from there and Jenkins passed out (slowed down to a point where he cannot operate) and is preventing you from getting your updates! @Top_Cat is getting a mirror set up, and I am starting to work on a way to prevent this from happening by setting up the launcher to get updates from mirrors.

    When will Jenkins be up?
    @Wulfspider is not online at the moment and he has the keys to Jenkins, when he gets up we will be able to resolve the issue!

    Thanks for your patience! If you need help please get on IRC!

    irc.esper.net
    #spout and #spoutdev

    First other plugins download it automatically and we tell them not to, second our auto-update was turned off before the 1.8 release to prevent any issues, and you can turn off our auto-update in the Setting config.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  23. Offline

    Top_Cat

    It's not in our API, as I said our plugin can't download itself because it's not there to do so. Anything in the api is in our plugin not theirs and therefore needs to download ours first.

    So completely not controllable by us
     
  24. Offline

    alta189

    Do you have log block?
     
  25. Offline

    BeerHuntor

  26. Offline

    Wulfspider

    Then that is most likely the culprit. Any plugin can potentially download anything from a valid URL, it's not us, it's them.

    It's in the works. We have a budget to work with. ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  27. Offline

    BeerHuntor

    Not possible. I have been using LogBlock for months and never had this issue.
     
  28. Offline

    Wulfspider

    It didn't download the launcher correctly, delete any launcher jar that may be under .spoutcraft and try again.

    Have you ever thought that LogBlock may update itself? Because one of LogBlock's features uses Spout by default and will download it without asking you. Try disabling chest logging in LogBlock and see if that solves it.

    You are running the updater which has to download the launcher... and the host it is downloading from is running poorly right now due to the load. We will be setting up a mirroring system soon to ease the load.

    I doubt it's banned... that is just a short URL site of ours that doesn't actually host anything.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  29. Offline

    kayloe

    Hiya!

    Not sure what is causing this error, my only guess is that its spout related since it mentions Spout in the error itself. This happens when I /reload the server, and also sometimes randomly happens and will disconnect random players.

    Running latest CB #1185. Latest Spout Version.

    Plugins:
    Alerter
    BlockBlock
    ChatManager
    ColoredSigns
    LogBlock
    MantraSpawn
    Minequery
    MobDisguise
    Modifyworld
    MyHome
    Netherban
    NoCheat
    NoMoreRollbacks
    NoWeather
    Permissions
    PermissionsEx
    PluginSpy
    SafeFire
    TorchArrow
    VanishNoPacket
    WorldEdit

    Thanks for taking the time to read this, and any ideas as to whats causing my problem is appreciated :)

    Code:
    >11:51:53 [INFO] SafeFire 1.2 Disabled.
    
    >11:51:53 [INFO] [MantraSpawn] disabled.
    
    >11:51:53 [INFO] [MobDisguise] by desmin88 version 1.6 disabled.
    
    >11:51:53 [INFO] [NoCheat] version [2.07] is disabled.
    
    >11:51:53 [INFO] [Alerter] Alerter v1.34 is DISABLED!!!
    
    >11:51:53 [INFO] TorchArrow v0.7 disabled.
    
    >11:51:53 [INFO] [NetherBan] NetherBan Disabled.
    
    >11:51:53 [INFO] Unloading ColoredSigns
    
    >11:51:53 [INFO] Stopping Minequery server
    
    >11:51:54 [SEVERE] Error occurred while disabling Spout v1.1.370 (Is it up to date?): org/apache/commons/io/FilenameUtils
    
    java.lang.NoClassDefFoundError: org/apache/commons/io/FilenameUtils
    
      at org.apache.commons.io.FileUtils.isSymlink(FileUtils.java:2193)
    
      at org.apache.commons.io.FileUtils.deleteDirectory(FileUtils.java:1199)
    
      at org.getspout.spout.player.SimpleFileManager.clearTempDirectory(SimpleFileManager.java:366)
    
      at org.getspout.spout.Spout.onDisable(Spout.java:156)
    
      at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:128)
    
      at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:941)
    
      at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:294)
    
      at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:287)
    
      at org.bukkit.plugin.SimplePluginManager.clearPlugins(SimplePluginManager.java:315)
    
      at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:381)
    
      at org.bukkit.Bukkit.reload(Bukkit.java:173)
    
      at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:22)
    
      at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
    
      at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:353)
    
      at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:756)
    
      at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:721)
    
      at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:714)
    
      at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    
      at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    
      at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    
      at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:500)
    
      at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    
      at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    
      at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    
      at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    
    Caused by: java.lang.ClassNotFoundException: org.apache.commons.io.FilenameUtils
    
      at java.net.URLClassLoader$1.run(Unknown Source)
    
      at java.net.URLClassLoader$1.run(Unknown Source)
    
      at java.security.AccessController.doPrivileged(Native Method)
    
      at java.net.URLClassLoader.findClass(Unknown Source)
    
      at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    
      at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    
      at java.lang.ClassLoader.loadClass(Unknown Source)
    
      at java.lang.ClassLoader.loadClass(Unknown Source)
    
      ... 25 more
    
    >11:51:54 [INFO] [PermissionsEx] v1.14 disabled successfully.
    
    >11:51:54 [INFO] [BlockBlock] BlockBlock has been disabled
    
    >11:51:54 [INFO] NoMoreRollBack is disabled!
    
    >11:51:54 [INFO] CONSOLE: Forcing save.. [0m
    
    >11:51:54 [INFO] CONSOLE: Forcing save..
    
    >11:51:54 [INFO] CONSOLE: Forcing save..
    
    >11:51:54 [INFO] CONSOLE: Save complete. [0m
    
    >11:51:54 [INFO] CONSOLE: Save complete.
    
    >11:51:54 [INFO] CONSOLE: Save complete.
    
    >11:51:54 [INFO] [MyHome] MyHome 2.0 disabled
    
    >11:51:54 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    
    >11:51:54 [INFO] [ChatManager] ChatManager disabled!
    
    >11:51:54 [INFO] [VANISH] Version 1.6.1 disabled.
    
    >11:51:54 [INFO] LogBlock disabled.
    
    >11:51:54 [INFO] Starting Minequery server on 208.122.48.35:25566
    
    >11:51:54 [INFO] [PermissionsEx] sql backend registered!
    
    >11:51:54 [INFO] [PermissionsEx] file backend registered!
    
    >11:51:54 [INFO] [PermissionsEx] PermissionEx plugin initialized.
    
    >11:51:54 [INFO] [PermissionsEx] p2compat backend registered!
    
    >11:51:54 [INFO] [PermissionsCompat] Compatibility Layer Initalized!
    
    >11:51:54 [INFO] [PermissionsEx] Initializing file backend
    
    >11:51:54 [INFO] [LogBlock] Version check: Your version is up to date
    
    >11:51:54 [INFO] [LogBlock] Connecting to kayloe@jdbc:mysql://208.122.48.35:3306/kayloedb...
    
    >11:51:55 [INFO] Spout 1.0.6.381 has been initialized
    
    >11:51:55 [INFO] SafeFire 1.2 Enabled.
    
    >11:51:55 [INFO] [SafeFire] Permission system detected.
    
    >11:51:55 [INFO] [MantraSpawn] version [0.2] enabled.
    
    >11:51:55 [INFO] [MobDisguise] by desmin88 version 1.6 enabled.
    
    >11:51:55 [INFO] [NoCheat] This version is for CB #1185. It may break at any time and for any other version.
    
    >11:51:55 [INFO] [NoCheat] version [2.07] is enabled.
    
    >11:51:55 [INFO] [Alerter] ALERTER v1.34 is enabled! created by: Patrick_pk91
    
    >11:51:55 [INFO] [Alerter] Permissions v2.7.7 found
    
    >11:51:55 [INFO] [Alerter] PermissionsEx v1.14 found
    
    >11:51:55 [INFO] [Alerter] Database area ''world''' FOUND and loaded!!
    
    >11:51:55 [INFO] [Alerter]: Searching upgrade...(maybe during few second)
    
    >11:51:55 [INFO] [Alerter]: Your version of Alerter is the lastest!
    
    >11:51:55 [INFO] TorchArrow v0.7 - Plugin Enabled.
    
    >11:51:55 [INFO] PluginSpy version 1.1 is now running.
    
    >11:51:55 [INFO] [NetherBan] NetherBan Enabled. Torturing souls...
    
    >11:51:55 [INFO] Loading ColoredSigns
    
    >11:51:55 [INFO] WorldEdit 4.6 enabled.
    
    >11:51:55 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    
    >11:51:55 [INFO] [PermissionsEx] Superperms support enabled.
    
    >11:51:55 [INFO] [PermissionsEx] v1.14 enabled
    
    >11:51:55 [INFO] NoWeather version 1.6 is enabled!
    
    >11:51:55 [INFO] [BlockBlock] Found and will use plugin Permissions v2.7.7
    
    >11:51:55 [INFO] [BlockBlock] BlockBlock version 12.6 has been enabled!
    
    >11:51:55 [INFO] NoMoreRollBack has been enabled!
    
    >11:51:55 [INFO] NoMoreRollBack by Jumla. V.0.4.1
    
    >11:51:55 [INFO] [MyHome] 28 homes loaded
    
    >11:51:55 [INFO] [MyHome] Permissions enabled using: PermissionsEx v1.14
    
    >11:51:55 [WARNING] [MyHome] Help plugin not detected. Only providing help via /home help.
    
    >11:51:55 [INFO] [MyHome] MyHome 2.0 enabled
    
    >11:51:55 [INFO] [Modifyworld] Modifyworld disabled. Check config.yml!
    
    >11:51:55 [INFO] [Modifyworld] Modifyworld disabled!
    
    >11:51:55 [INFO] [PermissionsCompat] Compatibility layer enabled.
    
    >11:51:55 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    
    >11:51:55 [INFO] [ChatManager] ChatManager enabled!
    
    >11:51:55 [INFO] [VANISH] Version 1.6.1 enabled.
    
    >11:51:56 [INFO] [LogBlock] Permissions plugin found.
    
    >11:51:56 [INFO] [LogBlock] Scheduled consumer with bukkit scheduler.
    
    >11:51:56 [INFO] LogBlock v1.30 by DiddiZ enabled.
    
    >11:51:56 [INFO] Server permissions file permissions.yml is empty, ignoring it
    
    >11:51:56 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    
    >11:51:56 [WARNING] Failed to handle packet: java.lang.ClassCastException: org.getspout.spout.player.SpoutCraftPlayer cannot be cast to org.getspout.spoutapi.player.SpoutPlayer
    
    java.lang.ClassCastException: org.getspout.spout.player.SpoutCraftPlayer cannot be cast to org.getspout.spoutapi.player.SpoutPlayer
    
      at org.getspout.spout.packet.listener.EntitySpawnListener.checkPacket(EntitySpawnListener.java:24)
    
      at org.getspout.spout.packet.listener.PacketListeners.canSend(PacketListeners.java:76)
    
      at org.getspout.spout.SpoutNetServerHandler.syncedSendPacket(SpoutNetServerHandler.java:526)
    
      at org.getspout.spout.SpoutNetServerHandler.syncFlushPacketQueue(SpoutNetServerHandler.java:518)
    
      at org.getspout.spout.SpoutNetServerHandler.syncFlushPacketQueue(SpoutNetServerHandler.java:511)
    
      at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:499)
    
      at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    
      at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    
      at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    
      at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    
    >11:51:56 [INFO] WainbowDash lost connection: disconnect.endOfStream
    
    >11:51:57 [INFO] Server is saving the map, expect some lag... [0m
    
    >11:51:57 [INFO] Server is saving the map, expect some lag...
    
    >11:51:57 [INFO] CONSOLE: Forcing save..
    
    >11:51:57 [INFO] CONSOLE: Forcing save.. [0m
    
    >11:51:57 [INFO] CONSOLE: Forcing save..
    
    >11:51:57 [INFO] CONSOLE: Save complete.
    
    >11:51:57 [INFO] CONSOLE: Save complete. [0m
    
    >11:51:57 [INFO] CONSOLE: Save complete.
    
    >11:51:57 [INFO] Save complete!
    
    >11:51:57 [INFO] Save complete! [0m
    
    >11:51:57 [INFO] Save complete!
    
    **EDIT** I also relooked through the error I posted above, and notice >11:51:54 [SEVERE] Error occurred while disabling Spout v1.1.370 (Is it up to date?): org/apache/commons/io/FilenameUtils
    >11:51:55 [INFO] Spout 1.0.6.381 has been initialized

    Seems that it was trying to disable spout 370 but then when it reloads its initializing 381?



     
  30. Offline

    Afforess

    Looks like Spout was corrupted and is missing some files. Try deleting it and redownloading it.
     
  31. Offline

    Clintonxa

    That is a sad thing to say. If you cannot host the files successfully, it only makes sense to allow the community to temporarily host for you.

    Anyway, can't you just drop a download onto mediafire for us while it's down?
     
Thread Status:
Not open for further replies.

Share This Page