Craftbukkit.jar issue need help!!!

Discussion in 'Bukkit Help' started by UnfortunateStart Issue, Feb 1, 2014.


Did you get the same issue?

Poll closed Feb 8, 2014.
  1. Yes

    0 vote(s)
  2. No

Thread Status:
Not open for further replies.
  1. I am making a craftbukkit server and whenever I start it up it says:
    Error: Invalid or corrupt jarfile craftbukkit.jar

    I use this coding for the batch file:
    Java Xmx1G Xms1G -jar craftbukkit.jar -o true

    Please help!!!!

    Ps: I run it on a folder with the craftbukkit.jar and the run.bat
  2. What is the file you downloaded from Bukkit called? Usually, it is called something such as 'craftbukkit_r02.jar' or along those lines. Copy the file name of the craftbukkit jar you downloaded and replace it with "craftbukkit.jar" in your run.bat.
  3. I use craftbukkit-1.6.4-R2.0 and i even tried earlier bulids too that were recommended builds.

    Connor2weirdness it is craftbukkit-1.6.4-R2.0

    Srry I forgot to tahg on the first one
  4. Ok so you need to change the craftbukkit.jar in you run.bat to craftbukkit-1.6.4-R2.0.
  5. Connor2weirdness I did I get that message whenever I try to start that version
  6. Uhm alright... maybe you don't have enough RAM? I know you said you have 4 gigs but your computer could be using at least 2.
  7. I run it at 1G cuz the coding for the run.bat is:
    Java -Xmx1G -Xms1G -jar craftbukkit-1.6.4-R2.0 -o true

    As I said before this might be an issue with my computer as I run java 7 51 for x86
  8. Offline


    Re-download the craftbukkit jar file, make sure the name matches what is in the bat file. If it is still happening and you are sure that your bat file is correct, let us know.
  9. nala3 Connor2weirdness I've tried that a few times and it always says the same thing

    At this point I am clueless as to what I can do to fix it
  10. Offline


    Make a brand new server folder.
    Download a fresh craftbukkit build
    Name that download "craftbukkit.jar" and put it in the new folder
    Make a new start.bat file with this in it:
    java -server -jar craftubukkit.jar -Xms1G -Xmx1G
    Run it and tell me if it works. If not, some more involved steps may need to be taken.
  11. Okay I'll let you know nala3

    I got the same error. Involved steps it is
  12. Offline


    Okay, first lets make sure the download isn't corrupt for some reason.
    Download the Microsoft File Integrity Verifier from here:
    1. Next, run the program and extract the files to your desktop (should just be a readme and fciv.exe)
    2. Open a command prompt and type "cd %userprofile%\Desktop"
    3. Go to and download the latest development build (#3005 at the time of writing this)
    4. Rename the downloaded jar to "craftbukkit.jar"
    5. Now in the command prompt window, type "fciv craftbukkit.jar". You should get an output that looks something like this: [​IMG]
    6. Now compare that big long number (the md5 checksum), to what it should be, which is "3b5f5295d15e7ca5451c0785287f7138" for build #3005. If it does not match, exactly the file got corrupt somehow during the download which would indicate a problem with your internet connection.
    I really doubt this would be the problem, but I would like to verify before we try other things.
  13. Okay that will hopefully work but it will be confirmed tommorow cuz the Super Bowl is tonight and I'm gonna watch it so that will take up the rest of today. nala3
  14. Apparantly nala3 and Connor2weirdness ,I have an internet problem. The number I got was a692db665d3d6e331d29b935a17bc447 and I tried it again and I got another different number. Can you fix this?
  15. Offline


    Just to confirm, this is the result from the md5 sum on Craftbukkit build #3005?

    If it is, can you tell me about your internet connection?
    These things would help to start:
    1. Are you on WiFi or directly wired
    2. How are you accessing the internet? (Dialup, DSL, Satellite, Fibre, etc.)
  16. I am on a laptop doing this through wifi via cable plan/ optimum and yes, nala3 , it unfortunately for me is #3005
    And another question: can a moderator please edit this to make the #3005 a link to the build cuz I can't seem to figure out how
  17. Offline


    Okay, well the first thing to try would be to to plug your laptop into the internet instead of using WiFi, because it may just be your wireless connection is weak
  18. Okay I will try that nala3
  19. How would I do that though nala3 ?
  20. Offline


    Here use this custom code, I use to get the same problem until I started using these steps.
    1. Rename craftbukkit jar file to craftbukkit.jar
    2. Make a batch file with the following code in it
    Echo off
    java -Djline.terminal=jline.UnsupportedTerminal -Xms1024M -jar "%~dp0craftbukkit.jar"

    Next run the batch file and it should work.
  21. I got it to work!!! What I did was (get this) I ran my anti-virus and deleted a ton of maleware and then it worked!!! Thank you for all of your help everyone, nala3 DrPyroCupcake and Connor2weirdness !!!! BYE!!!!
  22. Offline


    You, first of all, wrote "craftbukkit.jar" wrongly.

    You forgot to add .jar

    Dang so much mistakes.

    Anyways I'm glad you fixed it.
Thread Status:
Not open for further replies.

Share This Page