CraftBukkit for Minecraft 1.7.2 DEVELOPMENT build is now available!

Discussion in 'Bukkit News' started by EvilSeph, Nov 30, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    Since Minecraft 1.7.2 was released on October 25th we've been putting in a ridiculous amount of work non-stop towards a CraftBukkit for Minecraft 1.7.2 and I am happy to finally be able to announce that we now have development builds available. We strongly suggest that you only use this build if you would like to help us get a Beta build out sooner and are experienced with using unsupported development builds.

    WARNING: Minecraft 1.7.2 is an update that requires clients to update before being able to connect.

    What is a Development Build?
    A Development build is provided AS IS and COMPLETELY UNSUPPORTED. You should only be running these builds if you are completely aware of how to properly make use of them. Support requests of ANY KIND will be removed without warning. If you have to ask where or how to get the development build, you should NOT be running it and posts of that nature will be deleted.

    Will plugins break with this build?
    Minecraft 1.7 is one of the most involved updates to date, with Mojang having touched a reported ~220k+ lines of code. As a result, a significant amount of the code base has shifted making it difficult to ensure any stability with regards to our API. That being said, it is difficult to determine if plugins will be breaking with our 1.7.2 update and the state of the API in our earlier development builds should NOT be relied upon in any way.

    Known Issues:
    • None
    Download the development build CraftBukkit 1.7.2-R0.1-SNAPSHOT here
     
  2. Offline

    mdbryner

    Thanks for the reply, StealthBravo!
     
  3. Offline

    Mishrathium

    Great Job and thank you!

    PERMGEN: out of memory error, just wish this didnt suddenly startup for now reason in 1.7+
     
  4. Offline

    CorporalBruno

    Hello I am new. Please link me in the right direction. I have found a bug in the current build referenced in this thread's topic. I run the server and was using the following plugins (all latest as of 12/12/2013) when the error occurred.

    Bukkit, CommandBook, WorldGuard, WorldEdit, PermissionsBukkit

    I was //copy, //paste, an area which contained a hopper and a note block. and receeived this:

    2013-12-12_00.33.29.png
    NOTE:

    RED TEXT: Please report this error: [See console]
    java.lang.ClassCastException:
    net.minecraft.server.v1_7_R1.TileEntityNote cannot be cast to
    net.minecraft.server.v1_7_R1.TileEntityHopper

    -Bruno
     
  5. Offline

    kyle939

    Nice but I am happy to wait for beta or official builds I do not want to risk it with development.
     
  6. Offline

    shadowwalker97

    I don't know if it's a bug but my bukkit.yml can't "update". When i make changes it doesn't take affect, I tried several times to change it, save it and restart the server.
    Everything else seems good, less of my plugins broke in this update than the 1.6. Great work
     
  7. Offline

    pointdexter

    Any date coming close for the 1.7.2 craftbukkit completed version?
    You guys are doing a great job, keep it up guys!!!!!!!!!!!
     
  8. Offline

    EvilJackCarver

    leaky.bukkit.org is their bug tracker, though that looks more like a WorldEdit issue - might try their IRC first.

    [hr]

    Have you tried regenerating the file? There might be something not on there that is in the 1.7 bukkit.yml.
     
  9. Offline

    dezotnmc

    Thanks guys! Works great!
     
  10. Offline

    ImCrazyPony

    this glitches on the mac when i try to start the server but good work
     
  11. Offline

    server075

    Anny idea on when the first: Recommended Build for 1.7 comes out ??
     
  12. Offline

    KawaiiNeko

    Not soon
     
  13. Offline

    server075

    How do you know ?
     
  14. Offline

    Gravity Retired Staff

    There are no ETAs for Recommended Builds.
     
  15. Offline

    rcth

    Is it true that Packet70Bed isn't availible yet? I can't find it.
     
  16. Offline

    Ultra1108

    CraftBook, ProtocolLib, Dynmap, and V10Lift broke with this, but, other than that, great!
     
  17. Offline

    Black Hole

    rcth Packet70Bed is PacketPlayOutGameStateChange now.
     
  18. Offline

    rcth

    Thanks! Is there a way we can see what packets we should use now?
     
  19. Offline

    NervaL928

    Nice build, great work :)
    Is there a problem with several new 1.7 commands, or am I the only one not being able to use them ? Works fine in single player, but not on the server ? Also, in commandBlocks, it doesn't work... I tried /tellraw, /setblock, /testforblock, and other ones, but commands like /spreadplayers works :)
    Then, all the new scoreboard objectives aren't available

    Forgot to say that scoreboard setdisplay doesn't work D:
     
  20. Offline

    EvilJackCarver

    NervaL928

     
  21. Offline

    MinecraftrGuy

    Are they going to release a 1.7.4 dev build? Or are they just going to continue working on 1.7.2?
     
  22. Offline

    broro08

    What im thinking is that they will make the RB 1.7.4. But don't quote me on that.
     
  23. Offline

    NervaL928

  24. Offline

    HeavyMine13

    Hello! Me and FatAussieFatBoy are experiencing many bugs coding with CraftBukkit 1.7, is there any thing wrong? Help!
     
  25. Offline

    snivell

    My little update, This has been working flawlessly for me. Thanks team.
     
  26. Offline

    xbenas

    What's the word on 1.7.4?
     
  27. Offline

    Bobcat00

  28. Offline

    TnT Retired Staff

  29. Offline

    BSteurful

    Good work! I am proud of you ;)
     
  30. Offline

    AuZor

    >Impatiently waiting for a stable build.
     
  31. Offline

    KelpyJack

    Awesome! Thanks for this :D
     
Thread Status:
Not open for further replies.

Share This Page