CraftBukkit for Minecraft 1.4.4 DEVELOPMENT build is now available!

Discussion in 'Bukkit News' started by EvilSeph, Nov 13, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    With the news that the Minecraft 1.4.4 update will be released tomorrow, we've decided to push out a developer quality build (i.e. "it compiles and runs", no guarantees) to help us get to a Beta release faster. As of this post, we've shifted development over to Minecraft 1.4.4 compatibility and now have development builds available with Minecraft 1.4.4 support. While we would love to be able to do this for every Minecraft update, the speed at which we can update is determined by the size and complexity of the update and this varies with each release.

    Please only use this build if you're familiar with the Minecraft snapshot process and would like to help us get a Beta Build out soon after Minecraft 1.4.4 is officially released. This build is COMPLETELY UNSUPPORTED and if you do not know how to acquire Minecraft 1.4.4 early to use it, you should not be running it. We will be deleting any questions asking how to get this usable. If you have to ask where or how to get the development build, you should NOT be running it and posts of that nature will be deleted.

    WARNING: Minecraft 1.4.4 is an update that requires clients to update before being able to connect. Running this build will render your server inaccessible until Minecraft 1.4.4 is officially released.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine. Unless we specifically have to break plugins or the plugins you are using are employing inappropriate practises, most plugins should work without needing an update whenever we put out a new release.

    What is a Developer Build?
    A Developer build is provided AS IS and COMPLETELY UNSUPPORTED. You should only be running these builds if you are completely aware of how to properly make use of them. Support request of ANY KIND will be removed without warning. If you have to ask where or how to get the development build, you should NOT be running it and posts of that nature will be deleted.

    Known Issues:
    • Torch flame graphical glitch resulting in a torch's flame flickering randomly on the screen. This is a Minecraft bug that can't be fixed by Bukkit.
     
  2. Offline

    TwistedMexi

    Just use this in your InventoryClickEvent.

    Code:
    if (ev.getView().getType() == InventoryType.ANVIL){
                //get rawslots here to modify.
            }
    no need for a separate API that I can tell. If you need further assistance, The Plugin Development forum is the place to go.
     
  3. Offline

    DreTaX

    Jeeeeez. Bukkit decided the same thing as Spout?

    Pre update, from pre release....

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 29, 2016
  4. Offline

    TNTUP

    its sad to see 1.4.2 clients can't connect to 1.4.4 servers, like it happened for 1.3.1 clients to connect on a 1.3.2 server. I have my mods updated for 1.4.2 and I dont want to use 1.4.4 client until all mods are updated. You think its possible to allow 1.4.2 clients to connect on 1.4.4 servers?
     
  5. Offline

    Jombi

    Too bad the server dies whenever someone joins...
     
  6. Offline

    zipfe

    Testing b2461 on server with several huge maps, everything seems to work fine so far, RAM, CPU, almost all plugins looking good.
     
  7. Offline

    bigdaveberg

    Great work team. Can't wait for the recommended build. I want to update my client so bad. Lol.
    Keep up the great work.
     
  8. Offline

    TfT_02

    Thanks for all the hard work!
     
  9. Offline

    riglboy

    Hey, guys I have tested this bukkit build. But get the error. manifest attribute, in craftbukkit.jar.
    Sorry guys this is my response.
     
  10. Offline

    TheReverend403

    Big mistake. We now know how fast you can get a working build out, so you have no excuse ;)

    I joke, of course, I know how these things work :)
     
  11. Offline

    QriztaL

    So when will the build be released to everyone?
     
  12. Offline

    TnT Retired Staff

    Perhaps Spout decided to do the same thing as Bukkit? *Mind blown*

    It is released to everyone. Use it at your own risk.
     
  13. Offline

    Mishrathium

    2461 bukkit - mc client crash
    Exception in World Tick
    Ticking screen error

    possible conflicts:
    citizens - reported (unconfirmed)
    LWC - reported (unconfimed)

    plugins I removed to test
    worldguard
    worldedit
    playerheads
    essentials
    - still mc client crash without these

    Tested this with 10 separate people - same issue.
    (server starts fine no errors - this is on the MC client screen)
     
  14. Offline

    bwinkl04

    Is this update working for anyone? I'm not using spout, but none of my players (including me) can stay on. When I log on I see my home for about 3 seconds, and then my client crashes. I have updated the client a few times, I also removed all of my plugins from the server, and it is still happening. Is it just on my end, or are others having this issue?
     
  15. Offline

    RebzO1

    many others it would appear are having this issue @ bwinkl04
     
  16. Offline

    zeeveener

    Just curious: If you are so closely working with Mojang, how come it still takes awhile for you to update Bukkit? Wouldn't it make sense to update as you go so you are closer to releasing RB's when Minecraft updates?

    Just a thought. Nothing against you guys, I am just wondering.
     
  17. Offline

    TnT Retired Staff

    Because no matter how closely we work with Mojang, we still need to deobfuscate the code and build CraftBukkit around it.
     
  18. Offline

    Adrenaline

    Congratulations: The best FAIL build ever i see ;)

    Players cannot out from the spawn without lags, crashs and freezes.

    • Craftbukkit: #2461
    Crash-Report from my client:

    http://pastebin.com/ZqN5Lj9W
     
  19. Offline

    bwinkl04

    I get the whole "use at your own risk" thats why I asked if this was working for anyone. If it is working for some then it maybe something on my end, and waiting for a beta or release may not fix it. Please understand that until I know it's not on my end, I need to troubleshoot. So asking if anyone has this working really has nothing to do with "use at your own risk".
     
  20. Offline

    RebzO1

    im sure at this point they are aware of this give them time @ Adrenaline
     
  21. Offline

    MRI

    I use the #2461 on 7 servers,and for now works good,0 error...only with much people (50-60) ,the tps goes down to 12-13 , when before it runs on 20tps in any case.
     
  22. Offline

    Adrenaline

    :p I download alot of builds from dl.bukkit.org but THIS build is THE BEST XDD :D crashs rulez.
     
  23. Offline

    TnT Retired Staff

    You realize that it can be reproduced on vanilla right? It is likely a corrupted chunk. The dev team is still looking into it, and you are more than welcome to use 1.4.2 instead. Keep your rage to yourself, you have been warned this is a development build.

    For anyone looking for the dev build download link - its where every other dev build can be downloaded. These builds are not meant for everyone with a server to download and run because you will likely run into some problem. These are meant for only experienced server administrators who know the routine with proper backups and understanding what is a CraftBukkit concern, and what is a world corruption or plugin issue.
     
  24. Offline

    zipfe

    As you can see in some of the above posts, it works absolutely fine on other servers. Instead of blaming the DEV build, blame your (offline mode) server being maintained badly?

    Your arrogant "best FAIL build ever" makes me throw up.
     
  25. Offline

    TnT Retired Staff

    I'm watching my players on the server as well. I do not see the same issue either. Not saying it doesn't exist, I just do not currently see it.
     
  26. Offline

    bigbend

    When I start my server with build #2461, the CPU jumps to 100 percent right after it loads the world. I'm thinking this is a sign of a corrupted chunk. How can I best determine if this is the case and regenerate only that particular chunk? Any help would be appreciated.

    Thanks,
    bigbend
     
  27. Offline

    Mishrathium

    Well... the sad news is - generating a new map - solved the problem for me. But that is a terrible solution for any large established server..
     
  28. Offline

    zipfe

    Run a quick test with a blank, new map and see what your CPU does. To remove a particular chunk, go there, use something like WorldEdit //chunkinfo, it will give you the file name which contains the corrupt chunk. Delete that file while the server is not running. Note that this will of course remove much more than just a single chunk.

    Make sure to test it without certain plugins, for example, Citizens. Our server is 28GB in total size, and there's no problem with any of the old maps. Remove all plugins known to be a tad tricky with updates and try again.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 29, 2016
  29. Offline

    RebzO1

    wait, are you saying that i may have to start a new map to stop the crashing?
     
  30. Offline

    break2471

    I think I'll just patiently wait for a Rec. build....
    Thanks Bukkit team!
     
  31. Offline

    zipfe

    Actually the opposite. Since it works without problems on quite a few (large) servers, you should rather go through your plugins, see if one of them causes the issues. Citizens, for example, obviously needs to be updated and can easily crash the current DEV build of craftbukkit. I tested that myself. I'd also be careful with Inventory related plugins.
     
Thread Status:
Not open for further replies.

Share This Page