Craftbukkit 798/803 - High cpu

Discussion in 'Bukkit Help' started by Bakuhatsu, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I just noticed that build 803 use quite a lot cpu for me, the same amount with and without plugins, even if none being connected to the server.

    Overall it was 30% or so idle (with individual cores sometimes hitting 100%), while if I use build 766 it idles at 0.5-2%, this problem also applies to build 798.

    So, this issue started sometime after build 766.

    I run it on Ubuntu 11.04
    8gb ram
    Amd Phenom II x4 810

    Is this issue only for me or anyone else having it as well?
  2. Offline


    im not haveing a problem with it and im currently running at only 2Gb ram, while im testing.
  3. Offline


    It's not ram issues at all, the ram is pretty good as always, it's CPU related.
  4. Offline


    well, my log is filled with server can't keep up messages and there is only 1 person online on 4gb ram...
    i am going back to v. 766

    well first the server was exactly as you say it, 30% and now it is 100%

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  5. Offline


    This means the issue is more than just for me, then it's a possible craftbukkit issue that for some reason happens.
  6. Offline


    my server is totally fine again: i downgraded back to 766. i will stick to this until the next version is released, probably at 1.6
  7. Offline


    Mine does this as well until I downgrade back to 766.
  8. Offline

    tha d0ctor

    Are you using world edit, that killed it for me?
  9. Offline


    I also noticed this issue with 798 and 803. Another thing: while the server.log seems normal, if I attach the output of craftbukkit to a terminal it totally spams it with ">" characters:

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>15:00:40 [INFO] Starting minecraft server version Beta 1.5_02
    >>>>>>>>>>>>>>>>>15:00:40 [INFO] Loading properties
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>15:00:40 [INFO] Starting Minecraft server on *:25565
    etc. etc.
    It could be this spamming that's causing the slow-down.

    The console spam stops immediately after calling "CraftPlayer: Stopping the server", leaving the plugins to disable themselves in peace. It's definitely a Bukkit issue.
  10. Offline


    @asayers Do you still notice this behaviour with the newest 1.6 compatible builds?

    @EvilSeph This looks like an issue related to the commits in build 794
  11. Offline


    Yep. On 818 the console is just flooded with chevrons, the CPU screams away at 98%, and the server takes a matter of minutes to start up.
  12. Offline


    This is still affecting 818, come on bukkit devs... you're last three "Stable" releases have all been pretty unstable.
  13. Offline


    same problems :(( ramdomly loads processor to 100% few times a day
  14. Offline


    Hi, I've been having the same problem since every bukkit build after 766

    Server Specs:
    Quad-core Intel Xeon @2.27 GHz Ubuntu 32-bit os
    4 GB ram burstable to 8
    Server CPU spikes at random times causing log-outs and 15 second lag
    All 4 cores seem to spike randomly
    server starts with 2400mb, OS uses approx 500mb
    Problem happens with no plugins, but is substantially worse with even basic plugins installed

    This server ran fine, with the same plugins, all the way up to build 766. After that, the spikes have gotten progressively worse. I don't see this problem happening with the majority of the community, and fear I may to move to a MC hosted server.

    Any help would be greatly appreciated

    P.S. I've tried the "Djline.termail\=jline.UnsupportedTerminal fix with my bukkit launch and using remotetoolkit, the problem does not go away
  15. Offline


    Still having the very same issue. Is any bukkit dev aware of this? Its been posted at the leaky.
  16. Offline


    The reason other's aren't noticing it is probably because they are on hosted servers and they can't see the resource usage.
  17. Offline


    I don't have this problem on #818 and a few plugins. The console also doesn't seem to be full of chevrons. The CPU usage I think is about 25% when only I join (and I'm on the LAN), and this computer is rather old (2005 or so).

    They must have fixed it, as the previous build had it, or maybe it's because now I am using more powerful (yet older) hardware.
  18. Offline


    That CPU usage is still way too high. I was getting 0% - 1 % CPU usage on 766 and prior. Now I have 20%
  19. Offline


    The issue still remains, yep and the workaround I found only works for some.
  20. Offline


    Your CPU is probably newer than mine. I have an Intel Celeron 320, 2.4 GHz from quite a few generations ago.

    I also found that the 100% CPU usage is because of a glitch that is fixable. If you launch the server in the background, chevrons go crazy and no matter if you try redirecting them to /dev/null or not, it takes 100% CPU. If you launch the server in the foreground (STDOUT goes to a terminal), then this doesn't happen. To prevent myself from having to keep open a terminal window, I have to go to the server and launch Craftbukkit from there. I have confirmed this works, on my really old hardware and Debian 6.
  21. Offline


    the same problem occurred to us after upgrading from #740 to #834. The process was always started with nohup java ... &. As already discovered it spams >, reproducible on two other machines.
    I run a VisualVM over the process:

    Anyhow currently we switched to screen, which works quite well.
  22. Offline


    Using screen as well, but still very high CPU usage here...
  23. Offline


    Guess the whole screen solution doesn't work on windows servers?
  24. Offline


    Im having the same issue too. And I really dont think it will get fixed.
  25. Offline


    It's still in 860, I'm close to not using craftbukkit anymore and looking for an alternative...
  26. Offline


    What makes you think the issue is related to the commits in b794?

    We have discovered an issue with JLine not working with being run in the background and are looking to see if we can fix this, though it seems to be an issue with JLine itself... In the meantime, you can either run the server in the foreground or use -Djline.terminal=jline.UnsupportedTerminal in your launch line since we now disable ">" from being sent to the console if the jline terminal is unsupported.

    None of the many servers we run or are a part of, nor the test server we use is having any of these issues. If we can't reproduce the problem, we don't know where to start to go about fixing the issue. On top of this, we do not actively watch over the forums for bug reports since it is filled with people asking basic questions or failing to search for answers to their questions. In the future, if a thread has matured as this one has and you can gather a lot of information on the issue, it is better to post a ticket on, which we do actively monitor.
  27. Offline


    Simply the the references to '>' here:

    If I were able to reproduce the bug myself I would post something on the tracker.

    Can someone who can write out a detailed description for me here and I'll post that?
  28. Offline


    Adding "-Djline.terminal=jline.UnsupportedTerminal" to the launch command clears out the chevrons sure enough, but as soon as the server is done loading it immediately starts spamming the console with "[INFO] Unknown console command. Type "help" for help." On my server I'm getting 5-10 "unknown command" messages per second. The CPU is still at 99%.

    I'm on 860, Ubuntu Server 11.04, with the java VM daemonised (using an "&" at the end of the launch command). I don't remember if I'm using openJava or what.
  29. Offline


    I'm also having this issue.
    It only happens with running the server as a service (Firedaemon) I believe, the error doesn't happen when I run from a gui.
  30. Offline


    So if you run it as a service it breaks? Well at least there's some troubleshooting going on. Servers are useless as foreground applications rather than background services though.
Thread Status:
Not open for further replies.

Share This Page