CraftBukkit 1.4.6-R0.3 is now available!

Discussion in 'Bukkit News' started by EvilSeph, Dec 30, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    A new CraftBukkit Beta Build (1.4.6-R0.3) that provides Minecraft 1.4.6 compatibility and addresses issues found in the previous beta is now available in time for the holidays! Although Minecraft 1.4.7 is scheduled to release sometime after New Year's day, we've already fixed the issues it addresses in this beta. The previous beta contains a change that made a bug with enchantments being lost more noticeable and frequent. Upgrading to this new beta is highly recommended.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine, with the exception of plugins that use Minecraft or CraftBukkit code.

    Important Note: this Beta Build contains a new safeguard to protect servers against unchecked and thus potentially damaging plugins. See the announcement here for more information:
    http://forums.bukkit.org/threads/sa...cked-and-potentially-damaging-plugins.116749/

    What is a Beta build?
    A Beta Build is in between a developer build and a Recommended Build. These builds simply work and are promoted much more frequently than a Recommended Build. While we will do some testing before promoting a beta build, we will not be running it through our extensive test process. As such, there are no guarantees that they will not contain minor bugs. If we do find out they are broken, we will mark it as such on DLB and promote a new one. A beta build may contain incomplete API and new features but they should not interfere with running the build in any way.

    This particular Beta build, like every first Beta build for a Minecraft update, is primarily made available to help facilitate more testing coverage to bring us closer to a Recommended Build sooner. Please consider running this Beta build to give us a hand with discovering issues we need to address in order to reach a Recommended Build.

    Known Issues:
    • Monsters, villagers, etc. using portals (added in Minecraft 1.4) has been temporarily disabled.
    For more detailed information on what is contained in this update, please see the changelog here.

    Download CraftBukkit 1.4.6-R0.3 here
     
    karcraft123, En3der, gomeow and 9 others like this.
  2. Offline

    TnT Retired Staff

    Excellent work team.

    Support Requests will be deleted without warning. Use Bukkit Help please.
     
  3. Offline

    kin61

    2nd!
    Wow! Nice job bukkit team... doing well and first time ever being 2nd in a new craftbukkit! :p Nice BTW
     
  4. Offline

    Foxtapuss

    Good Job Guys
     
  5. Offline

    LaxWasHere

    Is EvilSeph's post automated? TnT
     
  6. Offline

    Aki M

    So quick.
     
  7. Offline

    LiLChris

    Looks like it. :eek:
     
  8. Offline

    NuclearW

    Nope
     
  9. Offline

    Foxtapuss

    Good job with pumping out builds, but i have a quick question, hostile mobs will not spawn on my server. I updated to the latest build, my server.properties are fine, and none of my plugins interfere. Other servers have hostile mobs accept mine, and was wondering if its the beta build acting up. -Thanks
     
  10. Offline

    owenftw

    great job :)
     
  11. Offline

    LaxWasHere

    So you guys need to press a button or something to make him post this?
    What language is he running on, python? What's EvilSeph's specs?

    Just kiddin! Good job on making craftbukkit more awsmr guys!
     
    gomeow, WarmakerT, worstboy32 and 3 others like this.
  12. Offline

    HappyPikachu

    R0.3's the charm. Thanks guys!
     
  13. Offline

    CleanlySteam

    I have a problem with my server. Every time i try to open my server everything goes well, until its finished loading all recipes, spawn location etc. it keeps on spamming something that i cant read because it comes so fast and ive tried everything but it wont stop. I'm not sure whats wrong. Thanks for your time
    CleanlySteam Jackson
     
  14. Offline

    YoFuzzy3

    I had a feeling it wasn't a plugin's fault... good job with the fix! :)
     
  15. Offline

    Ugpzt

    That was quick, Thank You.
     
  16. Offline

    Sshadow

    Try reading the server.log man

    Thanks Bukkit :)
     
  17. Offline

    macmc

    When will a FireworkExplodeEvent be available?
     
  18. Offline

    Tanite

    Anyone know which build the enchantment (or other bad) bug started in? I have a feeling I may already be affected by this since I put in a dev version the other day :/
     
  19. Offline

    tanveergt5

    lool fast update in 1 day from 0.2 0.3 thats the shit i do like
     
  20. Offline

    HazCubes

    Wooo! Thanks for the quick fix!
     
  21. Offline

    Haribo98

    Good work Bukkit team. None of the bugs in this build matter to me!
    Keep up the good work and fast development. Hope you can get the Plugin API being as amazing as possible so we can drop Spout and generally make the plugins we make cooler. Although... Can you make a method where you can do player.setPlayerNameTag(...)? Do I have to make a pull req. If so where? Thanks :D
     
  22. Offline

    Praqoon

    Yeah great work Bukkit. 1.4.6-R0.3 has screwed up my help.yml which was highly customized! I had certain plugins hidden and a custom rules section - now everybody can see ALL plugins (hidden or not) and the rules section is as if it doesn't exist.

    GREAT WORK!

    Happy New Year 2013 ...

    <edit> I have disabled it until further notice.
     
  23. Offline

    p1nkwafflez

    Will 1.4.6 people be able to join the 1.4.7 servers when they update?
     
  24. Offline

    TnT Retired Staff

    Yes

    Praqoon
    Are you sure it was the Beta that caused this issue? I can't see a problem with my custom help.yml (and we didn't change anything relating to the help.yml).
     
  25. Offline

    ASHninja1997

    Awesome Job. Great Work.
     
  26. Offline

    RiotShielder

    They probably SSH into him, a button would be too easy.
     
  27. Offline

    cnaude

    Good job!
     
  28. Offline

    p1nkwafflez

    Before i posted
    What i was supposed to put is can 1.4.7 people join the 1.4.6 servers i dont know if that is what you actually answered TnT but just making sure :)

    Thank You
     
  29. Offline

    TnT Retired Staff

    Same thing. 1.4.6/1.4.7 is interchangeable. Meaning, you can have 1.4.6 players join a 1.4.7 server, and 1.4.7 players joining a 1.4.6 server.
     
    p1nkwafflez likes this.
  30. Offline

    racecar56

    Great work as usual!
     
Thread Status:
Not open for further replies.

Share This Page