CraftBukkit 1.2.5-R5.0 is now available!

Discussion in 'Bukkit News' started by EvilSeph, Jul 27, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    A new CraftBukkit Recommended Build (1.2.5-R5.0) that provides Minecraft 1.2.5 compatibility and fixes issues in CraftBukkit 1.2.5-R4.0 and earlier is now available. As this RB contains a significant number of important changes and fixes, upgrading is highly recommended.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine.

    Notes:
    This Recommended Build includes an upgrade to the jLine we use in Bukkit. As a result, Windows servers need the Visual C++ 2008 redistributable if you want to be able to see text formatting in your console (or use -nojline to disable jLine if you don't want to).

    Unlike a previous Recommended Build (1.2.5-R2.0), this new RB does not need anything special like ANSICON.

    Known Issues:
    • None.
    For more detailed information on what is contained in this update, please see the changelog here.

    Download CraftBukkit 1.2.5-R5.0 here
     
  2. Offline

    feildmaster Retired Staff

  3. Offline

    travja

  4. Offline

    dark_hunter

  5. Offline

    spydercanopus

    I think there should be some novel IQ test to post on the bukkit forums. Seriously.
     
  6. Offline

    Kainzo

  7. Offline

    stefan0585

    when i try to join my server with the latest bukkit version and mc version 1.3 i got the message "this server is outdated"
     
  8. Offline

    Matthew8771

    When the craftbukkit 1.3 build comes out will all of my 1.2.5 plugins still work with 1.3?
     
  9. Offline

    iKeirNez

    It depends, usually yes but sometimes it won't and will need updating.

    A 1.3 version of CraftBukkit has not been finished/released yet.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 27, 2016
  10. Offline

    TnT Retired Staff

    Are you sure he wasn't just confirming that build 2261 was working as intended? That's what I'd hope he meant, because clearly this thread's title was 1.2.5-R5.0, not 1.3.0-R1.0.
     
  11. Offline

    MyPictures

  12. Offline

    iKeirNez

    Didn't think of that, my bad. Just seen so many of these posts going about.
     
  13. Offline

    TnT Retired Staff

    Support Requests removed. Please use the Bukkit Help forums for assistance.
     
  14. Offline

    phantomvision

    I wish there was a place to post a question to Bukkit team. Are you going to be providing Essentials with the new 1.3? I am not just talking about multiplayer but the new single player content that is programmed on same platform as multiplayer. The reason is why I am asking is because I would like the same command as I can with multiplayer and I think alot of players who likes both would love the same playing freedom in the game now that there is a link with single and multi player worlds. I hope I dont seem like I am rambling.
     
  15. Offline

    TnT Retired Staff

    phantomvision
    There will be a release available to the entire community when it is ready. When that time is, we do not know, so we wait patiently.
     
  16. Offline

    phantomvision

    TnT Thanks for answering my question
     
  17. Offline

    saturnine_nl

    delete your playername.dat file in the directory players of the primary world (make a backup of this file first in case this method also fails). You lose everything you had on you but at least you can play again. This trick has worked for me several times when i got caught in a loop.

    greets Sat
     
  18. Offline

    pcgirl

    oh my god. So it's not just people coming to my server that don't read stuff before posting the same bloody question over and over again! Geez..

    Anyway - just wanted to say that I updated all my plugins and bukkit on a copy of my server - tested everything and all is working seamlessly and well. I'm running 52 plugins(!!!) and they are all working and playing nicely. I then moved across all the changes I made to my proper server and kicked her into gear.

    I'm also using the BukkitGUI, which is a bit buggy - but otherwise, it's all good. :D

    Very happy guys. You are doing a wonderful job. I'll probably donate when I find work again. I rely so heavily on this site to keep my users happy. :)
     
  19. Offline

    gbsn

    Sugoe!!! Subarashi!!!
    Congratulations Bukkit team. And as aways i will use on my server, the second elder server on Brasil. I will send another donation.
     
  20. Offline

    builditallm8

  21. Offline

    Pcd2010

    Just Updated And The Server Running Great All 30 plugins running Properly Thanks Developers
     
  22. Offline

    Nucious

    Works great... but what good did it do from RF 4.0 ?
    I read the updates..
     
  23. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    There's a nice list of updates on the linked page...
    oh
     
  24. Offline

    Nucious

    Question answered. I'm crazy as fuck, so don't mind me :).
     
  25. Offline

    tremor

    Anyone other than me experiencing a 10-20% increase in CPU usage from R4.0 to R5.0? Perhaps it's plugin related but I haven't changed anything, on the other hand, none of my installed plugins have been rebuilt on 5.0 yet, so maybe there is something going on there... but the increase is enough to make players notice and create some block lag.
     
    Fuzzlr likes this.
  26. Offline

    Fuzzlr

    I'm having the same issue. When I hit 300 players the CPU usage will spike frequently and cause some lag. It was fine when I was using R4.0.
     
  27. Offline

    OllyHal

    Mine is working fine, must be one of your plugins causing the problem
     
  28. Offline

    CrazedLobster

    can this work with 1.3?
     
  29. Offline

    effortless

  30. Offline

    WolwX

  31. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    It correctly links to the latest beta build, which is a 1.2.5 build. There's only a dev build of CraftBukkit on 1.3
     
Thread Status:
Not open for further replies.

Share This Page