CraftBukkit 1.2.5-R1.0 is now available!

Discussion in 'Bukkit News' started by EvilSeph, Apr 4, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    A new CraftBukkit Recommended Build (1.2.5-R1.0) that provides Minecraft 1.2.5 compatibility is now available.

    Will plugins break with this build?
    Unless the plugin developers of your plugins have been keeping up with Bukkit development, plugins will most likely be broken due to the recent optimisation and cleaning of our code. However, if the plugins you use have already been updated to work with at least 1.1-R7 or at least 1.2.3-R0.1, then you should be fine.

    For more detailed information on what is contained in this update, please see the changelog here.

    Download CraftBukkit 1.2.5-R1.0 here
     
  2. Offline

    andrewpo

    ankmagicmn1 - Type "/save-on" then "/save-all"
     
  3. Offline

    ankmagicmn1

    This is what happens: I get the new jar file and put it in my server folder. I then launch the server and it converts it. After this I log on and time has been "rolled-back". I have save-on and I do save-all every time I stop my server. And I stop my server with the stop command.
     
  4. Offline

    ChronosTrigger

    So I tried to update my Craftbukkit server to 1.2.5 from 1.2.4, before working perfectly. As I updated it and started it back up, the black loading screen came up but my Pail window never loaded, unable to connect to my server nor anyone else. So I tried uninstalling, I forgot I don't have the download anymore and can't find the download for it anymore, the automatic installer page doesn't have a download and I can only find the updates, anyone know where I can find the actual download for bukkit?
     
  5. Offline

    zmr333

    dl.bukkit.org

    For some reason I have great trouble logging into my server even though it is a localhost. It says I took too long to log in when Minecraft doesn't crash. Is anybody else having this problem? If so, how do you fix it?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 25, 2016
  6. Offline

    palisade

    This just starting happening to me this evening. I was playing with some friends then I logged off to go eat dinner. When I went to come back on I couldn't log in, and received a "Took too long to long in." No matter how many times I reconnect, I can't get in. I restarted the server a few times, and even tried a more recent dev build. But, I still can't get into my server.

    I think I just solved it. I logged into another server, disconnected, and then tried my server again. I was able to get in.

    The problem now is, when I log out and back in again it locks me out again. Then, I attempted to log into the other server again like I did before, and I can't, same problem. So, I tried a server I hadn't tried before, and still can't get in. I can't seem to get into any servers at all. I'm thinking of completely blowing away my .minecraft directory and starting over.

    Re-installed the client. I thought re-installing the client fixed it, but it didn't. When I logged out and back in again, it wouldn't connect again. Client keeps getting a timed out socket error. I finally received this error in my server.log:

    2012-04-07 19:10:17 [INFO] Disconnecting blakesteel [REMOVED MY IP]: Failed to verify username! [internal error java.io.IOException: Server returned HTTP response code: 504 for URL: http://session.minecraft.net/game/checkserver.jsp?user=blakesteel&serverId=6bdbd449b7edd2d1]
    2012-04-07 19:10:17 [SEVERE] java.io.IOException: Server returned HTTP response code: 504 for URL: http://session.minecraft.net/game/checkserver.jsp?user=blakesteel&serverId=6bdbd449b7edd2d1
    2012-04-07 19:10:17 [SEVERE] at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1436)
    2012-04-07 19:10:17 [SEVERE] at java.net.URL.openStream(URL.java:1010)
    2012-04-07 19:10:17 [SEVERE] at net.minecraft.server.ThreadLoginVerifier.run(ThreadLoginVerifier.java:34)

    I went ahead and deleted my lastlogin file in the .minecraft directory, re-entered my username/password in the minecraft client and now I can relogin to my server over and over without problems now.

    I think the problem might be that the server that detects if you have a validly purchased Minecraft client is responding very slowly to queries today. I think that's what is preventing people from logging in.
     
  7. Offline

    zmr333

    Deleting the lastlogin file did not work for me :(, but it seems logical that it's the Minecraft website, as you said..
     
  8. Offline

    palisade

    Just discovered a new problem. I initially had mobs in my world; skeletons, spiders, etc. But, after we've been slaughtering the ones we've found, they aren't regenerating. My world is pretty empty of mobs now. Above and below ground. Mob spawners still spawn mobs, though. And, spawn monsters is turned on in the server.properties btw.

    I thought it was a plugin, but it's not because I've turned them all off and still no mobs are spawning.
     
  9. Offline

    ne0x86

    a little question guys. im noob with my own server.

    If i install mine 1.2.4, after those, install bukkit 1.2.5, all plugins must work or i need to reinstall one by one?
     
  10. Offline

    Deffe

    Hey guys,

    Might be a stupid question, but I just replaced the old 1.2.4 craftbukkit jar file with the new 1.2.5 and edited the starter batch file, like I did every time a new version came out. But for some reason now users and myself experience time outs A LOT when trying to login. Any ideas what might have gotten wrong? If you need more info, say so.

    Thx for the help, appreciate it.
     
  11. Offline

    DylanCamps


    I replaced my craftbukkit 1.2.4 to 1.2.5 a while ago, but it was yesterday when me and my players had started to get some difficulties logging in. I checked my server log and it said "Disconnecting DylanCamps [ip address] : Took to long to log in." It was also happening when my friends tried logging in, now when I try logging in to my own server my minecraft freezes and I have to force close it. I think I am having the same problem as you, We all need help. Someone please answer!
     
  12. Offline

    Spl1tz

    I think it would help a lot better if someone would create a thread about this in the Help section, that way we can get people's attention.

    Server owner with the same issue.
    EDIT: +i'm sure its the official servers. I didn't have this issue since the release of the latest RC CB up till now...
     
  13. Offline

    DylanCamps

    We are all having the same problem :( I was just figuring out redstone. Is it bukkit that is causing these problems or is it a Minecraft bug? I really wanna get my server running again.
     
  14. Offline

    Deffe

    Just found a thread in the help forum, gonna post my problem there too, recommend you guys do the same. http://forums.bukkit.org/threads/bukkit-crashing-disconnecting-players.69480/
     
  15. Offline

    y4se

    good job!
     
  16. Offline

    Godgeneral

    dit you guys from bukkit also fixed the problem from my map (posted in the 1.2.4 R1.0 forum)
    i need it very hard now

    yeah, you guys did it.
    you made me so happy
    thank you very much

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 25, 2016
  17. Offline

    palisade

    Mobs still aren't spawning. I turned off all plugins. I don't know what to do about this.
     
  18. Offline

    el_freakyfrog

    maybe this is just me being a derp but I'm not getting the console when i start the server, is there an in-world command to get it to show?

    edit the Server properties file to this"spawn-monsters=true" and "spawn-animals=true" if its that already then you might try turning the mobs and animals off and saving the server file, start your server, stop it, and change it back to true for mobs and animals, other than that i dont know what else to suggest (not editing this post again...rubs eyes...tired)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 25, 2016
  19. Offline

    robot56

    Do you mean "Disconnected from server" Buffer Overflow? I'm pretty sure that relates client side, when It receives too many block changes or some thing to the server while the server just denies it or something then the server kicks you. This really happens to me when a server is halted and the server denies the massive block changes while the client just keeps sending block changes. Don't really see why that would happen oftenly tho (just my guess)

    I've seen this error many places before but what craft bukkit version are you using and which client version?This is usually due to an error w/ incompatability.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 25, 2016
  20. Offline

    Amaranth Retired Staff

    Guys, the took too long to login and HTTP error 504 messages mean the minecraft auth servers are overloaded/down. It has nothing to do with your server or CraftBukkit in general.
     
  21. Offline

    robot56

    You need to be more detailed instead of I keep getting took too long to login error this probably has something to do with incompatibility like for example using 1.2 on a 1.1 server will return that do /Version and give your client version.Deleting last login only stores your last used user name and if u set it to remember, your password so that shouldn't really fix it.
     
  22. Offline

    Chubaca

    Please tell me what I need to do to update my server. I am a bit confused.
    And also if I understand correctly when I update it people that have updated to minecraft 1.2.5 will be able to play.
     
  23. Offline

    DylanCamps

    To update your server you need to replace the current craftbukkit with the newest version, you also need to create a new starter batch file, for example : Craftbukkit-1.2.4-R1.0 is the version, replace that with Craftbukkit-1.2.5-R1.0. Then you need to edit your starter batch file so it uses the craftbukkit-1.2.5-R1.0 as a path. And yes, people who update their minecraft will be able to join your server


    Everything on my server is up to date so it cannot be a compatibility error, my minecraft is updated and the Craftbukkit version is also up to date. My problem and cause is below

    This is my problem, so now I know that it is the Minecraft servers are overloaded/down.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 25, 2016
  24. Offline

    palisade

    I'll have to try that later tonight and see if it works.

    UPDATE: Mobs starting respawning again for no reason just last night.
     
  25. Offline

    Kainzo

    woo for 1.2.5!
     
  26. Offline

    robot56

    504 Internal Errors mean the server took to long to respond.
    It could be to being overloaded but it works for me, the servers aren't down as they wouldn't just do that with out notification. Most of the time(I said most) its due to the client not reviving a valid/no response while the server has sent the data back.If you still get this error and you just want to run your server, run it in offline mode with an authentication plugin like xauth.
     
  27. Offline

    fnlCtrl

    so now the problem is that i couldnt connect to my 1.2.4 server with a 1.2.5 client.(all original/clean version)
    no i am not a noob i've been running servers from 1.1-R1 for 20+ppl. so dont question me about my knowledge of this. my 1.2.3 server is functioning as we speak.
    all i wanna know is if the quote above is absolutly right and i need to check again and try using another computer, or if is proved wrong.


    ==========and==========
    why is my old post about this problem deleted, with no messages/warnings? a too dumb question?
    if you're gonna delete this one please simply tell me that this post is stupid and i will not ask anymore.
     
  28. Offline

    AcADIeN

    I ran my 1.2.4 server for a full week (upgraded to 1.2.5 this morning) and all my client (20 people) were on 1.2.5 without having a single issue, while I can't say that the protocol did not change (I'm not that hardcore yet) I can confirmed that it worked for us.
     
  29. Offline

    fnlCtrl

    thanks a lot. it turned out that i used a wrong minecraft.jar(modded version which i forgot to put a tag on it).lol it's stupid.
    and to moderaters please take the trouble to tell people why posts are deleted, which will be nicer.
     
  30. Offline

    robot56

    Hmm...
    I'd expect them to tell you something about it, but just saying that won't fix your problem go talk to a moderator.
     
  31. Offline

    TnT Retired Staff

    This is not a help forum. It is standard practice on these to remove all help requests. Sometimes I forget that people do not realize this - which was the case this time (I usually have a post on the first page after having to delete a few due to support requests).
     
Thread Status:
Not open for further replies.

Share This Page