Commandbook/Essentials gamemode error...

Discussion in 'Bukkit Help' started by spiral6, Dec 31, 2012.


Which general command plugin is better?

  1. Essentials

  2. CommandBook

    0 vote(s)
  3. Neither

Thread Status:
Not open for further replies.
  1. Offline


    I need help. Whenever I use commandbook, none of my players can use the gamemode command. After switching commandbook with essentials, the same thing happens! (in a different message of "you don't have permission") After removing both, the gamemode command works fine. Why is CommandBook/Essentials blocking the gamemode command? If there is a fix, I need help!
  2. Offline


    spiral6, in the case of Essentials, I believe it takes over control of the built-in gamemode command, in favor of its own gamemode command. So you may need to add the Essentials gamemode permission node to your permissions config for whatever groups you want having access to that command. The same could be true for CommandBook, but I've never used it, so I don't know.
  3. Offline


    There isn't documentation of an essentials gamemode command, nor of a commandbook gamemode command either. If it does take over, i can't find the permission node to fix it...

    I think i found the permission node after all, (sigh) I really don't want essentials taking over bukkit's functions completely, so could you somehow block it?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 30, 2016
  4. Offline


    It's the same thing as the bukkit command. It only adds better name matching and additional aliases.
  5. Offline


    There is a disabled-commands list in your plugins/Essentials/config.yml. Add gamemode:
      - gamemode
    EDIT: Essentials also overrides among other things, /spawn and /god, which are provided by CraftBukkit and WorldGuard, respectively.
  6. Offline


    thanx, everyone!
Thread Status:
Not open for further replies.

Share This Page