Filled Command signs

Discussion in 'Plugin Requests' started by skylerRU, Jul 2, 2016.

Thread Status:
Not open for further replies.
  1. Offline

    skylerRU

    Minecraft version: Minecraft 1.10

    Suggested name: Command sign

    What I want: I need a basic plugin were you type a command on a sign, when you click that sign it will run the command.

    When I'd like it by: preferably within the next week.

    @Astrophylite

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 2, 2016
  2. Offline

    BlockHeads36

    I know of a plugin that I used and liked, except its $2.50 <Edit by Moderator: Redacted not allowed paid resource url>
     
    Last edited by a moderator: Dec 4, 2016
  3. Offline

    Astrophylite

    I'll take this. Should be done within the next week.
     
  4. Offline

    skylerRU

    Thx huge help glad to see some decent people in the world :)
     
    Zeneth2727 likes this.
  5. Offline

    Jakeeeee

    I can do this within 30min - 2 hours if you (@Astrophylite) don't want to do this.
     
  6. Offline

    Astrophylite

    I am fine with doing this, but thanks for the offer.

    @skylerRU
    Hey!

    You can now download this from paulreffell.me/downloads/CommandSigns-1.10v1.jar!

    There are no commands (why would you need commands?).
    There are two permission nodes (commandsigns.use & commandsigns.create)

    Sign Format:
    Code:
    [CommandSigns]
    <command>
    <command arguments>
    To make it so different players can use it without changing the name on the sign, you can use %p instead of a player's username.

    Hope it works,
    Astrophylite.

    P.S: Before people say "OMG! RIP OFF OF SIMPLECOMMANDSIGNS!". Yes, I did take inspiration from SCS but it is outdated so I de-compiled SCS and took the code out of it and built it with 1.10.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.

    EDIT: I am also aware that there is already a plugin called CommandSigns but again, it's outdated and is not likely to be updated to 1.10 any time soon.
    EDIT 2: You can see the source code here! (https://github.com/astrophylite/CommandSigns)
     
    Last edited: Jul 2, 2016
  7. Offline

    skylerRU

    Great!! Thanks

    Hey the plugin isn't working did you test it?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 3, 2016
  8. Offline

    Astrophylite

    @skylerRU What do you mean it doesn't work?
    1. Are you using Spigot 1.10?
    2. Are you using the correct sign format? (example below)

    [​IMG]

    3. Does the plugin show up when you type /pl in chat? If so, what colour is it?

    I can't seem to find any problem because as you can see, it's working for me so please answer the questions above and I will be able to help.

    Thanks,
    Astrophylite.

    EDIT: Don't worry about answering the questions, I forgot I had a permissions system.
    You need to be op and/or have the following permissions to fully use the plugin:
    - commandsigns.use
    - commandsigns.create
    If you're not OP/don't have the permissions, there will be a message telling you that you don't permission.
     
    Last edited: Jul 3, 2016
  9. Offline

    I Al Istannen

    Astrophylite likes this.
  10. Offline

    skylerRU

    I am OP I have the permissions and I have spigot 1.10 still nothing when I do /plugins nothing comes up I get this error message in the console "java.lang.UnsupportedClassVersionError: me/astrophylite/commandsigns/CommandSigns : Unsupported major.minor version 52.0 03.07 12:40:23 [Server] ERROR Could not load 'plugins/CommandSigns-1.10v1.jar' in folder 'plugins'"
     
  11. Offline

    I Al Istannen

  12. Offline

    skylerRU

    Ya Im also using a mcprohost server
     
  13. Offline

    I Al Istannen

    @skylerRU
    Why does this matter? Either you can update your java to Java 8 (Which you should be able to do) or not. In the latter case you might simply have a problem. Here is a thread telling you how to change your java version. Don't know if it still works though.
     
  14. Offline

    skylerRU

    No m8, I already have java 8 but I don't host it from my desktop
     
  15. Offline

    I Al Istannen

    @skylerRU
    Which is why the link tells you how to change McProhosts java version... Have you actually read it?
     
  16. Offline

    skylerRU

    I am so sorry I mis understood you, Ill try that out!
     
  17. Offline

    I Al Istannen

  18. Offline

    skylerRU

    Plugin still doesnt work but Im pretty sure I have java 8 casue all my other plugins work
     
  19. Offline

    I Al Istannen

  20. Offline

    skylerRU

    When I follow the link you sent it just crashes :/
     
  21. Offline

    Shifty Lemon

    @Asrophylite could you shorten the [commandsigns] line to maybe something shorter like [cs]

    @atrophylitewhenever i try to put a sign it says unknown command

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 5, 2016
  22. Offline

    I Al Istannen

  23. Offline

    __Penguin__

  24. Offline

    skylerRU

    Yes but I need it for 1.10 :(
     
  25. Online

    timtower Moderator Moderator

    Outdated doesn't mean broken till proven otgerwise.
    Do you have a log to prove that it is broken?
     
  26. Offline

    skylerRU

    Oh it does work sorry XD
     
  27. Offline

    Astrophylite

    I'm sorry for being so inactive. I've been busy with other IRL things recently.
    I must be using Spigot 1.8.8 to compile it then, I'll fix the error(s), if I can find a way but I would recommend using ServerSigns anyways (as said above by @__Penguin__).

    Thanks,
    Astrophylite.

    EDIT: I cannot seem to find the error. I don't know why it's erroring for unsupported major.minor version 52.0 because I don't use that anywhere in my code. Even a quick Google search doesn't shed any light...

    Can anyone else help with that?
     
  28. Offline

    I Al Istannen

    @Astrophylite
    Here. It just means you have compiled it with Java 8, but he used a lowe version (probably Java 7). He would need to update it or you need to compile for Java 7. He should update.
     
  29. Offline

    Astrophylite

    Sorry again for being inactive, I can shorten it but I don't want to completely rip off SCS because they use [SCS] for their signs.

    Try putting the command on one line and the argument(s) on the other.
     
Thread Status:
Not open for further replies.

Share This Page