Solved "*command* is not allowed in this area" HELP ME!!

Discussion in 'Bukkit Help' started by PapiDimmi, Mar 1, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    My mod tried //set, /tp, /msg, and none of the commands works! NO COMMANDS WORKS!

    I need to do /region flag __global__ allowed-cmds *command*,*command*,*command*

    And so on, and I don't freaking want to do ALL THE COMMANDS for the whole servers, that would take hours, and hours, and hours, and hours...

    This happend after I installed NoCheatPlus, so is it NCP that causes the problem?
  2. Offline


    sounds like a world guard issue. check your config files for a global flag. secondly, if it is not there, check your area to see if it is region guarded. if it is region guarded, your region may have the command whitelist on it.
  3. Offline


    1. "Check your config files for a global flag"? What does that mean?
    2. It wasn't any region where I was. (I checked it with the World Guard tool (for me it's a clay ball))
  4. Offline


    open the folder /SERVER/plugins/worldguard/ and find the global config file. I dont know the name of it at this time, i am not home and posting from my tablet. If you never edited it or set global flags, you should not have any issues then. global flags do not set ANY whitlisted commands by default.
  5. Offline


    It isn't anything about global flags in the config file!
    And I haven't done anything, I just blacklisted some commands like /plugins,/pl,/?
  6. Offline


    how did you black list those commands?
  7. Offline


    I did this command in game:
    /region flag __global__ blocked-cmds /plugins,/pl,/?

    But I don't need to worry about that anymore, because I discovered that NoCheatPlus and Essentials Group Manager block those commands :)

    But now my players can't use ANY command! Please help anyone :'(

    Wait! Now I just saw this shit!


    How do I "undo" or disable that allowed-cmds so ALL COMMANDS they got permission for are allowed??

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 31, 2016
  8. Offline


    stop bumping so often, you arent going to die. theres also bukkit IRC for bukkit help, if you need.
  9. Offline


    I think: /region flag [region] allowed-cmds
    I think this clears the flag.
    Tell me if I helped you
  10. Offline


    So do some basic troubleshooting.
    1. what is the problem?

    2. when did it last work correctly?

    3. what did you change?

    4. remove change, see if it reverts.

    5. add change with default settings.

    6. lather, rinse, repeate.
  11. Offline


    Okay, thanks!
    I did /region flag __global__ allowed-cmds and it said "Region flag "allowed-cmds" cleared."! Thank you!
    I'll wait 'til someone logs on so they can test a command ;)

    Edit: Somebody tested commands for me, and it worked :) Marking thread as solved :D
  12. Offline


    Always here to help :)
    PapiDimmi likes this.
  13. Offline


    Read my Edit :D
  14. Offline


    Your welcome :)
Thread Status:
Not open for further replies.

Share This Page