Chunk saving bug ?!

Discussion in 'Bukkit Help' started by Gordon, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    yesterday I installed the latest build of Craftbukkit on my Server.
    Averything worked perfekt ... we started a new world and I mined two hours... the I went out and a creeper killed me ([​IMG]) . I ran bag an tried to pick my stuff up, but it didnt moved into my inventory, also there were 2 creepers (thay dont moved) So I diconncted and reconnected, my things were away and I went to my door....
    But there was no door anymore .... i mined a litle - no room-no chest - today I opened the Map with Minecraft X-Ray and found one of my tunnels with torches ... but nothing more....
    All the other things has been safed. (The house of my friend is still there)
    Any tipps for fixing this bug?
  2. Offline

    TnT Retired Staff

    What we need: What OS, including version, and whether it is x64 or x86. Java, and what version it is (again, x64 or x86). Also, what craftbukkit version have you used? Is this a new, or pre-existing world? What have you tried already?
  3. Offline


    I had this problem too, but then I installed 76 or something and it was fixed. Now, I've installed 87 (the newest version), and a large area that used to be my farm has been transformed into a part of the sea.
    My server uses Ubuntu Server 10.04 LTS, x86, it's the most recent Java (I don't know how it's called exactly) and the world is pre-existing. Plugins are MyHome, MyWarp, TelePlus and General.
    I know this is not my topic, but it would be a waste to make another one.
  4. Offline

    TnT Retired Staff

    Builds ~67-75 (can't remember it exactly) had this problem. Basically, anything you did during those builds is likely not going to be saved. I had to restore from backups to make sure my world was fine. I didn't want to leave anything those builds did saved on my world (don't trust it to save properly). I have been running 87 though, and I haven't had problems (when I can actually log in - the minecraft auth servers still having problems, or if they changed DNS, it hasn't replicated fully to me yet)
  5. Offline


    It may be a plugin (MyHome) I didn't update after updating CraftBukkit that caused the error, because after restarting the server and updating MyHome (I forgot it the first time), there is no more error on the console screen.
    Otherwise, it would show the same errors builds 67-75 used to show.
    Anyway, I'm glad I made a backup yesterday, I'll just be restoring it.
  6. Offline

    TnT Retired Staff

    Oh yeah, sorry, first step to troubleshooting these issues is to strip out every plugin and run the core system. Then put a plugin in one by one and try it out.
  7. Offline


    ok ... I downloaded the latest build from the guide .
    Im using a VServer with CentOS and 1,5 GB RAM.
    The only plugin I installed is the General Plugin.
  8. Offline


    I've also just had this problem with build 82.
    Will look into the plugins.
  9. Offline


    I am running 82 on my server two days in a row now. Just checked the map from a morning backup and it looks OK. Maybe the plugins?
  10. Offline


    stupid question, prolly been repeated several times but.... whats wrong with the latest build 106?
Thread Status:
Not open for further replies.

Share This Page