Solved Can't use WorldEdit //undo. Internal server error?

Discussion in 'Bukkit Help' started by MaliciousMan, Nov 29, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    Bukkit build 1.6.4 R2, Recently updated WE as well. Any ideas as to why this happened?

    2013-11-29 19:39:43 [INFO] OzOwnz issued server command: //wand
    2013-11-29 19:39:57 [INFO] OzOwnz issued server command: //expand vert
    2013-11-29 19:40:02 [INFO] [ClearLag] You just removed 0 entities!
    2013-11-29 19:40:03 [INFO] [0;33;22m[[0;32;1mClearLag[0;33;22m] [0;32;1m[0;33;22m81 [0;36;1mMobs have been removed![m
    2013-11-29 19:40:03 [INFO] [ClearLag] You just removed 7 entities!
    2013-11-29 19:40:03 [INFO] [0;33;22m[[0;32;1mClearLag[0;33;22m] [0;32;1m[0;33;22m32 [0;36;1mchunks have been unloaded![m
    2013-11-29 19:40:14 [SEVERE] com.sk89q.worldedit.UnknownItemException
    2013-11-29 19:40:14 [SEVERE]    at com.sk89q.worldedit.WorldEdit.getBlock(
    2013-11-29 19:40:14 [SEVERE]    at com.sk89q.worldedit.WorldEdit.getBlocks(
    2013-11-29 19:40:14 [SEVERE]    at me.frodenkvist.safeedit.ReplaceRunnable.<init>(
    2013-11-29 19:40:14 [SEVERE]    at me.frodenkvist.safeedit.SafeEdit.replace(
    2013-11-29 19:40:14 [SEVERE]    at me.frodenkvist.safeedit.PlayerListener.onPlayerCommandPreprocessEvent(
    2013-11-29 19:40:14 [SEVERE]    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2013-11-29 19:40:14 [SEVERE]    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    2013-11-29 19:40:14 [SEVERE]    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    2013-11-29 19:40:14 [SEVERE]    at java.lang.reflect.Method.invoke(Unknown Source)
    2013-11-29 19:40:14 [SEVERE]    at$1.execute(
    2013-11-29 19:40:14 [SEVERE]    at org.bukkit.plugin.RegisteredListener.callEvent(
    2013-11-29 19:40:14 [SEVERE]    at org.bukkit.plugin.SimplePluginManager.fireEvent(
    2013-11-29 19:40:14 [SEVERE]    at org.bukkit.plugin.SimplePluginManager.callEvent(
    2013-11-29 19:40:14 [SEVERE]    at net.minecraft.server.v1_6_R3.PlayerConnection.handleCommand(
    2013-11-29 19:40:14 [SEVERE]    at
    2013-11-29 19:40:14 [SEVERE]    at net.minecraft.server.v1_6_R3.PlayerConnection.a(
    2013-11-29 19:40:14 [SEVERE]    at net.minecraft.server.v1_6_R3.Packet3Chat.handle(SourceFile:49)
    2013-11-29 19:40:14 [SEVERE]    at net.minecraft.server.v1_6_R3.NetworkManager.b(
    2013-11-29 19:40:14 [SEVERE]    at net.minecraft.server.v1_6_R3.PlayerConnection.e(
    2013-11-29 19:40:14 [SEVERE]    at net.minecraft.server.v1_6_R3.ServerConnection.b(SourceFile:37)
    2013-11-29 19:40:14 [SEVERE]    at net.minecraft.server.v1_6_R3.DedicatedServerConnection.b(SourceFile:30)
    2013-11-29 19:40:14 [SEVERE]    at net.minecraft.server.v1_6_R3.MinecraftServer.t(
    2013-11-29 19:40:14 [SEVERE]    at net.minecraft.server.v1_6_R3.DedicatedServer.t(
    2013-11-29 19:40:14 [SEVERE]    at net.minecraft.server.v1_6_R3.MinecraftServer.s(
    2013-11-29 19:40:14 [SEVERE]    at
    2013-11-29 19:40:14 [SEVERE]    at
    2013-11-29 19:40:22 [INFO] [0;33;22m[[0;32;1mClearLag[0;33;22m] [0;32;1m[0;33;22m83 [0;36;1mMobs have been removed![m
    2013-11-29 19:40:22 [INFO] [ClearLag] You just removed 26 entities!
    2013-11-29 19:40:22 [INFO] [0;33;22m[[0;32;1mClearLag[0;33;22m] [0;32;1m[0;33;22m0 [0;36;1mchunks have been unloaded![m
    2013-11-29 19:40:25 [INFO] OzOwnz issued server command: //undo
    Bump. :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 5, 2016
  2. Offline


    Bleh. This happens to me sometimes too, especially when I update WE jars. What I do is simply delete my old config folder (the entire thing). Keep any schematics you have, and just put them back after a new one generates. Works every time :)
  3. Offline


    Alright I'll try that, if that doesn't work I'll just revert to the older jar. :) Thanks.
  4. Offline


    An unknown item exception means it tried to convert an item name to an item ID and failed.

    This is me glaring at SafeEdit.
  5. Offline


    Found out what the problem was, I had also recently installed a plugin called SafeEdit which works with WorldEdit to help counter lag, but there's a ton of comments on that plugin complaining about undoes not working.

    My fault for not reading comments, sorry about that. - Marked as solved

    EDIT: haha PseudoKnight xD nice timing
Thread Status:
Not open for further replies.

Share This Page