"Cannot find filepath specified" error when installing Craftbukkit?

Discussion in 'Bukkit Help' started by Obsidian Nightflare, Mar 20, 2011.

Thread Status:
Not open for further replies.
  1. [[Problem is solved]]

    So I'm trying to use the preview build of Craftbukkit for a new multiplayer server I'm trying to start for my friends and I (because I don't want to start over from scratch when Craftbukkit officially relseases). I made a little folder just for the server files and stuff or whatever right on my desktop, and went to the "Get Craftbukkit" link up at the ^^^^^ top there that's all nice and shiny. Everything seems to be alright until I double click RUN.bat and get "Cannot find the filepath specified. Press any key to continue..." I press a key and poof. Here's the contents of the .bat file (since it seems to have changed itself over various deletions and restorations):

    SET BINDIR=%~dp0
    "%ProgramFiles (x86)%\Java\jre6\bin\java.exe" -Xincgc -Xmx1G -jar "%~dp0\craftbukkit-0.0.1-snapshot.jar"

    I have checked my (x86) folder and the java executable is indeed located at the filepath it lists there. Is there anything wrong with the .bat (I did add the "(x86)" myself to make the filepath true), or is it because I'm using Windows Vista as opposed to Win7? (If it matters, I also tried doubleclicking the SNAPSHOT.jar file to see if I could get it to open itself without the .bat; the server-necessary files did pop up, but no command console, as is to be probably expected)
  2. Offline


    replace all that crap with the following :)

    java -Xincgc -Xmx1G -jar craftbukkit-0.0.1-SNAPSHOT.jar

    copy the batch file to the same folder as craftbukkit-0.0.1-SNAPSHOT.jar
    doubleclick the batch file

    if it fails, your java is not in the path or your craftbukkit file is named something else (probably jar.jar if you have file extensions hidden)
  3. OK, so I did that, but now I get a different error message:

    'java' is not recognized as an internal or external command, operable program or batch file."

    Uh... Perhaps adding "/run" to the beginning, perhaps? I'm pretty much a total noob with coding, so sorry if I seem hopeless ^.^;

    Oh, wait, got it to work by changing java to to the "(insert java executable filepath here)". thanks for the help :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  4. Offline


    Hello, i have the same problem as you a tried mughi's code but i end up with the same problem you had....
    please tell me how you fixed it?, thanks!:)
Thread Status:
Not open for further replies.

Share This Page