Cannot connect from external IP. Read timed out

Discussion in 'Bukkit Help' started by Dumpshock, Apr 27, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Running into an issue with the new Recommended build 733.

    I can connect to my server from the same machine the server is running from, but cannot connect from any internal IP or my external IP.

    1. What OS are you using? - Windows 7 Ultimate
    2. What architecture is the OS you are running? - x64
    3. What version and architecture is your java install? - 1.6.0_24
    4. Are you running any wrappers? - No
    5. What build of CraftBukkit are you running? 733
    6. What command are you using to run your CraftBukkit server?

    @Echo off
    java -Xms1024M -Xmx1024M -jar craftbukkit.jar nogui


    @Echo OFF
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%\Java\jre6\bin\java.exe" -Xincgc -Xmx1G -jar craftbukkit.jar

    7. What plugins are you running? - None (For testing purposes)
    8. What error are you getting (post your server.log file if possible)?

    Internal exception: Read timed out

    2011-04-27 15:24:29 [INFO] Starting minecraft server version Beta 1.5_02
    2011-04-27 15:24:29 [INFO] Loading properties
    2011-04-27 15:24:29 [INFO] Starting Minecraft server on *:25565
    2011-04-27 15:24:30 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-700-gf3ae4c3-b733jnks (MC: 1.5_02)
    2011-04-27 15:24:30 [INFO] Preparing level "world"
    2011-04-27 15:24:30 [INFO] Preparing start region
    2011-04-27 15:24:31 [INFO] Preparing spawn area: 73%
    2011-04-27 15:24:31 [INFO] Done (0.144s)! For help, type "help" or "?"
    2011-04-27 15:24:41 [INFO] Dumpshock [/**.***.***.***:*****] logged in with entity id 131
    2011-04-27 15:25:03 [SEVERE] Connection reset by peer: socket write error
    2011-04-27 15:25:03 [SEVERE]     at Method)
    2011-04-27 15:25:03 [SEVERE]     at Source)
    2011-04-27 15:25:03 [SEVERE]     at Source)
    2011-04-27 15:25:03 [SEVERE]     at Source)
    2011-04-27 15:25:03 [SEVERE]     at net.minecraft.server.Packet31RelEntityMove.a(SourceFile:66)
    2011-04-27 15:25:03 [SEVERE]     at net.minecraft.server.Packet.a(
    2011-04-27 15:25:03 [SEVERE]     at net.minecraft.server.NetworkManager.e(
    2011-04-27 15:25:03 [SEVERE]     at net.minecraft.server.NetworkManager.d(
    2011-04-27 15:25:03 [SEVERE]     at
    2011-04-27 15:25:03 [INFO] Read timed out
    2011-04-27 15:25:03 [INFO] Dumpshock lost connection: disconnect.genericReason
    9. What have you tried already? -
    Ports are correctly opened on router and firewall.
    Re-downloaded Minecraft client.
    Re-downloaded Bukkit .jar.

    10. Have you tried any of the things below?

    Run the vanilla Minecraft server. Yes, received No error.

    Update your CraftBukkit Build. Running latest recommended 733

    Remove all your plugins and try with just CraftBukkit. Running stock build, no plugins, new map.

    Any help at all?

    Or did I follow directions too well in gathering my information and just bump myself right off the table for getting any support? :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  2. Offline


    try connecting to "localhost" in your IP and see if it does the same thing.
  3. Offline


    That was described in my first post.

    It connects on the same machine as the server. It doesn't connect from any other machine.

    Server is running on home desktop. I can run Minecraft on there and connect internally (IE. from desktops IP or Localhost), connecting from an external IP doesn't connect. On my Laptop or anywhere else, either from an internal or external IP, I cannot get it to connect.
  4. Offline


    I don't think the server ip should be left blank. You should portforward your ipv4 address and put your ipv4 address in the server ip line in the
  5. Offline


    ServerIP is actually best left blank in properties. If I set it to my internal IP, then it will only allow connections from internal (from my experience at least, correct me if i'm wrong).

    For giggles, I just tried it, no dice. Can't connect from internal IP, and External IP gets a connection refused instead of the normal error. Like said as well in OP, all port forwards are fine.

    The server was running beautifully before the 1.5 update to Minecraft.
  6. Offline


    try putting your external IP there
  7. Offline


    I refer to this link:

    Binding my server to my modem instead of the computer its sitting on didn't help. Just created a error instead on failing to bind to port.

    2011-04-27 20:36:45 [INFO] Starting minecraft server version Beta 1.5_02
    2011-04-27 20:36:45 [INFO] Loading properties
    2011-04-27 20:36:45 [INFO] Starting Minecraft server on **.***.***.***:25565
    2011-04-27 20:36:45 [WARNING] **** FAILED TO BIND TO PORT!
    2011-04-27 20:36:45 [WARNING] The exception was: Cannot assign requested address: JVM_Bind
    2011-04-27 20:36:45 [WARNING] Perhaps a server is already running on that port?
    2011-04-27 20:36:49 [SEVERE] java.lang.NullPointerException
    2011-04-27 20:36:49 [SEVERE]     at net.minecraft.server.MinecraftServer.b(
    2011-04-27 20:36:49 [SEVERE]     at
    2011-04-27 20:36:49 [SEVERE]     at
    2011-04-27 20:36:49 [SEVERE] Unexpected exception
        at net.minecraft.server.MinecraftServer.b(
    2011-04-27 20:36:50 [INFO] Stopping server
    2011-04-27 20:36:50 [INFO] Stopping server
  8. Offline

    Firest Scarlet

    I actually have the same problem, and didn't have any success in solving it. Any external IP can't connect to my server, but i can, in the exact same conditions as you.
  9. Offline


    can both of you post up your server properties file and also,

    Close the server software. Ctrl + Shift + Esc to task manager Go to the processes tab. Sort alphabetically; look for all javaw.exe and end them.
    Reopen the server software.

    taken from:
  10. Offline



    server ip should almost always be blank
  11. Offline

    Firest Scarlet

    #Minecraft server properties
    #Mon Apr 25 14:28:32 BRT 2011
    Here are my properties.
    Also, your other solution didn't work for me.
  12. Offline


    do you have any other entries in your firewall referring to java or minecraft? these could conflict with the four that you actually need
  13. Offline


    Good to see I'm not alone here!

    Glad to see I'm on the right track here as well!

    Not that I've found. Windows Firewall is currently off, but I still have entries to allow the port through inbound and outbound on TCP and UDP.

    I think I might have found that the server works when running from my laptop, still not from my desktop, meaning it would be a localized issue I think.

    I am still testing this theory at the moment, but will post back on the results.
  14. Offline


    are you running Windows 7 SP1? because there was another person on the forums that also had an issue connecting to his server when it was running Sp1.
  15. Offline


    SP1 is neither on my Desktop or my Laptop.
  16. Offline


    But I put in my ipv4 address. I don't get how that is bad.
  17. Offline


    putting in any address makes it so the server ONLY talks to that 'network' that's why it says 'bind to port'

    you want it to be available to all ip addresses your computer uses
  18. Offline


    So just an update.

    Desktop is sitting on
    Laptop is on

    When server is running on Desktop, Can connect to own server either by localhost or, etc.
    Laptop cannot connect to Desktop server.

    When server is running on Laptop however at, there are no issues, Desktop on .103 can connect over.

    I thought maybe it was a borked Java install, so removed Java completely from desktop and reinstalled x64 Java latest which was just updated to 1.6.0_25.

    Still no dice.

    I can't find any differences between the two machines that would cause this except that my laptop is running Java 1.6.0_20 x64.
  19. Offline


    the OLDER java works?

    ...unless.. um.. when running on laptop, can the LAPTOP connect to itself?
  20. Offline


    Yeah, the older Java worked fine oddly enough. Leaves me scratching my head.

    And yes, Laptop is capable of connecting to itself.

    EDIT: Just for matter of completeness, I ripped out the old Java and installed the newest version.

    Laptops still working fine.
  21. Offline


    rats.. was thinking maybe it was a client issue on the laptop

    and both firewalls are configured the same?

    .... your laptop is wireless and your desktop is wired, right?

    any chance your desktop network card needs
    a) new drivers
    b) new cable/reseated cable
    c) replaced/reseated
    d) weird software config?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  22. Offline


    Herp da Derp....

    Thank you mughi, that made me remember there were issues previous with the Atheros chipset.

    Updated the Atheros drivers on my motherboard and I'm at least able to now connect over my local LAN.

    Having some router issues thats preventing my ports from forwarding properly so I can't quite test external connections, but I think you nailed it spot on. :)
  23. Offline


    .. i got lucky :)

    actually, what motherboard do you have? we have another guy w/ a similar issue that we can't figure out
  24. Offline


    Its a ASUS P5L-MX LGA 775 Micro board I picked up a few years ago.

    Havn't really had much of a chance to upgrade in a while. ^_^
Thread Status:
Not open for further replies.

Share This Page