Bukkit 1.2.5 Memory Leak

Discussion in 'Bukkit Help' started by MirkoKrizan, Jul 11, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    I've just started my new server today, and after a while (10 minutes) playing with my friend, everything started to lagg, we had 2GB of ram, and 1 core of 3.4 GhZ, upload was good too. Memory leak came on my mind! These are the plugins i am using on my server:

    This is a server log, but not from when the issue occurred:

    2012-07-11 14:58:27 [INFO] Starting minecraft server version 1.2.5
    2012-07-11 14:58:27 [WARNING] **** NOT ENOUGH RAM!
    2012-07-11 14:58:27 [WARNING] To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
    2012-07-11 14:58:27 [INFO] Loading properties
    2012-07-11 14:58:27 [INFO] Starting Minecraft server on *:25565
    2012-07-11 14:58:27 [WARNING] **** FAILED TO BIND TO PORT!
    2012-07-11 14:58:27 [WARNING] The exception was: java.net.BindException: Address already in use
    2012-07-11 14:58:27 [WARNING] Perhaps a server is already running on that port?
    2012-07-11 14:58:39 [SEVERE] java.lang.NullPointerException
    2012-07-11 14:58:39 [SEVERE]    at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:607)
    2012-07-11 14:58:39 [SEVERE]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:465)
    2012-07-11 14:58:39 [SEVERE]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    2012-07-11 14:58:39 [SEVERE] Unexpected exception
        at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:607)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:465)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    2012-07-11 14:58:42 [SEVERE] null
    java.io.IOException: Input/output error
        at java.io.FileInputStream.readBytes(Native Method)
        at java.io.FileInputStream.read(FileInputStream.java:236)
        at java.io.BufferedInputStream.fill(BufferedInputStream.java:235)
        at java.io.BufferedInputStream.read(BufferedInputStream.java:254)
        at java.io.FilterInputStream.read(FilterInputStream.java:83)
        at jline.console.ConsoleReader$1.read(ConsoleReader.java:167)
        at jline.internal.InputStreamReader.read(InputStreamReader.java:267)
        at jline.internal.InputStreamReader.read(InputStreamReader.java:204)
        at jline.console.ConsoleReader.readCharacter(ConsoleReader.java:995)
        at jline.console.ConsoleReader.readLine(ConsoleReader.java:1167)
        at net.minecraft.server.ThreadCommandReader.run(ThreadCommandReader.java:31)
    2012-07-11 14:58:42 [INFO] Stopping server
    2012-07-11 14:58:42 [SEVERE] Exception in thread "Thread-3"
    2012-07-11 14:58:42 [SEVERE] java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    2012-07-11 14:58:42 [SEVERE]    at java.util.ArrayList.rangeCheck(ArrayList.java:571)
    2012-07-11 14:58:42 [SEVERE]    at java.util.ArrayList.get(ArrayList.java:349)
    2012-07-11 14:58:42 [SEVERE]    at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:418)
    2012-07-11 14:58:42 [SEVERE]    at org.bukkit.craftbukkit.util.ServerShutdownThread.run(ServerShutdownThread.java:14)
    1. What OS are you using (Brand and version - Ex. Windows XP SP3)? Windows 7 SP1
    2. What architecture is the OS you are running (x64 or x86)? x64
    3. What version and architecture is your java install? Java 7 64-bit
    4. Are you running any wrappers? McMyAdmin, mcadmin, Hamachi, etc? No
    5. What build of CraftBukkit are you running? 1.2.5-R4.0
    6. What command are you using to run your CraftBukkit server?
    Im using this:
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%\Java\jre7\bin\java.exe" -Xmx2048M -Xms2048M -jar craftbukkit.jar
    7. What plugins are you running? Listed below
    8. What error are you getting (post your server.log file)? I don't get any errors, it's just starting to lagg sometimes after 10 minutes, sometimes after 30 minutes, randomly
    9. What have you tried already? Setting RAM to 6GB and CPU to 6 cores 3,4 GhZ
    10. Have you tried any of the things below? Everything, but running vanilla server

    - AuthDB
    - Essentials (Chat, GroupBridge, GroupManager, Protect, Spawn)
    - MyEvents

    I really doupt that these plugins would affect my server sooo much, that it would lagg so hard!

  2. Offline


  3. Offline


    2GB of ram really isn't that much tbh so I don't know if I would be calling out a memory leak
  4. You are trying to run two servers on the same port. Kill all the servers you have running via task manager.
  5. Offline


    That's not the point, they wanted the server log, but this is way after my issue appeard for the first time.. this log won't help you, it's just there becouse TnT asked me to put it in :p Please focus on random lagg and server crash...


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 26, 2016
  6. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı

    MirkoKrizan we need a full log, from a server that actually starts up not one that fails ;)
  7. Offline


    Since I've got the server to start, there's no server.log file when i stop the server... I've searched the forums, and there seem's to be a chunk corruption problem with this build. Can this be fixed manualy, or do we must wait for a new build?

    Anyone knows something about chunk corruption? Where is the next build comming!?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 26, 2016
  8. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı

    There is no issue with 1.2.5-R4.0 involving chunk corruption.

    Please provide a log. If your server.log inexplicably disappears after shutdown, grab it while it's running.
Thread Status:
Not open for further replies.

Share This Page