Web Blue Stats - The most advanced statistics web interface

Discussion in 'Bukkit Tools' started by robinp7720, Jan 7, 2015.

?

What should I add/change next?

Poll closed Jan 14, 2015.
  1. Charts

    0 vote(s)
    0.0%
  2. Change the layout

    0 vote(s)
    0.0%
  3. Change the colors

    50.0%
  4. Change the colors and layout

    0 vote(s)
    0.0%
  5. Online/Offline indicators

    0 vote(s)
    0.0%
  6. Player faces

    50.0%
  7. Admin Page

    0 vote(s)
    0.0%
  1. BlueStats does "just work". It's not BlueStats's or my fault if the user to incapable or unable to install the required dependencies that the installer makes you aware of. I would love to make it so everyone is able to run this, but I'm not able to supply or create a htaccess file or custom builds of BlueStats just because the user is unable to do it themselves.

    The errors I ignore are errors which are solved by things that the installer makes you aware of. This includes missing dependencies and wrong file permissions. I also ignore problems related to missing files when the user failed to download/unzip all the necessary files.

    BlueStats works on a base install of php and apache with only the required modules installed. It even works out of the box with php 7.

    Lastly, I have no will power to help a user who hasn't tried beforehand. I am not obligated or required to solve everyone's issue and I don't intend to do so either. I am also a student and am lacking the time to even help some people who have tried themselves.

    I make this because I enjoy doing so. I use it myself for my own small server and am only releasing it as I feel other people might befit from it. If you feel that you do not benefit from this, then simply don't use it. I believe fluidmcstats will deliver a much easier to use installation experience.
     
    Last edited: Jun 6, 2016
  2. Offline

    Craft-rp

  3. Offline

    JohnNine

    I've also had several problems getting BlueStats running. And even now I have several pieces that are broken or not working right.

    Firstly as far as I can tell Lolmewn Stats3 doesn't have an official release package. The http://dev.bukkit.org/bukkit-plugins/lolmewnstats/ page links to Stats2 not 3. The https://www.spigotmc.org/resources/stats.3638/history link for 3.1.0-RC package didn't work on my CraftBukkit 1.10.2 server, said version incompatible or something like that. The recommend reading link for "The Stat of Stats" at dev.bukkit.org is broken, so here is a working link http://blog.lolmewn.nl/index.php/the-state-of-stats-achievements-and-highscores/. Here I found Lolmewn's Jenkins build system and found what I think is the latest version. http://ci.lolmewn.nl/job/Stats/ This package loaded in the server and allowed me to configure the database for storage.

    So after all this I finally start getting data that BlueStats should be using. Unfortunately all I was getting was a error 500. I don't know if I started with the proper package, but I used the current master.zip from github. Apache didn't log any errors so I had nothing to do from there. Eventually after verifying and reconfiguring PHP7 on my server to verify error reporting was on. I found that there is a setting in the index.php for "Debug". After running the install and configuring the admin panel settings, I got nothing from the main page. After enabling debug, I found that this was related to query, a MC server setting, nothing to do with BlueStats at all. Reconfigure the server, still receive the error. Find somewhere unrelated that my problem is with NAT reflection. I pointed BlueStats to my public IP address. I needed to use 127.0.0.1 for query and database. Maybe a default/suggested setting of localhost would have been a wise move here.

    So now that I have the basics working I still have issues. The TopPlayers section says Nobody for all 4 stats. The player pages come up with "Notice: Undefined index: value in /var/www/html/bluestats/classes/player.class.php on line 56" haven't looked into that yet. As I type this I think I understand two of my other errors "Plugin not Found: query" and "Plugin not Found: nameHistory". I removed those from the admin panel setting for plugins while trying to reduce the errors. The gave some other php warning message and didn't have any useful information. Maybe the nameHistory error was related to the fact that my server is Offline without authentication. But I can't find any links to documentation about the plugins to justify this.

    The Player page BlockStats section iirc, seemed to be a paginated version of the Lolmewn Stats section. But right now is giving me an error saying "Warning: Invalid argument supplied for foreach() in /var/www/html/bluestats/plugins/lolmewnStats/modules/playerBlocks.php on line 11" No data in table.


    I'd love some input and help with this issues, but I'll figure it out on my own. The point of my post is mostly to say that is BlueStats 3 is not as simple and easy to install. The documentation is not that great. There are many pieces involved that are not listed.
     
  4. I have tested the installation proccess many times. To install BlueStats one does not have to touch any source files. The only thing you must change are config options in the admin panel.

    The errors you have shown me most likely occur due to an incorrect configuration. This is because the errors show that the tables which were expected could not be found.
     
  5. Offline

    TheSander562

    Fatal error: Uncaught Error: Call to undefined function posix_getpwuid() in C:\xampp\htdocs\pages\stats\install\views\step1.php:2 Stack trace: #0 C:\xampp\htdocs\pages\stats\install\index.php(114): include() #1 {main} thrown inC:\xampp\htdocs\pages\stats\install\views\step1.php on line 2

    Can someone help me?
     
  6. Offline

    Fleynaro

    check the PHP version. probably, that is old
     
  7. Like I said, windows will not be supported
     
  8. Offline

    ElliotPoots

    Hi, i'm very new to the Bukkit forums so I don't really know where I post errors.
    However; I keep getting this error. I don't know what's causing it, so I came here in hope to get some help :)

    All folders within the stats directory and stats both have 777 permissions.
    Error: https://gyazo.com/7826b262d9e55f412de2dba1bd6b174e

    Thanks a bunch :D
     
  9. Offline

    coldice4

    Hi, I just wanted to install this, but I don't know what you mean with Query IP and Query Port. What do I have to enter there?
     
  10. It's the ip and port of your minecraft server
     
  11. Offline

    gerardvanschip

    Hey guys, got a weird one. When I run the phpinfo.php script in the install folder it claims mysqlnd is installed but when I run the install it says its missing. Been talking to my hosting guys and they say there is nothing more they can do as the phpinfo clearly shows its installed and available.
     
  12. Offline

    blackops1711

  13. As stated in the original post, windows will not be supported. I believe there is a fork on github which removes some of the security checks to achieve windows support.
     
  14. Offline

    yamanipanuchi

    I love this presentation of stats from this site. It was easy to get going (Other then my screw ups). I am running into an issue that I cant seem to find out why its not working. The four top stats show no users and the block stats are blank. I cant find any error's in Apache or PHP. Not sure if there's something obvious I am over looking (Config setting or something). All other stats come up fine.

    http://yamen.amcrestddns.com

    Edit: So it seems the Highscore plugin is the culprit here. Its not loading. It seems it only works on older versions. Any known working plugin out there?
     
    Last edited: Dec 9, 2016
  15. Ah. I figured it out. Seams I didn't completely remove the need for mysqlnd. Just install mysqlnd using your system's package manager and it should work.
     
  16. Offline

    yamanipanuchi


    Hmmm, I fairly certain I have that installed. I can see Highscores plugin not loading correctly in the log files. I assumed that was the issue.

    But then looking before I post this It seems Me running PHP7 created an issue with that module and Ubuntu.
     
  17. PHP 7 is most certainly not the issue here. I use PHP 7 myself on my production environment. Could you share the errors you're receiving from the high scores page?
     
  18. Offline

    yamanipanuchi

    Im actually not getting an error on the website it self, Everything in the highscores area simply has zero's as if there's no information there at all.

    The highscores plugin gives an error when the server starts up.
     
  19. I believe you are confused about the difference between spigot plugins and BlueStats plugins. What you most likely are referring to is Lolmewns highscore plugin. BlueStats does not make use of that plugin. Your highscores page on the site however is not working. Please give me the five most recent entries in your error.log . This can most likely be found in /var/apache/error.log
     
  20. Offline

    yamanipanuchi

    You are correct, I am confused and I did suspect that I had it wrong but....

    I didn't think it was something in Apache due to the very few error's im getting. This below is literally everything in my error.log file.

    [Sun Dec 18 06:25:08.978573 2016] [mpm_prefork:notice] [pid 1128] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
    [Sun Dec 18 06:25:08.978616 2016] [core:notice] [pid 1128] AH00094: Command line: '/usr/sbin/apache2'
    [Sun Dec 18 20:30:26.111327 2016] [:error] [pid 6647] [client 189.100.63.223:49283] script '/var/www/html/command.php' not found or unable to stat
    [Sun Dec 18 20:30:27.054653 2016] [core:error] [pid 6652] [client 189.100.63.223:49291] AH00126: Invalid URI in request GET /../../../../../../../mnt/mtd/qt HTTP/1.0

    Possibly that 3rd line there?
     
  21. Offline

    Varo95

  22. Ok. I found the problem. It was not a problem with BlueStats with with the mysql mode. I ran into this issue myself when I updated mysql. It's caused the the mysql mode "only-full-group-by". As I am not a mysql expert I'm having trouble supporting this mode but one solution is to disable it. Solutions can be found here: http://stackoverflow.com/questions/23921117/disable-only-full-group-by

    Not a problem with BlueStats. Ask your host to allow you read and write to sockets

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Dec 21, 2016
  23. Offline

    Varo95

    Thanks for the info :). I will ask my host service.
     
  24. Offline

    yamanipanuchi

    Yup, That did the trick! Working 100% now
     
    Last edited by a moderator: Dec 27, 2016
  25. Offline

    yamanipanuchi

    Is there a way to filter out accounts that have not logged in after a specific amount of time? I dont have a lot of accounts but there are some that are well past 3 months and I wish for them to not show on any of the lists.
     
  26. Adding a feature like this would slow down the web interface considerably due to the layout of LolmewnStat's database.
     
  27. Offline

    Ajintaro

    Dear all,

    I really love the capabilities of blue stats, although I have the same problem as others concerning the 404 error for all the links. According to this thread, the solution is to mess around with a .htaccess file by adding Rewritebase /blue/. However, on a Windows Server 2012 with IIS 7.5 it does not seem to work.

    Do you have any ideas how to fix the 404 link problem on a windows machine?

    Kind regards,

    Ajin
     

Share This Page