API Versions

Discussion in 'Plugin Development' started by davidclue, Aug 29, 2021.

  1. Offline

    davidclue

    Alright, so I have a plugin that I made on 1.17 and specified the api-version to 1.17, if I use the same plugin on 1.12 it works because I made it universal but when I try it on 1.16 it throws me an unsupported API-version 1.17. So how can I go about making my plugin load on all versions without specifying an API version because if I don't then I can't use any content from 1.13-1.17. Horrible idea they had to implement this feature in 1.13.
     
  2. Offline

    timtower Administrator Administrator Moderator

    @davidclue That is because Mojang changed the ID's
    Set the api version to 1.13 and call it a day.
     
  3. Offline

    davidclue

    @timtower But I can't do that because now I can't reference any new content from 1.14-1.17 inside of a 1.17 server. This shouldn't be an issue but it is why did Mojang just decide to make plugins version incompatible?
     
  4. Offline

    timtower Administrator Administrator Moderator

    @davidclue Mojang changed item id's, not plugins.
    And then you need to make versions for each mc version.
     

Share This Page