[ADMN/WEB] OKB3 - Bulletin Board Bridge - Now on BukkitDev! [1337]

Discussion in 'Inactive/Unsupported Plugins' started by Kalman Olah, Jun 2, 2011.

  1. Offline

    Kalman Olah

  2. Offline

    Kalman Olah

    I should be thanking you! I would never have found that issue without your help, as I was only testing on test servers & forum setups with only myself registered :p.
  3. Offline


    I've a new bug yet. Synchronization is accepted only for some members. For me, it works fine, for one of my user, the identification isn't working. I'm sure of the password because I've reseted it to 123456 in the XenFor admin panel.

    Edit: I've tried later, and then it has worked for some users. For others, it is still not working. The passgen.php is working fine.
  4. Offline

    Kalman Olah

    Usernames and passwords are case sensitive.
  5. Offline


    Yes, I know.
  6. Offline

    Kalman Olah

    Updated to v0.3.11
    • Changed the RegEx function that I use to fetch salt values from a serialized array for XenForo forums. Thanks to @NeatMonster for helping me test my plugin fixes on his amazing server at http://craftisland.no-ip.org.
  7. Offline


    Thanks :D! You've forgotten to edit the tittle of the topic.
  8. Offline

    Kalman Olah

    No I didn't :eek:. How dare you!
  9. Offline


  10. Offline


    This does support SMF 2.0 RC3 right?
  11. Offline

    Kalman Olah

    It does. Old-school mode supports most, if not all forums. Normal mode has a specific settings for SMF. Read the setup guide for specifics :).
  12. Offline


    Please seriously consider adding blacklist support for normal mode.
  13. Offline

    Kalman Olah

    This would be pretty useless though. Think about it.
    In old-school mode a whitelist works because a user's forum rank is checked on the very first login.
    In normal mode a user's rank is only checked on login if they've used /bbb sync before.
    This means that, to be blacklisted or whitelisted, they'd have to join FIRST, then do /bbb sync, THEN relog...
    And since they would need to join the server to be whitelisted/blacklisted, it wouldn't exactly be a whitelist or blacklist, now would it?

    EDIT: Just thought I'd mention some stuff.
    A - You can use the plugin AntiBuild, make the Default GroupManager group a group that can't build. And make the standard forum member's rank sync to another GroupManager group, but one that CAN build. This way you can effectively limit building on your server to people who register on your forum & use /bbb sync.

    B - I may add blacklisting to normal mode, but not completely. I may allow you to add groups that should be kicked on login if the ranks can be checked, so you can blacklist players that get banned or something(after they've already played on your server). If I add this though, it'll have to wait until I'm done moving.
  14. Offline


    You should add support for permissions 2.7.4 even though it is discontinued alot of people use it.
  15. Offline


    Your edit B is exactly my purpose. I have it to where you have to be synced to the forum in order to build. I want my server moderators to be able to do their job from the forum.
  16. Offline


    Unless you get support for Kunena(Joomla) forums up in the next update, I'm having trouble with old-school mode.

    Server-side console says...
    Show Spoiler

    07:55:20 [INFO] [OKB3] PlayerList file successfully loaded.
    07:55:20 [INFO] [OKB3-MYSQL] Initializing MySQL connection...
    07:55:20 [SEVERE] [OKB3-MYSQL] SQLException! Packet for query is too large (4739923 > 1048576). You can change this value on the server by setting the max_allowed_packet' variable.
    07:55:20 [INFO] [OKB3-MYSQL] MySQL connection successful.
    07:55:20 [INFO] [OKB3] OKB3 enabled successfully.
    07:55:20 [INFO] [MultiVerse] Permissions Found
    07:55:20 [INFO] [MultiVerse] - Version 1.7.2 Enabled
    07:55:20 [INFO] [MultiVerse] Loading World & Settings - 'world' - NORMAL
    07:55:21 [INFO] [MultiVerse] Loading World & Settings - 'portals' - NORMAL
    07:55:21 [INFO] [MultiVerse] Loading World & Settings - 'portals_nether' - NETHER
    07:55:21 [INFO] [MultiVerse] 3 - World(s) loaded.
    07:55:21 [INFO] [MultiVerse] Loading Portals
    07:55:21 [INFO] [MultiVerse] 1 - Portal(s) loaded.
    07:55:21 [INFO] [BananaChunk] version 4.6 is enabled!
    07:55:21 [INFO] Done (0.466s)! For help, type "help" or "?"
    07:57:33 [INFO] NitrosDragon [/XXX.XXX.XXX.XXX:52905] logged in with entity id 206 at ([ world] 2.8646799732259516, 57.0, -41.78184217350583)
    07:57:33 [SEVERE] [OKB3-MYSQL] SQLException! Packet for query is too large (4739923 > 1048576). You can change this value on the server by setting the max_allowed_packet' variable.
    07:57:33 [SEVERE] Could not pass event PLAYER_JOIN to OKB3
            at com.alta189.sqlLibrary.MySQL.DatabaseHandler.sqlQuery(DatabaseHandler.java:75)
            at com.alta189.sqlLibrary.MySQL.mysqlCore.sqlQuery(mysqlCore.java:52)
            at net.genericgaming.kalmanolah.okb3.OKPlayerListener.onPlayerJoin(OKPlayerListener.java:180)
            at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:243)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
            at net.minecraft.server.ServerConfigurationManager.c(ServerConfigurationManager.java:126)
            at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:96)
            at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:33)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    07:57:49 [SEVERE] [OKB3-MYSQL] SQLException! Packet for query is too large (4739923 > 1048576). You can change this value on the server by setting the max_allowed_packet' variable.
    07:57:49 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'bbb' in plugin OKB3 v0.3.10
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:128)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:287)
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:712)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:678)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:671)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NullPointerException
            at com.alta189.sqlLibrary.MySQL.DatabaseHandler.sqlQuery(DatabaseHandler.java:75)
            at com.alta189.sqlLibrary.MySQL.mysqlCore.sqlQuery(mysqlCore.java:52)
            at net.genericgaming.kalmanolah.okb3.OKCmd.onCommand(OKCmd.java:225)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
            ... 12 more

    I've increased my max_allowed_packet=50M, and phpmysql confirms such in it's list of variables, but I still get the SQLException! Perhaps I've done so incorrectly?

    And, just in-case, I'm running bukkit 860 on Ubuntu.
    Need any more information? Is anyone still alive? I really love the cause and I'd hate to have to find a different plugin or try different forum software.
  17. Offline

    Kalman Olah

    I'm very much alive. As mentioned above, I was moving. All of my rooms are literally still full of boxes. I'll take a look at your issue soon.

    (I'm waiting for my ISP to move my internet connection. The guy who lived here before me only had 7 Megabit/s DL and 0.5 Megabit/sec UL...)
  18. Offline


    Thanks for the reply! Saw that you were moving in some previous posts, didn't realize how recent it really was. I look forward to hearing your thoughts on my problem. :)
  19. Offline

    Kalman Olah

    This part in your server log:
    It appearing on startup points towards an issue with the configuration of your MySQL server. It would only be an issue with my plugin if it gave you a "could not connect to "blergh" using "root"@"localhost" using password: yes/no" or something like that. The fact that you don't get this error means that the plugin DOES connect to your server. You also receive the error before the plugin has finished loading, which means you're getting an error before my plugin is actually trying to perform a mysql query. So there's two possibilities here. Either you haven't filled out the name of your MySQL database correctly in the config.yml(I highly doubt this is the case, since I'm pretty sure there's a specific error message for this, along the lines of "could not select database xxxxxx"), or there's an issue with the configuration of your MySQL server.

    Tonight I'll test the plugin in old-school-mode myself and google the max_allowed_packet thing and try to find you a solution :p. If you don't mind, please PM me your config.yml, and mention specifics such as the Distro/Distro version you're running, your JRE version, MySQL server version, etc...

    EDIT: Make that tomorrow morning... I forgot I actually have to unpack stuff.

    Permissions 2.7.x has no ways to set a player's group. It is literally impossible for me to add support for it. Permissions 3 does though, I'm told, hence why Permissions 3 support WILL be added.

    Alright, I'll use my CTRL+C and CTRL+V powers to add blacklist support to normal mode for you. Consider it added to my to-do list(at the top). I was just kidding about the CTRL+C and CTR+V. This'll actually take me multiple hours to add, since I'm amazing at creating twenty bugs when I fix one.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  20. Offline


    Any news on when Permission 3 support will be added ?
  21. Offline


    Hello. I've been trying to configure this with my server and myBB forum for quite some time today so i'm finally going to explain my situation...

    Everything is configured at I have checked my mysql connection info (connecting to external mysql ip which is correct)/matching link/and changed the type of forum to mybb...
    Yet in game I use the command /bbb sync myusername mypass and it returns the error "An internal error occurred while attempting to perform this command"... Any suggestions?
  22. Offline


    Post up your config.yml and the server console when the error occurs, please.
  23. Offline


    Heres my config.yml censoring out my stuff I think I got all of it... Those match the other files as said to do int he instructions

    I just tried doing something from another quote by typing in the blanks in the http:// location for passgen idk how to explain it, but it returned

    Edit: I'll try to get my server log right now as well
    EDIT2: The log file is huge, taking forever to copy from my servers ftp.. Will probably take just as long to open >_>
  24. Offline


    Unless you already edited this part out, it needs to be filled in.
    usertable: user_table
    username-field: username_field
    userpassword-field: user_pass_field
    rank-field: rank_field
    I'd also double check that the minecraft server has permissions (and correct credentials) to access the passgen.php .
  25. Offline


    Oh. I did not filter that out just didn't know it was supposed to be filled in :X I will set that up and see if it fixes it and after check my permissions and see if that is also a problem. Thanks
  26. Offline

    Kalman Olah


    You have to edit this to match your own myBB forum.
    user_table, username_field etc... are all placeholders.

    In a few days.
  27. Offline


    Ah okay everything is starting to make sense now, but same problem haha.. Maybe the permissions thing is causing the problem. I just fixed/edited my config.yml so here it is again
    Guessing its the permissions. I'm pretty sure ive got the table thing right not sure about the fields. My prefix for my tables is mybb_ everything else is default for mybb if you know what that is. I connected to mysql database and what i put there is what the name of the field etc. was.

    EDIT: Btw I did restart my server after setting this config.. Then try it.. Incase you're wondering >_>

    EDIT 2: I am once again confused to why it is not working, yet both of you are offline now D:.... I edited the permissions of passgen.php and tested it out giving public all permissions and the error changed to

    Wish I could get this cool plugin working, but in game I am still getting the same error no matter what I change. Personally I think it's something in my config.yml not my permissions but idk. I was wondering by in that area where I was told to put the fields in.. for the table do I need to put the "prefix" as in mysql_ ... because i've tried it with and without mysql_users and just users... And i'm not really sure but am guessing I need to have it as mysql_users

    EDIT 3:
    Just read the error_log file... Which says

    .. i looked on line 60 of passgen and its something about salt.. which is some sort of password encryption thing i think... therefore i have no idea how to fix any of my problems now. Still returning internal error in the server and that link returns "Internal Error" as well.. So I guess it all comes down to line 60 of passgen
  28. Offline

    Kalman Olah

    Show me your config.inc.php.(Remember to remove your MySQL password before you show it to me...)


    Updated to v0.3.12
    • Added support for Kunena to normal mode.
    I will now get to work on the other issues people are having with my plugin.


    Updated to v0.3.13
    • Added use-as-blacklist option to the whitelist to allow you to blacklist/whitelist forum ranks that aren't mentioned in the config.yml.
    • Added blacklist/whitelist support to normal mode.
    • Various bugfixes.

    Next up is Permissions 3 support, which I'll do tomorrow since I've got to help NitrosDragon out with his issues. I also want to call my ISP and yell at them a bit.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  29. Offline


    Heres my config.inc.php
    I am aware that mysql user/pass is CaSe SeNsItIvE
    EDIT: Going to work soon, may not be able to reply for about 8 and a half hours... Unless I do so at work which I might be able to :confused:
  30. Offline

    Kalman Olah

    I just tried my plugin with myBB. It worked just fine. I'd check if your user actually owns the passgen.php file. A quick chown should do it. You can also try setting the $dbhost to lowercase, as in $dbhost = 'sql09.freemysql.net'. Some webhosts also name their mysql databases in the <user>_<dbname> format, as in 'myuser_rubikscraft'... So yeah, check all of these things, let me know if anything changes.
  31. Offline


    Well I used Navicat to check my login information and was able to login fine typing it in all caps for the ip and my pass lowercase and user lowercase. Then my database was just called rubikscraft.

    I would change my ip to lowercase and try right now but I have to leave D:... I'll let you know it about 9 hours if anything has changed. I'll probably end up PM'ing you my actual configs with my users/pass :S

Share This Page