Inactive [ADMN/INFO] Permissions v2.1 - Continuing the legacy.

Discussion in 'Inactive/Unsupported Plugins' started by Nijikokun, Jan 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.1 (Handler)
    Download 2.1 (Jar Only)
    Older: 2.0, 1.9, 1.8, 1.7, 1.6, 1.5, 1.4, 1.3, 1.2, 1.1, 1.0

    Permissions... Done right.
    Permissions allows plugin-authors to utalize a permission system that handles group inheritance, globalized permission settings, and more. All the features of a fine-grained permission system in one plugin.​

    1. Groups
    2. Group Inheritance, Allows for groups to gain permissions from other groups.
    3. User Permission System
    4. Fine Grained Permission system.
      1. Allowing for Globalized permissions
    5. Easy to use, setup, and implement.
    6. Two cache layers, first from file to memory, then from memory to cache.
      1. Plugins can control cache since version 2.1
    7. And much more.
    For the users

    Permissions gives server admins great control, mostly in-game reloading. Simply use /pr and the file will be re-cached and never touched again until you need to reload it. This allows you to quickly give your users the commands that they need without having to restart the server.

    Installation for 2.0 down:
    1. Download the archive.
    2. Extract contents to the /plugins folder.
    3. Open up /plugins/Permissions/config.yml
      1. Read / modify.
      2. Save.
    4. Reload Server.

    • 2.1
      • Multiple-World support
      • New cache layer, and cache control support for plugins
      • Editing features for plugins to hook into
      • Exempt nodes
      • World copying
    • 2.0
      • Forgot.
    • 1.9
      • Fully fixes inheritance.
        • Groups now inherit groups of groups that inherit groups of...
      • Cache system implemented.
      • Plugin authors can now delegate a variable system if needed.
      • API Updated with two new functions to get the point of what they do across.
        • Along with the new variable checks.
    • 1.8
      • Fixes the broken globalized node issue.
        • node.* is called a `globalized node`
    Supporting Plugins

    I have hit the character limit for this post.​

    Thanks to:
    • sk89q for hiearchical and node system idea.
    • Creator of GroupUsers for api implementation.
    This author has stopped development of this plugin. It is no longer supported and I wouldn't ask for help here, as you won't get any. New Permissions
  2. Offline


    no spaces in between them, and yes.
  3. Offline


    Okay I fixed the WorldEdit commands. I forgot about the permissions in the WorldEdit config. Now I just need to figure out LWC.
  4. Offline


    group: Admins
    group: Moderators

    Like this? :)
  5. Offline


    you have a bunch of errors. First off. there is a broken line where cleaner.* and you have the single quote on the next line. No comments in-between permissions as per line 114 the previous is 112 and 113.

    Next the part you are erroring at is the non-existant group "mods" which you try and inherit at line 80 inside of the group admins.
  6. Offline


    Damn, have been waiting for a while now to have permissions work with Build 135 or higher. Without permissions, it cancels the ability to use a lot of other useful plugins.

    Thought 1.9 would have done it. Doesn't seem to have.
  7. Offline


    Works fine here, using #135.

    Permissions.jar and Permissions/ folder both are in the folder plugins, worked this way before.[/quote]

    Edit your post with a pastebin link containing your config.yml, thank you
  8. Works fine fore me as well. You've probably got a config problem if it's not working.
  9. Offline


  10. Offline


    Edit your post with a pastebin link containing your config.yml, thank you[/quote]

    Cheers for the help, if it's working for you, then i've definitely done something wrong...
  11. Offline


    Edit your post with a pastebin link containing your config.yml, thank you[/quote]

    Sry edited it and uploaded my config as .txt file.
    --- merged: Jan 24, 2011 6:26 PM ---
    Ahhh im confused of this forum ^^
    Sry im new here.
    Okay now with pastbin:

    like i said, jar and the folder are in the plugin folder, worked finde before the new 1.9.

  12. Offline


    Bunch of spacing issues, unnecessary inheritance, and capitols used. This one works ^ it's the difference to show you how its done.

    You had information in the wrong places, two things weren't single quoted:

    Also, another one is that moderator inheritance is not needed and ignored if the '*' is flagged:
  13. Offline


    Edit: Nevermind, just directly copied your correction (which included proper spacing), now working. Cheers!
  14. Offline


    Thx Plugin is starting again :)

    But the Prefix is not showed, why is that?
  15. Offline


    Any idea why none of the myhome commands work for the groups Default and Moderator? =)

    I have tried just printing the whole permission string like 'myhome.home.basic.home', and it works, but I don't want to mess up my config with writing lines upon lines of permissions when 1 line can do the trick.
  16. Offline


    Lets try agian with more info....haha problem /pr dont reload , people on essencials able to execute kick tp /i etc

    Permissions config

    File Structure
    minecraft/world edit
  17. Offline


    Look for iChat for prefix/suffix usage.

    You don't have any permissions related to mywarp in your configuration file. that's why.
  18. Offline


    @Nijikokun Did you see the converter application I wrote for yoooou? I thought it might help ppl migrate to your plugin =)

    Any chance of CraftBukkit using Permissions for /kick, /ban, /stop, /save, etc..?
  19. Offline


    If someone makes a mod for it, it would work. And yes I saw it :]
  20. Offline


  21. Offline


    I don't use MyWarp, I have only installed the MyHome plugin. And as it says on the MyHome plugin page:

    "For simple set-up, give your users 'myhome.home.*'
    and your moderators 'myhome.*' (includes myhome.admin and myhome.home.*)"
  22. Offline


    It seems like you have been having the same problem as me, did you ever fix it? If so if you could help me out, I would give you like anything.
  23. Offline


    Niijko How Do i Add Colours Im New To Permissions Btw You Great At Plugin's Love Yah <3 :D
  24. Offline


  25. Offline


    This is literally does nothing right for me. Permissions don't work, name colors don't either. I think it might have to do with me being on a CentOS 5 OS, I think its the same as linix, so any help would be appreciated!
  26. Offline


    Go to your plugin folder, then into Permissons folder and open the config.yml file and edit the Prefix (if you want the name to have another color) or the Suffix (if you want the text to be another color) of the group (perhaps users also, but i dont know) you wish to have another color.


    Prefix: '&2'
    Suffix: '&4'

    Check all color codes here.
  27. Offline


    And angain:

    Some basic help

    Soooo, so many questions about the same.... many users won't read the last pages, so read this please.
    I will link this post sometimes.

    Use: to check and correct your configs!
    If this page says error, you have to find the error by yourself!
    First, try to test the plugin with default settings/configs. Error-> Restart Server. Error -> look in the Forum, redownload and try again.
    If you have to edit the cfg that the plugin will start/cause no errors, then do this first, but with minimal settings.
    ..... Don't work? Check your inheritance and there can only be ONE default group!

    If you want to post your Error, post your Permissions Config, PluginConfig and Errorlog via Pastebin
    (With pastebin, you only post a link, no code-spamming the Forum, and it has the correct format)
    Post you Craftbukkit build number and your plugin version!

    Default users can build, help me:
    Look in the first post, you need AntiBuild

    Want to do this:
    Look in the first post, you need iChat
    I use:
    In the iChat config:
    message-format: '+prefix+name: +suffix+message'

    Prefix and Suffix in the permission config:
    prefix: '&1[&3Admin&1]&2'
    suffix: '&4'

    [Admin]Jobsti: My Chattexts
    In prefix, I can add Color for the prefix, the prefixtext and the nickname-color.
    In Suffix, I can edit the Chatcolor

    You have to add "message-format:...." to the iChat config by yourself, or you will get an error in the ServerConsole!

    If you have an error, that you get alltimes "no permission.... [see picture]", but command works?
    Check out all your plugins! (my waste producer was the mute plugin, first version.)

    You can reload the permissions with /pr to test your prefixex, BUT you have to restart the server, if you change the iChat config.

    Link this post please
  28. Offline


    sorry, but I am too lazy to read 39 pages of text xD
  29. Offline


    To change people into mods or admins, do I have to go to the config file and change it like:
            group: Owner
            - '*'
    then reload the plugin, or is there like a command for it.
  30. Offline


    Wait, error log? Plugins config? I have no idea where to find those, unless you mean Server Log and
  31. Offline


    I'm running CentOS also and I have this running fine. Try this:
    1. Download Permissions.jar and iChat.jar
    2. Put them in your plugins folder
    3. Once they run they'll create their own folders in the plugins folder with config.yml files
    4. Edit the Permissions/config.yml file with Notepad++ and follow the format in the OP
    5. If you have trouble verify your yml file is valid with: YML Parser
    6. If you still have trouble, post any errors you have by copying it from server.log and paste it into PasteBin
    7. Post the pastebin link here
    8. Have a nice day [​IMG]
Thread Status:
Not open for further replies.

Share This Page