[ADMN/GEN]AdminCmd 7.3.5-time, give, tp, repair,kill, warp,weather,afk,OpenInv [1.5.1]

Discussion in 'Archived: Plugin Releases' started by Dark_Balor, Apr 1, 2011.

  1. Offline

    Dark_Balor

    AdminCmd - Fork of PlgEssentials:
    [​IMG]
    [​IMG] Website : www.admincmd.com
    [​IMG] Wiki : http://wiki.admincmd.com
    [​IMG] BugTracker : http://bug.admincmd.com
    [​IMG] Downloads : HERE
    [​IMG] GitHub : http://github.com/Belphemur/AdminCmd
    Description

    AdminCMD is a powerful plug-in that brings you commands that can give you total management over your server. Featuring the most widely used commands in Bukkit server management such as: inventory management, banishment of bad players, limitation to teleporting, setting spawn and home way points, and much, much more! Blockface approved and rated as one of the best plug-in by server owners.
    Unleash the power of Bukkit!

    Features
    For the blog : www.admincmd.com
     
  2. Offline

    khamseen_air

    I'm not sure about AdminCmd having an option for it, but I know that if you're using MyHome you need to disable the ability for beds to set your home point to remove that message.
     
  3. Offline

    Sorken

    I am not using any other plugin that messes with homes or respawning.
     
  4. Offline

    khamseen_air

    Sorry, not sure how to disable it then. Perhaps someone else will be able to help out.
     
  5. Offline

    Crumbhead

    AdminCmd does not seem to deny flight. I can always fly. The server.properties has allow-flight=false and PEX permissions does not have admincmd permissions set. I tried setting both admincmd.player.fly.allowed and admincmd.player.fly to false but I still can fly. How can I stop flying?? If I remove the AdminCmd.jar from the plugins directory then I cannot fly but I don't want to remove AdminCmd.
     
  6. Offline

    Dark_Balor

    Sorken : strange we'll give a look

    Crumbhead : you just have the power Fly activated just do : /fly
    again to disable it.

    And of course AdminCmd is overpassing the fly restriction, it's not a bug, it's a feature.
    If you don't want the fly, just once /fly to disable it, then disable the command and restart your server.
     
  7. Offline

    Sorken

    Thanks, its nothing major so when you have time.
     
  8. Offline

    Crumbhead

    Thank you for helping me not lose my mind! So I set admincmd.player.fly=true in permissions so I can once /fly in game to disable it. Now I can't fly. I return to permissions and set admincmd.player.fly=false. Now the command is disabled, no flying.

    I'm trying to have players "rent" fly. The problem seems to be if I give them permissions to /fly then they will always be able to fly unless they run /fly to disable it. Am I understanding this correctly? Is there a way to "rent" fly command?
     
  9. Offline

    Dark_Balor

    Since you can give the fly power to everybody when you have the node : admincmd.player.fly and admincmd.player.fly.other

    You can give the fly to other player manually, you can also set a timeout for it (the time out doesn't stay after a reboot, meaning, if you set it, and restart the server, the user will keep the power).

    See the wiki for more information and commands
     
  10. Offline

    Crumbhead

    Dark_Balor admincmd.player.fly.other isn't documented on the wiki.

    I found a combination of plugins to offer rent /fly: SignShop, Pex (timeout permissions), and Flight.
     
  11. Offline

    Dark_Balor

    Oups ... forgot that ... added now.
    For the rent power, you have a lot of way to do it.

    Btw : WarpSign 1.1 out, new version with block place protection to avoid placing a block when clicking on the sign.
     
  12. Offline

    Quantas

    Hey! This plugin is awesome, i just have a problem with it: the plugin has worked for 2 months, without any problems. Then, one day it started to write at every login: "username has joined the server for the first time". It wrote "for the first time" for everybody, even for me, and definetly, an admin doesn't join it's server after 2 months of running time. I've started to check if anything have changed in the config file or something, but i couldn't find anything.

    So, what we're using:
    -CraftBukkit 1.2.5-R4.0
    -GriefLog
    -WorldEdit, WorldGuard
    -iConomy
    -Stargate
    -PermissionsEx
    -ChestShop
    -ButtonWarp
    -xAuth
    -Vault

    If you can help me with this "...for the first time" bug, my life would be so much easier.

    Thanks: Quantas
     
  13. Offline

    Sorken

    Dark_Balor
    Since upgrading to version 6.1-SNAPSHOT (BUILD 13.07.2012 @ 16:12:13) the death messages have become a little weird, theres a missing space after the name and has died message. And its the same message no matter how the player died.
     
  14. Offline

    Dark_Balor

    Quantas : that's a serious problem ... because it can only happen if AdminCmd can't access or read the data from the player ...
    Can you still access your homes ?

    Sorken : I'll give a look, but since it's Lathanael that has coded it, will take some time to see what's wrong.

    Edit : Okay found his little mistake, will be corrected for the next dev version.
     
  15. Offline

    Sorken

  16. Offline

    Dark_Balor

    You'll have to wait because I'm also working on a sqlite and mysql features.
     
  17. Offline

    Sorken

    Dark_Balor
    Its no rush, i was also wondering about /mob cat or /mob ocelot, neither seems to work. For spawning a tame cat vs wild one. Is there some other name i should be using?

    Edit: Hmm, it would seem you could also use /mob Cat:user to spawn a tame cat, tame to someone else (not you).
     
  18. Offline

    szabilcs14

    Dark_Balor
    I want to ask whether there admincmd/locale Hungarian language file?
    if there is can you give any download link?
    but if you build it does not exist?
    and yet I want to ask whether the accented letters used admincmd?

    If you can understand it more difficult sorry but google translator: S
     
  19. Offline

    craftovski

    Everything is working perfectly fine except /search command that searches every player who connected with that ip.
    When i try to do that command it searches for items and its ID's.

    If anyone knows a solution or if im doing something wrong pls help.

    Ty
     
  20. Offline

    Dark_Balor

    Sorry there isn't any Hungarian translation for the plugin, I don't had any translator for that.
    (By the way, I'm still looking for translators in EVERY language for the plugin).
    I'm sure you have an other plugin installed that have a search command and have taken over AdminCmd search command.
    You have 2 choices :
    1. Search and disable the plugin in question (most annoying choice)
    2. Put the search command as prioritized in the commands.yml file in the AdminCmd directory (faster and easier method)
    Sorken : You can't spawn tamed animal with AdminCmd, since the semi-colon is used to spawn ... rided animal (like skeleton on spider etc ...)
     
  21. Offline

    craftovski

    Ty for replying!
    That worked, now when i use /search command i see its going with AdminCmd plugin, But i dont know why
    all i get is blank respond in chat like there is nothing on that ip but i just checked IP of 1 player and typed exactly the same ip in. Maybe i did it wrong, here is what i typed: /search -i 11.11.1.11
    (IP 11.11.1.11 is example only)
    So if u know why it happened pls help

    Ty again.
     
  22. Offline

    Sorken


    You cant spawn wild cats either though, and that should be doable atleast.
     
  23. Offline

    Dark_Balor

    Strange ... Don't forget that it's the name of the Bukkit Entity that need to be used ... I'll check over.

    mmmh I'll look the command.
    Lathanael : can you check that when you have the time ? thanks :)
     
  24. Offline

    diamaunt

    Dark_Balor... I'm hoping you can help. I'm using the latest admincmd on the latest tekkit server, and all the commands are defaulting to "on" for everybody, I'm also using bukkit permissions, and I've set admincmd.*: false for the default group, then for the users group, I had turned on the commands I wanted them to have, this worked with an older version of admincmd. but now, I'm not getting any overrides... ie, if I have all set to false for default, then admincmd.player.fly: true, the player can't fly, and it says "you don't have permission" and shows admincmd.player.fly.

    help? suggestions? anything, please.
     
  25. Offline

    craftovski

    @Dark_Balor,
    Did u maybe found a time to take a look into that search command?
    Not rushing it or anything just wondering, cause it would be useful to know how many accounts have been accessed with same ip. Thx !

    Dark_Balor
    1 more thing i just found now, that is incompatibility with Citizens plugin. I started the server without Citizens and AdminCmd plugin works flawless, then i put Citizens in, start the server and in console i saw this http://pastebin.com/53YCdzvp .
    I removed Citizen to check what happened and error was still there, then i used 1 of the backups where i didnt Mix AdminCmd with citizens and did it happened again, after Citizen is mixed with AdminCmd there is that error and after Citizens is removed Error is still there, so Citizens damaged something or Confused AdminCmd.

    I hope i explained it so u can understand, if i find anything else on this matter ill let you know.

    Ty

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 17, 2016
  26. Offline

    Dark_Balor

    About the search command I didn't had the time.

    For your other error that's not a real problem, won't disable anything, you can do with it :)
    If you want to get rid of it download the dev version ;)

    It's surely a problem with your permission plugin, if you get the : you don't have the perm ...
    Or you have an another plugin that having that command also, then put the fly command as prioritized.
     
  27. Offline

    diamaunt

    with respect, I'm using bukkit permissions plugin, it's working normally for example, I have permissions.*: false for default users, but for regular users, I have permissions.build: true, and that works. but all admincmd commands, (fly was just an example) do not work that way, if I put admincmd.* in the default group, and put any other permissions in for regular users. it still doesn't work.

    Code:
    groups:
      default:
        permissions:
          permissions.*: false
          admincmd.*: false
      admin:
        permissions:
          permissions.*: true
          admincmd.*: true
      user:
        permissions:
          admincmd.player.list: true
          admincmd.player.msg: true
          admincmd.player.fly: true
          admincmd.spawn.tp: true
          admincmd.time.*: true
          admincmd.tp.home: true
          admincmd.tp.location: true
          admincmd.tp.to: true
          admincmd.warp.tp: true
          admincmd.weather.clear: true
          admincmd.server.motd: true
          admincmd.server.news: true
          admincmd.server.repeat: true
          admincmd.tp.toggle: true
          cabinet.abovechest: true
          cabinet.adjchest: true
          cabinet.covered: true
          permissions.build: true
        inheritance:
        - default
    
    the users in 'user' group can't use any of the admincmd commands that are listed as 'true' above. however, people in the admin group can.
     
  28. Offline

    Dark_Balor

    you shouldn't put admincmd.* : false in the default group.
    Because you use Inheritance, it seems that that false node have more power than the one you gave in the group.
    By default, only OP can use AdminCmd commands, just delete the line admincmd.* : false in the default group and everything should be working correctly.
     
  29. Offline

    khamseen_air

    I love how you say that as though that means it can't be the permissions plugin at fault. I recently switched away from Permissions Bukkit because it's so bugged that half my plugins permissions nodes don't even work with it any more.
     
    Dark_Balor likes this.
  30. Offline

    diamaunt

    actually, after I figured out that the user I'd been testing with had been opped by someone.... it's all working great. hope your new perm thingy works good for you.

    I'm sorry to have bothered you... after your reminder that ops can use everything.... I realized that the user I was testing with had gotten opped, so the perms weren't being applied...

    apologies for bothering you, and please, keep up the good work!

    yes, I feel stupid now.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 17, 2016
  31. Offline

    Sorken

    Dark_Balor
    Mind putting out a dev version which fixes those deprecated events? Its making my log all messy.
     

Share This Page