Inactive [ADMN/CHAT/INFO/SEC/TP] ALERTER v1.5 - Protect Areas & Object + Alert + Multilanguage [1.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Patrick_pk91, Jul 6, 2011.

  1. Offline

    Patrick_pk91

    ALERTER
    [​IMG]
    [​IMG]
    Current Version: v1.5 (JAR/ZIP)
    if you have problem with warning before post try to download again XD
    [​IMG]
    Donate to support this plugin XD​

    [​IMG]
    [​IMG]

    other pictures (open)

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]


    Alerter is a multi protection plugin ,that you can configure to give a warning into server console and ops, when anyone place and/or destroy a block or when anyone use a command in chat, you can protect areas, object and more other features!!

    Features:
    • Give a warning in the console (you must edit the settings file) :
      • Place certain Blocks
      • Destroy certain Blocks
      • Any command a player types in chat ("/...")
    • Teleport to player
    • Protect Areas
    • Protect Chest, furnaces, doors (wood, iron, trapdoors, fence door), dispenser, lever
    • Block place of forbidden objects
    Download the lastest Plugin v1.40 (JAR/ZIP)


    Previous version v 1.32 (JAR/ZIP)

    Commands & features & Permissions & configure "Alerter.dat"
    see information here: http://www.consolepk.altervista.org/page.php?19

    Installation (open)

    Just copy the .JAR file into your plugins directory.
    At start the plugin create automatically "Alerter.dat" with default settings
    If you want to custumize the settings you most modify "Alerter.dat"

    see information here: http://www.consolepk.altervista.org/page.php?19



    Commands: http://www.consolepk.altervista.org/page.php?19#commands
    Protect Object: http://www.consolepk.altervista.org/page.php?19#object
    Sign: http://www.consolepk.altervista.org/page.php?19#sign
    Permissions node: http://www.consolepk.altervista.org/page.php?19#permissions
    settings Alerter.dat: http://www.consolepk.altervista.org/page.php?19#dat
    Change language: http://www.consolepk.altervista.org/page.php?19#language
    plugin support: http://www.consolepk.altervista.org/page.php?19#plugin


    DO YOU WANT TO TRANSLATE MY PLUGIN IN YOUR LANGUAGE???
    Contact me on forum or on skype (Patrick_pk91)

    WARNING: if you want to use protect lever open Alerter.dat and change Plessure_plate_for_areas_activate=true (set true)

    TO DO:
    Future version:
    For more info future version: http://www.consolepk.altervista.org/page.php?26
    • Spout support
    • Jail
    • inventory control
    • Rollback
    • user can decide to use sqlite (default) or mysql (optional)
    • alerting of when someone joins the server for the first time
    • Areas can set only by one person (super_Admin)
    • mob spawns separated from animal spawns
    Changelog (open)

    Version 1.5
    Relased: 3 November 2011
    • Update bukkit 1.0.1-R1
    Version 1.41
    Relased: 3 November 2011
    • fix bug entity damage
    • Update bukkit #1337
    Version 1.40
    Relased: 26 October 2011
    • Area poligonal support
    • can change/set area height ("/al height (Area) (number)")
    • Open inventory of other players ("/al inv (Player)")
    • Trasform blocks into an area to air ("/al air (Area)")
    • fix bug notification
    • Add new language support (Portuguese, Spanish, Czech)
    Version 1.35
    Relased: 3 October 2011
    • fix bug char '
    • BOSEconomy version 7 , iConomy (version 4,5,6 ), Essential, MultiCurrency support
    • add economy features
    • Multilanguage support (English, Italian, French, German)
    Version 1.34



    Relased: 23 September 2011
    • Sub-Area support
    • Limit size of news areas
    • prevent entry of unauthorized players in a private area
    • permissions plugins support (permissions, permissionsEX, bpermission) and default permission (superperms)
    • Rename existing area
    • teleport to an area
    • set warp of an area
    • protect fence door
    • Bug Fix can not destroy block near unprotected sign
    • Bug Fix PVP
    • Update Recommended Build: 1185 (MC: 1.8.1)
    Version 1.33



    Relased: 16 September 2011
      • minecarft support 1.8.1
      • remove permissions 3.0 support (in next version i will support most recent permissions plugin)
    Version 1.32



    Relased: 07 September 2011
      • bug fix multiworld
      • Add new sign [OWNER] to add exception area
    Version 1.31



    Relased: 05 September 2011
    • bug fix "Alerter.dat"
    • add gruop permissions area/object
    • implement [AREA]
    • area multi-world support
    • auto update
    Version 1.3



    Relased: 03 September 2011
    • protect chest, door , furnace, lever, trapdoor with sign
    • get information of area from block selected
    • log alerter into a txt
    • Use the online "Alerter.dat creation" procedure:http://www.consolepk.altervista.org/php/Alerter/index.php
    • health regen
    • block place protection
    • now yoo can automatically update Alerter plugin from chat command
    • bug fix lava-bucket and water-bucket
    • update SQLibrary Version 3.0.4 (alpha)
    • update Permissions Latest Stable (3.1.6)
    • update Bukkit Build: 1060 (MC: 1.7.3)
    Version 1.24



    Relased: 19 July 2011
    • Bug fix: missing entry "Search_upgrade=true" in file Alerter.dat
    Version 1.23



    Relased: 18 July 2011
    • Update Bukkit Build: 1000 (MC: 1.7.3)
    • Add search update
    Version 1.22



    Relased: 17 July 2011
    • Bug Fix:"permissions" (IT IS OPTIONAL NOW)
    Version 1.21



    Released: 16 July 2011
    • Add the possibility to change the selection tools (see Settings ''Alerter.dat'' file)
    Version 1.2



    Released: 15 July 2011
    • create and protect Areas like regios



    Bugs (open)

    ou find a bug or a problem?? post here :
    • Description of bug
    • Screen of bug (if possible)
    You can add me on skype: consolepk@gmail.com or patrick_pk91


    Thanks XD


    STAFF (open)

    • Translate:
      • Ghost or Tron ® (french version)
      • Spyboot & xmxfabian (german version)
      • Patrick_pk91 (italian version)
      • Minotaurus (Dutch version)
      • ygorpatrickbr, alissoncraft (Portuguese version)
      • XMaster1 (Spanish version)
      • Phoenyx (Czech version)
    do you want create a new plugin with me?? contact me (skype: Patrick_pk91)




    For more info: http://www.consolepk.altervista.org/page.php?19

    do you want create a new plugin with me?? contact me (skype: Patrick_pk91)
     
  2. Offline

    polux7

    do we have to create our own the Alerter.dat ?? or it is create automatically ??
    plz answer
     
  3. Offline

    Patrick_pk91

    At start the plugin create automatically "Alerter.dat" with default settings
    If you want to custumize the settings you most modify "Alerter.dat"
    For example you can custumize which blocks activate the warning ecc.
     
  4. Offline

    polux7

    yes thanks

    THIS PLUGIN IS PERFECT !!!!!!

    THANKS
     
  5. Offline

    Mike A

    One problem I am having.

    When players chop down trees it says something about player breaking unknown ID 0. So I have to disable it or I get spammed with wood chopping... It's not in the config, only lava and TNT is in it.
     
  6. Offline

    Patrick_pk91

    can you post a screen of the problem??
    so i can search the error XD
     
  7. Offline

    Mike A

    Do you have any instant messenger Patrick? It would be quicker.

    It happens when people place stone halfstep blocks.
    It spams around 10-20 messages every time a block is placed..


    [​IMG]

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  8. Offline

    Patrick_pk91

    are you use a flight plugin??? What is the plugin's name??
    Because i see the id block number 0 is the "air block"
    I try to fix, when i have fixed i will post, thanks for bug's report XD
     
  9. Offline

    Mike A

    The block ID is 0 because it cannot find the block name most likely "Stone Slab" or whatnot.
    I do not use a server side fly plugin, it's the zombe mod single player fly mod (client).
     
  10. Offline

    Patrick_pk91

    I've solved with the relase 1.11 or higher.
     
  11. Offline

    dragon72

    ok iam having trubel with this plugin but when i try to do the two points and crate it dont work mybe iam not doing the points right can you tell me
     
  12. Offline

    Patrick_pk91

    Solved see spoiler FAQ
    1) write "/al set"
    2) set the two point, the first with left click the second with right click
    3)write "/al create <Name_area> " example "/al create sample"
    so you have succefully create an area
    for protect you must write "/al protect <Area_name>" example "/al protect sample"

    if there are conflict with other plugin to use "Gold Axe" change the ID selection tools on the "alerter.dat" (Selection_tools=286 default is 286 = gold axe)
     
  13. Offline

    hofikaa

    I protect an area ,add owner but other players can distroy blocks. why? :S

    /al set
    /al create area
    /al protect area
    /al add area1 player 1

    but player2 can distroy blocks :S:S

    /al add area player1*

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  14. Offline

    Patrick_pk91


    have you selected different height points??
    to modify the area height use this commands:
    • /al expandup <Area_name> <Number>
      expand an Area upwards.
    • /al expanddown <Area_name> <Number>
      expand an Area downwards.
    • /al expandmax <Area_name>
      expand an Area from Bedrock to SkyLimit.
     
  15. Offline

    hofikaa

    yes i selected hight points up 15 down 2 :s
     
  16. Offline

    Naruto

    I have same problem as hofikaa. I protect my house, but my friend (no op) can destroy it. I do: /al set, /al create, /al protect, /al expandmax. And it doesnt work!
     
  17. Offline

    Patrick_pk91


    1 )Have you xfire, steam, skype.....ecc?? so you can give me the ip of your server, and i can see what's the problem XD

    2) I make soon a video on youtube with the instructions.
     
  18. Offline

    hofikaa

    my skype: hofikaa
     
  19. Offline

    Simror

    I have the exactly same problem. I have protected an area - from bedrock up yet still Non-Op's can destroy and place blocks in it. Everything else seems to work fine except this thing.

    EDIT: I think it's because as soon as you become the area owner, you become an exception - and if I try to remove myself from the exceptions it doesn't work. Any way to fix this?
     
  20. Offline

    GSNerf

    I have an error and this plugin doesn't work for me -.-
    I'm new to Bukkit and I just installed it. This is my first plugin but it's failing me so far...
    Please help me, I'm new and don't know anything about this.
    Ignore the 3 stamps and my mouse cursor :/
     

    Attached Files:

  21. Offline

    Patrick_pk91

    BUG FOUND: There is a bug that i will fix soon with new version (i think tonight or tomorrow), for now to use my plugin you must download the plugin "permissions" (http://forums.bukkit.org/threads/admn-dev-permissions-3-1-6-the-plugin-of-tomorrow-935.18430/) and put in your plugin's folder!!!

    Special thanks to: hofikaa :)


    I HAVE SOLVED BUG




    I HAVE FIX THE BUG WITH RELEASE 1.22 or higher
    Download new version XD

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  22. Offline

    ShadowWTF

    I am having a problem i have done all the correct commands but when i got to /al create and put the name it says the two points need to be selected when i already have selected them
     
  23. Offline

    Patrick_pk91

    do you have set the two point, the first with left click the second with right click??
    if you have the problem again have you xfire, steam, skype.....ecc?? so you can give me the ip of your server, and i can see what's the problem XD

    My skype is: patrick_pk91
    my xfire is : patrickpk91





     
  24. Offline

    Satak

    Same problem as ShadowWTF
    Even though when having replaced the golden axe with a golden hoe in the .dat file, it still doesn't work
    It seems it may be because of an error I get when starting the server (which occurs again when using the "/al r" command to reload the .dat file setting)
    Error.PNG
     
  25. Offline

    Patrick_pk91

    post the "Alerter.dat"
     
  26. Offline

    Satak

    Code:
    #Alerter version 1.23
    #Tue Jul 19 11:49:34 CEST 2011
    Alerter_Command=true
    Selection_tools=294
    Alerter_Breaking=true
    Log_Breaking=49,7
    Activate_Alerter=true
    Activate_Areas=true
    Alerter_Placing=true
    Log_Placing=51,46
    Prefix=[Alerter]\:
    File_version=1.23
    

    Oh haha lol, found the error
    Appareantly this line was missing:
    Search_upgrade=true

    With this line added, the error is gone and it works
    Since I let the mod create the alerter.dat file himself, i thought it would have everything in it...
    Thanks anyway :D And, nice job! :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  27. Offline

    Simror

    I have a problem.
    I have changed the prefix to:
    Code:
    Prefix=[LOCATION]\:
    And reloaded it, yet in game it still says [Alerter]

    Any way to fix this?
     
  28. Offline

    Patrick_pk91


    yes i have fixed with the version 1.24


    i have temporarily removed this function
    see changelog vesrion 1.2

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  29. Offline

    ShadowWTF

    yes

    Never Mind i added the other line and now it works great plugin thanks

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  30. Offline

    Patrick_pk91

    yes i have fixed this bug with the version 1.24 :)
     

Share This Page