Inactive [ADMIN] MC Server GUI .9.7 (cross-platform) - A GUI wrapper for your server (now w/in-game cmds)

Discussion in 'Bukkit Tools' started by dumptruckman, May 18, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    ledhead900

    Oh I like this
    :)


    oh yea I will give the new version a test but im personally waiting for the other stuff to come back before really runniing it thru its paces.
     
  2. Offline

    Lolmewn Retired Staff

    How nice! I just received Linux box, so this comes in really handy =D
     
  3. Offline

    dumptruckman

    No problem! Colors will be .5.0 and Player list will be .6.0.. I think those are the two main features missing. I'll try to throw this new custom command idea in one of those probably which will make up for the lack of Restart and Warn Stop buttons. :D

    Great! :)

    @ledhead900
    .5.0 is here and it's nice and colorful!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 16, 2016
  4. Offline

    ledhead900

    God yes thank you kindly now I will need to find time to test this out its kinda hard when ppl are on server to do these changes lol.
     
  5. Offline

    BigRenegade

    @dumptruckman

    Just downloaded 5.0 and fired it up. Beautiful, dude!! Running great under windows, will launch Linux and see how it looks there.

    Tested with Linux and it works great (other than the issue we have run into about window sizes with Unity).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 16, 2016
  6. Offline

    ledhead900

    Going to give this latest girl a buzz now dumptruck.

    Edit

    Server hangs on stopping server.
    Why does this version continually give me grief over and over if it's not one thing its something else and its responds so slow on windows.

    Windows version by far blows this just by the fact that it actually does what its told exactly when I tell it I had this one sitting on Stopping server being show for 3mins before I was forced to end the processes.

    Whats going on man the changes are good but not good to me if the application is not usable.
    Maybe you were better off doing changes to windows version to match this and increases performance from that version instead ? it appears it still works 100% and never skips a beat ever.

    Kinda disappointed as I had my hopes up for this one but again need to revert.


    Edit:

    Honestly am I doing something wrong is my Os missing something?
    since I can't even use the console chat in ver 5.0 like it appears its not interfacing with the server at all was I ment to leavet the terminal stuff in the custom run section as it was coz I removed that as it would not start with it at all.






    How man How it must just be me just as its just me that seems to fail even with nether from notch as well everytime I launch nether with or with plugins using notchs method it spits huge chunk errors during spawn loading and locks server up :(.

    WTH lol I used 818-843
     
  7. Offline

    dumptruckman

    @ledhead900 Yeah dude, I think it's just you. I use this version as it works perfectly for me. And yes, if you removed some of that stuff from the custom launch it could cause issues. How about you post your guiconfig.json file on www.pastebin.com.

    The terminal bit in the run line is completely required if you want this to work with a bukkit server.
     
  8. Offline

    dumptruckman

    Well, I've reached fork in my road and I'm not sure which path I should take. Obviously, I want to implement a player list in the GUI but I have to make a decision.

    I can implement it like I did in the Windows version, which was by way of parsing the server output and determining when players join/leave through that. The issue with doing it that way is that due plugins and such, the output varies and I can't predict all it's possible forms. Players connecting seemed pretty consistent, but players leaving sometimes just never even added output to the server. This resulted in having players not get removed from the GUI's player list when they left the server. I came up with a "solution" to that by forcing a player list command on the server and parsing the output of that. The issue there then becomes that the player list output also varies due to plugins. One specific instance is if you use nicknames... Players join and it shows their username but the player list shows their nick name thus creating discrepancies. Needless to say, it's hard to get a really nice player list using this method.

    The other method would be to have the GUI act like a Proxy server for your MC server. Basically, players would connect to the GUI and the GUI would forward all the network traffic to the MC server. This would allow me to read the data being sent to and fro and make a very accurate player list as well as open up a huge number of possible new features for the GUI such as custom behavior that could mimic what plugins are capable of (even if you're not running a bukkit server!) I would MUCH rather do it this way however it is a significantly more complex way of doing it and honestly I'm utterly at a loss of how to even accomplish this (but I know it's possible!)

    tl;dr I could make a sort of crappy player list fairly easily or with someone's help I could make a really good player list AND open the possibility for some exciting features.

    So, if anyone knows anything about creating an HTTP proxy server and wants to help me figure it out, i would appreciate it tremendously!

    In the mean time, I will instead work on other features besides the player list.
     
  9. Offline

    iCore

    Hi :)

    I have a problem , when i start the program , nothing appear.

    Can you help me ?

    Thanks
    Bye :)
     
  10. Offline

    dumptruckman

    Please post your guiconfig.json file on www.pastebin.com. I probably know why, but if you show me that I can confirm.

    Edit: Actually are you saying that the program simply doesn't start at all? In this case, what OS are you running and how are you launching the GUI?
     
  11. Offline

    iCore

    Where is guiconfig.json ?
    I don't understand :/

    The program is simply doesn't start , i can see brievly a cmd window but disappear after and that all :(

    My OS is Windows 7 Home x64 .
    For installing , i have unzip the contain of mcservergui.5.0.zip in my minecraft bukkit server folder and lauch the program with the bat : "guilauncher.bat"
     
  12. Offline

    dumptruckman

    Ahh, my guess is that you don't have Java set up correctly in your System Path. Open the guilauncher.bat with a text editor (like notepad) and change the word javaw to the FULL path for java on your system. If you use to start your Minecraft Server with a .bat file, you can look in there and copy what it is using for java. It is probably something like C:\Program Files (x86)\Java\jre6\bin\java.exe. Anyway, replace javaw in guilauncher.bat with the path to your java (or javaw) executable contained in quotes like "C:\Program Files (x86)\Java\jre6\bin\javaw.exe".

    After that, save the file and then try using it again to launch the GUI.

    Make sure you leave the other stuff besides "javaw" alone in the guilauncher.bat or it may not work right.
     
  13. Offline

    iCore

    This is ok ?
     
  14. Offline

    dumptruckman

    That may work, but you may need quotes around the path, like
    Code:
    @echo off
    echo You may close this window!
    "C:\Program Files (x86)\Java\jre6\bin\javaw.exe" -Djava.library.path=./nativelibs -jar mcservergui.jar
    But could work without..
     
  15. Offline

    ledhead900

    @dumptruckman

    All I did was remove
    -Djava.library.path=./nativelib

    as it failed to start with it for some oddly reason, I'll try get it going again.
     
  16. Offline

    dumptruckman

    And you have the nativelib folder in the same directory as the gui?
     
  17. Offline

    ledhead900

    yes I do :D I'm not a retard lol!
    To be fair I did not replace java with C:\blablabla\blabla like windows usually wants to launch java but that is only due it loading fine with out the stuff I mentioned.

    Like I said I have it here again now going to give it another go *Rollupsleves
     
  18. Offline

    dumptruckman

    Hard to say.. I'm sure it has something to do with Sigar, which is the library I used for the cpu/memory/network stuff.
     
  19. Offline

    ledhead900

    Here thing Cpu and memory and network stuff work 100% fine with or without that command line u said was important.

    The only thingnot working is inputing commands to server console and stopping the server yet it starts fine.
    but pressing stop it says Stopping..... but does nothing.

    Making me think that command line play's a part in how gui talks to the server it would explain why no schedual msgs are showing.

    give couple mins to play around with it some more.

    Edit:
    With schedualr I assume I set the leftside to 0 and right side to 23 for every 24hr to run correct ?
     
  20. Offline

    dumptruckman

    Can you post your guiconfig.json on www.pastebin.com?
     
  21. Offline

    ledhead900

  22. Offline

    dumptruckman

    Ok, as I thought, you are using bukkit, so you must include -Djline.terminal=jline.UnsupportedTerminal in your custom command line. That's what it adds when you click the "Bukkit" check box. The terminal i/o doesn't function correctly without that. Just put it somewhere after java and before -jar.

    And no, for a daily backup (at 12 am) just leave the timing exactly as it sets it default and click backup and set your warnings. That's it. The default setting is for every day at 12am. Setting hour to 0 and checking again every 23 means it will happen at 12am and again at 11 pm. After that i'm not quite sure how it would proceed, it would either do it again at 12am or perhaps the next would be at 10pm.
     
  23. Offline

    ledhead900

    well that does not make sense lol but ok.
    so 0 24 that seems like 24hrs to me but default works in that case my whole schedual set up is retartedly wrong.

    as I have restarts set for 5 hours each I assumed would be 0- 5 and check have ALL checked. Maybe it is easier to just remove everything but the reuccuring hour or min boxes lol.
     
  24. Offline

    dumptruckman

    Perhaps I can reword it to make more sense... From what I can see in your config file, your "Automated restarts" happen at 12am, 5am, 10am, 3pm, 8pm, and then I imagine they repeat like that every day. If you just want to use specific hours, set the first hour box to 0,5,10,15,20. That will cause it to occur on those hours, then you can leave the other hours options alone.

    You "Save worlds" event happens every 2 hours on the even hours. The daily backup one is the only one i question.

    Edit: I'm going to rethink the setup in the next version.
     
  25. Offline

    ledhead900

    hmmm still confused see It reads as if you leave all boxes alone but the hours box that it would reccur every amount hours that box has in it as thats all I want it do. In that case my restarts are fine every 5 hours lol.

    As for backup I just want it every 24hr I don't care for specific times and I did not plan to calculate for them I just hoped to punch 23 or 24 into the hour box set all days leave it alone the schedular is handy and very usable but for my case I don't somthing going of at specific time at least not for those events I just want as stated and maybe have it force save worlds eveyr 30m or something.

    oh and save worlds has not tooltip so I took a gamble thinking it was to do a save all once in a while.
     
  26. Offline

    dumptruckman

    Ahh yeah, I forgot to add that tooltip in. Check this out:
    [​IMG]
     
  27. Offline

    ledhead900

    hmm that makes more sense so I would simply just set the "and again every" hour to what ever I wanted leave the other side alone and t days of weekand month to all then set my broadcasts ?.

    So for example If I wanted to to save all id put in the Hours 1 so for every 1 hours
    it would force save all.

    I suppose i could use Minute instead as 30 leave hours blank. tick the again box for minute.

    Edit:

    Oh yea you said leave it all blank for 24hrs repeating the thing does not say that lol and it does not seem obviouse it will since all boxs have nothing in them when I start it.
     
  28. Offline

    dumptruckman

    I'm not sure I follow... If you want something to repeat every hour, just check All for hours and leave everything else alone. If you want every 30 minutes, put 0 for minutes and check again every 30 and ALSO select ALL for hours.
     
  29. Offline

    ledhead900

    Right so It seems to work fine now but just to check with you to look over it once more

    I got backups set for 24hrs as u said to leave it all alone I just checked for all months and days.
    I got Restarts for every 5h and world save all every 30m.

    Restart annunce should be 1min - 30sec - 10sec and remain down for 30s
    Backups should be : 30min - 5min - 10sec

    Tho I haev noticed that its not updating when I click update I must re create a new event from scratch to make changes to the times. Noticed this with the 30min saveall it would not let me adjust that since it had not announces.

    http://pastebin.com/7KHNYTF3
     
  30. Offline

    BigRenegade


    To get a 24 hour time period select the first box in hours and place in there the time you want it to do the back up (0 for midnight, 1 for 1am, 13 for 1 pm, and so on). Then down below you select All for Day of Month and All for Months. This will have it repeat every day at the time specified.
     
Thread Status:
Not open for further replies.

Share This Page