Ability to filter bukkit plugins by bukkit version

Discussion in 'BukkitDev Information and Feedback' started by Marium0505, Apr 30, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    Marium0505

    Hello.

    This suggestion is quite simple.
    Here's a picture:

    [​IMG]

    If you are on that page as much as me, then I don't need to tell you where/what that is, but I will anyways. :)

    That is the top on http://dev.bukkit.org/bukkit-plugins/.
    ... It's the filter options when you look for plugins.

    Like you can see in the box with the red border, I suggest adding a new filter option!
    It would be great if we not only could search for plugins based on start/end date, but also bukkit/minecraft version.

    One place it can be is where I put the box.

    This shouldn't be too complicated, since plugin developers already set the bukkit versions for their (latest version of their) plugin.

    This would make it much easier to find plugins which \should\ be compatible with the bukkit/minecraft version your server is running on! :)

    Do you agree? Show your support by liking this post, and making a reply!
    Do you disagree? Tell me why by making a reply. :)
     
    Davidbe04 likes this.
  2. Offline

    TnT Retired Staff

    Marium0505
    If you do that, you would filter out the thousands of plugins that work perfectly fine on newer CraftBukkit versions. I still have plugins I run today that haven't been updated in over two years (I am running CB 1.7.9).

    It isn't as handy of a feature as you may think, but we can suggest it to Curse.
     
    Garris0n and drtshock like this.
  3. Offline

    Marium0505

    TnT

    I'm aware, and I understand, but it can still be useful, and it's not like plugins always would be filtered by version, you can easily remove the filter. :)

    But, you should be able to only show multiple versions, this might make it better.

    I'm not sure about this since I don't have any plugins on dev.bukkit.org, but is it possible to tell that a plugin/version of a plugin supports multiple Minecraft/bukkit versions?
     
Thread Status:
Not open for further replies.

Share This Page