"A plugin cancelled the block start break event"

Discussion in 'Bukkit Help' started by Shinfo, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I'm an admin. I've tried disabling plugins (world guard, world edit, some essentials), I've tried craftbukkit 440, and the latest build.

    For some reason. I and only I, am getting this error when I tried to dig. And I can't place blocks either. Yet users in other classes (default/custom class) can. In fact... people who aren't on whitelist (i'm using built in whitelist) can build, i've notice.

    Essentials (ban/chat/god/help/home/serverlist/spawn/tele/warp)
    Automessage (not working for some reason)
    Vanish (not working either)
    World Edit
    World Guard.
    --- merged: Mar 1, 2011 5:53 AM ---
    I just noticed I can't get into locked chests now, after updating to the new permissions from groupmanager plugin (change in an attempt to get this working)
  2. Offline


    I get this in console when I use superpick on world edit. Not sure about your other problems
  3. Offline


    It seems like this message is related to plugins that alter how you interact with blocks. I was using wordedit and whenever I used the super pickaxe, I received this message in the console. I didn't notice any errors or bugs though.
  4. Offline


    Yes, this is a WorldEdit issue. I was having a similar problem. It tends to be specifically from the superpickaxe command, however you seem to be having other problems. It sounds like it's permissions related.

    Also, when you update your plugins, ESPECIALLY Essentials and/or Permissions, make sure that you're updating their config files. They have both just recently changed the way their config files are set up, and I was having some major problems because I was just updating the .jar and not the config files - this was causing the .jar plugin to look for lines in the config.yml that were non-existent, resulting in the console puking errors everywhere.

    If I were to guess, one of the recent Essentials updates has made a major change that is overlapping with one or more of your non-working plugins and/or WorldEdit. I'd suggest checking in with the various config files, updating them, and removing the offending plugins. At this point, make sure you and your other users can do all the normal commands you should be able to do.

    Then, reintroduce one of the plugins, see if it works, if so, remove it again and introduce one of the others that don't work, check it, etc. until you have found the offender. If they all appear to work, introduce just two of them, check to see if they both work, then introduce a third. This should peg which one (if it's just one) is causing the problem.

    Also, are iChat and EssentialsChat not overlapping? I was under the impression they didn't play well together. I think Automessage and EssentialsChat also overlap, if I am correct. This may just be dependent on how EssentialsChat is set up. I'm not a plugin developer, so I haven't looked at their individual code, but it makes sense to me based on what I know of how they both work. It may be conflicting with iChat as well.

    I would also imagine Minequery and Vanish are conflicting, since Vanish hides players, and Minequery finds them.
    --- merged: Mar 1, 2011 9:39 AM ---

    I would also consider double checking your line of the Permissions config file (GroupManager, Permissions, whatever plugin you're using), and seeing whether or not you and/or other admins are in the Ops file. Some plugins seem to act funny without admins being in the ops file.

    But still sounds like your permissions aren't set up correctly.
    --- merged: Mar 1, 2011 9:43 AM ---

    Also, I'd like to note that I stopped receiving this message when I correctly updated the Essentials .jars, as well as the config.yml file.

    Your problem with accessing locked chests is probably a conflict with LWC and your permissions file. Or possibly, again, you're not on the op list?

  5. Offline


    believe it or not this also happened to me for the first time last night. i believe it to be attributed to a freak amalgamation of keypresses. i noticed it happend as i was hacking away at a tree and accidentally spammed a few F keys jumping in and out of fullscreen mode.... when i came back i couldnt use my mouse in game, so i closed it and noticed the error in console. it's never happened outside from that. the only plugin that we share in common however is treehugger.
Thread Status:
Not open for further replies.

Share This Page