A Couple Things To Clear Up

Discussion in 'Bukkit Help' started by Binner_Done, Oct 31, 2015.

Thread Status:
Not open for further replies.
  1. Offline

    Binner_Done

    Hey Guys, this thread will cover a couple topics...

    Topic #1
    Plugin Versions:
    Now, I do understand SOME plugins will not work at a later date as they use methods that have been removed etc, but some older plugins DO work, so don't bother thinking "Oh, this is version 1.6.9, I'm not even gonna try with it!" because it may work! Of course, if some plugins are really old and they are kind enough to let a developer take over, it will be updated.

    Topic #2
    Google:
    Now, it's annoying for us problem solvers when all we have to do is go onto google, summarize your problem and literally get the answer right there, the same with plugins. If you need a warning plugin, don't just request it straight away. Search google for 'warning plugin bukkit minecraft' and I'm sure you'll get an answer pretty quick ;)

    Topic #3
    Console Errors:
    Usually, console errors are pretty self explanatory. Like Syntax Error, wasn't expecting ( means you shouldn't have a ( there, you'll just have to remove that ( and then it should be fixed, of course the more complicated ones are okay to make a thread on.

    Topic #4
    Looking at other threads first:
    Clues in the title, just try and look for your problem on bukkit if google fails (Very unlikely) So if someone is having a problem with say a certain plugin, lets say laugh.jar and you are having the same problem, just watch the thread!

    Topic #5
    Message The Creator First:
    If you're having a problem with a plugin, ask the developer by PMing him or creating a ticket, he will know much more about the plugin and how to fix it than we do.


    ---@~=~@---
    I hope this comes in handy for linking people too, I know I will use it a lot!
    Any extra suggestions? Leave them in the comments below!
    ~ Jack
    ---@~=~@---
     
    shades161 likes this.
  2. Offline

    WHQ

    Good tips! :), but shouldn't this be in plugin developement/resources?
     
  3. Online

    timtower Ninja on the waves Moderator

    Moved to Bukkit help and stickied the thread.
     
  4. Offline

    Binner_Done

    Thanks for moving and sticking @timtower
     
  5. Offline

    teej107

    I still build my plugins with 1.7 and I know it'll work on 1.8. I have never had a plugin of mine that doesn't work on 1.8 but works on 1.7. That's the magic of and why you should use the Bukkit API when writing plugins.
     
    shades161 and timtower like this.
  6. Offline

    Binner_Done

  7. Offline

    Tecno_Wizard

    @teej107, i can vouch for this. I compiled my stuff with 1.6.9 for a LONG time and never ran into an issue. I only ever moved over because people complained about the "designed for" number thinking it wouldn't work.
     
    Binner_Done and timtower like this.
  8. Offline

    Binner_Done

    @Tecno_Wizard That's why you should put 'THIS REALLY DOES HONESTLY 100% WORK WITH ANY VERSION 1.6.9 + THAT INCLUDES 1.8!"
    But version number still shouldn't make people decide on if they should/should not download
     
  9. Offline

    oceantheskatr

    All caps header1 at the top of the page in red ;)
     
    shades161 and timtower like this.
  10. Offline

    mcdorli

    In an image with blue background, and UNDERGROUND fonz.
     
Thread Status:
Not open for further replies.

Share This Page